Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Language Subtags, Tag Extensions, and Tags Last Updated 2025-04-02 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • Language Subtag Registry • Language Tag Extensions • Language Tags (OBSOLETE) Language Subtag Registry Registration Procedure(s) Expert Review Expert(s) Doug Ewell Reference [RFC 5645][RFC 5646] Note Registration requests should be submitted to the [ietf-languages@ietf.org] mailing list. For more information, see [RFC 5646, Section 3.5]. Note The format of the registry is explained in Section 3 and [Section 3.1 of RFC 5646]. When referring to language tags in specifications, please refer to [RFC 5646]. Registry File [Language Subtag Registry] Supplemental Information Language subtag registration forms are available in the [Language Subtag Registration Form Archive.] Language Tag Extensions Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 5646] Note While registration requires IESG approval or an IETF Stream RFC, the maintaining authority for an extension can submit changes to contact information and/or URLs directly to IANA, as described in [RFC 5646, Section 5.2]. Registry File [Language Tag Extensions Registry] Language Tags (OBSOLETE) Registration Procedure(s) Registry closed Reference [RFC 3066][RFC 4646] Note This registry is obsolete and has been replaced by the [Language Subtag Registry], as described in [RFC 4646, Section 5.1]. Registry File [Language Tags (OBSOLETE)] Supplemental Information Language tag registration forms are available in the [Language Tag Registration Form Archive]. Licensing Terms