Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| retrospect | 497 | tcp | Retrospect backup and restore service | Retrospect, Inc. | JG Heithcock | 2012-02-02 | |||||
| retrospect | 497 | udp | Retrospect backup and restore service | Retrospect, Inc. | JG Heithcock | 2012-02-02 | |||||
| siam | 498 | tcp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| siam | 498 | udp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| iso-ill | 499 | tcp | ISO ILL Protocol | Mark H. Needleman | Mark H. Needleman | ||||||
| iso-ill | 499 | udp | ISO ILL Protocol | Mark H. Needleman | Mark H. Needleman | ||||||
| isakmp | 500 | tcp | isakmp | Mark Schertler | Mark Schertler | ||||||
| isakmp | 500 | udp | isakmp | Mark Schertler | Mark Schertler | ||||||
| stmf | 501 | tcp | STMF | Alan Ungar | Alan Ungar | ||||||
| stmf | 501 | udp | STMF | Alan Ungar | Alan Ungar | ||||||
| mbap | 502 | tcp | Modbus Application Protocol | modbus.org | Dennis Dube | 2014-06-10 | |||||
| mbap | 502 | udp | Modbus Application Protocol | modbus.org | Dennis Dube | 2014-06-10 | |||||
| intrinsa | 503 | tcp | Intrinsa | Robert Ford | Robert Ford | ||||||
| intrinsa | 503 | udp | Intrinsa | Robert Ford | Robert Ford | ||||||
| citadel | 504 | tcp | citadel | Art Cancro | Art Cancro | ||||||
| citadel | 504 | udp | citadel | Art Cancro | Art Cancro | ||||||
| mailbox-lm | 505 | tcp | mailbox-lm | Beverly Moody | Beverly Moody | ||||||
| mailbox-lm | 505 | udp | mailbox-lm | Beverly Moody | Beverly Moody | ||||||
| ohimsrv | 506 | tcp | ohimsrv | Scott Powell | Scott Powell | ||||||
| ohimsrv | 506 | udp | ohimsrv | Scott Powell | Scott Powell | ||||||
| crs | 507 | tcp | crs | Brad Wright | Brad Wright | ||||||
| crs | 507 | udp | crs | Brad Wright | Brad Wright | ||||||
| xvttp | 508 | tcp | xvttp | Keith J. Alphonso | Keith J. Alphonso | ||||||
| xvttp | 508 | udp | xvttp | Keith J. Alphonso | Keith J. Alphonso | ||||||
| snare | 509 | tcp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| snare | 509 | udp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| fcp | 510 | tcp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| fcp | 510 | udp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| passgo | 511 | tcp | PassGo | John Rainford | John Rainford | ||||||
| passgo | 511 | udp | PassGo | John Rainford | John Rainford | ||||||
| exec | 512 | tcp | remote process execution; authentication performed using passwords and UNIX login names | ||||||||
| comsat | 512 | udp | |||||||||
| biff | 512 | udp | used by mail system to notify users of new mail received; currently receives messages only from processes on the same machine | ||||||||
| login | 513 | tcp | remote login a la telnet; automatic authentication performed based on priviledged port numbers and distributed data bases which identify "authentication domains" | ||||||||
| who | 513 | udp | maintains data bases showing who's logged in to machines on a local net and the load average of the machine | ||||||||
| shell | 514 | tcp | cmd like exec, but automatic authentication is performed as for login server | ||||||||
| syslog | 514 | udp | 2020-06-01 | RFC 5426 | |||||||
| printer | 515 | tcp | spooler | ||||||||
| printer | 515 | udp | spooler | ||||||||
| videotex | 516 | tcp | videotex | Daniel Mavrakis | Daniel Mavrakis | ||||||
| videotex | 516 | udp | videotex | Daniel Mavrakis | Daniel Mavrakis | ||||||
| talk | 517 | tcp | like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established) | ||||||||
| talk | 517 | udp | like tenex link, but across machine - unfortunately, doesn't use link protocol (this is actually just a rendezvous port from which a tcp connection is established) | ||||||||
| ntalk | 518 | tcp | |||||||||
| ntalk | 518 | udp | |||||||||
| utime | 519 | tcp | unixtime | ||||||||
| utime | 519 | udp | unixtime | ||||||||
| efs | 520 | tcp | extended file name server | ||||||||
| router | 520 | udp | local routing process (on site); uses variant of Xerox NS routing information protocol - RIP | ||||||||
| ripng | 521 | tcp | ripng | Robert E. Minnear | Robert E. Minnear | ||||||
| ripng | 521 | udp | ripng | Robert E. Minnear | Robert E. Minnear | ||||||
| ulp | 522 | tcp | ULP | Max Morris | Max Morris | ||||||
| ulp | 522 | udp | ULP | Max Morris | Max Morris | ||||||
| ibm-db2 | 523 | tcp | IBM-DB2 | Juliana Hsu | Juliana Hsu | ||||||
| ibm-db2 | 523 | udp | IBM-DB2 | Juliana Hsu | Juliana Hsu | ||||||
| ncp | 524 | tcp | NCP | Don Provan | Don Provan | ||||||
| ncp | 524 | udp | NCP | Don Provan | Don Provan | ||||||
| timed | 525 | tcp | timeserver | ||||||||
| timed | 525 | udp | timeserver | ||||||||
| tempo | 526 | tcp | newdate | ||||||||
| tempo | 526 | udp | newdate | ||||||||
| stx | 527 | tcp | Stock IXChange | Ferdi Ladeira | Ferdi Ladeira | 2022-01-25 | |||||
| stx | 527 | udp | Stock IXChange | Ferdi Ladeira | Ferdi Ladeira | 2022-01-25 | |||||
| custix | 528 | tcp | Customer IXChange | Ferdi Ladeira | Ferdi Ladeira | 2022-01-25 | |||||
| custix | 528 | udp | Customer IXChange | Ferdi Ladeira | Ferdi Ladeira | 2022-01-25 | |||||
| irc-serv | 529 | tcp | IRC-SERV | Brian Tackett | Brian Tackett | ||||||
| irc-serv | 529 | udp | IRC-SERV | Brian Tackett | Brian Tackett | ||||||
| courier | 530 | tcp | rpc | ||||||||
| courier | 530 | udp | rpc | ||||||||
| conference | 531 | tcp | chat | ||||||||
| conference | 531 | udp | chat | ||||||||
| netnews | 532 | tcp | readnews | ||||||||
| netnews | 532 | udp | readnews | ||||||||
| netwall | 533 | tcp | for emergency broadcasts | Andreas Heidemann | Andreas Heidemann | ||||||
| netwall | 533 | udp | for emergency broadcasts | Andreas Heidemann | Andreas Heidemann | ||||||
| windream | 534 | tcp | windream Admin | Uwe Honermann | Uwe Honermann | ||||||
| windream | 534 | udp | windream Admin | Uwe Honermann | Uwe Honermann | ||||||
| iiop | 535 | tcp | iiop | Jeff M.Michaud | Jeff M.Michaud | ||||||
| iiop | 535 | udp | iiop | Jeff M.Michaud | Jeff M.Michaud | ||||||
| opalis-rdv | 536 | tcp | opalis-rdv | Laurent Domenech | Laurent Domenech | ||||||
| opalis-rdv | 536 | udp | opalis-rdv | Laurent Domenech | Laurent Domenech | ||||||
| nmsp | 537 | tcp | Networked Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| nmsp | 537 | udp | Networked Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| gdomap | 538 | tcp | gdomap | Richard Frith-Macdonald | Richard Frith-Macdonald | ||||||
| gdomap | 538 | udp | gdomap | Richard Frith-Macdonald | Richard Frith-Macdonald | ||||||
| apertus-ldp | 539 | tcp | Apertus Technologies Load Determination | ||||||||
| apertus-ldp | 539 | udp | Apertus Technologies Load Determination | ||||||||
| uucp | 540 | tcp | uucpd | ||||||||
| uucp | 540 | udp | uucpd | ||||||||
| uucp-rlogin | 541 | tcp | uucp-rlogin | Stuart Lynne | Stuart Lynne | ||||||
| uucp-rlogin | 541 | udp | uucp-rlogin | Stuart Lynne | Stuart Lynne | ||||||
| commerce | 542 | tcp | commerce | Randy Epstein | Randy Epstein | ||||||
| commerce | 542 | udp | commerce | Randy Epstein | Randy Epstein | ||||||
| klogin | 543 | tcp | |||||||||
| klogin | 543 | udp | |||||||||
| kshell | 544 | tcp | krcmd | ||||||||
| kshell | 544 | udp | krcmd | ||||||||
| appleqtcsrvr | 545 | tcp | appleqtcsrvr | Murali Ranganathan | Murali Ranganathan | ||||||
| appleqtcsrvr | 545 | udp | appleqtcsrvr | Murali Ranganathan | Murali Ranganathan | ||||||
| dhcpv6-client | 546 | tcp | DHCPv6 Client | ||||||||
| dhcpv6-client | 546 | udp | DHCPv6 Client | IESG | IETF Chair | 2018-05-21 | RFC 9915 |