Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ldoms-mgmt 6482 udp Logical Domains Management Interface Eric Sharakan Eric Sharakan 2008-02-14
SunVTS-RMI 6483 tcp SunVTS RMI Sumit Arora Sumit Arora 2007-06
SunVTS-RMI 6483 udp SunVTS RMI Sumit Arora Sumit Arora 2007-06
sun-sr-jms 6484 tcp Service Registry Default JMS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-jms 6484 udp Service Registry Default JMS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop 6485 tcp Service Registry Default IIOP Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop 6485 udp Service Registry Default IIOP Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiops 6486 tcp Service Registry Default IIOPS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiops 6486 udp Service Registry Default IIOPS Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop-aut 6487 tcp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
sun-sr-iiop-aut 6487 udp Service Registry Default IIOPAuth Domain Paul Sterk Paul Sterk 2006-03
sun-sr-jmx 6488 tcp Service Registry Default JMX Domain Paul Sterk Paul Sterk 2006-03
sun-sr-jmx 6488 udp Service Registry Default JMX Domain Paul Sterk Paul Sterk 2006-03
sun-sr-admin 6489 tcp Service Registry Default Admin Domain Paul Sterk Paul Sterk 2006-03
sun-sr-admin 6489 udp Service Registry Default Admin Domain Paul Sterk Paul Sterk 2006-03
6490-6499 Unassigned
boks 6500 tcp BoKS Master Magnus Nystrom Magnus Nystrom
boks 6500 udp BoKS Master Magnus Nystrom Magnus Nystrom
boks-servc 6501 tcp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501
boks_servc 6501 tcp BoKS Servc Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501 This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servc 6501 udp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom
boks_servc 6501 udp BoKS Servc Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 tcp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 tcp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 udp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 udp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 tcp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 tcp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 udp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 udp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6504 Unassigned
badm-priv 6505 tcp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 tcp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-priv 6505 udp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 udp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 tcp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 tcp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 udp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 udp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 tcp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 tcp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 udp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 udp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 tcp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 tcp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 udp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 udp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
mgcs-mfp-port 6509 tcp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mgcs-mfp-port 6509 udp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mcer-port 6510 tcp MCER Port Portnoy Boxman Portnoy Boxman
mcer-port 6510 udp MCER Port Portnoy Boxman Portnoy Boxman
6511 tcp Reserved
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
6512-6512 Unassigned
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
6513 udp Reserved
syslog-tls 6514 tcp Syslog over TLS RFC 5425
syslog-tls 6514 udp syslog over DTLS RFC 6012
syslog-tls 6514 dccp syslog over DTLS RFC 6012
elipse-rec 6515 tcp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
elipse-rec 6515 udp Elipse RPC Protocol Fl√°vio Englert Fl√°vio Englert 2007-09-17
6516-6542 Unassigned
lds-distrib 6543 tcp lds_distrib Jack Baker Jack Baker 2003-06
lds-distrib 6543 udp lds_distrib Jack Baker Jack Baker 2003-06
lds-dump 6544 tcp LDS Dump Service Jack Baker Jack Baker 2006-02
lds-dump 6544 udp LDS Dump Service Jack Baker Jack Baker 2006-02
6545-6546 Unassigned
apc-6547 6547 tcp APC 6547 American Power Conversion American Power Conversion
apc-6547 6547 udp APC 6547 American Power Conversion American Power Conversion
apc-6548 6548 tcp APC 6548 American Power Conversion American Power Conversion
apc-6548 6548 udp APC 6548 American Power Conversion American Power Conversion
apc-6549 6549 tcp APC 6549 American Power Conversion American Power Conversion
apc-6549 6549 udp APC 6549 American Power Conversion American Power Conversion
fg-sysupdate 6550 tcp fg-sysupdate Mark Beyer Mark Beyer
fg-sysupdate 6550 udp fg-sysupdate Mark Beyer Mark Beyer
sum 6551 tcp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
sum 6551 udp Software Update Manager Jan Dirven Jan Dirven 2007-12-13
6552-6555 Unassigned
checkmk-agent 6556 tcp Checkmk Monitoring Agent Checkmk GmbH Alexander Wilms 2020-07-14 2024-08-06
6556 udp Reserved
6557 Unassigned
xdsxdm 6558 tcp Brian Tackett Brian Tackett possible contact
xdsxdm 6558 udp Brian Tackett Brian Tackett possible contact
6559-6565 Unassigned
sane-port 6566 tcp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
sane-port 6566 udp SANE Control Port Henning Meier-Geinitz Henning Meier-Geinitz 2002-10
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
canit-store 6568 tcp CanIt Storage Manager

IANA assigned this well-formed service name as a replacement for "canit_store".
Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25
canit_store 6568 tcp CanIt Storage Manager Dianne Skoll Dianne Skoll 2009-04-22 2017-05-25 This entry is an alias to "canit-store". This entry is now historic, not usable for use with many common service discovery mechanisms.
rp-reputation 6568 udp Roaring Penguin IP Address Reputation Collection Dianne Skoll Dianne Skoll 2010-02-05 2017-05-25
6569-6578 Unassigned
affiliate 6579 tcp Affiliate David Catmull David Catmull 2006-01
affiliate 6579 udp Affiliate David Catmull David Catmull 2006-01
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
parsec-peer 6581 tcp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-peer 6581 udp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-game 6582 tcp Parsec Gameserver Andreas Varga Andreas Varga
parsec-game 6582 udp Parsec Gameserver Andreas Varga Andreas Varga
joaJewelSuite 6583 tcp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11
joaJewelSuite 6583 udp JOA Jewel Suite Bob Rundle Bob Rundle 2005-11

Contact Information

Name Organization Contact URI Last Updated
Alexander Wilms Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
American Power Conversion ports&apcc.com 2002-02
Andreas Varga sid&parsec.org
Bob Rundle rundle&rundle.com 2005-11
Brian Tackett cym&acrux.net
Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
David Catmull uncommon&uncommonplace.com 2006-01
Dianne Skoll dfs&roaringpenguin.com 2017-05-25
Eric Sharakan ldoms-iana-ports&sun.com 2008-02-14
Fl√°vio Englert flavio&elipse.com.br 2007-09-17
Henning Meier-Geinitz henning&meier-geinitz.de 2002-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jack Baker Jack.Baker&l-3com.com 2006-02
Jan Dirven jan.dirven&agfa.com 2007-12-13
Magnus Nystrom magnus&dynas.se
Mark Beyer mbeyer&freegate.com
Minoru Ozaki Minoru.Ozaki&rdmg.mgcs.mei.co.jp
Paul Sterk paul.sterk&sun.com 2006-03
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Sumit Arora sumit.arora&sun.com 2007-06