Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| joaJewelSuite | 6583 | udp | JOA Jewel Suite | Bob Rundle | Bob Rundle | 2005-11 | |||||
| 6584-6587 | Unassigned | ||||||||||
| 6588 | Unassigned | Unofficial use of port 6588 by AnalogX and Microsoft | |||||||||
| 6589-6599 | Unassigned | ||||||||||
| mshvlm | 6600 | tcp | Microsoft Hyper-V Live Migration | Rajesh Davé | Rajesh Davé | 2009-02-03 | |||||
| 6600 | udp | Reserved | |||||||||
| mstmg-sstp | 6601 | tcp | Microsoft Threat Management Gateway SSTP | Ori Yosefi | Ori Yosefi | 2009-05-04 | |||||
| 6601 | udp | Reserved | |||||||||
| wsscomfrmwk | 6602 | tcp | Windows WSS Communication Framework | Rong Yu | Rong Yu | 2010-08-10 | |||||
| 6602 | udp | Reserved | |||||||||
| 6603-6609 | Unassigned | ||||||||||
| bencher | 6610 | tcp | Bencher API | Bencher | Everett Pompeii | 2026-06-17 | |||||
| bencher | 6610 | udp | Bencher API | Bencher | Everett Pompeii | 2026-06-17 | |||||
| 6611-6618 | Unassigned | ||||||||||
| odette-ftps | 6619 | tcp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| odette-ftps | 6619 | udp | ODETTE-FTP over TLS/SSL | Ieuan Friend | Ieuan Friend | 2006-03 | RFC 5024 | ||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | tcp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp | 6621 | udp | Kerberos V5 FTP Control | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| mcftp | 6622 | tcp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| mcftp | 6622 | udp | Multicast FTP | Bruce Lueckenhoff | Bruce Lueckenhoff | 2006-02 | |||||
| ktelnet | 6623 | tcp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| ktelnet | 6623 | udp | Kerberos V5 Telnet | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| datascaler-db | 6624 | tcp | DataScaler database | Vasu Murthy | Vasu Murthy | 2010-02-08 | |||||
| 6624 | udp | Reserved | |||||||||
| datascaler-ctl | 6625 | tcp | DataScaler control | Vasu Murthy | Vasu Murthy | 2010-02-08 | |||||
| 6625 | udp | Reserved | |||||||||
| wago-service | 6626 | tcp | WAGO Service and Update | Wolfgang Adler | Wolfgang Adler | 2006-04 | |||||
| wago-service | 6626 | udp | WAGO Service and Update | Wolfgang Adler | Wolfgang Adler | 2006-04 | |||||
| nexgen | 6627 | tcp | Allied Electronics NeXGen | Lou Seitchik | Lou Seitchik | 2005-08 | |||||
| nexgen | 6627 | udp | Allied Electronics NeXGen | Lou Seitchik | Lou Seitchik | 2005-08 | |||||
| afesc-mc | 6628 | tcp | AFE Stock Channel M/C | K. K Ho | K. K Ho | 2004-04 | |||||
| afesc-mc | 6628 | udp | AFE Stock Channel M/C | K. K Ho | K. K Ho | 2004-04 | |||||
| nexgen-aux | 6629 | tcp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| nexgen-aux | 6629 | udp | Secondary, (non ANDI) multi-protocol multi-function interface to the Allied ANDI-based family of forecourt controllers | Allied Electronics | Robert E. Tomenchok Jr. | 2016-11-29 | |||||
| 6630 | Unassigned | ||||||||||
| 6631 | Unassigned | 2004-05-28 | |||||||||
| mxodbc-connect | 6632 | tcp | eGenix mxODBC Connect | Marc-Andre Lemburg | Marc-Andre Lemburg | 2009-11-13 | Unauthorized Use Known on port 6632 | ||||
| 6632 | udp | Reserved | |||||||||
| 6633 | tcp | Reserved | |||||||||
| cisco-vpath-tun | 6633 | udp | Cisco vPath Services Overlay | Cisco | Surendra Kumar | 2012-06-11 | |||||
| mpls-pm | 6634 | udp | MPLS Performance Measurement out-of-band response | Cisco Systems | Sagar Soni | 2014-02-20 | |||||
| 6634 | tcp | Reserved | |||||||||
| 6635 | tcp | Reserved | |||||||||
| mpls-udp | 6635 | udp | Encapsulate MPLS packets in UDP tunnels. | IESG | IETF Chair | 2015-02-10 | RFC 7510 | ||||
| 6636 | tcp | Reserved | |||||||||
| mpls-udp-dtls | 6636 | udp | Encapsulate MPLS packets in UDP tunnels with DTLS. | IESG | IETF Chair | 2015-02-10 | RFC 7510 | ||||
| 6637-6639 | Unassigned | ||||||||||
| ovsdb | 6640 | tcp | Open vSwitch Database protocol | Bruce Davie | Bruce Davie | 2013-07-31 | RFC 7047 | ||||
| 6640 | udp | Reserved | |||||||||
| 6641-6652 | Unassigned | ||||||||||
| openflow | 6653 | tcp | OpenFlow | Open Networking Foundation | Puneet Agarwal | 2013-07-18 | |||||
| openflow | 6653 | udp | OpenFlow | Open Networking Foundation | Puneet Agarwal | 2013-07-18 | |||||
| 6654 | Unassigned | ||||||||||
| pcs-sf-ui-man | 6655 | tcp | PC SOFT - Software factory UI/manager | Jerome AERTS | Jerome AERTS | 2010-11-30 | |||||
| 6655 | udp | Reserved | |||||||||
| emgmsg | 6656 | tcp | Emergency Message Control Service | Gerry Gorman | Gerry Gorman | 2010-12-06 | |||||
| 6656 | udp | Reserved | |||||||||
| 6657 | tcp | Reserved | |||||||||
| palcom-disc | 6657 | udp | PalCom Discovery | Boris Magnusson | Boris Magnusson | 2010-12-06 | |||||
| 6658-6664 | Unassigned | Unauthorized Use Known on Port 6659 | |||||||||
| ircu | 6665-6669 | tcp | IRCU | Brian Tackett | Brian Tackett | ||||||
| 6665-6669 | udp | Reserved | |||||||||
| vocaltec-gold | 6670 | tcp | Vocaltec Global Online Directory | Scott Petrack | Scott Petrack | ||||||
| vocaltec-gold | 6670 | udp | Vocaltec Global Online Directory | Scott Petrack | Scott Petrack | ||||||
| p4p-portal | 6671 | tcp | P4P Portal Service | Chris Griffiths | Chris Griffiths | 2008-07-28 | |||||
| p4p-portal | 6671 | udp | P4P Portal Service | Chris Griffiths | Chris Griffiths | 2008-07-28 | |||||
| vision-server | 6672 | tcp | vision_server IANA assigned this well-formed service name as a replacement for "vision_server". |
Chris Kramer | Chris Kramer | ||||||
| vision_server | 6672 | tcp | vision_server | Chris Kramer | Chris Kramer | This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vision-server | 6672 | udp | vision_server IANA assigned this well-formed service name as a replacement for "vision_server". |
Chris Kramer | Chris Kramer | ||||||
| vision_server | 6672 | udp | vision_server | Chris Kramer | Chris Kramer | This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vision-elmd | 6673 | tcp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | tcp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vision-elmd | 6673 | udp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | udp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 6674-6677 | Unassigned | ||||||||||
| vfbp | 6678 | tcp | Viscount Freedom Bridge Protocol | Chris MacDonald | Chris MacDonald | 2011-03-16 | |||||
| vfbp-disc | 6678 | udp | Viscount Freedom Bridge Discovery | Chris MacDonald | Chris MacDonald | 2011-03-16 | |||||
| osaut | 6679 | tcp | Osorno Automation | Peter Hombach | Peter Hombach | 2011-03-16 | |||||
| osaut | 6679 | udp | Osorno Automation | Peter Hombach | Peter Hombach | 2011-03-16 | |||||
| 6680-6686 | Unassigned | ||||||||||
| clever-ctrace | 6687 | tcp | CleverView for cTrace Message Service | David Cheng | David Cheng | 2010-02-01 | |||||
| 6687 | udp | Reserved | |||||||||
| clever-tcpip | 6688 | tcp | CleverView for TCP/IP Message Service | David Cheng | David Cheng | 2009-10-13 | |||||
| 6688 | udp | Reserved | |||||||||
| tsa | 6689 | tcp | Tofino Security Appliance | Scott Howard | Scott Howard | 2009-10-13 | |||||
| tsa | 6689 | udp | Tofino Security Appliance | Scott Howard | Scott Howard | 2009-10-13 | |||||
| cleverdetect | 6690 | tcp | CLEVERDetect Message Service | Applied Expert Systems, Inc. | David Cheng | 2014-12-03 | |||||
| 6690 | udp | Reserved | |||||||||
| 6691-6695 | Unassigned | ||||||||||
| 6696 | tcp | Reserved | |||||||||
| babel | 6696 | udp | Babel Routing Protocol | 2011-08-15 | RFC 8966 | ||||||
| ircs-u | 6697 | tcp | Internet Relay Chat via TLS/SSL | 2014-02-11 | RFC 7194 | ||||||
| 6697 | udp | Reserved | 2014-02-11 | ||||||||
| 6698 | Unassigned | ||||||||||
| 6699 | tcp | Reserved | |||||||||
| babel-dtls | 6699 | udp | Babel Routing Protocol over DTLS | IESG | IETF Chair | 2020-09-04 | RFC 8968 | ||||
| 6700 | Unassigned | 2010-01-26 | |||||||||
| kti-icad-srvr | 6701 | tcp | KTI/ICAD Nameserver | Stanley Knutson | Stanley Knutson | ||||||
| kti-icad-srvr | 6701 | udp | KTI/ICAD Nameserver | Stanley Knutson | Stanley Knutson |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Allied Electronics | Rob&AlliedElectronics.com | 2016-11-29 | |
| Applied Expert Systems, Inc. | davec&aesclever.com | 2014-12-03 | |
| Bencher | info&bencher.dev | 2026-06-17 | |
| Bob Rundle | rundle&rundle.com | 2005-11 | |
| Boris Magnusson | boris&cs.lth.se | 2010-12-06 | |
| Brian Tackett | cym&acrux.net | ||
| Bruce Davie | bdavie&vmware.com | 2013-07-31 | |
| Bruce Lueckenhoff | bruce&scalabledesign.com | 2006-02 | |
| Chris Griffiths | chris_griffiths&cable.comcast.com | 2008-07-28 | |
| Chris Kramer | CKramer&gis.shl.com | ||
| Chris MacDonald | chris&viscount.com | 2011-03-16 | |
| Cisco | smkumar&cisco.com | 2012-06-11 | |
| Cisco Systems | sagsoni&cisco.com | 2014-02-20 | |
| David Cheng | davec&aesclever.com | 2010-02-01 | |
| Everett Pompeii | everett&bencher.dev | 2026-06-17 | |
| Gerry Gorman | gerry.gorman&emclock.com | 2010-12-06 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ieuan Friend | ieuan.friend&dip.co.uk | 2006-03 | |
| Jerome AERTS | info&pcsoft.fr | 2010-11-30 | |
| K. K Ho | kk.ho&afe-solutions.com | 2004-04 | |
| Lou Seitchik | lou&alliedelectronics.com | 2005-08 | |
| Marc-Andre Lemburg | mal&egenix.com | 2009-11-13 | |
| Open Networking Foundation | iana&opennetworking.org | 2013-07-18 | |
| Ori Yosefi | Ori.Yosefiµsoft.com | 2009-05-04 | |
| Peter Hombach | p.hombach&osorno.ca | 2011-03-16 | |
| Puneet Agarwal | pagarwal&broadcom.com | 2013-07-18 | |
| Rajesh Dav√© | rajdaveµsoft.com | 2009-02-03 | |
| Robert E. Tomenchok Jr. | Rob&AlliedElectronics.com | 2016-11-29 | |
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| Rong Yu | rongyuµsoft.com | 2010-08-10 | |
| Sagar Soni | Cisco Systems | sagsoni&cisco.com | 2014-02-20 |
| Scott Howard | scott&byressecurity.com | 2009-10-13 | |
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Stanley Knutson | Stanley.Knutson&ktiworld.com | ||
| Surendra Kumar | Cisco | smkumar&cisco.com | 2012-06-11 |
| Vasu Murthy | vmurthy&datascaler.com | 2010-02-08 | |
| Wolfgang Adler | electronicc_rd&wago.com | 2006-04 |