Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| kti-icad-srvr | 6701 | udp | KTI/ICAD Nameserver | Stanley Knutson | Stanley Knutson | ||||||
| 6701 | sctp | Unassigned | 2010-01-26 | ||||||||
| e-design-net | 6702 | tcp | e-Design network | Janos Lerch | Janos Lerch | 2006-02 | |||||
| e-design-net | 6702 | udp | e-Design network | Janos Lerch | Janos Lerch | 2006-02 | |||||
| 6702 | sctp | Unassigned | 2010-01-26 | ||||||||
| e-design-web | 6703 | tcp | e-Design web | Janos Lerch | Janos Lerch | 2006-02 | |||||
| e-design-web | 6703 | udp | e-Design web | Janos Lerch | Janos Lerch | 2006-02 | |||||
| 6704 | udp | Reserved | |||||||||
| 6704 | tcp | Reserved | |||||||||
| frc-hp | 6704 | sctp | ForCES HP (High Priority) channel | RFC 5811 | |||||||
| 6705 | udp | Reserved | |||||||||
| 6705 | tcp | Reserved | |||||||||
| frc-mp | 6705 | sctp | ForCES MP (Medium Priority) channel | RFC 5811 | |||||||
| 6706 | udp | Reserved | |||||||||
| 6706 | tcp | Reserved | |||||||||
| frc-lp | 6706 | sctp | ForCES LP (Low priority) channel | RFC 5811 | |||||||
| 6707-6713 | Unassigned | ||||||||||
| ibprotocol | 6714 | tcp | Internet Backplane Protocol | Alessandro Bassi | Alessandro Bassi | ||||||
| ibprotocol | 6714 | udp | Internet Backplane Protocol | Alessandro Bassi | Alessandro Bassi | ||||||
| fibotrader-com | 6715 | tcp | Fibotrader Communications | Robert Wetzold | Robert Wetzold | 2006-01 | |||||
| fibotrader-com | 6715 | udp | Fibotrader Communications | Robert Wetzold | Robert Wetzold | 2006-01 | |||||
| princity-agent | 6716 | tcp | Princity Agent | ENSTEAM Sp. z o.o. | Tomasz Krakowiak | 2014-07-07 | 2015-07-08 | ||||
| 6716 | udp | Reserved | |||||||||
| 6717-6766 | Unassigned | ||||||||||
| bmc-perf-agent | 6767 | tcp | BMC PERFORM AGENT | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-agent | 6767 | udp | BMC PERFORM AGENT | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-mgrd | 6768 | tcp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-mgrd | 6768 | udp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| adi-gxp-srvprt | 6769 | tcp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| adi-gxp-srvprt | 6769 | udp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| plysrv-http | 6770 | tcp | PolyServe http | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-http | 6770 | udp | PolyServe http | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-https | 6771 | tcp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| plysrv-https | 6771 | udp | PolyServe https | Mike Spitzer | Mike Spitzer | 2005-08 | |||||
| 6772-6776 | Unassigned | ||||||||||
| ntz-tracker | 6777 | tcp | netTsunami Tracker | Tomahawk Holdings Ltd | Sagara Wijetunga | 2013-05-01 | |||||
| 6777 | udp | Reserved | |||||||||
| ntz-p2p-storage | 6778 | tcp | netTsunami p2p storage system | Tomahawk Holdings Ltd | Sagara Wijetunga | 2013-05-01 | |||||
| 6778 | udp | Reserved | |||||||||
| 6779-6783 | Unassigned | ||||||||||
| 6784 | tcp | Reserved | |||||||||
| bfd-lag | 6784 | udp | Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces | IESG | IETF BFD Working Group Chairs | 2012-11-08 | 2014-01-09 | RFC 7130 | |||
| dgpf-exchg | 6785 | tcp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| dgpf-exchg | 6785 | udp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| smc-jmx | 6786 | tcp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-jmx | 6786 | udp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | tcp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | udp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-http | 6788 | tcp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| smc-http | 6788 | udp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| radg | 6789 | tcp | GSS-API for the Oracle Remote Administration Daemon | Oracle | Shawn Emery | 2002-08 | 2016-09-15 | ||||
| 6789 | udp | Reserved | 2002-08 | 2016-09-15 | |||||||
| hnmp | 6790 | tcp | HNMP | Jude George | Jude George | ||||||
| hnmp | 6790 | udp | HNMP | Jude George | Jude George | ||||||
| hnm | 6791 | tcp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| hnm | 6791 | udp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| 6792-6800 | Unassigned | ||||||||||
| acnet | 6801 | tcp | ACNET Control System Protocol | Fermilab | Rich Neswold | 2007-02 | 2017-07-13 | ||||
| acnet | 6801 | udp | ACNET Control System Protocol | Fermilab | Rich Neswold | 2007-02 | 2017-07-13 | ||||
| 6802-6816 | Unassigned | ||||||||||
| pentbox-sim | 6817 | tcp | PenTBox Secure IM Protocol | Alberto Ortega Llamas | Alberto Ortega Llamas | 2009-11-04 | |||||
| 6817 | udp | Reserved | |||||||||
| 6818-6830 | Unassigned | ||||||||||
| ambit-lm | 6831 | tcp | ambit-lm | Don Hejna | Don Hejna | ||||||
| ambit-lm | 6831 | udp | ambit-lm | Don Hejna | Don Hejna | ||||||
| 6832-6840 | Unassigned | ||||||||||
| netmo-default | 6841 | tcp | Netmo Default | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-default | 6841 | udp | Netmo Default | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-http | 6842 | tcp | Netmo HTTP | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-http | 6842 | udp | Netmo HTTP | Urs Bertschinger | Urs Bertschinger | ||||||
| 6843-6849 | Unassigned | ||||||||||
| iccrushmore | 6850 | tcp | ICCRUSHMORE | Dave Hubbard | Dave Hubbard | ||||||
| iccrushmore | 6850 | udp | ICCRUSHMORE | Dave Hubbard | Dave Hubbard | ||||||
| 6851-6867 | Unassigned | ||||||||||
| acctopus-cc | 6868 | tcp | Acctopus Command Channel | Stefan Auweiler | Stefan Auweiler | 2009-11-16 | |||||
| acctopus-st | 6868 | udp | Acctopus Status | Stefan Auweiler | Stefan Auweiler | 2009-11-16 | |||||
| 6869-6887 | Unassigned | ||||||||||
| muse | 6888 | tcp | MUSE | Muse Communications Corporation | Muse Communications Corporation | ||||||
| muse | 6888 | udp | MUSE | Muse Communications Corporation | Muse Communications Corporation | ||||||
| 6889-6899 | Unassigned | ||||||||||
| rtimeviewer | 6900 | tcp | R*TIME Viewer Data Interface | Curtiss-Wright Corporation | Robert Ammon | 2016-12-14 | |||||
| 6900 | udp | Reserved | |||||||||
| jetstream | 6901 | tcp | Novell Jetstream messaging protocol | Anil Tyagi | Anil Tyagi | 2010-06-11 | |||||
| 6901 | udp | Reserved | |||||||||
| 6902-6923 | Unassigned | ||||||||||
| split-ping | 6924 | tcp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| split-ping | 6924 | udp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| 6925-6934 | Unassigned | ||||||||||
| ethoscan | 6935 | tcp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| ethoscan | 6935 | udp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| xsmsvc | 6936 | tcp | XenSource Management Service | Roger Klorese | Roger Klorese | 2006-06 | |||||
| xsmsvc | 6936 | udp | XenSource Management Service | Roger Klorese | Roger Klorese | 2006-06 | |||||
| 6937-6945 | Unassigned | ||||||||||
| bioserver | 6946 | tcp | Biometrics Server | ISHII AKIO | ISHII AKIO | 2006-01 | |||||
| bioserver | 6946 | udp | Biometrics Server | ISHII AKIO | ISHII AKIO | 2006-01 | |||||
| 6947-6950 | Unassigned | ||||||||||
| otlp | 6951 | tcp | OTLP | Brent Foster | Brent Foster | 2006-04 | |||||
| otlp | 6951 | udp | OTLP | Brent Foster | Brent Foster | 2006-04 | |||||
| 6952-6960 | Unassigned | ||||||||||
| jmact3 | 6961 | tcp | JMACT3 | Yutaka Ono | Yutaka Ono | ||||||
| jmact3 | 6961 | udp | JMACT3 | Yutaka Ono | Yutaka Ono |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alberto Ortega Llamas | alberto.kun666&gmail.com | 2009-11-04 | |
| Alessandro Bassi | abassi&cs.utk.edu | ||
| Anil Tyagi | tanil&novell.com | 2010-06-11 | |
| Ben Cartwright-Cox | ben&benjojo.co.uk | 2020-02-12 | |
| IETF BFD Working Group Chairs | bfd-chairs&tools.ietf.org | 2014-01-09 | |
| Bill Edwards | bill.edwards&sun.com | 2005-08 | |
| Brent Foster | brent.foster&onstreamsystems.com | 2006-04 | |
| Curtiss-Wright Corporation | rammon&curtisswright.com | 2016-12-14 | |
| Dave Hubbard | dave&icc.net | ||
| Don Hejna | djhejna&ambit.com | ||
| ENSTEAM Sp. z o.o. | support&ensteam.com | 2015-07-08 | |
| Fermilab | neswold&fnal.gov | 2017-07-13 | |
| Fortra | info&fortra.com | 2023-05-24 | |
| Henriët Wilkinson | henriet.wilkinson&fortra.com | 2023-05-24 | |
| IESG | iesg&ietf.org | ||
| ISHII AKIO | ishii.akio&jp.fujitsu.com | 2006-01 | |
| Janos Lerch | lerch&softic.hu | 2006-02 | |
| Jude George | jude&nas.nasa.gov | ||
| Marty Campbell | martycðosinfo.com | 2011-06-10 | |
| Mathew Pitchforth | mathew&adinstruments.co.nz | 2005-08 | |
| Mike Spitzer | mjs&polyserve.com | 2005-08 | |
| Muse Communications Corporation | howard&muse3d.com | ||
| Oracle | shawn.emery&oracle.com | 2016-09-15 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Ratnadeep Bhattacharjee | ratnadeep.bhattacharjee&sun.com | 2002-11 | |
| Rich Neswold | neswold&fnal.gov | 2007-02 | |
| Robert Ammon | rammon&curtisswright.com | 2016-12-14 | |
| Robert Wetzold | robert.wetzold&fibotrader.com | 2006-01 | |
| Roger Klorese | roger&xensource.com | 2006-06 | |
| Sagara Wijetunga | Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 |
| Shawn Emery | shawn.emery&oracle.com | 2016-09-15 | |
| Stanley Knutson | Stanley.Knutson&ktiworld.com | ||
| Stefan Auweiler | stefan.auweiler&saitc.de | 2009-11-16 | |
| Thomas Weise | weise&vs.uni-kassel.de | 2006-04 | |
| Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 | |
| Tomasz Krakowiak | ENSTEAM Sp. z o.o. | tomasz.krakowiak&ensteam.com | 2015-07-08 |
| Urs Bertschinger | urs&netmosphere.com | ||
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |