Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
jmact3 6961 udp JMACT3 Yutaka Ono Yutaka Ono
jmevt2 6962 tcp jmevt2 Yutaka Ono Yutaka Ono
jmevt2 6962 udp jmevt2 Yutaka Ono Yutaka Ono
swismgr1 6963 tcp swismgr1 Yutaka Ono Yutaka Ono
swismgr1 6963 udp swismgr1 Yutaka Ono Yutaka Ono
swismgr2 6964 tcp swismgr2 Yutaka Ono Yutaka Ono
swismgr2 6964 udp swismgr2 Yutaka Ono Yutaka Ono
swistrap 6965 tcp swistrap Yutaka Ono Yutaka Ono
swistrap 6965 udp swistrap Yutaka Ono Yutaka Ono
swispol 6966 tcp swispol Yutaka Ono Yutaka Ono
swispol 6966 udp swispol Yutaka Ono Yutaka Ono
6967-6968 Unassigned
acmsoda 6969 tcp acmsoda Daniel Simms Daniel Simms
acmsoda 6969 udp acmsoda Daniel Simms Daniel Simms
conductor 6970 tcp Conductor test coordination protocol George Neville-Neil George Neville-Neil 2014-09-18
6970 udp Reserved
conductor-mpx 6970 sctp conductor for multiplex George Neville-Neil George Neville-Neil 2014-07-29
6971-6979 Unassigned
6980 tcp Reserved
qolyester 6980 udp QoS-extended OLSR protocol Green Communications SAS Ignacy Gawedzki 2022-05-24
6981-6996 Unassigned
MobilitySrv 6997 tcp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
MobilitySrv 6997 udp Mobility XE Protocol Joseph T Savarese Joseph T Savarese 2007-06
iatp-highpri 6998 tcp IATP-highPri John Murphy John Murphy
iatp-highpri 6998 udp IATP-highPri John Murphy John Murphy
iatp-normalpri 6999 tcp IATP-normalPri John Murphy John Murphy
iatp-normalpri 6999 udp IATP-normalPri John Murphy John Murphy
afs3-fileserver 7000 tcp file server itself
afs3-fileserver 7000 udp file server itself
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-prserver 7002 tcp users & groups database Known Unauthorized Use on port 7002
afs3-prserver 7002 udp users & groups database Known Unauthorized Use on port 7002
afs3-vlserver 7003 tcp volume location database
afs3-vlserver 7003 udp volume location database
afs3-kaserver 7004 tcp AFS/Kerberos authentication service
afs3-kaserver 7004 udp AFS/Kerberos authentication service
afs3-volser 7005 tcp volume managment server Known Unauthorized Use on port 7005
afs3-volser 7005 udp volume managment server Known Unauthorized Use on port 7005
afs3-errors 7006 tcp error interpretation service
afs3-errors 7006 udp error interpretation service
afs3-bos 7007 tcp basic overseer process
afs3-bos 7007 udp basic overseer process
afs3-update 7008 tcp server-to-server updater
afs3-update 7008 udp server-to-server updater
afs3-rmtsys 7009 tcp remote cache manager service
afs3-rmtsys 7009 udp remote cache manager service
ups-onlinet 7010 tcp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
ups-onlinet 7010 udp onlinet uninterruptable power supplies Jim Thompson Jim Thompson
talon-disc 7011 tcp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-disc 7011 udp Talon Discovery Port Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 tcp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
talon-engine 7012 udp Talon Engine Jim Thompson Jim Thompson Known Unauthorized Use on 7011
microtalon-dis 7013 tcp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-dis 7013 udp Microtalon Discovery Jim Thompson Jim Thompson
microtalon-com 7014 tcp Microtalon Communications Jim Thompson Jim Thompson
microtalon-com 7014 udp Microtalon Communications Jim Thompson Jim Thompson
talon-webserver 7015 tcp Talon Webserver Jim Thompson Jim Thompson
talon-webserver 7015 udp Talon Webserver Jim Thompson Jim Thompson
spg 7016 tcp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
spg 7016 udp SPG Controls Carrier SPG Controls Ltd Steve Barton 2017-03-27
grasp 7017 tcp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
grasp 7017 udp GeneRic Autonomic Signaling Protocol IESG IETF Chair 2017-04-28 2017-07-20 RFC 8990
fisa-svc 7018 tcp FISA Service FAUCONNET Ingénierie SA FAUCONNET Ingénierie SA 2011-05-19
7018 udp Reserved
doceri-ctl 7019 tcp doceri drawing service control Paul Brown Paul Brown 2011-04-27
doceri-view 7019 udp doceri drawing service screen view Paul Brown Paul Brown 2011-04-27
dpserve 7020 tcp DP Serve Allan Stanley Allan Stanley
dpserve 7020 udp DP Serve Allan Stanley Allan Stanley
dpserveadmin 7021 tcp DP Serve Admin Allan Stanley Allan Stanley
dpserveadmin 7021 udp DP Serve Admin Allan Stanley Allan Stanley
ctdp 7022 tcp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ctdp 7022 udp CT Discovery Protocol James Kirkwood James Kirkwood 2005-06
ct2nmcs 7023 tcp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
ct2nmcs 7023 udp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
vmsvc 7024 tcp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc 7024 udp Vormetric service Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 tcp Vormetric Service II Tom Boyle Tom Boyle 2005-06
vmsvc-2 7025 udp Vormetric Service II Tom Boyle Tom Boyle 2005-06
loreji-panel 7026 tcp Loreji Webhosting Panel J.A. Smit DALTCORE 2018-02-21
7026 udp Reserved
7027-7029 Unassigned
op-probe 7030 tcp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
op-probe 7030 udp ObjectPlanet probe Bjorn Jarle Kvande Bjorn Jarle Kvande 2002-04
iposplanet 7031 tcp IPOSPLANET retailing multi devices protocol Fabrice Paget Fabrice Paget 2012-10-23
7031 udp Reserved
7032-7039 Unassigned
7040 tcp Reserved
quest-disc 7040 udp Quest application level network service discovery Quest Software Henrik Johnson 2012-04-09
7041-7069 Unassigned
arcp 7070 tcp ARCP Jude George Jude George
arcp 7070 udp ARCP Jude George Jude George
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iba-cfg 7072 tcp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
iba-cfg-disc 7072 udp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
martalk 7073 tcp MarTalk protocol Mahr GmbH Göttingen Kevin Bube 2013-09-02
7073 udp Reserved
7074-7079 Unassigned
empowerid 7080 tcp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
empowerid 7080 udp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16

Contact Information

Name Organization Contact URI Last Updated
Alexander Melamed alexander.melamed&iba-ag.com 2018-02-12
Allan Stanley allan&hummingbird.com
Bjorn Jarle Kvande bjorn&objectplanet.com 2002-04
Bryan Wilcutt bwilcutt&comtechefdata.com 2005-06
DALTCORE Info&daltcore.com 2018-02-21
Daniel Simms dsimms&acm.uiuc.edu
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Fabrice Paget onefrench&me.com 2012-10-23
FAUCONNET Ingénierie SA dev&fisa.fr 2011-05-19
George Neville-Neil gnn&neville-neil.com 2014-07-29
Green Communications SAS contact&green-communications.fr 2022-05-24
Henrik Johnson Quest Software henrik.johnson&quest.com 2012-04-09
iba AG info&iba-ag.com 2018-02-12
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ignacy Gawedzki Green Communications SAS ignacy.gawedzki&green-communications.fr 2022-05-24
J.A. Smit rsmit&daltcore.com 2018-02-21
James Kirkwood james.kirkwood&controltechniques.com 2005-06
Jim Thompson jim.thompson&powerware.com
John Murphy john.m.murphy&mci.com
Joseph T Savarese joesa&nmwco.com 2007-06
Jude George jude&nas.nasa.gov
Kevin Bube Mahr GmbH Göttingen kevin.bube&mahr.de 2013-09-02
Mahr GmbH Göttingen info&mahr.de 2013-09-02
Matthew Whited matt&thedotnetfactory.com 2008-01-16
Paul Brown pbrown&spcontrols.com 2011-04-27
Quest Software iana.quest-disc&quest.com 2012-04-09
SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Steve Barton SPG Controls Ltd steveb&spgcontrols.com 2017-03-27
Tom Boyle tboyle&vormetric.com 2005-06
Yutaka Ono ono&saint.nm.fujitsu.co.jp