Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bolt 7687 tcp Bolt database connection Neo Technology, Inc Julian Simpson 2016-09-29
7687 udp Reserved
7688 Unassigned
collaber 7689 tcp Collaber Network Service Rajesh Akkineni Rajesh Akkineni 2007-01
collaber 7689 udp Collaber Network Service Rajesh Akkineni Rajesh Akkineni 2007-01
sovd 7690 tcp Service-Oriented Vehicle Diagnostics ASAM e.V. Bernd Wenzel 2022-07-01
7690 udp Reserved
7691-7696 Unassigned
klio 7697 tcp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08
klio 7697 udp KLIO communications Helmut Giritzer Helmut Giritzer 2005-08
7698-7699 Unassigned
em7-secom 7700 tcp EM7 Secure Communications Christopher Cordray Christopher Cordray 2008-06-05
7700 udp Reserved
7701 tcp Reserved
7701 udp Reserved
nfapi 7701 sctp SCF nFAPI defining MAC/PHY split Small Cell Forum Richard Kennedy 2017-01-24
7702-7706 Unassigned
sync-em7 7707 tcp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
sync-em7 7707 udp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
scinet 7708 tcp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
scinet 7708 udp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
7709-7719 Unassigned
medimageportal 7720 tcp MedImage Portal Robert Helton Robert Helton 2003-10
medimageportal 7720 udp MedImage Portal Robert Helton Robert Helton 2003-10
7721-7723 Unassigned
nsdeepfreezectl 7724 tcp Novell Snap-in Deep Freeze Control David Crowe David Crowe 2008-01-07
nsdeepfreezectl 7724 udp Novell Snap-in Deep Freeze Control David Crowe David Crowe 2008-01-07
nitrogen 7725 tcp Nitrogen Service Randy Lomnes Randy Lomnes 2004-11
nitrogen 7725 udp Nitrogen Service Randy Lomnes Randy Lomnes 2004-11
freezexservice 7726 tcp FreezeX Console Service David Crowe David Crowe 2005-06
freezexservice 7726 udp FreezeX Console Service David Crowe David Crowe 2005-06
trident-data 7727 tcp Trident Systems Data Jeremy McClintock Jeremy McClintock 2005-08
trident-data 7727 udp Trident Systems Data Jeremy McClintock Jeremy McClintock 2005-08
osvr 7728 tcp Open-Source Virtual Reality Open Source Virtual Reality (OSVR.com) Yuval Boger 2015-07-14
osvr 7728 udp Open-Source Virtual Reality Open Source Virtual Reality (OSVR.com) Yuval Boger 2015-07-14
osvr 7728 sctp Open-Source Virtual Reality Open Source Virtual Reality (OSVR.com) Yuval Boger 2015-07-14
7729-7733 Unassigned
smip 7734 tcp Smith Protocol over IP Guidant Measurement Jim Pettinato 2007-04 2024-10-08
smip 7734 udp Smith Protocol over IP Guidant Measurement Jim Pettinato 2007-04 2024-10-08
7735-7737 Unassigned
aiagent 7738 tcp HP Enterprise Discovery Agent Matthew Darwin Matthew Darwin 2005-08
aiagent 7738 udp HP Enterprise Discovery Agent Matthew Darwin Matthew Darwin 2005-08
7739-7740 Unassigned
scriptview 7741 tcp ScriptView Network Reinhard Wolf Reinhard Wolf 2010-08-19
scriptview 7741 udp ScriptView Network Reinhard Wolf Reinhard Wolf 2010-08-19
msss 7742 tcp Mugginsoft Script Server Service Jonathan Mitchell Jonathan Mitchell 2008-09-08
7742 udp Reserved
sstp-1 7743 tcp Sakura Script Transfer Protocol Kouichi Takeda Kouichi Takeda
sstp-1 7743 udp Sakura Script Transfer Protocol Kouichi Takeda Kouichi Takeda
raqmon-pdu 7744 tcp RAQMON PDU RFC 4712
raqmon-pdu 7744 udp RAQMON PDU RFC 4712
7745-7746 Unassigned
prgp 7747 tcp Put/Run/Get Protocol Jayasooriah Jayasooriah 2008-02-22
prgp 7747 udp Put/Run/Get Protocol Jayasooriah Jayasooriah 2008-02-22
7748-7776 Unassigned
inetfs 7775 tcp A File System using TLS over a wide area network Roger Allan Roger Allan 2016-01-28
7775 udp Reserved
7776 Unassigned
cbt 7777 tcp cbt Tony Ballardie Tony Ballardie Known Unauthorized Use on port 7777
cbt 7777 udp cbt Tony Ballardie Tony Ballardie Known Unauthorized Use on port 7777
interwise 7778 tcp Interwise Joseph Gray Joseph Gray
interwise 7778 udp Interwise Joseph Gray Joseph Gray
vstat 7779 tcp VSTAT Vinh Nguyn Vinh Nguyn
vstat 7779 udp VSTAT Vinh Nguyn Vinh Nguyn
7780 Unassigned
accu-lmgr 7781 tcp accu-lmgr Moises E. Hernandez Moises E. Hernandez
accu-lmgr 7781 udp accu-lmgr Moises E. Hernandez Moises E. Hernandez
7782-7783 Unassigned
s-bfd 7784 udp Seamless Bidirectional Forwarding Detection (S-BFD) IESG IETF Chair 2014-12-24 2016-07-14 RFC 7881
7784 tcp Reserved
7785 Unassigned Known Unauthorized Use on port 7785
minivend 7786 tcp MINIVEND Mike Heins Mike Heins Known Unauthorized Use on port 7786
minivend 7786 udp MINIVEND Mike Heins Mike Heins Known Unauthorized Use on port 7786
popup-reminders 7787 tcp Popup Reminders Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7787
popup-reminders 7787 udp Popup Reminders Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7787
7788 Unassigned Known Unauthorized Use on port 7788
office-tools 7789 tcp Office Tools Pro Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7789
office-tools 7789 udp Office Tools Pro Receive Robert Harvey Robert Harvey 2006-01 Known Unauthorized Use on port 7789
7790-7793 Unassigned
q3ade 7794 tcp Q3ADE Cluster Service Uffe Harksen Uffe Harksen 2005-08
q3ade 7794 udp Q3ADE Cluster Service Uffe Harksen Uffe Harksen 2005-08
7795-7796 Unassigned
pnet-conn 7797 tcp Propel Connector port
pnet-conn 7797 udp Propel Connector port
pnet-enc 7798 tcp Propel Encoder port Leif Hedstrom Leif Hedstrom 2002-04
pnet-enc 7798 udp Propel Encoder port Leif Hedstrom Leif Hedstrom 2002-04
altbsdp 7799 tcp Alternate BSDP Service Dieter Siegmund Dieter Siegmund 2007-10-22
altbsdp 7799 udp Alternate BSDP Service Dieter Siegmund Dieter Siegmund 2007-10-22
asr 7800 tcp Apple Software Restore Jim Kateley; Shantonu Sen Jim Kateley; Shantonu Sen 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
asr 7800 udp Apple Software Restore Jim Kateley; Shantonu Sen Jim Kateley; Shantonu Sen 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
ssp-client 7801 tcp Secure Server Protocol - client Rick Macchio Rick Macchio 2006-11
ssp-client 7801 udp Secure Server Protocol - client Rick Macchio Rick Macchio 2006-11
vns-tp 7802 udp Virtualized Network Services Tunnel Protocol Juniper Networks Bruno Rijsman 2013-02-01
7802 tcp Reserved
7803-7809 Unassigned
rbt-wanopt 7810 tcp Riverbed WAN Optimization Protocol Vladimir Legalov Vladimir Legalov 2007-09-04
rbt-wanopt 7810 udp Riverbed WAN Optimization Protocol Vladimir Legalov Vladimir Legalov 2007-09-04
7811-7844 Unassigned
apc-7845 7845 tcp APC 7845 American Power Conversion American Power Conversion
apc-7845 7845 udp APC 7845 American Power Conversion American Power Conversion
apc-7846 7846 tcp APC 7846 American Power Conversion American Power Conversion

Contact Information

Name Organization Contact URI Last Updated
American Power Conversion ports&apcc.com 2002-02
ASAM e.V. marius.dupuis&asam.net 2022-07-01
Bernd Wenzel ASAM e.V. bernd.wenzel&asam.net 2022-07-01
Bruno Rijsman Juniper Networks brijsman&juniper.net 2013-02-01
Christoph Anton Mitterer calestyo&scientia.net 2009-03-10
Christopher Cordray ccordray&sciencelogic.com 2008-06-05
David Crowe dcrowe&faronics.com 2008-01-07
Dieter Siegmund dieter&apple.com 2007-10-22
Guidant Measurement james.pettinato&guidantmeasurement.com 2024-10-08
Helmut Giritzer helmut.giritzer&o.roteskreuz.at 2005-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jayasooriah jayasooriah&cast.com.au 2008-02-22
Jeremy McClintock jeremy&tridsys.com 2005-08
Jim Kateley asr-dev&group.apple.com 2006-01
Jim Pettinato james.pettinato&guidantmeasurement.com 2024-10-08
Jonathan Mitchell jonathan&mugginsoft.com 2008-09-08
Joseph Gray gray&interwise.co.il
Julian Simpson Neo Technology, Inc julian.simpson&neotechnology.com 2016-09-29
Juniper Networks brijsman&juniper.net 2013-02-01
Kouichi Takeda KHBO5271&nifty.com
Leif Hedstrom leif&propel.com 2002-04
Matthew Darwin matthew.darwin&hp.com 2005-08
Mike Heins mike&minivend.com
Moises E. Hernandez moises&accugraph.com
Neo Technology, Inc admins&neotechnology.com 2016-09-29
Open Source Virtual Reality (OSVR.com) iana&sensics.com 2015-07-14
Rajesh Akkineni rajesh&vimukti.com 2007-01
Randy Lomnes rlomnes&faronics.com 2004-11
Reinhard Wolf Adsoft AG adsoft&vtxmail.ch 2010-08-19
Richard Kennedy Richard&smallcellforum.org 2017-01-24
Rick Macchio rmacchio&juniper.net 2006-11
Robert Harvey robert&officetoolspro.com 2006-01
Robert Helton bob_helton&medimage.com 2003-10
Roger Allan rallan&inetfs.org 2016-01-28
Shantonu Sen ssen&apple.com
Small Cell Forum Richard&smallcellforum.org 2017-01-24
Tony Ballardie A.Ballardie&cs.ucl.ac.uk
Uffe Harksen uh&uhcommunications.com 2005-08
Vinh Nguyn vinh&sportvision.com
Vladimir Legalov vlegalov&riverbed.com 2007-09-04
Yuval Boger iana&sensics.com 2015-07-14