Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| apc-7846 | 7846 | tcp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| apc-7846 | 7846 | udp | APC 7846 | American Power Conversion | American Power Conversion | ||||||
| csoauth | 7847 | tcp | A product key authentication protocol made by CSO | Jeff Wamsley | Jacob Kiesel | 2013-09-04 | |||||
| 7847 | udp | Reserved | |||||||||
| 7848-7868 | Unassigned | ||||||||||
| mobileanalyzer | 7869 | tcp | MobileAnalyzer& MobileMonitor | Jonas Gyllensvaan | Jonas Gyllensvaan | 2009-04-27 | |||||
| 7869 | udp | Reserved | |||||||||
| rbt-smc | 7870 | tcp | Riverbed Steelhead Mobile Service | Gabriel Levy | Gabriel Levy | 2008-08-29 | |||||
| 7870 | udp | Reserved | |||||||||
| mdm | 7871 | tcp | Mobile Device Management | Dan Harkins | Dan Harkins | 2011-08-15 | |||||
| 7871 | udp | Reserved | |||||||||
| 7872 | tcp | Reserved | |||||||||
| mipv6tls | 7872 | udp | TLS-based Mobile IPv6 Security | IESG | IETF Chair | 2012-04-12 | RFC 6618 | ||||
| 7873-7877 | Unassigned | ||||||||||
| owms | 7878 | tcp | Opswise Message Service | Stonebranch, Inc. | Nathan Hammond | 2013-06-25 | |||||
| 7878 | udp | Reserved | |||||||||
| 7879 | Unassigned | ||||||||||
| pss | 7880 | tcp | Pearson | Pearson | Pearson | 2008-01-17 | |||||
| pss | 7880 | udp | Pearson | Pearson | Pearson | 2008-01-17 | |||||
| 7881-7886 | Unassigned | ||||||||||
| ubroker | 7887 | tcp | Universal Broker | Nathan Hammond | Nathan Hammond | 2005-10 | |||||
| ubroker | 7887 | udp | Universal Broker | Nathan Hammond | Nathan Hammond | 2005-10 | |||||
| 7888-7899 | Unassigned | ||||||||||
| mevent | 7900 | tcp | Multicast Event | YoonSoo Kim | YoonSoo Kim | 2006-05 | |||||
| mevent | 7900 | udp | Multicast Event | YoonSoo Kim | YoonSoo Kim | 2006-05 | |||||
| tnos-sp | 7901 | tcp | TNOS Service Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-sp | 7901 | udp | TNOS Service Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dp | 7902 | tcp | TNOS shell Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dp | 7902 | udp | TNOS shell Protocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dps | 7903 | tcp | TNOS Secure DiaguardProtocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| tnos-dps | 7903 | udp | TNOS Secure DiaguardProtocol | Rene Kurt | Rene Kurt | 2005-08 | |||||
| 7904-7912 | Unassigned | ||||||||||
| qo-secure | 7913 | tcp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| qo-secure | 7913 | udp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| 7914-7931 | Unassigned | ||||||||||
| t2-drm | 7932 | tcp | Tier 2 Data Resource Manager | Peter Carlson | Peter Carlson | ||||||
| t2-drm | 7932 | udp | Tier 2 Data Resource Manager | Peter Carlson | Peter Carlson | ||||||
| t2-brm | 7933 | tcp | Tier 2 Business Rules Manager | Peter Carlson | Peter Carlson | ||||||
| t2-brm | 7933 | udp | Tier 2 Business Rules Manager | Peter Carlson | Peter Carlson | ||||||
| 7934-7961 | Unassigned | ||||||||||
| generalsync | 7962 | tcp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| generalsync | 7962 | udp | Encrypted, extendable, general-purpose synchronization protocol | Dirk Steinmetz | Dirk Steinmetz | 2014-04-17 | |||||
| 7963-7966 | Unassigned | ||||||||||
| supercell | 7967 | tcp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| supercell | 7967 | udp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| 7968-7978 | Unassigned | ||||||||||
| micromuse-ncps | 7979 | tcp | Micromuse-ncps | Hing Wing To | Hing Wing To | ||||||
| micromuse-ncps | 7979 | udp | Micromuse-ncps | Hing Wing To | Hing Wing To | ||||||
| quest-vista | 7980 | tcp | Quest Vista | Preston Bannister | Preston Bannister | ||||||
| quest-vista | 7980 | udp | Quest Vista | Preston Bannister | Preston Bannister | ||||||
| sossd-collect | 7981 | tcp | Spotlight on SQL Server Desktop Collect | Rob Griffin | Rob Griffin | 2010-08-30 | |||||
| 7981 | udp | Reserved | |||||||||
| sossd-agent | 7982 | tcp | Spotlight on SQL Server Desktop Agent | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| sossd-disc | 7982 | udp | Spotlight on SQL Server Desktop Agent Discovery | Rob Griffin | Rob Griffin | 2010-09-13 | |||||
| 7983-7997 | Unassigned | ||||||||||
| pushns | 7997 | tcp | PUSH Notification Service | Tristan Seifert | Tristan Seifert | 2011-01-31 | |||||
| 7997 | udp | Reserved | |||||||||
| 7998 | tcp | Reserved | |||||||||
| usicontentpush | 7998 | udp | USI Content Push Service | Prakash Iyer | Prakash Iyer | 2009-08-10 | |||||
| irdmi2 | 7999 | tcp | iRDMI2 | ||||||||
| irdmi2 | 7999 | udp | iRDMI2 | ||||||||
| irdmi | 8000 | tcp | iRDMI | Gil Shafriri | Gil Shafriri | ||||||
| irdmi | 8000 | udp | iRDMI | Gil Shafriri | Gil Shafriri | ||||||
| vcom-tunnel | 8001 | tcp | VCOM Tunnel | Mark Lewandowski | Mark Lewandowski | Known Unauthorized Use on port 8001 | |||||
| vcom-tunnel | 8001 | udp | VCOM Tunnel | Mark Lewandowski | Mark Lewandowski | Known Unauthorized Use on port 8001 | |||||
| teradataordbms | 8002 | tcp | Teradata ORDBMS | Curt Ellmann | Curt Ellmann | ||||||
| teradataordbms | 8002 | udp | Teradata ORDBMS | Curt Ellmann | Curt Ellmann | ||||||
| mcreport | 8003 | tcp | Mulberry Connect Reporting Service | Dave Stoneham | Dave Stoneham | 2008-03-10 | |||||
| mcreport | 8003 | udp | Mulberry Connect Reporting Service | Dave Stoneham | Dave Stoneham | 2008-03-10 | |||||
| p2pevolvenet | 8004 | tcp | Opensource Evolv Enterprise Platform P2P Network Node Connection Protocol | Tris Puki | Adrians Borsteins | 2018-01-16 | |||||
| 8004 | udp | Reserved | |||||||||
| mxi | 8005 | tcp | MXI Generation II for z/OS | Rob Scott | Rob Scott | 2007-05 | |||||
| mxi | 8005 | udp | MXI Generation II for z/OS | Rob Scott | Rob Scott | 2007-05 | |||||
| wpl-analytics | 8006 | tcp | World Programming analytics | World Programming Limited | Thomas Quarendon | 2017-04-04 | |||||
| wpl-disc | 8006 | udp | World Programming analytics discovery | World Programming Limited | Thomas Quarendon | 2017-04-04 | |||||
| warppipe | 8007 | tcp | I/O oriented cluster computing software | MirrorWeb LTD | Jonathan Kingsley | 2017-07-19 | |||||
| warppipe | 8007 | udp | I/O oriented cluster computing software | MirrorWeb LTD | Jonathan Kingsley | 2017-07-19 | |||||
| http-alt | 8008 | tcp | HTTP Alternate | James Gettys | James Gettys | ||||||
| http-alt | 8008 | udp | HTTP Alternate | James Gettys | James Gettys | ||||||
| nvme-disc | 8009 | tcp | NVMe over Fabrics Discovery Service | NVM Express, Inc. | Amber Huffman | 2018-03-27 | |||||
| 8009 | udp | Reserved | |||||||||
| 8010 | Reserved | 2018-01-09 | yes | ||||||||
| 8011-8014 | Unassigned | ||||||||||
| cfg-cloud | 8015 | tcp | Configuration Cloud Service | admin_at_cfg_cloud | Goksel Darcan | 2019-01-09 | |||||
| 8015 | udp | Reserved | |||||||||
| ads-s | 8016 | tcp | Beckhoff Automation Device Specification | Beckhoff Automation GmbH & Co. KG | Henning Mersch | 2019-02-28 | |||||
| 8016 | udp | Reserved | |||||||||
| 8017 | tcp | Reserved | |||||||||
| cisco-cloudsec | 8017 | udp | Cisco Cloudsec Dataplane Port Number | Cisco Systems, Inc. | Govind Sharma | 2021-03-18 | |||||
| 8018 | Unassigned | ||||||||||
| qbdb | 8019 | tcp | QB DB Dynamic Port | Sridhar Krishnamurthy | Sridhar Krishnamurthy | 2008-02-15 | |||||
| qbdb | 8019 | udp | QB DB Dynamic Port | Sridhar Krishnamurthy | Sridhar Krishnamurthy | 2008-02-15 | |||||
| intu-ec-svcdisc | 8020 | tcp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-svcdisc | 8020 | udp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-client | 8021 | tcp | Intuit Entitlement Client | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-client | 8021 | udp | Intuit Entitlement Client | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| oa-system | 8022 | tcp | oa-system | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| oa-system | 8022 | udp | oa-system | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| arca-api | 8023 | tcp | ARCATrust vault API | ARCATrust SA | Yacince Felk | 2018-07-05 | |||||
| arca-api | 8023 | udp | ARCATrust vault API | ARCATrust SA | Yacince Felk | 2018-07-05 | |||||
| 8024 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| admin_at_cfg_cloud | gdarcan&gmail.com | 2019-01-09 | |
| Adrians Borsteins | evolv&protonmail.com | 2018-01-16 | |
| Amber Huffman | amber.huffman&intel.com | 2018-03-27 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| ARCATrust SA | info&arcatrust.io | 2018-07-05 | |
| Beckhoff Automation GmbH & Co. KG | legal&beckhoff.com | 2019-02-28 | |
| Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 | |
| Curt Ellmann | curt.ellmann&ncr.com | ||
| Dan Harkins | dharkins&lounge.org | 2011-08-15 | |
| Daniel C. McGloin | daniel_mcgloin&intuit.com | 2005-05 | |
| Dave Stoneham | dave&mulberry-consultants.co.uk | 2008-03-10 | |
| Dirk Steinmetz | ds&generalsync.com | 2014-04-17 | |
| Gabriel Levy | glevy&riverbed.com | 2008-08-29 | |
| Gil Shafriri | shafriri&ilccm1.iil.intel.com | ||
| Goksel Darcan | gdarcan&gmail.com | 2019-01-09 | |
| Govind Sharma | Cisco Systems, Inc. | gosharma&cisco.com | 2021-03-18 |
| Henning Mersch | support&beckhoff.com | 2019-02-28 | |
| Hing Wing To | wing.to&mircromuse.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jacob Kiesel | gocso.net | jake.k&gocso.net | 2013-09-04 |
| James Gettys | jg&w3.org | ||
| Jeff Wamsley | gocso.net | jeffw&gocso.net | 2013-09-04 |
| Jonas Bovin | jonas.bovin&quickobjects.com | ||
| Jonas Gyllensvaan | jonas&conceivium.com | 2009-04-27 | |
| Jonathan Kingsley | jon&mirrorweb.com | 2017-07-19 | |
| Kevin Nakagawa | nakagawa&sigsci.com | ||
| Marie-France Dubreuil | Marie-France.Dubreuil&evidian.com | 2002-11 | |
| Mark Lewandowski | mlewan0&us.ibm.com | ||
| MirrorWeb LTD | jon&mirrorweb.com | 2017-07-19 | |
| Nathan Hammond | nathan.hammond&stonebranch.com | 2005-10 | |
| Nathan Hammond | Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 |
| NVM Express, Inc. | admin&nvmexpress.org | 2018-03-27 | |
| Pearson | chad.smith&pearson.com | 2008-01-17 | |
| Peter Carlson | pcarlson&tier2.com | ||
| Prakash Iyer | prakash.iyer&intel.com | 2009-08-10 | |
| Preston Bannister | pbannister&quests.com | ||
| Rene Kurt | rene.kurt&adasoft.ch | 2005-08 | |
| Rob Griffin | rob.gri55in&gmail.com | 2010-09-13 | |
| Rob Scott | rscott&rs.com | 2007-05 | |
| Sridhar Krishnamurthy | Sridhar_Krishnamurthy&intuit.com | 2008-02-15 | |
| Stonebranch, Inc. | nathan.hammond&stonebranch.com | 2013-06-25 | |
| Thomas Quarendon | World Programming Limited | tom.quarendon&worldprogramming.com | 2017-04-04 |
| Tris Puki | evolv&protonmail.com | 2018-01-16 | |
| Tristan Seifert | admin&247server.net | 2011-01-31 | |
| World Programming Limited | support&worldprogramming.com | 2017-04-04 | |
| Yacince Felk | yacine&arcatrust.io | 2018-07-05 | |
| YoonSoo Kim | ys71.kim&samsung.com | 2006-05 |