Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcpv6-client 546 udp DHCPv6 Client IESG IETF Chair 2018-05-21 RFC 9915
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
afpovertcp 548 tcp AFP over TCP Leland Wallace Leland Wallace Defined TXT keys: u=<username> p=<password> path=<path>
afpovertcp 548 udp AFP over TCP Leland Wallace Leland Wallace Defined TXT keys: u=<username> p=<password> path=<path>
idfp 549 tcp IDFP Ramana Kovi Ramana Kovi
idfp 549 udp IDFP Ramana Kovi Ramana Kovi
new-rwho 550 tcp new-who n/a
new-rwho 550 udp new-who n/a
cybercash 551 tcp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
cybercash 551 udp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
devshr-nts 552 tcp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
devshr-nts 552 udp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
pirp 553 tcp pirp D. J. Bernstein D. J. Bernstein
pirp 553 udp pirp D. J. Bernstein D. J. Bernstein
rtsp 554 tcp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
rtsp 554 udp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
dsf 555 tcp
dsf 555 udp
remotefs 556 tcp rfs server
remotefs 556 udp rfs server
openvms-sysipc 557 tcp openvms-sysipc Alan Potter Alan Potter
openvms-sysipc 557 udp openvms-sysipc Alan Potter Alan Potter
sdnskmp 558 tcp SDNSKMP
sdnskmp 558 udp SDNSKMP
teedtap 559 tcp TEEDTAP Charlie Limoges Charlie Limoges
teedtap 559 udp TEEDTAP Charlie Limoges Charlie Limoges
rmonitor 560 tcp rmonitord
rmonitor 560 udp rmonitord
monitor 561 tcp
monitor 561 udp
chshell 562 tcp chcmd
chshell 562 udp chcmd
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
9pfs 564 tcp plan 9 file service
9pfs 564 udp plan 9 file service
whoami 565 tcp whoami
whoami 565 udp whoami
streettalk 566 tcp streettalk
streettalk 566 udp streettalk
banyan-rpc 567 tcp banyan-rpc Tom Lemaire Tom Lemaire
banyan-rpc 567 udp banyan-rpc Tom Lemaire Tom Lemaire
ms-shuttle 568 tcp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-shuttle 568 udp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-rome 569 tcp microsoft rome Rudolph Balaz Rudolph Balaz
ms-rome 569 udp microsoft rome Rudolph Balaz Rudolph Balaz
meter 570 tcp demon
meter 570 udp demon
meter 571 tcp udemon
meter 571 udp udemon
sonar 572 tcp sonar Keith Moore Keith Moore
sonar 572 udp sonar Keith Moore Keith Moore
banyan-vip 573 tcp banyan-vip Denis Leclerc Denis Leclerc
banyan-vip 573 udp banyan-vip Denis Leclerc Denis Leclerc
ftp-agent 574 tcp FTP Software Agent System Michael S. Greenberg Michael S. Greenberg
ftp-agent 574 udp FTP Software Agent System Michael S. Greenberg Michael S. Greenberg
vemmi 575 tcp VEMMI Daniel Mavrakis Daniel Mavrakis
vemmi 575 udp VEMMI Daniel Mavrakis Daniel Mavrakis
ipcd 576 tcp ipcd
ipcd 576 udp ipcd
vnas 577 tcp vnas
vnas 577 udp vnas
ipdd 578 tcp ipdd Jay Farhat Jay Farhat
ipdd 578 udp ipdd Jay Farhat Jay Farhat
decbsrv 579 tcp decbsrv Rudi Martin Rudi Martin
decbsrv 579 udp decbsrv Rudi Martin Rudi Martin
sntp-heartbeat 580 tcp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
sntp-heartbeat 580 udp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
bdp 581 tcp Bundle Discovery Protocol Gary Malkin Gary Malkin
bdp 581 udp Bundle Discovery Protocol Gary Malkin Gary Malkin
scc-security 582 tcp SCC Security Prashant Dholakia Prashant Dholakia
scc-security 582 udp SCC Security Prashant Dholakia Prashant Dholakia
philips-vc 583 tcp Philips Video-Conferencing Janna Chang Janna Chang
philips-vc 583 udp Philips Video-Conferencing Janna Chang Janna Chang
keyserver 584 tcp Key Server Gary Howland Gary Howland
keyserver 584 udp Key Server Gary Howland Gary Howland
585 De-registered 2006-04-25 Use of 585 is not recommended, use 993 instead
password-chg 586 tcp Password Change
password-chg 586 udp Password Change
submission 587 tcp Message Submission 2011-11-17 RFC 6409
submission 587 udp Message Submission 2011-11-17 RFC 6409
cal 588 tcp CAL Myron Hattig Myron Hattig
cal 588 udp CAL Myron Hattig Myron Hattig
eyelink 589 tcp EyeLink Dave Stampe Dave Stampe
eyelink 589 udp EyeLink Dave Stampe Dave Stampe
tns-cml 590 tcp TNS CML Jerome Albin Jerome Albin
tns-cml 590 udp TNS CML Jerome Albin Jerome Albin
http-alt 591 tcp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
http-alt 591 udp FileMaker, Inc. - HTTP Alternate (see Port 80) Clay Maeckel Clay Maeckel
eudora-set 592 tcp Eudora Set Randall Gellens Randall Gellens
eudora-set 592 udp Eudora Set Randall Gellens Randall Gellens
http-rpc-epmap 593 tcp HTTP RPC Ep Map Edward Reus Edward Reus
http-rpc-epmap 593 udp HTTP RPC Ep Map Edward Reus Edward Reus
tpip 594 tcp TPIP Brad Spear Brad Spear
tpip 594 udp TPIP Brad Spear Brad Spear
cab-protocol 595 tcp CAB Protocol Winston Hetherington Winston Hetherington
cab-protocol 595 udp CAB Protocol Winston Hetherington Winston Hetherington
smsd 596 tcp SMSD Wayne Barlow Wayne Barlow
smsd 596 udp SMSD Wayne Barlow Wayne Barlow
ptcnameservice 597 tcp PTC Name Service Yuri Machkasov Yuri Machkasov

Contact Information

Name Organization Contact URI Last Updated
Alan Potter potter&movies.enet.dec.com
Benjamin Rosenberg brosenberg&advsyscon.com
Brad Spear spear&platinum.com
Charlie Limoges Charlie.Limoges&gdc4s.com
Clay Maeckel clay&claris.com 2023-09-12
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Daniel Mavrakis mavrakis&mctel.fr
Dave Stampe dstampe&psych.toronto.edu
Denis Leclerc DLeclerc&banyan.com
Donald E. Eastlake 3rd d3e3e3&gmail.com
Edward Reus edwardr&microsoft.com
Gary Howland gary&systemics.com
Gary Malkin gmalkin&xylogics.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Janna Chang janna&pmc.philips.com
Jay Farhat jfarhat&ipass.com
Jerome Albin albin&taec.enet.dec.com
Keith Moore moore&cs.utk.edu
Leland Wallace randall&apple.com
Louis Mamakos louie&uu.net
Michael S. Greenberg arnoff&ftp.com
Myron Hattig Myron_Hattig&ccm.jf.intel.com
Prashant Dholakia prashant&semaphorecom.com
Ramana Kovi ramana&kovi.com
Randall Gellens rg+ietf&coretechnologyconsulting.com 2024-07-29
Rob Lanphier robla&prognet.com
Rudi Martin movies::martin%22@movies.enet.dec.com
Rudolph Balaz rudolphb&microsoft.com
Tom Lemaire toml&banyan.com
Wayne Barlow web&unx.dec.com
Winston Hetherington
Yuri Machkasov yuri&ptc.com