Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mtl8000-matrix 8115 udp MTL8000 Matrix David Pinch David Pinch 2002-04
cp-cluster 8116 tcp Check Point Clustering Roni Moshitzky Roni Moshitzky
cp-cluster 8116 udp Check Point Clustering Roni Moshitzky Roni Moshitzky
purityrpc 8117 tcp Purity replication clustering and remote management Pure Storage Steve Hodgson 2013-08-13
8117 udp Reserved
privoxy 8118 tcp Privoxy HTTP proxy Andreas Oesterhelt Andreas Oesterhelt 2002-06
privoxy 8118 udp Privoxy HTTP proxy Andreas Oesterhelt Andreas Oesterhelt 2002-06
8119-8120 Unassigned
apollo-data 8121 tcp Apollo Data Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-data 8121 udp Apollo Data Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-admin 8122 tcp Apollo Admin Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-admin 8122 udp Apollo Admin Port Anthony Carrabino Anthony Carrabino 2003-08
8123-8127 Unassigned
paycash-online 8128 tcp PayCash Online Protocol MegaZone MegaZone 2005-08
paycash-online 8128 udp PayCash Online Protocol MegaZone MegaZone 2005-08
paycash-wbp 8129 tcp PayCash Wallet-Browser MegaZone MegaZone 2005-08
paycash-wbp 8129 udp PayCash Wallet-Browser MegaZone MegaZone 2005-08
indigo-vrmi 8130 tcp INDIGO-VRMI Colin Caughie Colin Caughie
indigo-vrmi 8130 udp INDIGO-VRMI Colin Caughie Colin Caughie
indigo-vbcp 8131 tcp INDIGO-VBCP Colin Caughie Colin Caughie
indigo-vbcp 8131 udp INDIGO-VBCP Colin Caughie Colin Caughie
dbabble 8132 tcp dbabble Chris Pugmire Chris Pugmire
dbabble 8132 udp dbabble Chris Pugmire Chris Pugmire
8133-8139 Unassigned
puppet 8140 tcp The Puppet master service Puppet Charles Dunbar 2014-09-18
8140 udp Reserved
8141-8147 Unassigned
isdd 8148 tcp i-SDD file transfer Frank Waarsenburg Frank Waarsenburg 2004-11
isdd 8148 udp i-SDD file transfer Frank Waarsenburg Frank Waarsenburg 2004-11
8149 tcp Reserved
eor-game 8149 udp Edge of Reality game data Sky Schulz Sky Schulz 2011-05-09
8150-8152 Unassigned
quantastor 8153 tcp QuantaStor Management Interface OS NEXUS, Inc. Steven Umbehocker 2012-09-21
8153 udp Reserved
8154-8159 Unassigned
patrol 8160 tcp Patrol Portnoy Boxman Portnoy Boxman
patrol 8160 udp Patrol Portnoy Boxman Portnoy Boxman
patrol-snmp 8161 tcp Patrol SNMP Portnoy Boxman Portnoy Boxman
patrol-snmp 8161 udp Patrol SNMP Portnoy Boxman Portnoy Boxman
lpar2rrd 8162 tcp LPAR2RRD client server communication LPAR2RRD project Pavel Hampl 2013-08-14
8162 udp Reserved
8163-8180 Unassigned
intermapper 8181 tcp Intermapper network management system William Fisher William Fisher 2011-05-09
8181 udp Reserved
vmware-fdm 8182 tcp VMware Fault Domain Manager Ron Passerini Ron Passerini 2010-04-27
vmware-fdm 8182 udp VMware Fault Domain Manager Ron Passerini Ron Passerini 2010-04-27
proremote 8183 tcp ProRemote Alex Lelievre Alex Lelievre 2009-08-18
8183 udp Reserved
itach 8184 tcp Remote iTach Connection Barend Jacobus van der Merwe Barend Jacobus van der Merwe 2010-04-27
itach 8184 udp Remote iTach Connection Barend Jacobus van der Merwe Barend Jacobus van der Merwe 2010-04-27
8185-8189 Unassigned
gcp-rphy 8190 tcp Generic control plane for RPHY CableLabs Karthik Sundaresan 2015-11-24
8190 udp Reserved
limnerpressure 8191 tcp Limner Pressure Aaron Kleinsteiber Aaron Kleinsteiber 2014-01-16
8191 udp Reserved
spytechphone 8192 tcp SpyTech Phone Service Bill Kay Bill Kay 2006-04
spytechphone 8192 udp SpyTech Phone Service Bill Kay Bill Kay 2006-04
8193 Unassigned
blp1 8194 tcp Bloomberg data API Albert Hou Albert Hou 2006-05
blp1 8194 udp Bloomberg data API Albert Hou Albert Hou 2006-05
blp2 8195 tcp Bloomberg feed Albert Hou Albert Hou 2006-05
blp2 8195 udp Bloomberg feed Albert Hou Albert Hou 2006-05
8196-8198 Unassigned
vvr-data 8199 tcp VVR DATA Ming Xu Ming Xu
vvr-data 8199 udp VVR DATA Ming Xu Ming Xu
trivnet1 8200 tcp TRIVNET Saar Wilf Saar Wilf
trivnet1 8200 udp TRIVNET Saar Wilf Saar Wilf
trivnet2 8201 tcp TRIVNET Saar Wilf Saar Wilf
trivnet2 8201 udp TRIVNET Saar Wilf Saar Wilf
8202 tcp Reserved
aesop 8202 udp Audio+Ethernet Standard Open Protocol POWERSOFT S.R.L. Paolo Desii; Claudio Lastrucci 2012-01-03
8203-8203 Unassigned
lm-perfworks 8204 tcp LM Perfworks Chris Flynn Chris Flynn
lm-perfworks 8204 udp LM Perfworks Chris Flynn Chris Flynn
lm-instmgr 8205 tcp LM Instmgr Chris Flynn Chris Flynn
lm-instmgr 8205 udp LM Instmgr Chris Flynn Chris Flynn
lm-dta 8206 tcp LM Dta Chris Flynn Chris Flynn
lm-dta 8206 udp LM Dta Chris Flynn Chris Flynn
lm-sserver 8207 tcp LM SServer Chris Flynn Chris Flynn
lm-sserver 8207 udp LM SServer Chris Flynn Chris Flynn
lm-webwatcher 8208 tcp LM Webwatcher Chris Flynn Chris Flynn
lm-webwatcher 8208 udp LM Webwatcher Chris Flynn Chris Flynn
8209-8210 Unassigned
8211 tcp Reserved
aruba-papi 8211 udp Aruba Networks AP management Aruba Networks Jon Green 2018-10-04
8212-8229 Unassigned
rexecj 8230 tcp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
rexecj 8230 udp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
8231 tcp Reserved
hncp-udp-port 8231 udp HNCP IESG IETF Chair 2016-01-13 RFC 7788
8232 tcp Reserved
hncp-dtls-port 8232 udp HNCP over DTLS IESG IETF Chair 2016-01-13 RFC 7788
8233-8242 Unassigned
synapse-nhttps 8243 tcp Synapse Non Blocking HTTPS Ruwan Linton Ruwan Linton 2008-07-10
synapse-nhttps 8243 udp Synapse Non Blocking HTTPS Ruwan Linton Ruwan Linton 2008-07-10
8244-8265 Unassigned
8266 tcp Reserved
espeasy-p2p 8266 udp ESPeasy peer-2-peer communication ESPeasy Gijs Noorlander 2018-11-28
8267-8269 Unassigned
robot-remote 8270 tcp Robot Framework Remote Library Interface Robot Framework Foundation Chris Newman 2017-01-26
8270 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Aaron Kleinsteiber protocol&limnerapp.com 2014-01-16
Albert Hou ahou1&bloomberg.com 2006-05
Alex Lelievre alex&folabs.com 2009-08-18
Andreas Oesterhelt oes&privoxy.org 2002-06
Anthony Carrabino anthonyc&vistasoftware.com 2003-08
Aruba Networks jon.green&hpe.com 2018-10-04
Barend Jacobus van der Merwe berneau.v&gmail.com 2010-04-27
Bill Kay bkay&spy-tec.com 2006-04
CableLabs info&cablelabs.com 2015-11-24
Charles Dunbar Puppet charles&puppet.com 2016-04-12
Chris Flynn cflynn&landmark.com
Chris Newman chris.newman&oracle.com 2017-01-26
Chris Pugmire chrisp&netwinsite.com
Claudio Lastrucci POWERSOFT S.R.L. claudio.lastrucci&powersoft.it 2012-01-03
Colin Caughie cfc&indigo-avs.com
Curtiss Howard cjhoward&unity.ncsu.edu 2004-11
David Pinch dpinch&mtl-inst.com 2002-04
ESPeasy gijs.noorlander&gmail.com 2018-11-28
Frank Waarsenburg frank&eye-display.nl 2004-11
Gijs Noorlander gijs.noorlander&gmail.com 2018-11-28
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jon Green Aruba Networks jon.green&hpe.com 2018-10-04
Karthik Sundaresan k.sundaresan&cablelabs.com 2015-11-24
LPAR2RRD project pavel.hampl&lpar2rrd.com 2013-08-14
MegaZone megazone&paycash.us 2005-08
Ming Xu ming&veritas.com
OS NEXUS, Inc. info&osnexus.com 2012-09-21
Paolo Desii POWERSOFT S.R.L. paolo.desii&powersoft.it 2012-01-03
Pavel Hampl LPAR2RRD project pavel.hampl&lpar2rrd.com 2013-08-14
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
POWERSOFT S.R.L. claudio.lastrucci&powersoft.it 2012-01-03
Puppet sysops-dept&puppetlabs.com 2016-04-12
Pure Storage iana&purestorage.com 2016-04-04
Robot Framework Foundation robotframework-foundation&googlegroups.com 2017-01-26
Ron Passerini rpasserini&vmware.com 2010-04-27
Roni Moshitzky rmosh&checkpoint.com
Ruwan Linton ruwan&wso2.com 2008-08-20
Saar Wilf saar&trivnet.com
Sky Schulz sky&edgeofreality.com 2011-05-09
Steve Hodgson Pure Storage steve&purestorage.com 2013-08-13
Steven Umbehocker OS NEXUS, Inc. steven.umbehocker&osnexus.com 2012-09-21
William Fisher william.w.fisher&intermapper.com 2011-05-09