Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cisco-avp 8470 tcp Cisco Address Validation Protocol Cullen Jennings Cullen Jennings 2009-02-13
8470 udp Reserved
pim-port 8471 tcp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
pim-port 8471 sctp PIM over Reliable Transport IESG IETF Chair 2008-08-21 RFC 6559
8471 udp Reserved
otv 8472 tcp Overlay Transport Virtualization (OTV) Dino Farinacci Dino Farinacci 2008-01-07
otv 8472 udp Overlay Transport Virtualization (OTV) Dino Farinacci Dino Farinacci 2008-01-07
vp2p 8473 tcp Virtual Point to Point Jerome Grimbert Jerome Grimbert
vp2p 8473 udp Virtual Point to Point Jerome Grimbert Jerome Grimbert
noteshare 8474 tcp AquaMinds NoteShare Michael McNabb Michael McNabb 2005-10
noteshare 8474 udp AquaMinds NoteShare Michael McNabb Michael McNabb 2005-10
8475-8499 Unassigned
fmtp 8500 tcp Flight Message Transfer Protocol Eivan Cerasi Eivan Cerasi 2003-12
fmtp 8500 udp Flight Message Transfer Protocol Eivan Cerasi Eivan Cerasi 2003-12
cmtp-mgt 8501 tcp CYTEL Message Transfer Management
cmtp-av 8501 udp CYTEL Message Transfer Audio and Video Frank Jäkel Frank Jäkel 2011-04-29
ftnmtp 8502 tcp FTN Message Transfer Protocol Yuri Myakotin Yuri Myakotin 2014-01-07
8502 udp Reserved
lsp-self-ping 8503 udp MPLS LSP Self-Ping IESG IETF Chair 2015-06-11 2016-02-01 RFC 7746
8503 tcp Reserved
8504-8553 Unassigned
rtsp-alt 8554 tcp RTSP Alternate (see port 554) Stephen Casner Stephen Casner
rtsp-alt 8554 udp RTSP Alternate (see port 554) Stephen Casner Stephen Casner
d-fence 8555 tcp SYMAX D-FENCE Thomas Geisel Thomas Geisel 2003-01
d-fence 8555 udp SYMAX D-FENCE Thomas Geisel Thomas Geisel 2003-01
8556-8566 Unassigned
dof-tunnel 8567 tcp DOF Tunneling Protocol OpenDOF Bryant Eastham 2005-08 2015-04-23
dof-tunnel 8567 udp DOF Tunneling Protocol OpenDOF Bryant Eastham 2005-08 2015-04-23
8568-8599 Unassigned
asterix 8600 tcp Surveillance Data Eivan Cerasi Eivan Cerasi 2005-11
asterix 8600 udp Surveillance Data Eivan Cerasi Eivan Cerasi 2005-11
8601-8608 Unassigned
8609 tcp Reserved
canon-cpp-disc 8609 udp Canon Compact Printer Protocol Discovery Canon Inc. Ryusuke Okuhara 2012-06-08 2012-06-15
canon-mfnp 8610 tcp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-bjnp1 8611 tcp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp1 8611 udp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 tcp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 udp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 tcp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 tcp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
imink 8615 tcp Imink Service Control Canon Inc. Ken'ichi FUJII 2011-10-10
8615 udp Reserved
8616-8664 Unassigned Unauthorized Use Known on ports 8616 and 8617
monetra 8665 tcp Monetra Main Street Softworks Inc Brad House 2013-04-02
8665 udp Reserved
monetra-admin 8666 tcp Monetra Administrative Access Main Street Softworks Inc Brad House 2013-04-02
8666 udp Reserved
8667 Unassigned
spartan 8668 tcp Spartan management Tenebris Technologies Inc. Eric Jacksch 2023-10-26
8668 udp Reserved
8669-8674 Unassigned
msi-cps-rm 8675 tcp Motorola Solutions Customer Programming Software for Radio Management Motorola Solutions, Inc. Jenish Amin 2012-03-14
msi-cps-rm-disc 8675 udp Motorola Solutions Customer Programming Software for Radio Management Discovery Motorola Solutions, Inc. Jenish Amin 2012-03-14
8676-8685 Unassigned
sun-as-jmxrmi 8686 tcp Sun App Server - JMX/RMI Abhijit Kumar Abhijit Kumar 2005-11
sun-as-jmxrmi 8686 udp Sun App Server - JMX/RMI Abhijit Kumar Abhijit Kumar 2005-11
8687 Unassigned
openremote-ctrl 8688 tcp OpenRemote Controller HTTP/REST OpenRemote, Inc. Juha Lindfors 2012-12-18
8688 udp Reserved
8689-8698 Unassigned
vnyx 8699 tcp VNYX Primary Port Gregg Green Gregg Green 2004-11
8699 udp Reserved 2004-11 2013-05-24 This entry is being removed on 2013-05-24.
8700-8709 Unassigned
semi-grpc 8710 tcp gRPC for SEMI Standards implementations SEMI Albert Fuchigami 2020-01-10
8710 udp Reserved
nvc 8711 tcp Nuance Voice Control Nuance Communications Diego Negre 2012-10-05
8711 udp Reserved
8712-8731 Unassigned
8732 tcp Reserved
dtp-net 8732 udp DASGIP Net Services Dr. Matthias Arnold Dr. Matthias Arnold 2009-03-23
ibus 8733 tcp iBus Silvano Maffeis Silvano Maffeis
ibus 8733 udp iBus Silvano Maffeis Silvano Maffeis
8734-8749 Unassigned
dey-keyneg 8750 tcp DEY Storage Key Negotiation DEY Storage Systems, Inc. Garrett D'Amore 2013-03-01
8750 udp Reserved
8751-8762 Unassigned
mc-appserver 8763 tcp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
mc-appserver 8763 udp MC-APPSERVER Romeo Kasanwidjojo Romeo Kasanwidjojo
openqueue 8764 tcp OPENQUEUE Matt Jensen Matt Jensen
openqueue 8764 udp OPENQUEUE Matt Jensen Matt Jensen
ultraseek-http 8765 tcp Ultraseek HTTP Walter Underwood Walter Underwood
ultraseek-http 8765 udp Ultraseek HTTP Walter Underwood Walter Underwood
amcs 8766 tcp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
amcs 8766 udp Agilent Connectivity Service Keysight Technologies, Inc. Tom Fay 2013-01-16 2016-09-12
core-of-source 8767 tcp Online mobile multiplayer game Alt Solve Sdn Bhd Almaz Hong 2019-07-24
8767 udp Reserved
sandpolis 8768 tcp Sandpolis Server Tyler Cook Tyler Cook 2019-11-22
8768 udp Reserved
oktaauthenticat 8769 tcp Okta MultiPlatform Access Mgmt for Cloud Svcs Okta Inc Tom Belote 2019-12-19
8769 udp Reserved
dpap 8770 tcp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
dpap 8770 udp Digital Photo Access Protocol (iPhoto) Amandeep Jawa Amandeep Jawa 2004-11 Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password
8771-8777 Unassigned
uec 8778 tcp Stonebranch Universal Enterprise Controller Stonebranch, Inc. Nathan Hammond 2013-06-25
8778 udp Reserved
8779-8785 Unassigned
msgclnt 8786 tcp Message Client Michael O'Brien Michael O'Brien 2003-03

Contact Information

Name Organization Contact URI Last Updated
Abhijit Kumar as-iana-ports&sun.com 2005-11
Albert Fuchigami albert.fuchigami&peergroup.com 2020-01-10
Almaz Hong almaz.hong&altsolve.com 2019-07-24
Alt Solve Sdn Bhd support&altsolve.com 2019-07-24
Amandeep Jawa dpap&apple.com 2004-11
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Brad House Main Street Softworks Inc brad&mainstreetsoftworks.com 2013-04-02
Bryant Eastham OenDOF protocol&opendof.org 2015-04-23
Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Cullen Jennings fluffy&cisco.com 2010-02-03
DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Diego Negre Nuance Communications Diego.Negre&nuance.com 2012-10-05
Dino Farinacci dino&cisco.com 2008-08-21
Dr. Matthias Arnold m.arnold&dasgip.de 2009-03-23
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Eric Jacksch eric&tenebris.com 2023-10-26
Frank Jäkel Frank.Jaekel&cytel.de 2011-04-29
Garrett D'Amore DEY Storage Systems, Inc. garrett&dey-sys.com 2013-03-01
Gregg Green legal&vnyx.net 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jenish Amin Motorola Solutions, Inc. jenish&motorolasolutions.com 2012-03-14
Jerome Grimbert jerome.grimbert&atosorigin.com
Juha Lindfors OpenRemote, Inc. juha&openremote.org 2012-12-18
Ken'ichi FUJII Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Keysight Technologies, Inc. iana.contact&keysight.com 2016-09-12
Main Street Softworks Inc info&mainstreetsoftworks.com 2013-04-02
Matt Jensen mattj&newsblip.com
Michael McNabb michael&aquaminds.com 2005-10
Michael O'Brien mobrien03&gmail.com 2020-05-11
Motorola Solutions, Inc. jenish&motorolasolutions.com 2012-03-14
Nathan Hammond Stonebranch, Inc. nathan.hammond&stonebranch.com 2013-06-25
Nuance Communications NOD_SolutionsArchitecture&nuance.com 2012-10-05
Okta Inc tbelote&okta.com 2019-12-19
OpenDOF protocol&opendof.org 2015-04-23
OpenRemote, Inc. juha&openremote.org 2012-12-18
Ritsuto Sako sakou.ritsuto&canon.co.jp 2009-05-04
Romeo Kasanwidjojo romeo&microcomgroup.com
Ryusuke Okuhara Canon Inc. okuhara.ryuusuke&canon.co.jp 2012-06-08
SEMI jamano&semi.org 2020-01-10
Silvano Maffeis maffeis&softwired.ch
Stephen Casner casner&precept.com
Stonebranch, Inc. nathan.hammond&stonebranch.com 2013-06-25
Tenebris Technologies Inc. info&tenebris.com 2023-10-26
Thomas Geisel tgeisel&symax.de 2003-01
Tom Belote tbelote&okta.com 2019-12-19
Tom Fay iana.contact&keysight.com 2016-09-12
Tyler Cook tcc&sandpolis.com 2019-11-22
Walter Underwood wunder&infoseek.com
Yuri Myakotin yuri&ym-com.net 2014-01-07