Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 9003-9004 | Unassigned | ||||||||||
| golem | 9005 | tcp | Golem Inter-System RPC | Jose Luis Tallon | Jose Luis Tallon | 2015-03-09 | |||||
| 9005 | udp | Reserved | |||||||||
| 9006 | De-Commissioned Port | 2000-02-24 | |||||||||
| 9007 | tcp | Reserved | |||||||||
| ogs-client | 9007 | udp | Open Grid Services Client | Gareth Nelson | Gareth Nelson | 2008-08-22 | |||||
| ogs-server | 9008 | tcp | Open Grid Services Server | Gareth Nelson | Gareth Nelson | 2008-08-22 | |||||
| 9008 | udp | Reserved | |||||||||
| pichat | 9009 | tcp | Pichat Server | Mark Seuffert | Mark Seuffert | 2004-11 | |||||
| pichat | 9009 | udp | Pichat Server | Mark Seuffert | Mark Seuffert | 2004-11 | |||||
| sdr | 9010 | tcp | Secure Data Replicator Protocol | Sufyan Almajali | Sufyan Almajali | 2008-06-27 | |||||
| 9010 | udp | Reserved | |||||||||
| 9011 | tcp | Reserved | |||||||||
| d-star | 9011 | udp | D-Star Routing digital voice+data for amateur radio | QuadNet2 USA IRC Network | Thomas A Early | 2018-03-16 | |||||
| 9012-9019 | Unassigned | ||||||||||
| tambora | 9020 | tcp | TAMBORA | Jason van Zyl | Jason van Zyl | 2002-03 | |||||
| tambora | 9020 | udp | TAMBORA | Jason van Zyl | Jason van Zyl | 2002-03 | |||||
| panagolin-ident | 9021 | tcp | Pangolin Identification | William Benner | William Benner | 2002-03 | |||||
| panagolin-ident | 9021 | udp | Pangolin Identification | William Benner | William Benner | 2002-03 | |||||
| paragent | 9022 | tcp | PrivateArk Remote Agent | Gal Cucuy | Gal Cucuy | 2002-03 | |||||
| paragent | 9022 | udp | PrivateArk Remote Agent | Gal Cucuy | Gal Cucuy | 2002-03 | |||||
| swa-1 | 9023 | tcp | Secure Web Access - 1 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-1 | 9023 | udp | Secure Web Access - 1 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-2 | 9024 | tcp | Secure Web Access - 2 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-2 | 9024 | udp | Secure Web Access - 2 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-3 | 9025 | tcp | Secure Web Access - 3 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-3 | 9025 | udp | Secure Web Access - 3 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-4 | 9026 | tcp | Secure Web Access - 4 | Tim McGranaghan | Tim McGranaghan | ||||||
| swa-4 | 9026 | udp | Secure Web Access - 4 | Tim McGranaghan | Tim McGranaghan | ||||||
| 9027-9049 | Unassigned | ||||||||||
| versiera | 9050 | tcp | Versiera Agent Listener | Frank Pikelner | Frank Pikelner | 2010-01-15 | |||||
| 9050 | udp | Reserved | |||||||||
| fio-cmgmt | 9051 | tcp | Fusion-io Central Manager Service | Jim Sermersheim | Jim Sermersheim | 2010-01-15 | |||||
| 9051 | udp | Reserved | |||||||||
| 9052-9059 | Unassigned | ||||||||||
| CardWeb-IO | 9060 | tcp | CardWeb request-response I/O exchange | CardWare, Inc | David Wyatt | 2016-10-07 | 2025-07-17 | ||||
| CardWeb-RT | 9060 | udp | CardWeb realtime device data | CardWare, Inc | David Wyatt | 2016-10-07 | 2025-07-17 | ||||
| 9061-9079 | Unassigned | ||||||||||
| glrpc | 9080 | tcp | Groove GLRPC | Adrian Popescu | Adrian Popescu | 2002-09 | |||||
| glrpc | 9080 | udp | Groove GLRPC | Adrian Popescu | Adrian Popescu | 2002-09 | |||||
| 9081 | tcp | Reserved | |||||||||
| cisco-aqos | 9081 | udp | Required for Adaptive Quality of Service | Manish Surolia | Manish Surolia | 2017-10-27 | |||||
| lcs-ap | 9082 | sctp | LCS Application Protocol | Kimmo Kymalainen | Kimmo Kymalainen | 2010-06-04 | |||||
| emc-pp-mgmtsvc | 9083 | tcp | EMC PowerPath Mgmt Service | Jim Perreault | Jim Perreault | 2010-06-04 | |||||
| 9083 | udp | Reserved | |||||||||
| aurora | 9084 | tcp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| aurora | 9084 | udp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| aurora | 9084 | sctp | IBM AURORA Performance Visualizer | Jeroen Massar | Jeroen Massar | 2008-08-21 | |||||
| ibm-rsyscon | 9085 | tcp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| ibm-rsyscon | 9085 | udp | IBM Remote System Console | William LePera | William LePera | 2008-06-18 | |||||
| net2display | 9086 | tcp | Vesa Net2Display | Kenneth B. Ocheltree | Kenneth B. Ocheltree | 2008-01-07 | |||||
| net2display | 9086 | udp | Vesa Net2Display | Kenneth B. Ocheltree | Kenneth B. Ocheltree | 2008-01-07 | |||||
| classic | 9087 | tcp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| classic | 9087 | udp | Classic Data Server | Paul Cadarette | Paul Cadarette | 2007-01 | |||||
| sqlexec | 9088 | tcp | IBM Informix SQL Interface | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec | 9088 | udp | IBM Informix SQL Interface | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec-ssl | 9089 | tcp | IBM Informix SQL Interface - Encrypted | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| sqlexec-ssl | 9089 | udp | IBM Informix SQL Interface - Encrypted | Jonathan Leffler | Jonathan Leffler | 2005-12 | |||||
| websm | 9090 | tcp | WebSM | I-Hsing Tsao | I-Hsing Tsao | ||||||
| websm | 9090 | udp | WebSM | I-Hsing Tsao | I-Hsing Tsao | ||||||
| xmltec-xmlmail | 9091 | tcp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| xmltec-xmlmail | 9091 | udp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| XmlIpcRegSvc | 9092 | tcp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| XmlIpcRegSvc | 9092 | udp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| copycat | 9093 | tcp | Copycat database replication service | Microtec Informatique | Raphael Neve | 2012-03-15 | |||||
| 9093 | udp | Reserved | |||||||||
| 9094-9099 | Unassigned | ||||||||||
| hp-pdl-datastr | 9100 | tcp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| hp-pdl-datastr | 9100 | udp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| bacula-dir | 9101 | tcp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-dir | 9101 | udp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | tcp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | udp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | tcp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | udp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| peerwire | 9104 | tcp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| peerwire | 9104 | udp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| astergate | 9106 | tcp | Astergate Control Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergate-disc | 9106 | udp | Astergate Discovery Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergatefax | 9107 | tcp | AstergateFax Control Service | Gijs Middelkamp | Gijs Middelkamp | 2010-02-03 | |||||
| 9107 | udp | Reserved | |||||||||
| 9108-9110 | Unassigned | ||||||||||
| hexxorecore | 9111 | tcp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| hexxorecore | 9111 | udp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| 9112-9118 | Unassigned | ||||||||||
| mxit | 9119 | tcp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| mxit | 9119 | udp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| 9120-9121 | Unassigned | ||||||||||
| grcmp | 9122 | tcp | Global Relay compliant mobile instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9122 | udp | Reserved | |||||||||
| grcp | 9123 | tcp | Global Relay compliant instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9123 | udp | Reserved | |||||||||
| 9124-9130 | Unassigned | ||||||||||
| dddp | 9131 | tcp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| dddp | 9131 | udp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| 9132-9159 | Unassigned | ||||||||||
| apani1 | 9160 | tcp | apani1 | Neal Taylor | Neal Taylor |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adrian Popescu | Adrian_Popescu&groove.net | 2002-09 | |
| Ariën Huisken | astergate&huisken-systems.nl | 2010-01-04 | |
| CardWare, Inc | dwyatt&cardware.com | 2025-07-17 | |
| Casey Harrington | charrington&isxinc.com | 2006-01 | |
| David Wyatt | dwyatt&cardware.com | 2025-07-17 | |
| Frank Pikelner | frank.pikelner&netcraftcommunications.com | 2010-01-15 | |
| Gal Cucuy | galc&cyber-ark.com | 2002-03 | |
| Gareth Nelson | gareth&litesim.com | 2008-08-22 | |
| Gijs Middelkamp | astergate-fax&huisken-systems.nl | 2010-02-03 | |
| Global Relay Communications Inc | info&globalrelay.net | 2025-06-12 | |
| Hexxore | info&hexxore.nl | 2018-07-31 | |
| I-Hsing Tsao | itsao&austin.ibm.com | ||
| Jason van Zyl | jvanzyl&zenplex.com | 2002-03 | |
| Jeroen Massar | jma&zurich.ibm.com | 2008-08-21 | |
| Jim Perreault | jim.perreault&emc.com | 2010-06-04 | |
| Jim Sermersheim | jims&fusionio.com | 2010-01-15 | |
| Jonathan Leffler | jleffler&us.ibm.com | 2005-12 | |
| Jose Luis Tallon | joseluis&talloncorp.com | 2015-03-09 | |
| Kenneth B. Ocheltree | kennetho&us.ibm.com | 2008-01-07 | |
| Kern Sibbald | kern&sibbald.com | 2002-01 | |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Lu Vo | Global Relay Communications Inc | lu.vo&globalrelay.net | 2025-06-12 |
| Manish Surolia | masurolia@cisco.com> | 2017-10-27 | |
| Mark Seuffert | captain2004&pirate.de | 2004-11 | |
| Marnus Freeman | marnus&swistgroup.com | 2006-02 | |
| Microtec Informatique | raphµtec.fr | 2012-03-15 | |
| Mitch Kaufman | mk&weconnectyou.com | ||
| Neal Taylor | ianareg&apani.com | ||
| Patrick Roozeboom | info&hexxore.nl | 2018-07-31 | |
| Paul Cadarette | pcadaret&us.ibm.com | 2007-01 | |
| QuadNet2 USA IRC Network | admins&openquad.net | 2018-03-16 | |
| Raphael Neve | Microtec Informatique | raphµtec.fr | 2012-03-15 |
| Shane Dick | shane.dick&amx.com | 2005-08 | |
| Shivaun Albright | shivaun_albright&hp.com | 2002-04 | |
| Steven Gerhardt | sgerhardt&ixiononline.com | 2004-02 | |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 | |
| Sufyan Almajali | sufyan.almajali&sdrlive.com | 2008-06-27 | |
| Thomas A Early | tom.n7tae&tearly.net | 2018-03-16 | |
| Tim McGranaghan | tim_mcgranaghan&mech.disa.mil | ||
| William Benner | wrb2&pangolin.com | 2025-03-27 | |
| William LePera | lepera&us.ibm.com | 2008-06-18 |