Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| streamcomm-ds | 9612 | tcp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| streamcomm-ds | 9612 | udp | StreamComm User Directory | Brian C. Wiles | Brian C. Wiles | ||||||
| 9613 | Unassigned | ||||||||||
| iadt-tls | 9614 | tcp | iADT Protocol over TLS | Paul A. Suhler | Paul A. Suhler | 2009-02-05 | |||||
| 9614 | udp | Reserved | |||||||||
| 9615 | Unassigned | ||||||||||
| erunbook-agent | 9616 | tcp | eRunbook Agent IANA assigned this well-formed service name as a replacement for "erunbook_agent". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_agent | 9616 | tcp | eRunbook Agent | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-agent". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9616 | udp | Reserved | |||||||||
| erunbook-server | 9617 | tcp | eRunbook Server IANA assigned this well-formed service name as a replacement for "erunbook_server". |
Gerhard Wagner | Gerhard Wagner | 2009-03-10 | |||||
| erunbook_server | 9617 | tcp | eRunbook Server | Gerhard Wagner | Gerhard Wagner | 2009-03-10 | This entry is an alias to "erunbook-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 9617 | udp | Reserved | |||||||||
| condor | 9618 | tcp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| condor | 9618 | udp | Condor Collector Service | Todd Tannenbaum | Todd Tannenbaum | 2008-04-03 | |||||
| 9619-9627 | Unassigned | ||||||||||
| odbcpathway | 9628 | tcp | ODBC Pathway Service | Adrian Hungate | Adrian Hungate | 2007-05 | |||||
| odbcpathway | 9628 | udp | ODBC Pathway Service | Adrian Hungate | Adrian Hungate | 2007-05 | |||||
| uniport | 9629 | tcp | UniPort SSO Controller | Adrian Hungate | Adrian Hungate | 2007-09-05 | |||||
| uniport | 9629 | udp | UniPort SSO Controller | Adrian Hungate | Adrian Hungate | 2007-09-05 | |||||
| peoctlr | 9630 | tcp | Peovica Controller | Adrian Hungate | Adrian Hungate | 2009-09-14 | |||||
| 9630 | udp | Reserved | |||||||||
| peocoll | 9631 | tcp | Peovica Collector | Adrian Hungate | Adrian Hungate | 2009-09-14 | |||||
| 9631 | udp | Reserved | |||||||||
| 9632 | tcp | Reserved | |||||||||
| mc-comm | 9632 | udp | Mobile-C Communications | David Ko | David Ko | 2009-09-14 | |||||
| 9633-9639 | Unassigned | ||||||||||
| pqsflows | 9640 | tcp | ProQueSys Flows Service | Sarene Caiazza | Sarene Caiazza | 2010-04-27 | |||||
| 9640 | udp | Reserved | |||||||||
| 9641-9665 | Unassigned | ||||||||||
| zoomcp | 9666 | tcp | Zoom Control Panel Game Server Management | Zoom Control Panel | Joshua Pedroza | 2014-02-26 | |||||
| 9666 | udp | Reserved | |||||||||
| xmms2 | 9667 | tcp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | 2009-04-14 | |||||
| xmms2 | 9667 | udp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | ||||||
| tec5-sdctp | 9668 | tcp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| tec5-sdctp | 9668 | udp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| 9669-9693 | Unassigned | ||||||||||
| client-wakeup | 9694 | tcp | T-Mobile Client Wakeup Message | Michael Schönborn | Michael Schönborn | 2009-09-11 | |||||
| client-wakeup | 9694 | udp | T-Mobile Client Wakeup Message | Michael Schönborn | Michael Schönborn | 2009-09-11 | |||||
| ccnx | 9695 | tcp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| ccnx | 9695 | udp | Content Centric Networking | Van Jacobson; Simon Barber | Van Jacobson; Simon Barber | 2009-09-29 | |||||
| 9696-9699 | Unassigned | ||||||||||
| board-roar | 9700 | tcp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-roar | 9700 | udp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9701-9746 | Unassigned | ||||||||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| 9748-9749 | Unassigned | ||||||||||
| board-voip | 9750 | tcp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-voip | 9750 | udp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9751-9752 | Unassigned | ||||||||||
| rasadv | 9753 | tcp | rasadv | Dave Thaler | Dave Thaler | ||||||
| rasadv | 9753 | udp | rasadv | Dave Thaler | Dave Thaler | ||||||
| 9754-9761 | Unassigned | ||||||||||
| tungsten-http | 9762 | tcp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| tungsten-http | 9762 | udp | WSO2 Tungsten HTTP | Afkham Azeez | Afkham Azeez | 2006-06 | |||||
| 9763-9799 | Unassigned | ||||||||||
| davsrc | 9800 | tcp | WebDav Source Port | Ethan Fremen | Ethan Fremen | ||||||
| davsrc | 9800 | udp | WebDav Source Port | Ethan Fremen | Ethan Fremen | ||||||
| sstp-2 | 9801 | tcp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| sstp-2 | 9801 | udp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| davsrcs | 9802 | tcp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| davsrcs | 9802 | udp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| 9803-9874 | Unassigned | ||||||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| sd | 9876 | tcp | Session Director | Van Jacobson | Van Jacobson | ||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| 9877 | udp | Reserved | |||||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 9878 | tcp | Reserved | |||||||||
| 9879-9887 | Unassigned | ||||||||||
| cyborg-systems | 9888 | tcp | CYBORG Systems | Malcolm Graham | Malcolm Graham | ||||||
| cyborg-systems | 9888 | udp | CYBORG Systems | Malcolm Graham | Malcolm Graham | ||||||
| gt-proxy | 9889 | tcp | Port for Cable network related data proxy or repeater | Dawei Qi | Dawei Qi | 2010-07-07 | |||||
| gt-proxy | 9889 | udp | Port for Cable network related data proxy or repeater | Dawei Qi | Dawei Qi | 2010-07-07 | |||||
| 9890-9897 | Unassigned | ||||||||||
| monkeycom | 9898 | tcp | MonkeyCom | Yuji Kuwabara | Yuji Kuwabara | ||||||
| monkeycom | 9898 | udp | MonkeyCom | Yuji Kuwabara | Yuji Kuwabara | ||||||
| 9899 | tcp | Reserved | 2013-04-10 | ||||||||
| sctp-tunneling | 9899 | udp | SCTP TUNNELING | IESG | IETF Chair | 2013-04-10 | RFC 6951 | ||||
| iua | 9900 | tcp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | udp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | sctp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| enrp | 9901 | udp | enrp server channel | ||||||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| 9903 | tcp | Reserved | |||||||||
| multicast-ping | 9903 | udp | Multicast Ping Protocol | 2011-12-09 | RFC 6450 | ||||||
| 9904-9908 | Unassigned | ||||||||||
| domaintime | 9909 | tcp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| domaintime | 9909 | udp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| 9910 | Unassigned | ||||||||||
| sype-transport | 9911 | tcp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| sype-transport | 9911 | udp | SYPECom Transport Protocol | Sylvain Pedneault | Sylvain Pedneault | 2003-03 | |||||
| 9912-9924 | Unassigned | ||||||||||
| xybrid-cloud | 9925 | tcp | XYBRID Cloud | Rx Networks Inc. | Drew Davies | 2013-04-25 | |||||
| 9925 | udp | Reserved | |||||||||
| 9926-9949 | Unassigned | ||||||||||
| apc-9950 | 9950 | tcp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9950 | 9950 | udp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9951 | 9951 | tcp | APC 9951 | American Power Conversion | American Power Conversion |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adrian Hungate | adrian&tlspu.com | 2014-07-11 | |
| Afkham Azeez | azeez&wso2.com | 2006-06 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Brian C. Wiles | brian&streamcomm.com | ||
| Dave Thaler | dthalerµsoft.com | ||
| David Ko | david.dk.ko&gmail.com | 2009-09-14 | |
| Dawei Qi | dqi&galaxytelecomms.com | 2010-07-07 | |
| Drew Davies | Rx Networks Inc. | ddavies&rxnetworks.com | 2013-04-25 |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Ethan Fremen | mindlace&digicool.com | ||
| Francesco Rosi | frosi&orenburg.com | 2006-01 | |
| Gerhard Wagner | gw&nova-ratio.de | 2009-03-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jeffry Dwight | jeffryd&greyware.com | ||
| Joshua Pedroza | Zoom Control Panel | info&zoomcp.com | 2014-02-26 |
| Juho Vähä-Herttua | juhovh&iki.fi | 2009-04-14 | |
| Kouichi Takeda | KHB05271&nifty.com | ||
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Lyndon Ong | Lyong&ciena.com | ||
| Malcolm Graham | Malcolm_Graham&cyborg.com | ||
| Michael Muth | m.muth&tec5.com | 2009-05-11 | |
| Michael Schönborn | T-Mobile International AG | michael.schoenborn&t-mobile.net | 2009-09-11 |
| Paul A. Suhler | paul.suhler&quantum.com | 2009-02-06 | |
| Rob Isaac | rob&automagic.org | 2003-07 | |
| Rx Networks Inc. | ddavies&rxnetworks.com | 2013-04-25 | |
| Sarene Caiazza | scaiazza&proquesys.com | 2010-04-27 | |
| Simon Barber | simon.barber&parc.com | 2009-09-29 | |
| Sylvain Pedneault | sylvain&sypecom.qc.ca | 2003-03 | |
| Todd Tannenbaum | tannenba&cs.wisc.edu | 2008-04-03 | |
| Van Jacobson | van&ee.lbl.gov | ||
| Van Jacobson | van&parc.com | 2009-09-29 | |
| Yuji Kuwabara | HHG01200&niftyserve.or.jp | ||
| Zoom Control Panel | ianaport&zoomcp.com | 2014-02-26 |