Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ptcnameservice | 597 | tcp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| ptcnameservice | 597 | udp | PTC Name Service | Yuri Machkasov | Yuri Machkasov | ||||||
| sco-websrvrmg3 | 598 | tcp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| sco-websrvrmg3 | 598 | udp | SCO Web Server Manager 3 | Simon Baldwin | Simon Baldwin | ||||||
| acp | 599 | tcp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| acp | 599 | udp | Aeolon Core Protocol | Michael Alyn Miller | Michael Alyn Miller | ||||||
| ipcserver | 600 | tcp | Sun IPC server | Bill Schiefelbein | Bill Schiefelbein | ||||||
| ipcserver | 600 | udp | Sun IPC server | Bill Schiefelbein | Bill Schiefelbein | ||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | RFC 3195 | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | RFC 3195 | |||||||
| xmlrpc-beep | 602 | tcp | XML-RPC over BEEP | RFC 3529 | |||||||
| xmlrpc-beep | 602 | udp | XML-RPC over BEEP | RFC 3529 | |||||||
| idxp | 603 | tcp | IDXP | RFC 4767 | |||||||
| idxp | 603 | udp | IDXP | RFC 4767 | |||||||
| tunnel | 604 | tcp | TUNNEL | RFC 3620 | |||||||
| tunnel | 604 | udp | TUNNEL | RFC 3620 | |||||||
| soap-beep | 605 | tcp | SOAP over BEEP | RFC 4227 | |||||||
| soap-beep | 605 | udp | SOAP over BEEP | RFC 4227 | |||||||
| urm | 606 | tcp | Cray Unified Resource Manager | ||||||||
| urm | 606 | udp | Cray Unified Resource Manager | ||||||||
| nqs | 607 | tcp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| nqs | 607 | udp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| sift-uft | 608 | tcp | Sender-Initiated/Unsolicited File Transfer | Rick Troth | Rick Troth | ||||||
| sift-uft | 608 | udp | Sender-Initiated/Unsolicited File Transfer | Rick Troth | Rick Troth | ||||||
| npmp-trap | 609 | tcp | npmp-trap | ||||||||
| npmp-trap | 609 | udp | npmp-trap | ||||||||
| npmp-local | 610 | tcp | npmp-local | ||||||||
| npmp-local | 610 | udp | npmp-local | ||||||||
| npmp-gui | 611 | tcp | npmp-gui | John Barnes | John Barnes | ||||||
| npmp-gui | 611 | udp | npmp-gui | John Barnes | John Barnes | ||||||
| hmmp-ind | 612 | tcp | HMMP Indication | ||||||||
| hmmp-ind | 612 | udp | HMMP Indication | ||||||||
| hmmp-op | 613 | tcp | HMMP Operation | Andrew Sinclair | Andrew Sinclair | ||||||
| hmmp-op | 613 | udp | HMMP Operation | Andrew Sinclair | Andrew Sinclair | ||||||
| sshell | 614 | tcp | SSLshell | Simon J. Gerraty | Simon J. Gerraty | ||||||
| sshell | 614 | udp | SSLshell | Simon J. Gerraty | Simon J. Gerraty | ||||||
| sco-inetmgr | 615 | tcp | Internet Configuration Manager | ||||||||
| sco-inetmgr | 615 | udp | Internet Configuration Manager | ||||||||
| sco-sysmgr | 616 | tcp | SCO System Administration Server | ||||||||
| sco-sysmgr | 616 | udp | SCO System Administration Server | ||||||||
| sco-dtmgr | 617 | tcp | SCO Desktop Administration Server | Christopher Durham | Christopher Durham | ||||||
| sco-dtmgr | 617 | udp | SCO Desktop Administration Server | Christopher Durham | Christopher Durham | ||||||
| dei-icda | 618 | tcp | DEI-ICDA | David Turner | David Turner | ||||||
| dei-icda | 618 | udp | DEI-ICDA | David Turner | David Turner | ||||||
| compaq-evm | 619 | tcp | Compaq EVM | Jem Treadwell | Jem Treadwell | ||||||
| compaq-evm | 619 | udp | Compaq EVM | Jem Treadwell | Jem Treadwell | ||||||
| sco-websrvrmgr | 620 | tcp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| sco-websrvrmgr | 620 | udp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| escp-ip | 621 | tcp | ESCP | Lai Zit Seng | Lai Zit Seng | ||||||
| escp-ip | 621 | udp | ESCP | Lai Zit Seng | Lai Zit Seng | ||||||
| collaborator | 622 | tcp | Collaborator | Johnson Davis | Johnson Davis | ||||||
| collaborator | 622 | udp | Collaborator | Johnson Davis | Johnson Davis | ||||||
| oob-ws-http | 623 | tcp | DMTF out-of-band web services management protocol | Jim Davis | Jim Davis | 2007-06 | |||||
| asf-rmcp | 623 | udp | ASF Remote Management and Control Protocol | Carl First | Carl First | ||||||
| cryptoadmin | 624 | tcp | Crypto Admin | Tony Walker | Tony Walker | ||||||
| cryptoadmin | 624 | udp | Crypto Admin | Tony Walker | Tony Walker | ||||||
| dec-dlm | 625 | tcp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | tcp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| dec-dlm | 625 | udp | DEC DLM IANA assigned this well-formed service name as a replacement for "dec_dlm". |
Rudi Martin | Rudi Martin | ||||||
| dec_dlm | 625 | udp | DEC DLM | Rudi Martin | Rudi Martin | This entry is an alias to "dec-dlm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| asia | 626 | tcp | ASIA | Michael Dasenbrock | Michael Dasenbrock | ||||||
| asia | 626 | udp | ASIA | Michael Dasenbrock | Michael Dasenbrock | ||||||
| passgo-tivoli | 627 | tcp | PassGo Tivoli | John Rainford | John Rainford | ||||||
| passgo-tivoli | 627 | udp | PassGo Tivoli | John Rainford | John Rainford | ||||||
| qmqp | 628 | tcp | QMQP | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| qmqp | 628 | udp | QMQP | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| 3com-amp3 | 629 | tcp | 3Com AMP3 | Prakash Banthia | Prakash Banthia | ||||||
| 3com-amp3 | 629 | udp | 3Com AMP3 | Prakash Banthia | Prakash Banthia | ||||||
| rda | 630 | tcp | RDA | John Hadjioannou | John Hadjioannou | ||||||
| rda | 630 | udp | RDA | John Hadjioannou | John Hadjioannou | ||||||
| ipp | 631 | tcp | IPP (Internet Printing Protocol) | IESG | IETF Chair | 2018-07-06 | RFC 8011 | Defined TXT keys: See BonjourPrinting.pdf. | |||
| ipp | 631 | udp | IPP (Internet Printing Protocol) | IESG | IETF Chair | 2018-07-06 | RFC 8011 | Defined TXT keys: See BonjourPrinting.pdf. | |||
| ipps | 631 | tcp | Internet Printing Protocol over HTTPS | IESG | IETF Chair | 2018-07-06 | RFC 8011 | ||||
| bmpp | 632 | tcp | bmpp | Troy Rollo | Troy Rollo | ||||||
| bmpp | 632 | udp | bmpp | Troy Rollo | Troy Rollo | ||||||
| servstat | 633 | tcp | Service Status update (Sterling Software) | Greg Rose | Greg Rose | ||||||
| servstat | 633 | udp | Service Status update (Sterling Software) | Greg Rose | Greg Rose | ||||||
| ginad | 634 | tcp | ginad | Mark Crother | Mark Crother | ||||||
| ginad | 634 | udp | ginad | Mark Crother | Mark Crother | ||||||
| rlzdbase | 635 | tcp | RLZ DBase | Michael Ginn | Michael Ginn | ||||||
| rlzdbase | 635 | udp | RLZ DBase | Michael Ginn | Michael Ginn | ||||||
| ldaps | 636 | tcp | ldap protocol over TLS/SSL (was sldap) | Pat Richard | Pat Richard | ||||||
| ldaps | 636 | udp | ldap protocol over TLS/SSL (was sldap) | Pat Richard | Pat Richard | ||||||
| lanserver | 637 | tcp | lanserver | Chris Larsson | Chris Larsson | ||||||
| lanserver | 637 | udp | lanserver | Chris Larsson | Chris Larsson | ||||||
| mcns-sec | 638 | tcp | mcns-sec | Kaz Ozawa | Kaz Ozawa | ||||||
| mcns-sec | 638 | udp | mcns-sec | Kaz Ozawa | Kaz Ozawa | ||||||
| msdp | 639 | tcp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| msdp | 639 | udp | MSDP | Dino Farinacci | Dino Farinacci | ||||||
| entrust-sps | 640 | tcp | entrust-sps | Marek Buchler | Marek Buchler | ||||||
| entrust-sps | 640 | udp | entrust-sps | Marek Buchler | Marek Buchler | ||||||
| repcmd | 641 | tcp | repcmd | Scott Dale | Scott Dale | ||||||
| repcmd | 641 | udp | repcmd | Scott Dale | Scott Dale | ||||||
| esro-emsdp | 642 | tcp | ESRO-EMSDP V1.3 | Mohsen Banan | Mohsen Banan | ||||||
| esro-emsdp | 642 | udp | ESRO-EMSDP V1.3 | Mohsen Banan | Mohsen Banan | ||||||
| sanity | 643 | tcp | SANity | Peter Viscarola | Peter Viscarola | ||||||
| sanity | 643 | udp | SANity | Peter Viscarola | Peter Viscarola | ||||||
| dwr | 644 | tcp | dwr | Bill Fenner | Bill Fenner | ||||||
| dwr | 644 | udp | dwr | Bill Fenner | Bill Fenner | ||||||
| pssc | 645 | tcp | PSSC | Egon Meier-Engelen | Egon Meier-Engelen | ||||||
| pssc | 645 | udp | PSSC | Egon Meier-Engelen | Egon Meier-Engelen |