Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
infotos 18881 udp Infotos Marcel Dube Marcel Dube 2004-11
18882-18887 Unassigned
apc-necmp 18888 tcp APCNECMP Michael Yip Michael Yip
apc-necmp 18888 udp APCNECMP Michael Yip Michael Yip
18889-18999 Unassigned
igrid 19000 tcp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
igrid 19000 udp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
19001-19006 Unassigned
scintilla 19007 tcp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
scintilla 19007 udp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
19008-19019 Unassigned
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
19021-19190 Unassigned
opsec-uaa 19191 tcp OPSEC UAA Reuven Harrison Reuven Harrison
opsec-uaa 19191 udp OPSEC UAA Reuven Harrison Reuven Harrison
19192-19193 Unassigned
ua-secureagent 19194 tcp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
ua-secureagent 19194 udp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
19195-19219 Unassigned
cora 19220 tcp Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
cora-disc 19220 udp Discovery for Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
19221-19282 Unassigned
keysrvr 19283 tcp Key Server for SASSAFRAS Mark Valence Mark Valence
keysrvr 19283 udp Key Server for SASSAFRAS Mark Valence Mark Valence
19284-19314 Unassigned
keyshadow 19315 tcp Key Shadow for SASSAFRAS Mark Valence Mark Valence
keyshadow 19315 udp Key Shadow for SASSAFRAS Mark Valence Mark Valence
19316-19397 Unassigned
mtrgtrans 19398 tcp mtrgtrans Katsuhito Muroi Katsuhito Muroi
mtrgtrans 19398 udp mtrgtrans Katsuhito Muroi Katsuhito Muroi
19399-19409 Unassigned
hp-sco 19410 tcp hp-sco Larry Schwartz Larry Schwartz
hp-sco 19410 udp hp-sco Larry Schwartz Larry Schwartz
hp-sca 19411 tcp hp-sca Larry Schwartz Larry Schwartz
hp-sca 19411 udp hp-sca Larry Schwartz Larry Schwartz
hp-sessmon 19412 tcp HP-SESSMON Gita Murthy Gita Murthy
hp-sessmon 19412 udp HP-SESSMON Gita Murthy Gita Murthy
19413-19538 Unassigned
fxuptp 19539 tcp FXUPTP Keiji Okuma Keiji Okuma 2005-08
fxuptp 19539 udp FXUPTP Keiji Okuma Keiji Okuma 2005-08
sxuptp 19540 tcp SXUPTP Keiji Okuma Keiji Okuma 2002-08
sxuptp 19540 udp SXUPTP Keiji Okuma Keiji Okuma 2002-08
jcp 19541 tcp JCP Client Yuji Sasaki Yuji Sasaki
jcp 19541 udp JCP Client Yuji Sasaki Yuji Sasaki
19542-19787 Unassigned
mle 19788 udp Mesh Link Establishment IESG IETF Chair 2012-12-18
19788 tcp Reserved
19789 Unassigned
faircom-db 19790 tcp FairCom Database FairCom Corporation Michael Bowers 2020-12-04
19790 udp Reserved
19791-19997 Unassigned
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
19998 udp Reserved
dnp-sec 19999 tcp Distributed Network Protocol - Secure Grant Gilchrist Grant Gilchrist 2008-08-04
dnp-sec 19999 udp Distributed Network Protocol - Secure Grant Gilchrist Grant Gilchrist 2008-08-04
dnp-sec 19999 sctp Distributed Network Protocol - secured DNP Users Group Andrew West 2022-12-20
dnp 20000 tcp DNP Michael Thesing Michael Thesing
dnp 20000 udp DNP Michael Thesing Michael Thesing
dnp 20000 sctp Distributed Network Protocol DNP Users Group Andrew West 2022-12-20
microsan 20001 tcp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
microsan 20001 udp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
commtact-http 20002 tcp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-http 20002 udp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 tcp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 udp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
20004 Unassigned
openwebnet 20005 tcp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
openwebnet 20005 udp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
20006-20011 Unassigned
20012 tcp Reserved
ss-idi-disc 20012 udp Samsung Interdevice Interaction discovery Hong, Jungkih Hong, Jungkih
ss-idi 20013 tcp Samsung Interdevice Interaction Hong, Jungkih Hong, Jungkih
20013 udp Reserved
opendeploy 20014 tcp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
opendeploy 20014 udp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
20015-20033 Unassigned
nburn-id 20034 tcp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 tcp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
nburn-id 20034 udp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 udp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
20035-20045 Unassigned
tmophl7mts 20046 tcp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
tmophl7mts 20046 udp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
20047-20047 Unassigned
mountd 20048 tcp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
mountd 20048 udp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
20050-20056 Unassigned
avesterra 20057 tcp AvesTerra Hypergraph Transfer Protocol (HGTP) Georgetown University J.C. Smart 2016-06-06
20057 udp Reserved
20058-20166 Unassigned
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
20168-20201 Unassigned
ipdtp-port 20202 tcp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
ipdtp-port 20202 udp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
20203-20221 Unassigned
ipulse-ics 20222 tcp iPulse-ICS Meggie Garica-Woodruff Meggie Garica-Woodruff

Contact Information

Name Organization Contact URI Last Updated
Andrew West andrew.west&ieee.org 2022-12-20
BTicino S.p.A. admin-myopen&myopen-bticino.it 2008-04-09
Chirag Patel Veejansh Inc cpatel&veejansh.com 2014-03-04
DNP Users Group chair_tech&dnp.org 2022-12-20
FairCom Corporation alysha.brown&faircom.com 2020-12-04
Georgetown University smart&georgetown.edu 2016-06-06
Gita Murthy gita&cup.hp.com
Grant Gilchrist grant&enernex.com 2010-10-18
Hong, Jungkih jungkih.hong&samsung.com 2010-09-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.C. Smart smart&georgetown.edu 2016-06-06
Katsuhito Muroi muroi&pfu.co.jp
Keiji Okuma okuma&silex.jp 2005-08
Larry Schwartz lrs&cup.hp.com
Marcel Dube marceldube&videotron.ca 2004-11
Mark Valence kurash&sassafras.com
Massimo Cafaro massimo.cafaro&unile.it 2004-11
Meggie Garica-Woodruff ipulse&ericsson.com
Michael Bowers FairCom Corporation mike.bowers&faircom.com 2020-12-04
Michael Thesing michael.thesing&acsatlanta.com
Michael Yip Michael.Yip&alcatel.com
Nicolas Williams Nicolas.Williams&oracle.com 2010-08-09
Paul Breed paul&netburner.com 2003-11
Pierre Couderc pcouderc&tol.fr 2006-03
Reuven Harrison rnd_ana&checkpoint.com
Reuven Harrison rharrison&checkpoint.com 2003-01
Ronny Krüger from-iana&softvise.de 2016-11-10
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Softvise GmbH from-iana&softvise.de 2016-11-10
Thomas E. Ludwig tom.ludwig&zetera.com 2004-02
Tim Riley rileyt&saic.com 2009-07-31
Todd Scallan tscallan&interwoven.com 2005-08
Tomas Svoboda svoboda&infima.cz 2004-12
Veejansh Inc admin&veejansh.com 2014-03-04
Vikki Yin Wei vikki&ipdynamics.com 2003-01
Yuji Sasaki sasaki&silex.jp