Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
22537 udp Reserved
22538-22554 Unassigned
vocaltec-wconf 22555 tcp Vocaltec Web Conference Scott Petrack Scott Petrack
vocaltec-phone 22555 udp Vocaltec Internet Phone Scott Petrack Scott Petrack
22556-22762 Unassigned
talikaserver 22763 tcp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
talikaserver 22763 udp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
22764-22799 Unassigned
aws-brf 22800 tcp Telerate Information Platform LAN Timo Sivonen Timo Sivonen
aws-brf 22800 udp Telerate Information Platform LAN Timo Sivonen Timo Sivonen
22801-22950 Unassigned
brf-gw 22951 tcp Telerate Information Platform WAN Timo Sivonen Timo Sivonen
brf-gw 22951 udp Telerate Information Platform WAN Timo Sivonen Timo Sivonen
22952-22999 Unassigned
inovaport1 23000 tcp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport1 23000 udp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 tcp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 udp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 tcp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 udp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 tcp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 udp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 tcp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 udp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 tcp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 udp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
23006-23052 Unassigned
gntp 23053 tcp Generic Notification Transport Protocol The Growl Project Chris Forsythe 2012-02-07
23053 udp Reserved
23054-23271 Unassigned
23272 tcp Reserved
s102 23272 udp S102 application Kimmo Kymalainen Kimmo Kymalainen 2009-08-26
23273-23293 Unassigned
5afe-dir 23294 tcp 5AFE SDN Directory Ayoda GmbH Laurenz Eschwey 2016-04-01
5afe-disc 23294 udp 5AFE SDN Directory discovery Ayoda GmbH Laurenz Eschwey 2016-04-01
23295-23332 Unassigned
elxmgmt 23333 tcp Emulex HBAnyware Remote Management Maziar Tamadon Maziar Tamadon 2007-11-06
elxmgmt 23333 udp Emulex HBAnyware Remote Management Maziar Tamadon Maziar Tamadon 2007-11-06
23334-23399 Unassigned
novar-dbase 23400 tcp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-dbase 23400 udp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 tcp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 udp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 tcp Novar Global Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 udp Novar Global Keith Kilroy Keith Kilroy 2006-02
23403-23455 Unassigned
aequus 23456 tcp Aequus Service James Anson James Anson 2009-02-12
23456 udp Reserved
aequus-alt 23457 tcp Aequus Service Mgmt James Anson James Anson 2009-02-12
23457 udp Reserved
23458-23545 Unassigned
areaguard-neo 23546 tcp AreaGuard Neo - WebServer SODATSW spol. s r.o. Roman Štěpánek 2012-05-31
23546 udp Reserved
23547-23999 Unassigned
med-ltp 24000 tcp med-ltp Juergen Fischbach Juergen Fischbach
med-ltp 24000 udp med-ltp Juergen Fischbach Juergen Fischbach
med-fsp-rx 24001 tcp med-fsp-rx Juergen Fischbach Juergen Fischbach
med-fsp-rx 24001 udp med-fsp-rx Juergen Fischbach Juergen Fischbach
med-fsp-tx 24002 tcp med-fsp-tx Juergen Fischbach Juergen Fischbach
med-fsp-tx 24002 udp med-fsp-tx Juergen Fischbach Juergen Fischbach
med-supp 24003 tcp med-supp Juergen Fischbach Juergen Fischbach
med-supp 24003 udp med-supp Juergen Fischbach Juergen Fischbach
med-ovw 24004 tcp med-ovw Juergen Fischbach Juergen Fischbach
med-ovw 24004 udp med-ovw Juergen Fischbach Juergen Fischbach
med-ci 24005 tcp med-ci Juergen Fischbach Juergen Fischbach
med-ci 24005 udp med-ci Juergen Fischbach Juergen Fischbach
med-net-svc 24006 tcp med-net-svc Juergen Fischbach Juergen Fischbach
med-net-svc 24006 udp med-net-svc Juergen Fischbach Juergen Fischbach
24007-24241 Unassigned
filesphere 24242 tcp fileSphere Carl Cedergren Carl Cedergren
filesphere 24242 udp fileSphere Carl Cedergren Carl Cedergren
24243-24248 Unassigned
vista-4gl 24249 tcp Vista 4GL Ingenta plc Mark Itzcovitz 2020-01-06
vista-4gl 24249 udp Vista 4GL Ingenta plc Mark Itzcovitz 2020-01-06
24250-24320 Unassigned
ild 24321 tcp Isolv Local Directory Mitchell Bass Mitchell Bass 2005-08
ild 24321 udp Isolv Local Directory Mitchell Bass Mitchell Bass 2005-08
hid 24322 udp Transport of Human Interface Device data streams Freebox SAS Nicolas Pouillon 2012-12-14
24322 tcp Reserved
vrmg-ip 24323 tcp Verimag mobile class protocol over TCP Verimag, OOO Denis Ionov 2018-08-15
24323 udp Reserved
24324-24385 Unassigned
intel-rci 24386 tcp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
Mark Lewis Mark Lewis
intel_rci 24386 tcp Intel RCI Mark Lewis Mark Lewis This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
intel-rci 24386 udp Intel RCI

IANA assigned this well-formed service name as a replacement for "intel_rci".
Mark Lewis Mark Lewis
intel_rci 24386 udp Intel RCI Mark Lewis Mark Lewis This entry is an alias to "intel-rci". This entry is now historic, not usable for use with many common service discovery mechanisms.
24387-24464 Unassigned
tonidods 24465 tcp Tonido Domain Server Madhan Kanagavel Madhan Kanagavel 2008-07-18
tonidods 24465 udp Tonido Domain Server Madhan Kanagavel Madhan Kanagavel 2008-07-18
24466-24553 Unassigned
binkp 24554 tcp BINKP Maxim Masiutin Maxim Masiutin 2020-06-02
binkp 24554 udp BINKP Maxim Masiutin Maxim Masiutin 2020-06-02
24555-24576 Unassigned
bilobit 24577 tcp bilobit Service bilobit GmbH Martin Schmuker 2014-08-15
bilobit-update 24577 udp bilobit Service Update bilobit GmbH Martin Schmuker 2014-08-15
24578-24600 Unassigned
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol IESG IETF Chair 2025-09-26 RFC 9946
24601 tcp Reserved
24602-24665 Unassigned
sdtvwcam 24666 tcp Service used by SmarDTV to communicate between a CAM and a second screen application SmarDTV Vincent Demortier 2015-03-04
24666 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Ayoda GmbH info&ayoda.net 2016-04-01
bilobit GmbH ms&bilobit.com 2014-08-15
Carl Cedergren asperon&home.se
Chris Forsythe The Growl Project chris&growl.info 2012-02-07
Chris Koeritz portmanager&inovasolutions.com 2006-10
Denis Ionov Verimag, OOO iddi&verimag.ru 2018-07-20
Freebox SAS npouillon&freebox.fr 2012-12-14
The Growl Project support&growl.info 2012-02-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ingenta plc mark.itzcovitz&ingenta.com 2020-01-06
James Anson janson&bigpond.com 2009-02-12
Juergen Fischbach juergen.fischbach&philips.com
Keith Kilroy Keith.Kilroy&novarcontrols.com 2006-02
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Laurenz Eschwey laurenz.eschwey&ayoda.net 2016-04-01
Laxman C. Marathe lcmarathe&thomsonpress.com 2006-12
Madhan Kanagavel madhan&codelathe.com 2008-07-18
Mark Itzcovitz mark.itzcovitz&ingenta.com 2020-01-06
Mark Lewis mark.h.lewis&intel.com
Martin Schmuker bilobit GmbH ms&bilobit.com 2014-08-15
Maxim Masiutin maxim.masiutin&gmail.com 2020-06-02
Maziar Tamadon maziar.tamadon&emulex.com 2007-11-06
Mitchell Bass mitch&integrasolv.com 2005-08
Nicolas Pouillon Freebox SAS npouillon&freebox.fr 2012-12-14
Roman Štěpánek SODATSW spol. s r.o. roman.stepanek&sodatsw.cz 2012-05-31
Scott Petrack Scott_Petrack&vocaltec.com
SmarDTV vincent.demortier&smardtv.com 2015-03-04
SODATSW spol. s r.o. info&sodatsw.cz 2012-05-31
Timo Sivonen timo.sivonen&ccmail.dowjones.com
Verimag, OOO support&verimag.ru 2018-07-20
Vincent Demortier SmarDTV vincent.demortier&smardtv.com 2015-03-04