Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pssc 645 udp PSSC Egon Meier-Engelen Egon Meier-Engelen
ldp 646 tcp LDP Bob Thomas Bob Thomas
ldp 646 udp LDP Bob Thomas Bob Thomas
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
dhcp-failover 647 udp DHCP Failover Bernard Volz Bernard Volz
rrp 648 tcp Registry Registrar Protocol (RRP) Scott Hollenbeck Scott Hollenbeck
rrp 648 udp Registry Registrar Protocol (RRP) Scott Hollenbeck Scott Hollenbeck
cadview-3d 649 tcp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
cadview-3d 649 udp Cadview-3d - streaming 3d models over the internet David Cooper David Cooper
obex 650 tcp OBEX Jeff Garbers Jeff Garbers
obex 650 udp OBEX Jeff Garbers Jeff Garbers
ieee-mms 651 tcp IEEE MMS Curtis Anderson Curtis Anderson
ieee-mms 651 udp IEEE MMS Curtis Anderson Curtis Anderson
hello-port 652 tcp HELLO_PORT Patrick Cipiere Patrick Cipiere
hello-port 652 udp HELLO_PORT Patrick Cipiere Patrick Cipiere
repscmd 653 tcp RepCmd Scott Dale Scott Dale
repscmd 653 udp RepCmd Scott Dale Scott Dale
aodv 654 tcp AODV Charles Perkins Charles Perkins
aodv 654 udp AODV Charles Perkins Charles Perkins
tinc 655 tcp TINC Ivo Timmermans Ivo Timmermans
tinc 655 udp TINC Ivo Timmermans Ivo Timmermans
spmp 656 tcp SPMP Jakob Kaivo Jakob Kaivo
spmp 656 udp SPMP Jakob Kaivo Jakob Kaivo
rmc 657 tcp RMC Michael Schmidt Michael Schmidt
rmc 657 udp RMC Michael Schmidt Michael Schmidt
tenfold 658 tcp TenFold Louis Olszyk Louis Olszyk
tenfold 658 udp TenFold Louis Olszyk Louis Olszyk
659 Removed 2001-06-06
mac-srvr-admin 660 tcp MacOS Server Admin Forest Hill Forest Hill
mac-srvr-admin 660 udp MacOS Server Admin Forest Hill Forest Hill
hap 661 tcp HAP Igor Plotnikov Igor Plotnikov
hap 661 udp HAP Igor Plotnikov Igor Plotnikov
pftp 662 tcp PFTP Ben Schluricke Ben Schluricke
pftp 662 udp PFTP Ben Schluricke Ben Schluricke
purenoise 663 tcp PureNoise Sam Osa Sam Osa
purenoise 663 udp PureNoise Sam Osa Sam Osa
oob-ws-https 664 tcp DMTF out-of-band secure web services management protocol Jim Davis Jim Davis 2007-06
asf-secure-rmcp 664 udp ASF Secure Remote Management and Control Protocol Carl First Carl First
sun-dr 665 tcp Sun DR Harinder Bhasin Harinder Bhasin
sun-dr 665 udp Sun DR Harinder Bhasin Harinder Bhasin
mdqs 666 tcp
mdqs 666 udp
doom 666 tcp doom Id Software ddt ddt
doom 666 udp doom Id Software ddt ddt
disclose 667 tcp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
disclose 667 udp campaign contribution disclosures - SDR Technologies Jim Dixon Jim Dixon
mecomm 668 tcp MeComm
mecomm 668 udp MeComm
meregister 669 tcp MeRegister Armin Sawusch Armin Sawusch
meregister 669 udp MeRegister Armin Sawusch Armin Sawusch
vacdsm-sws 670 tcp VACDSM-SWS
vacdsm-sws 670 udp VACDSM-SWS
vacdsm-app 671 tcp VACDSM-APP
vacdsm-app 671 udp VACDSM-APP
vpps-qua 672 tcp VPPS-QUA
vpps-qua 672 udp VPPS-QUA
cimplex 673 tcp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
cimplex 673 udp CIMPLEX Ulysses G. Smith Jr. Ulysses G. Smith Jr.
acap 674 tcp ACAP Chris Newman Chris Newman 2010-10-15
acap 674 udp ACAP Chris Newman Chris Newman 2010-10-15
dctp 675 tcp DCTP Andre Kramer Andre Kramer
dctp 675 udp DCTP Andre Kramer Andre Kramer
vpps-via 676 tcp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpps-via 676 udp VPPS Via Ulysses G. Smith Jr. Ulysses G. Smith Jr.
vpp 677 tcp Virtual Presence Protocol Klaus Wolf Klaus Wolf
vpp 677 udp Virtual Presence Protocol Klaus Wolf Klaus Wolf
ggf-ncp 678 tcp GNU Generation Foundation NCP Noah Paul Noah Paul
ggf-ncp 678 udp GNU Generation Foundation NCP Noah Paul Noah Paul
mrm 679 tcp MRM Liming Wei Liming Wei
mrm 679 udp MRM Liming Wei Liming Wei
entrust-aaas 680 tcp entrust-aaas
entrust-aaas 680 udp entrust-aaas
entrust-aams 681 tcp entrust-aams Adrian Mancini Adrian Mancini
entrust-aams 681 udp entrust-aams Adrian Mancini Adrian Mancini
xfr 682 tcp XFR Noah Paul Noah Paul
xfr 682 udp XFR Noah Paul Noah Paul
corba-iiop 683 tcp CORBA IIOP
corba-iiop 683 udp CORBA IIOP
corba-iiop-ssl 684 tcp CORBA IIOP SSL Andrew Watson Andrew Watson
corba-iiop-ssl 684 udp CORBA IIOP SSL Andrew Watson Andrew Watson
mdc-portmapper 685 tcp MDC Port Mapper Noah Paul Noah Paul
mdc-portmapper 685 udp MDC Port Mapper Noah Paul Noah Paul
hcp-wismar 686 tcp Hardware Control Protocol Wismar David Merchant David Merchant
hcp-wismar 686 udp Hardware Control Protocol Wismar David Merchant David Merchant
asipregistry 687 tcp asipregistry Erik Sea Erik Sea
asipregistry 687 udp asipregistry Erik Sea Erik Sea
realm-rusd 688 tcp ApplianceWare managment protocol Stacy Kenworthy Stacy Kenworthy
realm-rusd 688 udp ApplianceWare managment protocol Stacy Kenworthy Stacy Kenworthy
nmap 689 tcp NMAP Peter Dennis Bartok Peter Dennis Bartok
nmap 689 udp NMAP Peter Dennis Bartok Peter Dennis Bartok
vatp 690 tcp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
vatp 690 udp Velneo Application Transfer Protocol Velneo David Gutiérrez 2015-02-03
msexch-routing 691 tcp MS Exchange Routing David Lemson David Lemson
msexch-routing 691 udp MS Exchange Routing David Lemson David Lemson
hyperwave-isp 692 tcp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
hyperwave-isp 692 udp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
connendp 693 tcp almanid Connection Endpoint Ronny Bremer Ronny Bremer
connendp 693 udp almanid Connection Endpoint Ronny Bremer Ronny Bremer
ha-cluster 694 tcp ha-cluster Alan Robertson Alan Robertson
ha-cluster 694 udp ha-cluster Alan Robertson Alan Robertson
ieee-mms-ssl 695 tcp IEEE-MMS-SSL Curtis Anderson Curtis Anderson

Contact Information

Name Organization Contact URI Last Updated
Adrian Mancini adrian.mancini&entrust.com
Alan Robertson alanr&unix.sh
Andre Kramer Andre.Kramer&ansa.co.uk
Andrew Watson andrew&omg.org
Armin Sawusch armin&esd1.esd.de
Ben Schluricke support&pftp.de
Bernard Volz bevolz&gmail.com 2022-08-03
Bob Thomas rhthomas&cisco.com
Carl First Carl.L.First&intel.com
Charles Perkins cperkins&eng.sun.com
Chris Newman chris.newman&oracle.com 2017-01-26
Curtis Anderson canderson&turbolinux.com
Curtis Anderson ecanderson&turbolinux.com
David Cooper david.cooper&oracle.com
David Gutiérrez Velneo velneo&velneo.com 2015-02-03
David Lemson dlemson&microsoft.com
David Merchant d.f.merchant&livjm.ac.uk
Egon Meier-Engelen egon.meier-engelen&dlr.de
Erik Sea sea&apple.com
Forest Hill forest&apple.com
Gerald Mesaric gmesaric&hyperwave.com
Harinder Bhasin Harinder.Bhasin&sun.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Igor Plotnikov igor&uroam.com
Ivo Timmermans itimmermans&bigfoot.com
Jakob Kaivo jkaivo&nodomainname.net
Jeff Garbers FJG030&email.mot.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jim Dixon jim&lambda.com
Klaus Wolf wolf&cobrow.com
Liming Wei lwei&cisco.com
Louis Olszyk lolszyk&10fold.com
Michael Schmidt mmaass&us.ibm.com
Noah Paul noahp&altavista.net
Noah Paul noahp&ultranet.com
Patrick Cipiere Patrick.Cipiere&udcast.com
Peter Dennis Bartok peter&novonyx.com
Ronny Bremer rbremer&almanid.com
Sam Osa pristine&mailcity.com
Scott Dale scott&tioga.com
Scott Hollenbeck shollenb&netsol.com
Stacy Kenworthy skenworthy&applianceware.com
Ulysses G. Smith Jr. ugsmith&cesi.com
Velneo velneo&velneo.com
ddt&idcube.idsoftware.com