Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| speedtrace | 33334 | tcp | SpeedTrace TraceAgent | Holger Heinrich | Holger Heinrich | 2012-02-01 | |||||
| speedtrace-disc | 33334 | udp | SpeedTrace TraceAgent Discovery | Holger Heinrich | Holger Heinrich | 2012-02-01 | |||||
| 33335-33433 | Unassigned | ||||||||||
| traceroute | 33434 | tcp | traceroute use | IANA | IANA | ||||||
| traceroute | 33434 | udp | traceroute use | IANA | IANA | ||||||
| 33435 | tcp | Reserved | |||||||||
| mtrace | 33435 | udp | IP Multicast Traceroute | IESG | IETF Chair | 2017-12-13 | 2019-08-09 | RFC 8487 | Known Unauthorized Use on port 33435 | ||
| 33436-33655 | Unassigned | Known Unauthorized Use on ports 33436-33534 | |||||||||
| snip-slave | 33656 | tcp | SNIP Slave | Dr. Chris Tucker | Dr. Chris Tucker | 2005-08 | |||||
| snip-slave | 33656 | udp | SNIP Slave | Dr. Chris Tucker | Dr. Chris Tucker | 2005-08 | |||||
| 33657-33889 | Unassigned | ||||||||||
| digilent-adept | 33890 | tcp | Adept IP protocol | Digilent Inc. | Michael T. Alexander | 2020-06-25 | |||||
| 33890 | udp | Reserved | |||||||||
| 33891-34248 | Unassigned | ||||||||||
| turbonote-2 | 34249 | tcp | TurboNote Relay Server Default Port | Peter Hyde | Peter Hyde | ||||||
| turbonote-2 | 34249 | udp | TurboNote Relay Server Default Port | Peter Hyde | Peter Hyde | ||||||
| 34250-34377 | Unassigned | ||||||||||
| p-net-local | 34378 | tcp | P-Net on IP local | Kurt Nissen | Kurt Nissen | 2004-02 | |||||
| p-net-local | 34378 | udp | P-Net on IP local | Kurt Nissen | Kurt Nissen | 2004-02 | |||||
| p-net-remote | 34379 | tcp | P-Net on IP remote | Kurt Nissen | Kurt Nissen | 2004-02 | |||||
| p-net-remote | 34379 | udp | P-Net on IP remote | Kurt Nissen | Kurt Nissen | 2004-02 | |||||
| 34380-34566 | Unassigned | ||||||||||
| dhanalakshmi | 34567 | tcp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2010-04-20 | |||||
| edi_service | 34567 | udp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2016-10-26 | |||||
| 34568-34961 | Unassigned | ||||||||||
| profinet-rt | 34962 | tcp | PROFInet RT Unicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-rt | 34962 | udp | PROFInet RT Unicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-rtm | 34963 | tcp | PROFInet RT Multicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-rtm | 34963 | udp | PROFInet RT Multicast | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-cm | 34964 | tcp | PROFInet Context Manager | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-cm | 34964 | udp | PROFInet Context Manager | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2004-11 | 2026-03-16 | ||||
| profinet-cm-sec | 34965 | tcp | PROFINET secure connection management and key provisioning | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| profinet-cm-sec | 34965 | udp | PROFINET secure connection management and key provisioning | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| 34966 | tcp | Reserved | |||||||||
| profinet-rt-sec | 34966 | udp | PROFINET secure real-time data transfer over UDP (unicast and multicast) | PNO – PROFIBUS Nutzerorganisation e.V. | Dietmar Bohn | 2026-03-10 | |||||
| 34967-34979 | Unassigned | ||||||||||
| ethercat | 34980 | tcp | EtherCAT Port | Martin Rostan | Martin Rostan | 2003-11 | |||||
| ethercat | 34980 | udp | EtherCAT Port | Martin Rostan | Martin Rostan | 2003-11 | |||||
| 34981-34999 | Unassigned | ||||||||||
| heathview | 35000 | tcp | HeathView | Heathwest Systems Limited | Andrew Porrer | 2013-03-21 | |||||
| 35000 | udp | Reserved | |||||||||
| rt-viewer | 35001 | tcp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-viewer | 35001 | udp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-sound | 35002 | tcp | ReadyTech Sound Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35002 | udp | Reserved | |||||||||
| rt-devicemapper | 35003 | tcp | ReadyTech DeviceMapper Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35003 | udp | Reserved | |||||||||
| rt-classmanager | 35004 | tcp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-classmanager | 35004 | udp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-labtracker | 35005 | tcp | ReadyTech LabTracker | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35005 | udp | Reserved | |||||||||
| rt-helper | 35006 | tcp | ReadyTech Helper Service | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35006 | udp | Reserved | |||||||||
| 35007-35099 | Unassigned | ||||||||||
| axio-disc | 35100 | tcp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| axio-disc | 35100 | udp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| 35101-35353 | Unassigned | ||||||||||
| kitim | 35354 | tcp | KIT Messenger | Rudi Visser | Rudi Visser | 2011-07-07 | |||||
| 35354 | udp | Reserved | |||||||||
| altova-lm | 35355 | tcp | Altova License Management | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| altova-lm-disc | 35355 | udp | Altova License Management Discovery | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| guttersnex | 35356 | tcp | Gutters Note Exchange | Squee! Application Development | Tristan Seifert | 2011-07-19 | |||||
| 35356 | udp | Reserved | |||||||||
| openstack-id | 35357 | tcp | OpenStack ID Service | Rackspace Hosting | Ziad Sawalha | 2011-08-15 | |||||
| 35357 | udp | Reserved | |||||||||
| 35358-36000 | Unassigned | ||||||||||
| allpeers | 36001 | tcp | AllPeers Network | Cedric Maloux | Cedric Maloux | 2007-04 | |||||
| allpeers | 36001 | udp | AllPeers Network | Cedric Maloux | Cedric Maloux | 2007-04 | |||||
| 36002-36410 | Unassigned | ||||||||||
| wlcp | 36411 | udp | Wireless LAN Control plane Protocol (WLCP) | 3GPP | Dongwook Kim | 2014-11-14 | 2026-01-23 | ||||
| 36411 | tcp | Reserved | |||||||||
| 36412 | tcp | Reserved | |||||||||
| 36412 | udp | Reserved | |||||||||
| s1-control | 36412 | sctp | S1-Control Plane (3GPP) | Kimmo Kymalainen | Kimmo Kymalainen | 2009-09-01 | |||||
| 36413-36421 | Unassigned | ||||||||||
| 36422 | tcp | Reserved | |||||||||
| 36422 | udp | Reserved | |||||||||
| x2-control | 36422 | sctp | X2-Control Plane (3GPP) | Kimmo Kymalainen | Kimmo Kymalainen | 2009-09-01 | |||||
| slmap | 36423 | sctp | SLm Interface Application Protocol | 3GPP | Kimmo Kymalainen | 2015-06-18 | |||||
| nq-ap | 36424 | sctp | Nq and Nq' Application Protocol | 3GPP | Kimmo Kymalainen | 2015-06-18 | |||||
| 36425-36442 | Unassigned | ||||||||||
| m2ap | 36443 | sctp | M2 Application Part | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| m3ap | 36444 | sctp | M3 Application Part | Dario S. Tonesi | Dario S. Tonesi | 2011-02-07 | |||||
| 36445-36461 | Unassigned | ||||||||||
| 36462 | tcp | Reserved | |||||||||
| 36462 | udp | Reserved | |||||||||
| xw-control | 36462 | sctp | Xw-Control Plane (3GPP) | Boubacar KIMNBA DIT ADAMOU | Boubacar KIMNBA DIT ADAMOU | 2015-11-13 | |||||
| 36463-36523 | Unassigned | ||||||||||
| febooti-aw | 36524 | tcp | Febooti Automation Workshop | Maris Bormanis | Maris Bormanis | 2011-06-10 | |||||
| 36524 | udp | Reserved | |||||||||
| 36525-36601 | Unassigned | ||||||||||
| observium-agent | 36602 | tcp | Observium statistics collection agent | Observium | Adam Armstrong | 2013-05-10 | |||||
| 36602 | udp | Reserved | |||||||||
| 36603-36699 | Unassigned | ||||||||||
| mapx | 36700 | tcp | MapX communication | MicroTechniX | Yarochkin Michail | 2014-10-13 | |||||
| 36700 | udp | Reserved | |||||||||
| 36701-36864 | Unassigned | ||||||||||
| kastenxpipe | 36865 | tcp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| kastenxpipe | 36865 | udp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| 36866-37471 | Unassigned | ||||||||||
| 37472 | tcp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | dongwook.kim&etsi.org | 2026-01-23 | |
| 3GPP | kimmo.kymalainen&etsi.org | 2015-06-18 | |
| Adam Armstrong | Observium | adama&observium.org | 2013-05-10 |
| Alexander Falk | Altova, Inc. | al&altova.com | 2011-07-07 |
| Andrew Porrer | Heathwest Systems Limited | Andrew.Porrer&heathwest.com | 2013-03-21 |
| Axiomatic Technologies Corporation | obogush&axiomatic.com | 2016-12-09 | |
| Boubacar KIMNBA DIT ADAMOU | jinba&chinamobile.com | 2015-11-13 | |
| Cedric Maloux | cedric&allpeers.com | 2007-04 | |
| Dario S. Tonesi | dario.tonesi&nsn.com | 2011-02-07 | |
| Dietmar Bohn | standards.central-office&profibus.com | 2026-03-10 | |
| Digilent Inc. | software&digilent.com | 2020-06-25 | |
| Dongwook Kim | 3GPP | dongwook.kim&etsi.org | 2026-01-23 |
| Dr. Chris Tucker | chris.tucker&ioltd.co.uk | 2005-08 | |
| Girish Gopalakrishnan | girish&shankar-software.org | 2016-10-26 | |
| Guy Cheng | GCHE&kastenchase.com | ||
| Heathwest Systems Limited | info&heathwest.com | 2013-03-21 | |
| Holger Heinrich | holger2222&googlemail.com | 2012-02-01 | |
| IANA | iana&iana.org | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Kevin Woodward | ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Kurt Nissen | kn&proces-data.com | 2004-02 | |
| Maris Bormanis | info&febooti.com | 2011-06-10 | |
| Martin Rostan | m.rostan&beckhoff.com | 2003-11 | |
| Michael T. Alexander | malexander&digilentinc.com | 2020-06-25 | |
| MicroTechniX | Infoµtechnix.com | 2014-10-13 | |
| Observium | adama&observium.org | 2013-05-10 | |
| Oleksandr_Bogush | obogush&axiomatic.com | 2016-12-09 | |
| Peter Hyde | peter&spis.co.nz | ||
| PNO – PROFIBUS Nutzerorganisation e.V. | standards.central-office&profibus.com | 2026-03-10 | |
| Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 | |
| ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 | |
| Rudi Visser | rudi.visser&ljund.eu | 2011-07-07 | |
| Squee! Application Development | tristan&squee.co | 2011-07-19 | |
| Tristan Seifert | Squee! Application Development | tristan&squee.co | 2011-07-19 |
| Yarochkin Michail | MicroTechniX | Michail.Yarochkinµtechnix.com | 2014-10-13 |
| Ziad Sawalha | Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 |