Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| candrp | 42509 | tcp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| candrp | 42509 | udp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | tcp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | udp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| 42511-42998 | Unassigned | ||||||||||
| curiosity | 42999 | tcp | API endpoint for search application | Curiosity GmbH | Rafael Fernandes de Oliveira | 2022-12-09 | |||||
| 42999 | udp | Reserved | |||||||||
| recvr-rc | 43000 | tcp | Receiver Remote Control | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| recvr-rc-disc | 43000 | udp | Receiver Remote Control Discovery | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| 43001-43187 | Unassigned | ||||||||||
| reachout | 43188 | tcp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| reachout | 43188 | udp | REACHOUT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | tcp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | udp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | tcp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | udp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| noit-transport | 43191 | tcp | Reconnoiter Agent Data Transport | Theo Schlossnagle | Theo Schlossnagle | 2009-05-19 | |||||
| 43191 | udp | Reserved | |||||||||
| 43192-43209 | Unassigned | ||||||||||
| shaperai | 43210 | tcp | Shaper Automation Server Management | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| shaperai-disc | 43210 | udp | Shaper Automation Server Management Discovery | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| 43211-43437 | Unassigned | ||||||||||
| 43438 | tcp | Reserved | |||||||||
| hmip-routing | 43438 | udp | HmIP LAN Routing | eQ-3 Entwicklung GmbH | Tido de Vries | 2018-02-28 | |||||
| eq3-update | 43439 | tcp | EQ3 firmware update | eQ-3 Entwicklung GmbH | Tido de Vries | 2012-02-10 | 2014-05-09 | ||||
| eq3-config | 43439 | udp | EQ3 discovery and configuration | eQ-3 Entwicklung GmbH | Tido de Vries | 2012-02-10 | 2014-05-09 | ||||
| ew-mgmt | 43440 | tcp | Cisco EnergyWise Management | ||||||||
| ew-disc-cmd | 43440 | udp | Cisco EnergyWise Discovery and Command Flooding | John Parello | John Parello | 2009-05-19 | |||||
| ciscocsdb | 43441 | tcp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| ciscocsdb | 43441 | udp | Cisco NetMgmt DB Ports | Cisco Systems | Cisco Systems | 2005-11 | |||||
| 43442-44122 | Unassigned | ||||||||||
| z-wave-tunnel | 44123 | tcp | Z-Wave Secure Tunnel | Sigma Designs, Inc. | Anders Brandt | 2012-10-12 | 2015-06-26 | ||||
| 44123 | udp | Reserved | |||||||||
| 44124-44320 | Unassigned | ||||||||||
| pmcd | 44321 | tcp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| pmcd | 44321 | udp | PCP server (pmcd) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2010-12-20 | 2025-09-29 | ||||
| pmproxy | 44322 | tcp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 | ||||
| pmproxy | 44322 | udp | PCP proxy (pmproxy) | Performance Co-Pilot (PCP) Project | Ken McDonell | 2003-07 | 2025-09-26 | ||||
| pmwebapi | 44323 | tcp | HTTP binding for Performance Co-Pilot client API | Performance Co-Pilot (PCP) Project | Ken McDonell | 2013-10-09 | |||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| 44324-44443 | Unassigned | ||||||||||
| cognex-dataman | 44444 | tcp | Cognex DataMan Management Protocol | Cognex Corporation | Mario Joussen | 2012-08-28 | |||||
| 44444 | udp | Reserved | |||||||||
| acronis-backup | 44445 | tcp | Acronis Backup Gateway service port | Acronis | Kevin Reed | 2019-11-25 | |||||
| 44445 | udp | Reserved | |||||||||
| 44446-44543 | Unassigned | Known UNAUTHORIZED USE: Ports 44515 & 44516 | |||||||||
| 44544 | tcp | Reserved | |||||||||
| domiq | 44544 | udp | DOMIQ Building Automation | DOMIQ Sp. z o.o. | Filip Zawadiak | 2011-08-29 | |||||
| 44545-44552 | Unassigned | ||||||||||
| rbr-debug | 44553 | tcp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| rbr-debug | 44553 | udp | REALbasic Remote Debug | Aaron Ballman | Aaron Ballman | 2004-11 | |||||
| 44554-44599 | Unassigned | ||||||||||
| 44600 | tcp | Reserved | |||||||||
| asihpi | 44600 | udp | AudioScience HPI | Eliot Blennerhassett | Eliot Blennerhassett | 2011-07-07 | |||||
| 44601-44817 | Unassigned | ||||||||||
| EtherNet-IP-2 | 44818 | tcp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | tcp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| EtherNet-IP-2 | 44818 | udp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | udp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 44819-44899 | Unassigned | ||||||||||
| m3da | 44900 | tcp | M3DA is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| m3da-disc | 44900 | udp | M3DA Discovery is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| 44901-44999 | Unassigned | ||||||||||
| asmp | 45000 | tcp | Nuance AutoStore Status Monitoring Protocol (data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmp-mon | 45000 | udp | Nuance AutoStore Status Monitoring Protocol (device monitoring) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmps | 45001 | tcp | Nuance AutoStore Status Monitoring Protocol (secure data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| 45001 | udp | Reserved | |||||||||
| rs-status | 45002 | tcp | Redspeed Status Monitor | Redspeed International Ltd | Simon Griffiths | 2015-03-10 | |||||
| 45002 | udp | Reserved | |||||||||
| 45003-45044 | Unassigned | ||||||||||
| synctest | 45045 | tcp | Remote application control protocol | Eleks, Ltd. | Andriy Skop | 2013-04-08 | |||||
| 45045 | udp | Reserved | |||||||||
| 45046-45053 | Unassigned | ||||||||||
| invision-ag | 45054 | tcp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| invision-ag | 45054 | udp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| 45055-45184 | Unassigned | ||||||||||
| witsnet | 45185 | tcp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| witsnet | 45185 | udp | Wire and Wireless transfer on synchroniz | Shenzhen Inovance Technology Co., Ltd | Yan Yi | 2025-03-11 | |||||
| 45186-45513 | Unassigned | ||||||||||
| cloudcheck | 45514 | tcp | ASSIA CloudCheck WiFi Management System | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| cloudcheck-ping | 45514 | udp | ASSIA CloudCheck WiFi Management keepalive | ASSIA Inc. | Leonardo Dagum | 2016-08-29 | |||||
| 45515-45677 | Unassigned | ||||||||||
| eba | 45678 | tcp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| eba | 45678 | udp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| 45679-45823 | Unassigned | ||||||||||
| dai-shell | 45824 | tcp | Server for the DAI family of client-server products | Data Access, Inc. | Adam Robinson | 2012-04-30 | |||||
| 45824 | udp | Reserved | |||||||||
| qdb2service | 45825 | tcp | Qpuncture Data Access Service | Michael Yun | Michael Yun | 2007-10-24 | |||||
| qdb2service | 45825 | udp | Qpuncture Data Access Service | Michael Yun | Michael Yun | 2007-10-24 | |||||
| 45826-45965 | Unassigned | ||||||||||
| ssr-servermgr | 45966 | tcp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| ssr-servermgr | 45966 | udp | SSRServerMgr | Jeremy Gilliat | Jeremy Gilliat | ||||||
| 45967-46335 | Unassigned | ||||||||||
| inedo | 46336 | tcp | Listen port used for Inedo agent communication | Inedo | Steve Dennis | 2016-01-12 | |||||
| 46336 | udp | Reserved | |||||||||
| 46337-46997 | Unassigned | ||||||||||
| spremotetablet | 46998 | tcp | Connection between a desktop computer or server and a signature tablet to capture handwritten signatures | SOFTPRO GmbH | Christoph Hipp | 2012-07-19 | 2013-08-02 | ||||
| 46998 | udp | Reserved | |||||||||
| mediabox | 46999 | tcp | MediaBox Server | Alexander Graef | Alexander Graef | 2004-11 | |||||
| mediabox | 46999 | udp | MediaBox Server | Alexander Graef | Alexander Graef | 2004-11 | |||||
| mbus | 47000 | tcp | Message Bus | Dirk Kutscher | Dirk Kutscher |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Ballman | aaron&realsoftware.com | 2004-11 | |
| Acronis | kr&acronis.com | 2019-11-25 | |
| Adam Robinson | Data Access, Inc. | adam&dataaccessinc.com | 2012-04-30 |
| Alexander Graef | alex&graef.cc | 2004-11 | |
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2012-10-12 |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| Andriy Skop | Eleks, Ltd. | andriy.skop&eleks.com | 2013-04-08 |
| ASSIA Inc. | info&assia-inc.com | 2016-08-29 | |
| Brian Batke | eip.jsig&gmail.com | ||
| Christoph Hipp | SOFTPRO GmbH | christoph.hipp&softpro.de | 2013-08-02 |
| Cisco Systems | nmtg-port-numbers&cisco.com | 2005-11 | |
| Cognex Corporation | contactus&cognex.com | 2012-08-28 | |
| Curiosity GmbH | hello&curiosity.ai | 2022-12-09 | |
| Data Access, Inc. | development&dataaccessinc.com | 2012-04-30 | |
| Didier Lahay | dlahay&sierrawireless.com | 2013-02-22 | |
| Dirk Kutscher | dku&informatik.uni-bremen.de | ||
| DOMIQ Sp. z o.o. | registries&domiq.pl | 2011-08-29 | |
| Eclipse Foundation | license&eclipse.org | 2013-02-22 | |
| Eleks, Ltd. | eleksinfo&eleks.com | 2013-04-08 | |
| Eliot Blennerhassett | eblennerhassett&audioscience.com | 2011-07-07 | |
| eQ-3 Entwicklung GmbH | ports&entwicklung.eq-3.de | 2018-02-28 | |
| Filip Zawadiak | DOMIQ Sp. z o.o. | fzawadiak&domiq.pl | 2011-08-29 |
| Inedo | support&inedo.com | 2016-01-12 | |
| Jeremy Gilliat | jeremy.gilliat&geac.com | ||
| John Parello | jparello&cisco.com | 2009-05-19 | |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| Ken McDonell | kenj&kenj.id.au | 2025-09-26 | |
| Kevin Reed | kr&acronis.com | 2019-11-25 | |
| Leonardo Dagum | ldagum&assia-inc.com | 2016-08-29 | |
| Mario Joussen | Cognex Corporation | mario.joussen&cognex.com | 2012-08-28 |
| Matthias Schroer | matthias.schroer&invision.de | ||
| Michael Yun | cinnanda&gmail.com | 2007-10-24 | |
| Nuance Communications, Inc. | dev&nsius.com | 2017-04-26 | |
| Patrick Kara | Patrick&eba.net | ||
| Performance Co-Pilot (PCP) Project | pcp-maintainers&groups.io | 2025-09-26 | |
| Rafael Fernandes de Oliveira | rafael&curiosity.ai | 2022-12-09 | |
| Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 | |
| Research Electronics International | software&reiusa.net | 2012-12-20 | |
| Roman Kriis | roman&previo.ee | ||
| Ross Binkley | Research Electronics International | software&reiusa.net | 2012-12-20 |
| Shaper Automation Inc. | ports&shaperai.com | 2012-06-22 | |
| Shenzhen Inovance Technology Co., Ltd | yanyi&inovance.com | 2025-03-11 | |
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Simon Griffiths | Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 |
| SOFTPRO GmbH | christoph.hipp&softpro.de | 2013-08-02 | |
| Steve Dennis | sdennis&inedo.com | 2016-01-12 | |
| Theo Schlossnagle | jesus&omniti.com | 2009-05-19 | |
| Tido de Vries | eQ-3 Entwicklung GmbH | tido.devries&entwicklung.eq-3.de | 2018-02-28 |
| Yan Yi | yanyi&inovance.com | 2025-03-11 | |
| Yohann Sulaiman | ports&shaperai.com | 2012-06-22 |