Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ip-ieee | Internet Protocol on IEEE 802 | ||||||||||
| ip-ipx | Transmission of 802.2 over IPX Networks | ||||||||||
| ip-mtu | IP MTU Discovery Options | ||||||||||
| ip-netbios | Internet Protocol over NetBIOS Networks | ||||||||||
| ip-slip | Transmission of IP over Serial Lines | ||||||||||
| ip-wb | Internet Protocol on Wideband Network | ||||||||||
| ip-x25 | Internet Protocol on X.25 Networks | ||||||||||
| irtp | Internet Reliable Transaction Protocol | ||||||||||
| iso-tp4 | ISO Transport Protocol Class 4 | ||||||||||
| larp | Locus Address Resoultion Protocol | ||||||||||
| leaf-1 | Leaf-1 Protocol | ||||||||||
| leaf-2 | Leaf-2 Protocol | ||||||||||
| loc-srv | Location Service | ||||||||||
| Format of Electronic Mail Messages | |||||||||||
| merit-inp | MERIT Internodal Protocol | ||||||||||
| mib | Management Information Base | ||||||||||
| mihcs | MIH Command Services | RFC 5679 | |||||||||
| mihes | MIH Event Services | RFC 5679 | |||||||||
| mihis | MIH Information Services | RFC 5679 | |||||||||
| mfe-nsp | MFE Network Services Protocol | ||||||||||
| mit-subnet | MIT Subnet Support | ||||||||||
| mux | Multiplexing Protocol | ||||||||||
| netblt | Bulk Data Transfer Protocol | ||||||||||
| neted | Network Standard Text Editor | ||||||||||
| netrjs | Remote Job Service | ||||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| nfile | A File Access Protocol | ||||||||||
| nvp-ii | Network Voice Protocol | ||||||||||
| ospf | Open Shortest Path First Interior GW Protocol | ||||||||||
| pcmail | Pcmail Transport Protocol | ||||||||||
| ppp | Point-to-Point Protocol | ||||||||||
| prm | Packet Radio Measurement | ||||||||||
| pup | PUP Protocol | ||||||||||
| quote | Quote of the Day Protocol | ||||||||||
| rarp | A Reverse Address Resolution Protocol | ||||||||||
| ratp | Reliable Asynchronous Transfer Protocol | ||||||||||
| rdp | Reliable Data Protocol | ||||||||||
| rip | Routing Information Protocol | ||||||||||
| rvd | Remote Virtual Disk Protocol | ||||||||||
| sat-expak | Satnet and Backroom EXPAK | ||||||||||
| sat-mon | SATNET Monitoring | ||||||||||
| smi | Structure of Management Information | ||||||||||
| stp | Stream Protocol | ||||||||||
| sun-rpc | SUN Remote Procedure Call | ||||||||||
| tcp | Transmission Control Protocol | ||||||||||
| tcp-aco | TCP Alternate Checksum Option | ||||||||||
| thinwire | Thinwire Protocol | ||||||||||
| tp-tcp | ISO Transport Service on top of the TCP | ||||||||||
| trunk-1 | Trunk-1 Protocol | ||||||||||
| trunk-2 | Trunk-2 Protocol | ||||||||||
| ucl | University College London Protocol | ||||||||||
| udp | User Datagram Protocol | ||||||||||
| users | Active Users Protocol | ||||||||||
| via-ftp | VIA Systems-File Transfer Protocol | ||||||||||
| visa | VISA Protocol | ||||||||||
| vmtp | Versatile Message Transaction Protocol | ||||||||||
| wb-expak | Wideband EXPAK | ||||||||||
| wb-mon | Wideband Monitoring | ||||||||||
| xnet | Cross Net Debugger | ||||||||||
| xns-idp | Xerox NS IDP | ||||||||||
| 1password | 1Password Password Manager data sharing and synchronization protocol | Roustem Karimov | Roustem Karimov | Defined TXT keys: None | |||||||
| 7ksonar | tcp | Teledyne Marine 7k Sonar Protocol | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| 7ksonar | udp | Teledyne Marine 7k Sonar Protocol | Teledyne Marine | Anders Brandt | 2023-10-03 | Defined TXT keys: None | |||||
| a-d-sync | Altos Design Synchronization protocol | David Lasker | David Lasker | Defined TXT keys: None | |||||||
| abi-instrument | Applied Biosystems Universal Instrument Framework | ThermoFisher Scientific | Carlo Quiñónez | 2021-07-27 | Defined TXT keys: product=<short product name/model> description=<readable name> version=<firmware/instrument controller version> | ||||||
| ab-secure | tcp | AB Secure Protocol | Saso Ahmed | Saso Ahmed | 2026-05-29 | Defined TXT keys: None | |||||
| ab-secure | udp | AB Secure Protocol | Saso Ahmed | Saso Ahmed | 2026-05-29 | Defined TXT keys: None | |||||
| accessdata-f2d | FTK2 Database Discovery Service | Rick Russell | Rick Russell | Defined TXT keys: Proprietary | |||||||
| accessdata-f2w | FTK2 Backend Processing Agent Service | Rick Russell | Rick Russell | Defined TXT keys: Proprietary | |||||||
| accessone | Strix Systems 5S/AccessOne protocol | Scott Herscher | Scott Herscher | Defined TXT keys: None | |||||||
| accountedge | MYOB AccountEdge | Defined TXT keys: None | |||||||||
| acrobatsrv | Adobe Acrobat | Defined TXT keys: type, path, FeedType | |||||||||
| acs-ctl-ds | tcp | Access Control Device | Honeywell Security Group | John Dziadosz | 2012-04-09 | Defined TXT keys: MAC=, GW-MAC | |||||
| acs-ctl-ds | udp | Access Control Device | Honeywell Security Group | John Dziadosz | 2012-04-09 | Defined TXT keys: MAC=, GW-MAC | |||||
| acs-ctl-gw | tcp | Access Control Gateway | Honeywell Security Group | John Dziadosz | 2012-04-09 | Defined TXT keys: MAC=, GW-MAC | |||||
| acs-ctl-gw | udp | Access Control Gateway | Honeywell Security Group | John Dziadosz | 2012-04-09 | Defined TXT keys: MAC=, GW-MAC | |||||
| acsp-server | tcp | AXIS Camera Station Pro Server | Axis Communications | Joachim Ståhl | 2024-04-19 | Defined TXT keys: None | |||||
| actionitems | ActionItems | Sailalong Software | Sailalong Software | Defined TXT keys: None | |||||||
| activeraid | Active Storage Proprietary Device Management Protocol | Skip Levens | Skip Levens | Defined TXT keys: None | |||||||
| activeraid-ssl | Encrypted transport of Active Storage Proprietary Device Management Protocol | Skip Levens | Skip Levens | Defined TXT keys: None | |||||||
| adamhall | tcp | Adam Hall network control and monitoring | Adam Hall Group | Eric Sawade | 2022-07-15 | Defined TXT keys: None | |||||
| adamhall | udp | Adam Hall network control and monitoring | Adam Hall Group | Eric Sawade | 2022-07-15 | Defined TXT keys: None | |||||
| adaptive-rn | tcp | ARN (Adaptive Routing Notification) is a protocol designed to enable dynamic routing adjustments by sharing network status information between nodes in data center networks, improving efficiency and fault tolerance. | Hongyi Huang | Hongyi Huang | 2024-11-22 | Defined TXT keys: arn-protocol, adaptive-routing | |||||
| adaptive-rn | udp | ARN (Adaptive Routing Notification) is a protocol designed to enable dynamic routing adjustments by sharing network status information between nodes in data center networks, improving efficiency and fault tolerance. | Hongyi Huang | Hongyi Huang | 2024-11-22 | Defined TXT keys: arn-protocol, adaptive-routing | |||||
| addressbook | Address-O-Matic | Massimiliano Ribuoli and Marco Stefani | Massimiliano Ribuoli and Marco Stefani | Defined TXT keys: None | |||||||
| addressbooksrv | tcp | Address Book Server used for contacts and calendar synchronisation | AddressBookServer.com | Alexander Hartner | 2011-10-14 | Defined TXT keys: _suffix, _prefix | |||||
| adnodes | difusi Cloud based plug & play network synchronization protocol, content pool database discovery, and cloudOS SAaS discovery protocol. | DIFUSI, Inc. | Mike Wright | 2011-11-07 | Defined TXT keys: Proprietary | ||||||
| adobe-shadow | tcp | Adobe Shadow Server | Adobe Systems Inc. | Mike Harris | 2012-04-17 | Defined TXT keys: id | |||||
| adobe-vc | Adobe Version Cue | Defined TXT keys: txtvers=1, name, version, build | |||||||||
| adisk | Automatic Disk Discovery | Bob Bradley | Bob Bradley | Defined TXT keys: sys, dkX | |||||||
| adpro-setup | ADPRO Security Device Setup | Patrick Noffke | Patrick Noffke | Defined TXT keys: txtvers, type | |||||||
| ae-control | tcp | Acoustics Engineering network device control | Acoustics Engineering | Han Vertegaal | 2026-10-13 | Defined TXT keys: name, api-family, api, product, model, hw-rev, version | |||||
| aecoretech | Apple Application Engineering Services | Hani Abdelazim | Hani Abdelazim | Defined TXT keys: None | |||||||
| aeroflex | Aeroflex instrumentation and software | David Hagood | David Hagood | Defined TXT keys: orb_server=<port #> (optional) CORBA ORB server used for resource discovery product_id=<string> (optional) ID of licensed product txtvers="*IDN?=<identifier>" (optional) as per LXI specification (for not yet LXI compatible instruments) | |||||||
| aerohive-proxy | tcp | Aerohive Proxy Configuration Service | Aerohive Networks | Matthew Gast | 2012-05-31 | Defined TXT keys: name, port, username | |||||
| affinity-docs0 | tcp | Affinity Designer document sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary | |||||
| affinity-docs1 | tcp | Affinity Photo document sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary | |||||
| affinity-docs2 | tcp | Affinity Publisher document sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary | |||||
| affinity-cntent | tcp | Affinity content sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Acoustics Engineering | info&acoustics-engineering.com | 2026-10-13 | |
| Adam Hall Group | eric.sawade&adamhall.com | 2022-07-15 | |
| AddressBookServer.com | iana&addressbookserver.com | 2011-10-18 | |
| Adobe Systems Inc. | mikeharr&adobe.com | 2012-04-17 | |
| Aerohive Networks | iana&aerohive.com | 2012-06-04 | |
| Alexander Hartner | AddressBookServer.com | dev&addressbookserver.com | 2011-10-14 |
| Anders Brandt | Teledyne Marine | Anders.Brandt&Teledyne.com | 2023-10-03 |
| Axis Communications | contact-iana&axis.com | 2024-04-19 | |
| Bob Bradley | bradley&apple.com | ||
| Carlo Quiñónez | ThermoFisher Scientific | carlo.quinonez&thermofisher.com | 2021-07-27 |
| David Hagood | david.hagood&aeroflex.com | ||
| David Lasker | dave&altosdesign.com | ||
| DIFUSI, Inc. | mike&difusi.com | 2011-11-07 | |
| Eric Sawade | Adam Hall Group | eric.sawade&adamhall.com | 2022-07-15 |
| Han Vertegaal | Acoustics Engineering | h.vertegaal&acoustics-engineering.com | 2026-10-13 |
| Hani Abdelazim | hani&apple.com | ||
| Honeywell Security Group | john.dziadosz&honeywell.com | 2012-04-09 | |
| Hongyi Huang | hhy.hongyi&outlook.com | 2024-11-22 | |
| Joachim Ståhl | Axis Communications | contact-iana&axis.com | 2024-04-19 |
| John Dziadosz | Honeywell Security Group | john.dziadosz&honeywell.com | 2012-04-09 |
| Massimiliano Ribuoli and Marco Stefani | support&address-o-matic.com | ||
| Matthew Gast | Aerohive Networks | mgast&aerohive.com | 2012-05-31 |
| Mike Harris | Adobe Systems Inc. | mikeharr&adobe.com | 2012-04-17 |
| Mike Wright | DIFUSI, Inc. | mike&adnodes.co | 2011-11-07 |
| Patrick Noffke | patrick.noffke&adpro.com.au | ||
| Rick Russell | rrussell&accessdata.com | ||
| Roustem Karimov | roustem&agilewebsolutions.com | ||
| Sailalong Software | CustomerService&sailalong.com | ||
| Saso Ahmed | NotDreamPVP&gmail.com | 2026-05-29 | |
| Scott Herscher | scott&strixsystems.com | ||
| Serif (Europe) Ltd. | affinity&serif.com | 2023-03-30 | |
| Skip Levens | skip&activestoragelabs.com | ||
| Teledyne Marine | info&teledynemarine.com | 2023-10-03 | |
| ThermoFisher Scientific | carlo.quinonez&thermofisher.com | 2021-07-27 | |
| Tom Lachecki | Serif (Europe) Ltd. | tlachecki&serif.com | 2023-03-30 |