Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
breas udp Breas Breas Medical AB Jonas Sjostedt 2015-09-09 Defined TXT keys: None
bri RFID Reader Basic Reader Interface Thaddeus Ternes Thaddeus Ternes Defined TXT keys: None
bridgeprotocol tcp JSON RPC Bridge Protocol Michel Stam Michel Stam 2012-11-20 Defined TXT keys: path, version
brocoli-concert tcp brocoliconcert telecom brocoliconcert.corp Jang Hwanhee 2026-05-26 Defined TXT keys: None
brski-pledge tcp The Bootstrapping Remote Secure Key Infrastructure Pledge IESG IETF Chair 2026-05-11 RFC-ietf-anima-brski-prm-23 Defined TXT keys: None
brski-proxy tcp The Bootstrapping Remote Secure Key Infrastructure Proxy IESG IETF Chair 2020-04-29 RFC 8995 Defined TXT keys: None
brski-reg-cmp tcp Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 IESG IETF Chair 2024-09-23 RFC 9733 Defined TXT keys: None
brski-registrar tcp The Bootstrapping Remote Secure Key Infrastructure Registrar IESG IETF Chair 2020-04-29 RFC 8995 Defined TXT keys: None
bsqdea Backup Simplicity Qdea Qdea Defined TXT keys: None
btp tcp Beats Transfer Protocol allows for the discovery and control of devices Beats Electronics LLC. Yunho Huh 2014-02-17 2014-06-27 Defined TXT keys: None
buddycloud-api tcp buddycloud API buddycloud Simon Tennant 2013-05-20 Defined TXT keys: v, host, protocol, path, port
buzzer tcp Service for opening electric doors Mnemo.ai Arturo Falck 2017-12-22 Defined TXT keys: None
caldav tcp Calendaring Extensions to WebDAV (CalDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the http service. Defined TXT keys: path=<context path>
caldavs tcp Calendaring Extensions to WebDAV (CalDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the https service. Defined TXT keys: path=<context path>
caltalk CalTalk Joe Groff Joe Groff Defined TXT keys: None
canon-chmp tcp Canon HTTP Management Protocol Canon Inc. Tomoyuki Hansaki 2014-09-03 2015-03-16 Defined TXT keys: txtvers, mpath
carddav tcp vCard Extensions to WebDAV (CardDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6352 This is an extension of the http service. Defined TXT keys: path=<context path>
carddavs tcp vCard Extensions to WebDAV (CardDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6352 This is an extension of the https service. Defined TXT keys: path=<context path>
cardsend Card Send Protocol Jeff Grossman Jeff Grossman Defined TXT keys: Proprietary
carousel tcp Carousel Player Protocol Tightrope Media Systems, Inc. Scott Jann 2011-10-17 Defined TXT keys: None
cctv IP and Closed-Circuit Television for Securitiy applications Frank Rottmann Frank Rottmann Defined TXT keys: u=<username>, p=<password>, path=<path to XML file>
cerebra tcp Control the Cerebra Aquarium Controller Vertex Technologies Inc Christopher Schlacta 2018-04-20 Defined TXT keys: None
certificates tcp Server for S/MIME and PGP certificates IESG John Levine 2016-07-26 draft-bhjl-x509-srv-01 Defined TXT keys: None
cheat The Cheat Chaz McGarvey Chaz McGarvey Defined TXT keys: None
chess Project Gridlock Defined TXT keys: None
chfts Fluid Theme Server Defined TXT keys: None
chili The CHILI Radiology System Andre Schroter Andre Schroter Defined TXT keys: None
ciao tcp Ciao Arduino Protocol Mike Colagrosso Mike Colagrosso 2011-10-24 Defined TXT keys: see www.ciaoapp.com
cip4discovery Discovery of JDF (CIP4 Job Definition Format) enabled devices Stefan Daun Stefan Daun Defined TXT keys: None
clipboard Clipboard Sharing Defined TXT keys: None
clique udp Clique Link-Local Multicast Chat Room Telepathy project Telepathy project Defined TXT keys: see http://telepathy.freedesktop.org/xmpp/clique
clscts Oracle CLS Cluster Topology Service David Brower David Brower Defined TXT keys: None
collabio tcp Collabio XCDS International Ltd. Dmitriy Rusakov 2020-07-29 Defined TXT keys: firstName, lastName, documentName
collabio udp Collabio XCDS International Ltd. Dmitriy Rusakov 2020-07-29 Defined TXT keys: firstName, lastName, documentName
collection Published Collection Object Brady Anderson Brady Anderson Defined TXT keys: version=?
commfort tcp A client-server chat for LAN or Internet with video chat support CommFort software Ltd. Maxim Mirgorodsky 2016-03-03 Defined TXT keys: commfort, chat, communications, client-server, local chat, LAN, network, voice chat, video chat, video communication, video conference, file transfer
com-ocs-es-mcc ElectraStar media centre control protocol OC OC Defined TXT keys: None
compressnet tcp Management Utility/Compression Process Bernie Volz Bernie Volz 2025-02-13 Defined TXT keys: None
compressnet udp Management Utility/Compression Process Bernie Volz Bernie Volz 2025-02-13 Defined TXT keys: None
conecube udp DNS SRV service for smarthome server cone smart solution Christoph Bimminger 2019-04-22 Defined TXT keys: none
contactserver Now Contact Defined TXT keys: None
controllerplus tcp game controller forwarding protocol Apps From Outer Space, LLC John Haney 2022-07-05 Defined TXT keys: None
convert tcp 0-RTT TCP Convert Protocol IESG IETF Chair 2020-03-27 RFC 8803 Defined TXT keys: None
coolanetaudio tcp Coolatoola Network Audio Coolatoola.com Tim Hewett 2014-01-03 Defined TXT keys: None
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
corroboree Corroboree Server Heath Raftery Heath Raftery Defined TXT keys: None
cosir tcp Computer Op System Information Report Kevin C. Barber Kevin C. Barber 2009-01-13 2023-12-05 Defined TXT keys: None
coviot tcp Service for coviot branded devices Coviot Adnan Senyurt 2017-05-19 Defined TXT keys: FW_VERSION, PROTOCOL_VERSION, SERVICE_DESCRIPTION
coviot udp Service for coviot branded devices Coviot Adnan Senyurt 2017-05-19 Defined TXT keys: FW_VERSION, PROTOCOL_VERSION, SERVICE_DESCRIPTION
cpnotebook2 NoteBook 2 Circus Ponies Support Circus Ponies Support Defined TXT keys: None
csi-mmws tcp Canfield Scientific Inc - Mirror Mobile Web Services Canfield Scientific, Inc. James Crismale 2013-07-02 Defined TXT keys: path
cw-codetap CodeWarrior HTI Xscale PowerTAP Ted Woodward Ted Woodward Defined TXT keys: None
cw-dpitap CodeWarrior HTI DPI PowerTAP Ted Woodward Ted Woodward Defined TXT keys: None
cw-oncetap CodeWarrior HTI OnCE PowerTAP Ted Woodward Ted Woodward Defined TXT keys: None
cw-powertap CodeWarrior HTI COP PowerTAP Ted Woodward Ted Woodward Defined TXT keys: None
cytv CyTV - Network streaming for Elgato EyeTV Andreas Junghans Andreas Junghans Defined TXT keys: None
dacp Digital Audio Control Protocol (iTunes) Amandeep Jawa Amandeep Jawa Defined TXT keys: txtvers, Ver, DbId
dancepartner Dance partner application for iPhone Rory McClure Rory McClure Defined TXT keys: None
darkhorsetimer tcp Timer LAN service Dark Horse GmbH & Co KG Ludwig Kannicht 2015-06-02 Defined TXT keys: None
dataturbine Open Source DataTurbine Streaming Data Middleware Tony Fountain Tony Fountain Defined TXT keys: None
dbaudio tcp d&b audiotechnik remote network d&b audiotechnik Christian Laendner 2011-10-06 Defined TXT keys:txtvers=<TXT-Record version> protovers=<version of proprietary protocol> guid=<type> name=<name> sn=<serial number> device=<cleartext type> fwver=<firmware version>
dbaudio udp d&b audiotechnik remote network d&b audiotechnik Christian Laendner 2011-10-06 Defined TXT keys:txtvers=<TXT-Record version> protovers=<version of proprietary protocol> guid=<type> name=<name> sn=<serial number> device=<cleartext type> fwver=<firmware version>
dccp-ping dccp ping/traceroute using DCCP Samuel Jero Samuel Jero 2012-11-14 1885957735 Defined TXT keys: None
dell-soo-ds tcp Spotlight on Oracle Diagnostic Server Dell Rob Griffin 2013-10-03 Defined TXT keys: None
dell-soo-ds udp Spotlight on Oracle Diagnostic Server Dell Rob Griffin 2013-10-03 Defined TXT keys: None
dell-soss-ds-w tcp Spotlight on SQL Server Diagnostic Server HTTP Dell Rob Griffin 2013-10-03 Defined TXT keys: None
dell-ssms-ds tcp Spotlight SSMS Plugin Diagnostic Server Dell Rob Griffin 2013-10-03 Defined TXT keys: None
demoncamremote tcp Peer-to-peer real-time video streaming James Alan Bush James Alan Bush 2017-09-26 Defined TXT keys: None
demoncamremote udp Peer-to-peer real-time video streaming James Alan Bush James Alan Bush 2017-09-26 Defined TXT keys: None
device-info Device Info Stuart Cheshire; Marc Krochmal Stuart Cheshire; Marc Krochmal Not a service type. Special name reserved for DNS-SD device info.
devonsync tcp DEVONthink synchronization protocol DEVONtechnologies, LLC Rob Rix; Eric Boehnisch-Volkmann 2011-10-18 Defined TXT keys: None at present
dhanda-g tcp DHANDAg is going for a site DHANDAg Deepam 2017-12-29 Defined TXT keys: None
dhanda-g udp DHANDAg is going for a site DHANDAg Deepam 2017-12-29 Defined TXT keys: None
dhanda-g sctp DHANDAg is going for a site DHANDAg Deepam 2017-12-29 Defined TXT keys: None
dictation Use of a dictation service by a hand-held device Nuance Communications, Inc. Mark Jackson 2011-10-27 Defined TXT keys: ver, name
difi EyeHome Elgato Elgato Defined TXT keys: None
digitalelectric tcp Digital Electricity Transmitter VoltServer, Inc Thom Nichols 2025-07-21 Defined TXT Keys: vendor, model, serialNo, mac
disconnect DisConnect Peer to Peer Game Protocol Michael S. Bogovich Michael S. Bogovich Defined TXT keys: None
displaysrc tcp Wi-Fi Alliance Display Source service Wi-Fi Alliance Gaurav Jain 2017-03-14 Defined TXT keys: None
dist-opencl Distributed OpenCL discovery protocol William Dillon William Dillon 2013-04-10 Defined TXT keys: TCPendpoint, UDPendpoint, UUID
ditrios Ditrios SOA Framework Protocol Mark Schmatz Mark Schmatz Defined TXT keys: http://www.ditrios.org/index.php?link=tutorial/index#zeroconf
divelogsync Dive Log Data Sharing and Synchronization Protocol Greg McLaughlin Greg McLaughlin Defined TXT keys: None
dlpx-sp tcp Delphix Session Protocol Delphix Corp Peng Dai 2012-10-02 Defined TXT keys: None
dltimesync udp Local Area Dynamic Time Synchronisation Protocol Geoff Back Geoff Back Defined TXT keys: None
dns-llq-tls tcp DNS Long-Lived Queries over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 Defined TXT Keys: None
dns-push-tls tcp DNS Push Notification Service Type IESG IETF Chair 2019-11-25 RFC 8765, Section 6.1 Defined TXT Keys: None
dns-query-tls tcp DNS queries to the authoritative server over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 Defined TXT Keys: None
dns-sd DNS Service Discovery Stuart Cheshire; Marc Krochmal Stuart Cheshire; Marc Krochmal Not a service type. Special name reserved for DNS-SD meta queries.
dns-update tcp DNS Dynamic Update Service Stuart Cheshire Stuart Cheshire 2019-05-04 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dns-update udp DNS Dynamic Update Service Stuart Cheshire Stuart Cheshire 2019-05-04 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dns-update-tls tcp DNS Dynamic Update Service over TLS Stuart Cheshire Stuart Cheshire 2019-05-04 RFC 6281 DNS Dynamic Update Service for a given domain may not necessarily be provided by the principal name servers as advertised by the domain's "NS" records, and may not necessarily always be provided on port 53. The "_dns-update._udp.<domain>." SRV record gives the target host and port where DNS Dynamic Update Service is provided for the named domain.
dnssd-srp tcp DNS-Based Service Discovery IESG IETF Chair 2024-04-12 2024-09-05 RFC 9665 Defined TXT keys: None
dnssd-srp-tls tcp DNS-Based Service Discovery (TLS) IESG IETF Chair 2024-04-12 2024-09-05 RFC 9665 Defined TXT keys: None
dop Roar (Death of Productivity) Massive Flow Productions Massive Flow Productions Defined TXT keys: name=<full username>
dots-call-home tcp DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
dots-call-home udp DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
dots-data tcp DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. IESG IETF Chair 2020-11-19 RFC 8973 Defined TXT keys: None
dropcopy DropCopy 10base-t Interactive 10base-t Interactive Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Adnan Senyurt Coviot adnansenyurt&coviot.com 2017-05-19
Amandeep Jawa daap&apple.com
Andre Schroter A.Schroeter&chili-radiology.com
Andreas Junghans cytv&lucid-cake.net
Apps From Outer Space, LLC john&appsfromouterspace.com 2022-07-05
Arturo Falck info&mnemo.ai 2017-12-22
Beats Electronics LLC. yunho.huh&beatsbydre.com 2014-06-27
Bernie Volz volz&cisco.com
Brady Anderson banderso&novell.com
Breas Medical AB jonas.sjostedt&breas.com
brocoliconcert.corp janghwanhee&brocoliconcert.com 2026-05-26
buddycloud simon&buddycloud.com 2013-05-20
Canfield Scientific, Inc. jim.crismale&canfieldsci.com 2013-07-02
Canon Inc. fujii.ken-ichi149&canon.co.jp 2014-09-03
Chaz McGarvey chaz&brokenzipper.com
Christian Laendner d&b audiotechnik software.support&dbaudio.com 2011-10-06
Christoph Bimminger cone smart solution christoph.bimminger&cone.at 2019-04-22
Christopher Schlacta Vertex Technologies Inc christopher&vertextechnologies.net 2018-04-20
Circus Ponies Support admin&cirros.net
CommFort software Ltd. support&commfort.com 2016-03-03
cone smart solution office&cone.at 2019-04-22
Coolatoola.com helpme&coolatoola.com 2014-01-03
Coviot tubainci&coviot.com 2017-05-19
d&b audiotechnik software.support&dbaudio.com 2011-10-06
Dark Horse GmbH & Co KG l.kannicht&thedarkhorse.de 2015-06-02
David Brower david.brower&oracle.com
Deepam jaatdeepam&gmail.com 2017-12-29
Dell rob.gri55in&gmail.com 2013-10-03
Delphix Corp peng.dai&delphix.com 2012-11-01
DEVONtechnologies, LLC info&devontechnologies.com 2011-10-18
DHANDAg groupsdhanda&gmail.com 2017-12-29
Dmitriy Rusakov Dmitriy.Rusakov&collabio.team 2020-07-29
Elgato support&elgato.com
Eric Boehnisch-Volkmann DEVONtechnologies, LLC eboehnisch&devo-technologies.com 2011-10-18
Frank Rottmann Frank.Rottmann&web.de
Gaurav Jain Wi-Fi Alliance gjain&wifi.org 2017-03-14
Geoff Back geoff&demonlair.co.uk
Greg McLaughlin ggregm&moremobilesoftware.com
Heath Raftery heath&hrsoftworks.net
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Alan Bush jamesalanbush&yahoo.com 2017-09-26
James Crismale Canfield Scientific, Inc. jim.crismale&canfieldsci.com 2013-07-02
Jang Hwanhee janghwanhee&brocoliconcert.com 2026-05-26
Jeff Grossman jagrossm&andrew.cmu.edu
Joe Groff arcata&gmail.com
John Haney Apps From Outer Space, LLC john&appsfromouterspace.com 2022-07-05
John Levine standards&taugh.com 2016-07-26
Jonas Sjostedt jonas.sjostedt&breas.com
Kevin C. Barber kevin.c.barber&saic.com 2023-12-05
Ludwig Kannicht Dark Horse GmbH & Co KG l.kannicht&thedarkhorse.de 2015-06-02
Marc Krochmal marc&apple.com
Mark Jackson Nuance Communications, Inc. Mark.Jackson&nuance.com 2011-10-27
Mark Schmatz ditrios&markschmatz.de
Massive Flow Productions info&massiveflow.de
Maxim Mirgorodsky CommFort software Ltd. support&commfort.com 2016-03-03
Michael S. Bogovich info&burnthebox.us
Michel Stam michel.iana&reverze.net 2012-11-20
Mike Colagrosso ciao&ciaoapp.com 2011-10-24
Mnemo.ai info&mnemo.ai 2017-12-22
Nuance Communications, Inc. Mark.Jackson&nuance.com 2011-10-27
OC ocs&ocs.cz
Peng Dai Delphix Corp peng.dai&delphix.com 2012-11-01
Qdea support&qdea.com
Rob Griffin Dell rob.gri55in&gmail.com 2013-10-03
Rob Rix DEVONtechnologies, LLC rrix&devontechnologies.com 2011-10-18
Rory McClure mcclurert&hotmail.com
Samuel Jero sj323707&ohio.edu 2012-11-14
Scott Jann Tightrope Media Systems, Inc. sjann&trms.com 2011-10-17
Simon Tennant buddycloud simon&buddycloud.com 2013-05-20
Stefan Daun secretariat&cip4.org
Stuart Cheshire cheshire&apple.com 2022-07-11
Ted Woodward ted&metrowerks.com
Telepathy project telepathy&lists.freedesktop.org
Thaddeus Ternes thaddeus.ternes&intermec.com
Thom Nichols VoltServer, Inc thom.nichols&voltserver.com 2025-07-21
Tightrope Media Systems, Inc. sjann&trms.com 2011-10-17
Tim Hewett Coolatoola.com helpme&coolatoola.com 2014-01-03
Tomoyuki Hansaki Canon Inc. hansaki.tomoyuki&canon.co.jp 2014-09-03
Tony Fountain tfountain&ucsd.edu
Vertex Technologies Inc info&vertextechnologies.net 2018-04-20
VoltServer, Inc admin&voltserver.com 2025-07-21
Wi-Fi Alliance gjain&wi-fi.org 2017-03-14
William Dillon wdillon&coas.oregonstate.edu
XCDS International Ltd. contact&xcds.com 2020-07-29
Yunho Huh Beats Electronics LLC. yunho.huh&beatsbydre.com 2014-06-27
10base-t Interactive support&10base-t.com