Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ieee-mms-ssl | 695 | tcp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| ieee-mms-ssl | 695 | udp | IEEE-MMS-SSL | Curtis Anderson | Curtis Anderson | ||||||
| rushd | 696 | tcp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| rushd | 696 | udp | RUSHD | Greg Ercolano | Greg Ercolano | ||||||
| uuidgen | 697 | tcp | UUIDGEN | James Falkner | James Falkner | ||||||
| uuidgen | 697 | udp | UUIDGEN | James Falkner | James Falkner | ||||||
| olsr | 698 | tcp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| olsr | 698 | udp | OLSR | Thomas Clausen | Thomas Clausen | ||||||
| accessnetwork | 699 | tcp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| accessnetwork | 699 | udp | Access Network | Yingchun Xu | Yingchun Xu | ||||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| lmp | 701 | tcp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| lmp | 701 | udp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| 703 | Unassigned | ||||||||||
| elcsd | 704 | tcp | errlog copy/server daemon | ||||||||
| elcsd | 704 | udp | errlog copy/server daemon | ||||||||
| agentx | 705 | tcp | AgentX | Bob Natale | Bob Natale | ||||||
| agentx | 705 | udp | AgentX | Bob Natale | Bob Natale | ||||||
| silc | 706 | tcp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| silc | 706 | udp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| borland-dsj | 707 | tcp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| borland-dsj | 707 | udp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| 708 | Unassigned | ||||||||||
| entrust-kmsh | 709 | tcp | Entrust Key Management Service Handler | ||||||||
| entrust-kmsh | 709 | udp | Entrust Key Management Service Handler | ||||||||
| entrust-ash | 710 | tcp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| entrust-ash | 710 | udp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| cisco-tdp | 711 | tcp | Cisco TDP | Bruce Davie | Bruce Davie | ||||||
| cisco-tdp | 711 | udp | Cisco TDP | Bruce Davie | Bruce Davie | ||||||
| tbrpf | 712 | tcp | TBRPF | RFC 3684 | |||||||
| tbrpf | 712 | udp | TBRPF | RFC 3684 | |||||||
| iris-xpc | 713 | tcp | IRIS over XPC | ||||||||
| iris-xpc | 713 | udp | IRIS over XPC | ||||||||
| iris-xpcs | 714 | tcp | IRIS over XPCS | RFC 4992 | |||||||
| iris-xpcs | 714 | udp | IRIS over XPCS | RFC 4992 | |||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| pana | 716 | udp | PANA Messages | RFC 5191 | |||||||
| 717-728 | Unassigned | ||||||||||
| netviewdm1 | 729 | tcp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm1 | 729 | udp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm2 | 730 | tcp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm2 | 730 | udp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm3 | 731 | tcp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| netviewdm3 | 731 | udp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| 732-740 | Unassigned | ||||||||||
| netgw | 741 | tcp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netgw | 741 | udp | netGW | Oliver Korfmacher | Oliver Korfmacher | ||||||
| netrcs | 742 | tcp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| netrcs | 742 | udp | Network based Rev. Cont. Sys. | Gordon C. Galligher | Gordon C. Galligher | ||||||
| 743 | Unassigned | ||||||||||
| flexlm | 744 | tcp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| flexlm | 744 | udp | Flexible License Manager | Matt Christiano | Matt Christiano | ||||||
| 745-746 | Unassigned | ||||||||||
| fujitsu-dev | 747 | tcp | Fujitsu Device Control | ||||||||
| fujitsu-dev | 747 | udp | Fujitsu Device Control | ||||||||
| ris-cm | 748 | tcp | Russell Info Sci Calendar Manager | ||||||||
| ris-cm | 748 | udp | Russell Info Sci Calendar Manager | ||||||||
| kerberos-adm | 749 | tcp | kerberos administration | ||||||||
| kerberos-adm | 749 | udp | kerberos administration | ||||||||
| rfile | 750 | tcp | |||||||||
| loadav | 750 | udp | |||||||||
| kerberos-iv | 750 | udp | kerberos version iv | Martin Hamilton | Martin Hamilton | ||||||
| pump | 751 | tcp | |||||||||
| pump | 751 | udp | |||||||||
| qrh | 752 | tcp | |||||||||
| qrh | 752 | udp | |||||||||
| rrh | 753 | tcp | |||||||||
| rrh | 753 | udp | |||||||||
| tell | 754 | tcp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| tell | 754 | udp | send | Josyula R. Rao | Josyula R. Rao | ||||||
| 755-757 | Unassigned | ||||||||||
| nlogin | 758 | tcp | |||||||||
| nlogin | 758 | udp | |||||||||
| con | 759 | tcp | |||||||||
| con | 759 | udp | |||||||||
| ns | 760 | tcp | |||||||||
| ns | 760 | udp | |||||||||
| rxe | 761 | tcp | |||||||||
| rxe | 761 | udp | |||||||||
| quotad | 762 | tcp | |||||||||
| quotad | 762 | udp | |||||||||
| cycleserv | 763 | tcp | |||||||||
| cycleserv | 763 | udp | |||||||||
| omserv | 764 | tcp | |||||||||
| omserv | 764 | udp | |||||||||
| webster | 765 | tcp | Josyula R. Rao | Josyula R. Rao | |||||||
| webster | 765 | udp | Josyula R. Rao | Josyula R. Rao | |||||||
| 766 | Unassigned | ||||||||||
| phonebook | 767 | tcp | phone | Josyula R. Rao | Josyula R. Rao | ||||||
| phonebook | 767 | udp | phone | Josyula R. Rao | Josyula R. Rao | ||||||
| 768 | Unassigned | ||||||||||
| vid | 769 | tcp | |||||||||
| vid | 769 | udp | |||||||||
| cadlock | 770 | tcp | |||||||||
| cadlock | 770 | udp | |||||||||
| rtip | 771 | tcp | |||||||||
| rtip | 771 | udp |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bob Natale | bob.natale&appliedsnmp.com | ||
| Bruce Davie | bsd&cisco.com | ||
| Curtis Anderson | ecanderson&turbolinux.com | ||
| Gerg Cole | gcole&corp.borland.com | ||
| Gordon C. Galligher | gorpong&ping.chi.il.us | ||
| Greg Ercolano | erco&netcom.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Falkner | james.falkner&sun.com | ||
| Josyula R. Rao | jrrao&watson.ibm.com | ||
| Martin Hamilton | martin&mrrl.lut.as.uk | ||
| Matt Christiano | globes@matt&oliveb.atc.olivetti.com | ||
| Oliver Korfmacher | okorf&netcs.com | ||
| Pekka Riikonen | priikone&poseidon.pspt.fi | ||
| Peter Whittaker | pww&entrust.com | ||
| Philippe Binet | phbinet&vnet.ibm.com | ||
| Thomas Clausen | thomas.clausen&polytechnique.edu | 2023-02-28 | |
| Yingchun Xu | Yingchun_Xu&3com.com |