Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
larvaio-control udp Larva IP Controller larva.io ltd. Reijo Sirila 2019-02-11 Defined TXT keys: None
leaf Lua Embedded Application Framework Ico Doornekamp Ico Doornekamp Defined TXT keys: name=<readable name> product=<product name/model> version=<version number>
lexicon Lexicon Vocabulary Sharing Jacob Godwin-Jones Jacob Godwin-Jones Defined TXT keys: None
liaison Liaison Brian Cully Brian Cully Defined TXT keys: None
library Delicious Library 2 Collection Data Sharing Protocol William Shipley William Shipley Defined TXT keys: None
libratone Protocol for setup and control of Libratone products Libratone A/S Claus Jensen 2011-10-27 Defined TXT keys: None
licor LI-COR Biosciences instrument discovery Software LI-COR Biosciences Kevin Ediger 2011-10-18 Defined TXT keys: None
llrp-secure RFID reader Low Level Reader Protocol over SSL/TLS Jason Schoon Jason Schoon Defined TXT keys: None
lobby Gobby 0x539 dev group 0x539 dev group Defined TXT keys: None
logicnode udp Logic Pro Distributed Audio Nikolaus Gerteis Nikolaus Gerteis Defined TXT keys: None
logsheetserver tcp logSheet Server Synchronization Server X2 Studios Ltd Jason McNeil 2020-05-06 Defined TXT keys: lssvers
lonbridge Echelon LonBridge Server Rich Blomseth Rich Blomseth Defined TXT keys: None
lontalk LonTalk over IP (ANSI 852) Michael Tennefoss Michael Tennefoss Defined TXT keys: None
lonworks Echelon LNS Remote Client Michael Tennefoss Michael Tennefoss Defined TXT keys: None
lsys-appserver Linksys One Application Server API Frank Zerangue Frank Zerangue Defined TXT keys: path=value (relative URL) engname=value (string)
lsys-camera Linksys One Camera API Frank Zerangue Frank Zerangue Defined TXT keys: brand=value (string) model=value (string) version=value (string)
lsys-ezcfg LinkSys EZ Configuration Frank Zerangue Frank Zerangue Defined TXT keys: model=value (string) serial=value (sring) hwversion=value (string) swversion=value (string) ifversion=value (string) type=value (string) mac=value (12 hex digits)
lsys-oamp LinkSys Operations, Administration, Management, and Provisioning Frank Zerangue Frank Zerangue Defined TXT keys: model=value (string) serial=value (sring) hwversion=value (string) swversion=value (string) ifversion=value (string) type=value (string) mac=value (12 hex digits)
lumiere tcp A protocol to remotely control DMX512 devices over the network Gangsta Ltd. Jean-Charles Boude 2011-10-13 Defined TXT keys: None
lumis-lca tcp Lumis Cache Appliance Protocol Lumis Rodrigo Terra 2011-10-24 Defined TXT keys: none
lux-dtp Lux Solis Data Transport Protocol Laurence Flath Laurence Flath Defined TXT keys: None
lxi LXI Nick Barendt Nick Barendt Defined TXT keys: txtvers, *IDN?=<response defined by IEEE 488; e.g., manufacturer, model, serial number, version>
lyrics iPod Lyrics Service Gary Giebler Gary Giebler Defined TXT keys: Proprietary
M30S1PT tcp Moritz30-Project Standard protocol 1 Plain Text Moritz30 Matthias Merkel 2015-12-07 Defined TXT keys: None
M30S1PT udp Moritz30-Project Standard protocol 1 Plain Text Moritz30 Matthias Merkel 2015-12-07 Defined TXT keys: None
macfoh MacFOH Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-admin MacFOH admin services Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-audio udp MacFOH audio stream Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-events udp MacFOH show control events Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-data udp MacFOH realtime data Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-db MacFOH database Shaun Wexler Shaun Wexler Defined TXT keys: None
macfoh-remote MacFOH Remote Shaun Wexler Shaun Wexler Defined TXT keys: None
macminder Mac Minder Luma Code Luma Code Defined TXT keys: None
maestro Maestro Music Sharing Service Luke Steffen Luke Steffen Defined TXT keys: None
magicdice Magic Dice Game Protocol Mike Yenco Mike Yenco Defined TXT keys: None
mandos Mandos Password Server Mandos Maintainers Mandos Maintainers Defined TXT keys: None
mas tcp Pravala Mobility and Aggregation Service Pravala Networks ULC Severn Tsui 2016-06-01 Defined TXT keys: None
mas udp Pravala Mobility and Aggregation Service Pravala Networks ULC Severn Tsui 2016-06-01 Defined TXT keys: None
matrix MATRIX Remote AV Switching Ken Jibiki Ken Jibiki Defined TXT keys: None
matterc tcp Matter Commissionable Node Discovery Connectivity Standards Alliance Aron Rosenberg 2021-05-21 Defined TXT keys: None
matterc udp Matter Commissionable Node Discovery Connectivity Standards Alliance Aron Rosenberg 2021-05-21 Defined TXT keys: None
matterd tcp Matter Commissioner Discovery Connectivity Standards Alliance Aron Rosenberg 2021-05-21 Defined TXT keys: None
matterd udp Matter Commissioner Discovery Connectivity Standards Alliance Aron Rosenberg 2021-05-21 Defined TXT keys: None
mavlink tcp MAVLink Micro Air Vehicle Communication Protocol Roderick Mann Roderick Mann 2011-10-20 Defined TXT keys: 0
mazepseudo-game udp Peer to peer communication between instances of the Maze Pseudo game. Mad Elf Software, Inc. Kenneth Suda 2016-02-02 2016-03-30 Defined TXT keys: 1 TXT record key for the RSA public key used by the server instance.
mbconsumer MediaBroker++ Consumer Nate Rivard Nate Rivard Defined TXT keys: None
mbproducer MediaBroker++ Producer Nate Rivard Nate Rivard Defined TXT keys: None
mbserver MediaBroker++ Server Nate Rivard Nate Rivard Defined TXT keys: None
mconnect ClairMail Connect Sachin Desai Sachin Desai Defined TXT keys: None
mcrcp MediaCentral equinux equinux Defined TXT keys: None
mediaboard1 MediaBoardONE Asset and Information Manager data sharing and synchronization protocol Thomas K. Fischer Thomas K. Fischer Defined TXT keys: None
mediatap tcp Mediatap streaming protocol Mediatap GbR Mario Pörner 2011-10-11 Defined TXT keys: Proprietary
mercurydock tcp Mercury Dock Assistant Spider Electronics Kenny Millar 2014-03-10 Defined TXT keys: status, signature, ver
mesamis Mes Amis David Priest David Priest Defined TXT keys: None
meshcop udp Thread Mesh Commissioning Thread Group, Inc. Esko Dijk 2020-11-20 Defined TXT keys: Thread 1.1 Specification, Section 8.4.1.1.2. https://www.threadgroup.org/ThreadSpec
meshcop-e udp Thread Mesh Commissioning Ephemeral-key Thread Group, Inc. Esko Dijk 2024-01-22 Defined TXT keys: TXT records keys, if any, will be defined in Section 8.12 of the Thread Specification. https://www.threadgroup.org/ThreadSpec
mi-raysat Mental Ray for Maya Autodesk Autodesk Defined TXT keys: None
microdeep tcp A protocol for controlling a microscope Zorth Sarl David Mendels 2023-08-02 Defined TXT keys: txtvers version name uuid
midi2 udp MIDI 2.0 Device Discovery MIDI Manufacturers Association Florian Bomers 2023-11-07 Defined TXT keys: EndpointName, ProductInstanceId
mieleacs tcp Protocol for connected accessories Miele & Cie. KG Dr. Nils Langhammer 2018-04-20 Defined TXT keys: txtvers and proprietary keys
mieleathome tcp Miele@home Protocol Miele & Cie. KG Dr. Nils Langhammer 2014-03-13 Defined TXT keys: txtvers and proprietary keys
mieleprof tcp Miele protocol for prof. appliances Miele & Cie. KG Dr. Nils Langhammer 2018-04-20 Defined TXT keys: txtvers and proprietary keys
mielesemiprof tcp Miele protocol for semi prof. appliances Miele & Cie. KG Dr. Nils Langhammer 2018-04-20 Defined TXT keys: txtvers and proprietary keys
mist tcp A Medical Interoperability Service Type, used to identify medical devices providing network interfaces. Jon Griffeth Jon Griffeth 2017-01-12 Defined TXT keys: https://www.praesentia.com/medkit/mist-service-type (dn dt md mf pr sn vn)
mles tcp Mles is a client-server data distribution protocol targeted to serve as a lightweight and reliable distributed publish/subscribe database service. Juhamatti Kuusisaari Juhamatti Kuusisaari 2017-02-24 2024-01-05 Defined TXT keys: None
mmm tcp Provides a client with access to the Mathematical Mesh, a user-focused PKI. Phillip Hallam-Baker Phillip Hallam-Baker 2015-11-18 Defined TXT keys: None
mms-edgerouter tcp Maritime Messaging Service Edge Router Radio Technical Commission for Maritime Services Radio Technical Commission for Maritime Services 2026-03-18 Defined TXT keys: None
mn-passage tcp A Remote Control Application service used to control Computers on a Local Area Network Midnight Oil Enterprises, LLC Dan Corkill 2013-07-09 Defined TXT keys: inherited from bonjour/iOS multipeer connectivity
mn-passage udp A Remote Control Application service used to control Computers on a Local Area Network Midnight Oil Enterprises, LLC Dan Corkill 2013-07-09 Defined TXT keys: inherited from bonjour/iOS multipeer connectivity
modolansrv modo LAN Services Matt Craig Matt Craig Defined TXT keys: None
mogeneti-auth tcp Authentication service for Mogeneti Software Applications Mogeneti Bart Rijpers 2012-09-26 Defined TXT keys: none
moncon udp Sonnox MCON monitor controller protocol Sonnox Ltd Nicolas Haynes 2018-08-15 Defined TXT keys: None
moneysync SplashMoney Synchronization Service Justin Cepelak Justin Cepelak Defined TXT keys: Proprietary
moneyworks MoneyWorks Gold and MoneyWorks Datacentre network service Rowan Daniell Rowan Daniell Defined TXT keys: None
moodring Bonjour Mood Ring tutorial program Daniel Steinberg Daniel Steinberg Defined TXT keys: txtvers=1 mood=<ascii digit from 0-4>
mother Mother script server protocol Jonathan Jonathan Defined TXT keys: user, ssl
movieslate MovieSlate digital clapperboard Cliff Joyce Cliff Joyce Defined TXT keys: Proprietary
mp3sushi MP3 Sushi Alexandre Carlhian Alexandre Carlhian Defined TXT keys: None
mqtt IBM MQ Telemetry Transport Broker AndySC AndySC Defined TXT keys: topics=<open topic to subscribe to for information>, eg topic=/info
mslingshot Martian SlingShot Martin Technology Martin Technology Defined TXT keys: displayName, passwordRequired, acceptsUpdates
msrps tcp MSRP protocol over TLS 2014-04-25 RFC 4976 Defined TXT keys:
mumble Mumble VoIP communication protocol Thorvald Natvig Thorvald Natvig Defined TXT keys: None
musicmachine Protocol for a distributed music playing service Johan Mjones Johan Mjones Defined TXT keys: apiversion, passreq
mysync MySync Protocol Martin Redington Martin Redington Defined TXT keys: None
mttp MenuTunes Sharing iThink Software iThink Software Defined TXT keys: None
mxim-art2 Maxim Integrated Products Automated Roadtest Mk II Zach Metzinger Zach Metzinger Defined TXT keys: Proprietary
mxim-ice Maxim Integrated Products In-circuit Emulator Zach Metzinger Zach Metzinger Defined TXT keys: Proprietary
mxs MatrixStore Object Matrix Object Matrix Defined TXT keys: None mxs.system.id=<system id> mxs.system.version=<system layer version> mxs.cluster.id=<cluster id the system belongs to>
naio tcp NetAcquire server input/output protocol NetAcquire Corporation David Hauck 2018-06-20 Defined TXT keys: txtvers, fn
nasmon tcp Proprietary communication protocol for NAS Monitor Infinite Loop Claus Broch 2012-10-09 Defined TXT keys: Proprietary
nasmon udp Proprietary communication protocol for NAS Monitor Infinite Loop Claus Broch 2012-10-09 Defined TXT keys: Proprietary
nasunifiler tcp This DNS-SD service is used by mobile clients to locate the Nasuni Filer (a storage product) for a given company. Nasuni Corporation David Shaw 2016-01-22 Defined TXT keys: companyfullname == The name of the company hosting the Nasuni Filer
ncbroadcast Network Clipboard Broadcasts Thom McGrath Thom McGrath Defined TXT keys: Contact The ZAZ Software <networkclipboard at thezaz.com>
ncdirect Network Clipboard Direct Transfers Thom McGrath Thom McGrath Defined TXT keys: Contact The ZAZ Software <networkclipboard at thezaz.com>
ncount-issuer tcp The issuer service in the n-Count electronic value transfer system n-Count Technology B.V. Eduard de Jong 2013-01-22 Defined TXT keys: None
ncsyncserver Network Clipboard Sync Server Thom McGrath Thom McGrath Defined TXT keys: Contact The ZAZ Software <networkclipboard at thezaz.com>
ndi tcp IP based video discovery and usage NewTek Inc Brad McFarland 2022-11-22 Defined TXT keys: Proprietary
ndi udp IP based video discovery and usage NewTek Inc Brad McFarland 2022-11-22 Defined TXT keys: Proprietary
nedap-aepu tcp Nedap AEOS processing unit Nedap Leon van der Voort van der Kleij 2014-08-28 Defined TXT keys: None
neoriders udp NeoRiders Client Discovery Protocol Jesse W. Towner Jesse W. Towner Defined TXT keys: None
netready tcp UpdateLogic NetReady Device Identification UpdateLogic, Inc. Chris Nigbur 2014-10-27 Defined TXT keys: Proprietary

Contact Information

Name Organization Contact URI Last Updated
Alexandre Carlhian alex&appeule.com
AndySC AndySC&uk.ibm.com
Aron Rosenberg Connectivity Standards Alliance arosenberg&logitech.com 2021-07-16
Autodesk me.licensing&autodesk.com
Bart Rijpers Mogeneti bart&mogeneti.com 2012-09-26
Brad McFarland NewTek Inc bmcfarland&newtek.com 2022-11-22
Brian Cully shmit&kublai.com
Chris Nigbur UpdateLogic, Inc. chris.nigbur&updatelogic.com 2014-10-27
Claus Broch Infinite Loop nasmon&infinite-loop.dk 2012-10-09
Claus Jensen Libratone A/S cjn&libratone.com 2011-10-27
Cliff Joyce cliffjoyce&pureblend.com
Connectivity Standards Alliance ianaregistrations&mail.csa-iot.org 2021-07-23
Dan Corkill Midnight Oil Enterprises, LLC corkill&mn-oil.com 2013-07-09
Daniel Steinberg daniel&oreilly.com
David Hauck davidh&netacquire.com 2018-06-20
David Mendels Zorth Sarl david&zorth.net 2023-08-02
David Priest priest&sfu.ca
David Shaw dshaw&nasuni.com 2016-01-22
Eduard de Jong n-Count Technology B.V. domains&dejongfrz.nl 2013-01-22
Esko Dijk Thread Group, Inc. esko.dijk&iotconsultancy.nl 2024-01-22
Florian Bomers Florian.Bomers.iana&bome.com 2023-11-07
Frank Zerangue fzerang&cisco.com
Gangsta Ltd. jc&gangstamedia.com 2011-10-13
Gary Giebler gary&giebler.com
0x539 dev group http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi
Ico Doornekamp ico&saedra.nl
Infinite Loop nasmon&infinite-loop.dk 2012-10-09
Jacob Godwin-Jones jacob&likethought.com
Jason McNeil jmcneil&x2studios.com 2020-05-06
Jason Schoon jason.schoon&intermec.com
Jean-Charles Boude Gangsta Ltd. jc&gangstamedia.com 2011-10-17
Jesse W. Towner jwtowner&dsmedialabs.com
Johan Mjones johan&nollbit.com
Jon Griffeth griffeth&praesentia.com 2017-01-12
Jonathan jonathan&mugginsoft.com
Juhamatti Kuusisaari juhamatti.kuusisaari&mles.io 2024-01-05
Justin Cepelak jcepelak&splashdata.com
Ken Jibiki ken&kenjij.com
Kenneth Suda Mad Elf Software, Inc. help&madelfsoftware.com 2016-03-30
Kenny Millar Spider Electronics kenny&spider-e.com 2014-03-10
Kevin Ediger Software LI-COR Biosciences kevin.ediger&licor.com 2011-10-18
larva.io ltd. hi&larva.io 2019-02-11
Laurence Flath lflath&luxsolis.com
Leon van der Voort van der Kleij Nedap leon.vandervoortvanderkleij&nedap.com 2014-08-28
Libratone A/S info&libratone.com 2011-10-27
Luke Steffen lukesteffen&deusty.com
Luma Code support&lumacode.com
Lumis rterra&lumis.com.br 2011-10-24
Mad Elf Software, Inc. help&madelfsoftware.com 2016-03-30
Mandos Maintainers mandos&fukt.bsnet.se
Mario Pörner Mediatap GbR mario.poerner&googlemail.com 2011-10-11
Martin Redington mildm8nnered&gmail.com
Martin Technology support&martian.com
Matt Craig matt&luxology.com
Matthias Merkel moritz30&moritz30.de 2015-12-07
Mediatap GbR info&audiotapapp.com 2011-10-11
Michael Tennefoss mtennefoss&echelon.com
MIDI Manufacturers Association info&midi.org 2023-11-07
Midnight Oil Enterprises, LLC corkill&mn-oil.com 2013-07-09
Miele & Cie. KG nils.langhammer&miele.de 2018-04-20
Mike Yenco mike&yenco.com
Mogeneti serveradmin&mogeneti.com 2012-09-26
Moritz30 moritz30&moritz30.de 2015-12-07
n-Count Technology B.V. ncount&dejongfrz.nl 2013-01-22
Nasuni Corporation it&nasuni.com 2016-01-22
Nate Rivard nrivard&cc.gatech.edu
Nedap leon.vandervoortvanderkleij&nedap.com 2014-08-28
NetAcquire Corporation davidh&netcquire.com 2018-06-20
NewTek Inc cs&newtek.com 2022-11-22
Nick Barendt nbarendt&vxitech.com
Nicolas Haynes nh&sonnox.co.uk 2018-08-15
Nikolaus Gerteis ngerteis&apple.com
Dr. Nils Langhammer Miele & Cie. KG nils.langhammer&miele.de 2018-04-20
Object Matrix support&object-matrix.com
Phillip Hallam-Baker phill&hallambaker.com 2015-11-18
Pravala Networks ULC admin&pravala.com 2016-06-01
Radio Technical Commission for Maritime Services hq&rtcm.org 2026-03-18
Reijo Sirila reijo&larva.io 2019-02-19
Rich Blomseth rich&echelon.com
Roderick Mann rmann&latencyzero.com 2011-10-20
Rodrigo Terra Lumis rterra&lumis.com.br 2011-10-24
Rowan Daniell rowan&cognito.co.nz
Radio Technical Commission for Maritime Services hq&rtcm.org 2026-03-18
Sachin Desai sachin&clairmail.com
Severn Tsui severn&pravala.com 2016-06-01
Shaun Wexler dev&macfoh.com
Software LI-COR Biosciences kevin.ediger&licor.com 2011-10-18
Sonnox Ltd rhd&sonnox.co.uk 2018-08-15
Spider Electronics kenny&spider-e.com 2014-03-10
Thom McGrath thom&thezaz.com
Thomas K. Fischer thomas.fischer&interservices.de
Thorvald Natvig thorvald&natvig.com
Thread Group, Inc. help&threadgroup.org 2024-01-22
UpdateLogic, Inc. it&updatelogic.com 2014-10-27
William Shipley wjs&me.com
X2 Studios Ltd support&x2studios.com 2020-05-06
Zach Metzinger zach.metzinger&maxim-ic.com
Zorth Sarl info&zorth.net 2023-08-02
equinux mediacentral&equinux.comdu
iThink Software contact&ithinksw.com