Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
pstmailsync tcp File synchronization protocol for Pst Mail Sync Arrow Bit SL Javier Nigro 2012-04-26 Defined TXT keys: uuid=<unique instance identifier>
pstmailsync-ssl tcp Secured file synchronization protocol for Pst Mail Sync Arrow Bit SL Javier Nigro 2012-04-26 Defined TXT keys: uuid=<unique instance identifier>
ptnetprosrv2 PTNetPro Service Apple Computer Apple Computer Defined TXT keys: None Profiling and performance analysis protocol for Shark 4.0 and BigTop.
ptp-init tcp Picture Transfer Protocol(PTP) Initiator Canon Inc. Tatsuhiko Sakai 2011-10-03 Defined TXT keys: srvver, mn, mf, md, srv, tid
ptp-req PTP Initiation Request Protocol Mark Wood Mark Wood Defined TXT keys: txtvers, guid, c0, c1, c2, ..., where the number of c_n attributes is variable
pulsar tcp Network service for Pulsar messaging and data sharing mobile app Volodymyr Pavliuk Volodymyr Pavliuk 2024-02-19 Defined TXT keys: None
puzzle Protocol used for puzzle games Michael Thomason Michael Thomason Defined TXT keys: None
pvaccess tcp Experimental Physics and Industrial Control System Matej Sekoranja Matej Sekoranja 2012-03-23 Defined TXT keys: None
qbox QBox Appliance Locator Geoff Back Geoff Back Defined TXT keys: None
qttp QuickTime Transfer Protocol Stuart Cheshire Stuart Cheshire Defined TXT keys: u=<username> p=<password> path=<path to document> (Same as for _http._tcp)
quad tcp Distributed Game Data Niall Hogg Niall Hogg 2011-10-25 Defined TXT keys: Proprietary
quinn Quinn Game Server Simon Haertel Simon Haertel Defined TXT keys: None
qwady-peer tcp Encrypted nearby Peer media exchange Qwady Solutions LLC Joseph May 2026-07-23 Defined TXT keys: None
qwizcollab tcp Broadcast of Qwizdom Presentation sessions for joining by a client, such as Qwizdom Notes+. Qwizdom, Inc. Matthew Owings 2015-09-21 Defined TXT keys: None
rakket Rakket Client Protocol Orion Reblitz-Richardson Orion Reblitz-Richardson Defined TXT keys: None
radicle-node Radicle peer to peer network Radicle Lorenz Leutgeb 2025-08-15 Defined TXT Keys: nid=<Node ID>, network=<Name of Network, e.g. 'main' or 'test'>, version=<Version Number>
radiotag RadioTAG: Event tagging for radio services Andy Buckingham Andy Buckingham Defined TXT keys: None
radiovis RadioVIS: Visualisation for radio services Andy Buckingham Andy Buckingham Defined TXT keys: None
radioepg RadioEPG: Electronic Programme Guide for radio services Andy Buckingham Andy Buckingham Defined TXT keys: None
radioport tcp RadioPort Message Service Bob Iannucci Bob Iannucci 2011-11-23 Defined TXT keys: NONE
radioport udp RadioPort Message Service Bob Iannucci Bob Iannucci 2011-11-23 Defined TXT keys: NONE
radiusdtls udp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiusdtls" for discovery of RADIUS/DTLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None
radiustls tcp Authentication, Accounting, and Dynamic Authorization via the RADIUS protocol. This service name is used to construct the SRV service label "_radiustls" for discovery of RADIUS/TLS servers. IESG IETF Chair 2015-03-23 2015-10-06 RFC 7585 Defined TXT keys: None
railduino tcp Model Railroad Messaging Railduino Volker Wiegand 2018-01-08 Defined TXT keys: role=master
raop Remote Audio Output Protocol (AirTunes) BonjourDev BonjourDev 2011-10-14 Defined TXT keys: None
rapta tcp Industrial IOT self-discovery network Rapta, Inc Matt Daue 2022-09-22 Defined TXT keys: version
rbr RBR Instrument Communication Greg Johnson Greg Johnson Defined TXT keys: None
rce PowerCard DeVoeSquared DeVoeSquared Defined TXT keys: None
rdp Windows Remote Desktop Protocol Jugaari Jugaari Defined TXT keys: None
realplayfavs RealPlayer Shared Favorites RealNetworks RealNetworks Defined TXT keys: None
recipe-box tcp The Recipe Box Exchange Corpus Collusion Kathy Tafel 2011-08-23 Defined TXT keys: txtvers
recipe-sharing tcp Recipe Sharing Protocol Daniel G. Taylor Daniel G. Taylor 2007-11 Defined TXT keys: http://www.recipemanager.org/rsp/rsp10draft.html#dnssd
recolive-cc tcp Remote Camera Control RecoLive Sàrl Gabriele Mondada 2012-08-29 Defined TXT keys: txtvers, cid, nbd, cap
recolive-cc udp Remote Camera Control RecoLive Sàrl Gabriele Mondada 2012-08-29 Defined TXT keys: txtvers, cid, nbd, cap
recordit-itp tcp Recordit Image Transport Protocol Freshout Ruben Beltran del Rio 2014-04-14 Defined TXT keys: None
remote Remote Device Control Protocol Gregory Dudek Gregory Dudek Defined TXT keys: txtvers=<TXT record version tag> protovers=<protocol vesion number> forground=<primary device or system> version=<firmware/instrument controller version>
remotebuddy tcp Remote Buddy remote control software command and data exchange IOSPIRIT GmbH Felix Schwarz 2014-09-23 Defined TXT keys: None
remoteburn LaCie Remote Burn Serge DE LUCA Serge DE LUCA Defined TXT keys: server_version, min_client_version
renderpipe ARTvps RenderDrive/PURE Renderer Protocol Andrew Hoddinott Andrew Hoddinott Defined TXT keys: None
rendezvouspong RendezvousPong Math Game House Software Math Game House Software Defined TXT keys: None
renkara-sync Renkara synchronization protocol Michael J Primeaux Michael J Primeaux Defined TXT keys: None
resol-vbus RESOL VBus Daniel Wippermann Daniel Wippermann Defined TXT keys: None
retrospect Retrospect backup and restore service Michael Marks Michael Marks Defined TXT keys: None
rfbc Remote Frame Buffer Client (Used by VNC viewers in listen-mode) Ole-Morten Duesund Ole-Morten Duesund Defined TXT keys: server=dns-name/ip-address:port of currently displayed VNC server. Empty if not showing anything/available.
rfid RFID Reader Mach1(tm) Protocol Paul Dietrich Paul Dietrich Defined TXT keys: None
rgb tcp RGB Spectrum Device Discovery RGB Spectrum Steve Hershey 2011-10-10 Defined TXT keys: Keyboard, Mouse, Option1, Option2, Option3, Option4, ModelName
riousbprint Remote I/O USB Printer Protocol Rob Newberry Rob Newberry Defined TXT keys: See BonjourPrinting.pdf.
roambot tcp Roambot communication Roambotics, Inc. Scott Menor 2013-10-18 Defined TXT keys: None
robustirc tcp Like ircu (RFC 1459), but failure tolerant due to strong consistency among n>=3 servers Michael Stapelberg Michael Stapelberg 2015-01-07 Defined TXT keys: None
roku-rcp Roku Control Protocol Don Woodward Don Woodward Defined TXT keys: txtvers=1
roomcast-capi tcp RoomCast Control Protocol Colin Corby Colin Corby 2017-02-01 Defined TXT keys: protocolVersion, uuid
roomcast-mapi tcp RoomCast Management Protocol Colin Corby Colin Corby 2017-02-01 Defined TXT keys: protocolVersion, uuid
rql RemoteQuickLaunch Daniel Heffernan Daniel Heffernan Defined TXT keys: None
rr-disc Robot Raconteur discovery Wason Technology, LLC John Wason 2014-01-27 Defined TXT keys: None
rradict tcp Ruckus Radio Access Device, Installation, Commissioning and Troubleshooting service. Dave Stephenson Dave Stephenson 2016-03-09 Defined TXT keys: txtvers=<version>, serial=<serial number>, mac=<mac-address>, model=<model number>, opMode=<operational mode>, tx=<transmitter-status>, timing=<timing-status>
rsmp-server Remote System Management Protocol (Server Instance) Geoff Back Geoff Back Defined TXT keys: apiver=<major.minor>
rubygems RubyGems GemServer Rich Kilmer Rich Kilmer Defined TXT keys: None
rxxmiele tcp Miele protocol robot cleaners Miele & Cie. KG Dr. Nils Langhammer 2018-04-20 Defined TXT keys: txtvers and proprietary keys
rym-rrc tcp Raymarine remote control protocol Raymarine UK Limited Geoffrey Beer 2012-05-24 2012-06-04 Defined TXT keys: raymarine-mfd-rrc-version, raymarine-mfd-model, raymarine-mfd-serial
s2connect tcp S2 Connect energy management protocol TNO Wilco Wijbrandi 2026-03-27 Defined TXT Keys: https://docs.s2standard.org/docs/communication-layer/discovery-pairing-authentication/#dns-sd-based-discovery
safarimenu Safari Menu Jesus De Meyer Jesus De Meyer Defined TXT keys: None
sallingbridge Salling Clicker Sharing Jonas Salling Jonas Salling Defined TXT keys: None
sallingclicker Salling Clicker Service Jonas Salling Jonas Salling Defined TXT keys: None
salutafugijms Salutafugi Peer-To-Peer Java Message Service Implementation David Walend David Walend Defined TXT keys: SalutaProperties
sandvox Sandvox Karelia Software Karelia Software Defined TXT keys: None
savagesoft tcp Proprietary Client Server Protocol Andy Savage Andy Savage 2012-07-13 Defined TXT keys: None
sc-golf StrawberryCat Golf Protocol Phil Willoughby Phil Willoughby Defined TXT keys: None
scanner Bonjour Scanning Baskaran Subramaniam Baskaran Subramaniam Defined TXT keys: None
schdca tcp schindler internal messaging service Schindler Aufzuege ag Arno Odermatt 2018-12-19 Defined TXT keys: None
schick Schick Heiko Kretschmer Heiko Kretschmer Defined TXT keys: None
schims tcp schindler internal messaging service Schindler Aufzuege ag Arno Odermatt 2015-12-05 Defined TXT keys: None
schlog tcp logging service Schindler Aufzuege ag Arno Odermatt 2015-12-05 Defined TXT keys: None
schmpp tcp Schindler maintenance portal protocol Schindler Aufzuege ag Arno Odermatt 2015-04-30 Defined TXT keys: None
schoms tcp schindler object messaging system Schindler Aufzuege ag Arno Odermatt 2015-05-12 Defined TXT keys: None
schsap tcp Schindler service authentication portal Schindler Aufzuege ag Arno Odermatt 2015-04-30 Defined TXT keys: None
schsrmp tcp Schindler internal messaging service Schindler Aufzuege ag Arno Odermatt 2017-07-07 2017-07-10 Defined TXT keys: None
schvpp tcp schindler internal messaging service Schindler Aufzuege ag Arno Odermatt 2018-12-19 Defined TXT keys: None
scone Scone James Moore James Moore Defined TXT keys: None
scoop-sftp tcp The service name is used by the SFTP protocol to upload log files from vehicles to road side units in a securely way in a cooperative intelligent transportation system. SCOOP@F Project Houda Labiod 2016-02-04 Defined TXT keys: None
scoop-sftp udp The service name is used by the SFTP protocol to upload log files from vehicles to road side units in a securely way in a cooperative intelligent transportation system. SCOOP@F Project Houda Labiod 2016-02-04 Defined TXT keys: None
scpi-raw IEEE 488.2 (SCPI) Socket Nick Barendt Nick Barendt Defined TXT keys: None
scpi-telnet IEEE 488.2 (SCPI) Telnet Nick Barendt Nick Barendt Defined TXT keys: None
sdsharing Speed Download Yazsoft Yazsoft Defined TXT keys: None
secugen-connect tcp SecuGen Connect local biometric bridge SecuGen Corporation SecuGen Corporation 2026-09-04 2026-09-07 https://connect.secugen.com/dev-guide-doc/bridge-api-contract Defined TXT keys: None
see SubEthaEdit 2 TheCodingMonkeys TheCodingMonkeys Defined TXT keys: txtvers=1, name=<Full Name>, userid=<User ID>, version=2
seeCard seeCard Stefan Pantke Stefan Pantke Defined TXT keys: None
senteo-http Senteo Assessment Software Protocol Michael Boyle Michael Boyle Defined TXT keys: None
sentillion-vlc Sentillion Vault System George Hartz George Hartz Defined TXT keys: None
sentillion-vlt Sentillion Vault Systems Cluster George Hartz George Hartz Defined TXT keys: None
sepvsync SEPV Application Data Synchronization Protocol Kazuya Ogata Kazuya Ogata Defined TXT keys: Proprietary
serendipd serendiPd Shared Patches for Pure Data Hans-Christoph Steiner Hans-Christoph Steiner Defined TXT keys: None
servereye ServerEye AgentContainer Communication Protocol Andreas Behr Andreas Behr Defined TXT keys: None
servermgr Mac OS X Server Admin Jeff Albouze Jeff Albouze Defined TXT keys: None
services DNS Service Discovery Stuart Cheshire; Marc Krochmal Stuart Cheshire; Marc Krochmal Not a service type. Special name reserved for DNS-SD meta queries.
sessionfs Session File Sharing Anthony Williams Anthony Williams Defined TXT keys: Text keys are the file extensions of any file the user plans to share, i.e. pdf, doc, mp3.
setlistmaker-rc tcp Remote Control for Set List Maker app Arlo Leach Arlo Leach 2017-04-21 Defined TXT keys: None
setlistmaker-ss tcp Screen sharing for Set List Maker app Arlo Leach Arlo Leach 2017-04-21 Defined TXT keys: None
sftp-ssh Secure File Transfer Protocol over SSH Bryan Cole Bryan Cole Defined TXT keys: u=<username> p=<password> path=<path>
sge-exec Sun Grid Engine (Execution Host) Bill Van Etten Bill Van Etten Defined TXT keys: None
sge-qmaster Sun Grid Engine (Master) Bill Van Etten Bill Van Etten Defined TXT keys: None
shifter Window Shifter server protocol Antoine Martin Antoine Martin Defined TXT keys: username The login username to use (optional) ssh_tunnel Whether an SSH tunnel must be used (required) iface The network interface the server is on (required - may be empty) version Software version (required) ID Server Identifier (requried)

Contact Information

Name Organization Contact URI Last Updated
Andreas Behr andreas.behr&kraemer-it.de
Andrew Hoddinott support&artvps.com
Andy Buckingham feedback&radiodns.org
Andy Savage andy.savage1&gmail.com 2012-07-13
Anthony Williams tonydubs&gmail.com
Antoine Martin antoine&nagafix.co.uk 2016-10-05
Apple Computer perftools-feedback&group.apple.com
Arlo Leach arlo&arlomedia.com 2017-04-21
Arno Odermatt Schindler Aufzuege ag arno.odermatt&schindler.com 2017-07-07
Arrow Bit SL info&arrowbit.com 2012-04-26
Baskaran Subramaniam baskaran&apple.com
Bill Van Etten Bill&bioteam.net
Bob Iannucci bob&rail.com 2011-11-23
BonjourDev bonjourdev&apple.com 2011-10-14
Bryan Cole bryan.cole&teraview.com
Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Colin Corby colin.corby&teleadapt.com 2017-02-01
Corpus Collusion developer&corpuscollusion.com 2011-08-23
Daniel G. Taylor dan&programmer-art.org 2007-11
Daniel Heffernan me&daniel.ie
Daniel Wippermann Daniel.Wippermann&resol.de
Dave Stephenson dave.stephenson&ruckuswireless.com 2016-03-09
David Walend david&walend.net
dev&salutafugijms.dev.java.net
DeVoeSquared support&devoesquared.com
Don Woodward dwoodward&rokulabs.com
Felix Schwarz IOSPIRIT GmbH felix.schwarz&iospirit.com 2014-09-23
Freshout navid&freshout.us 2014-04-14
Gabriele Mondada RecoLive Sàrl gmondada&recolive.com 2012-08-29
Geoff Back geoff&demonlair.co.uk
Geoff Back geoff.back&autocue.co.uk
Geoffrey Beer Raymarine UK Limited Geoff.Beer&raymarine.com 2012-05-24
George Hartz george.hartz&sentillion.com
Greg Johnson greg.johnson&ieee.org
Gregory Dudek dudek&y1d.com
Hans-Christoph Steiner hans&eds.org
Heiko Kretschmer info&wurst-wasser.net
Houda Labiod SCOOP@F Project houda.labiod&telecom-paristech.fr 2016-02-04
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
IOSPIRIT GmbH info&iospirit.com 2014-09-23
James Moore jam&wirerimmed.com
Javier Nigro Arrow Bit SL support&arrowbit.com 2012-04-26
Jeff Albouze foup&apple.com
Jesus De Meyer jesus&edot-studios.com
John Wason Wason Technology, LLC wason&wasontech.com 2014-01-27
Jonas Salling jonas&salling.com
Joseph May joedmay31&gmail.com 2026-07-23
Jugaari support&jugaari.com
Karelia Software
Kathy Tafel Corpus Collusion kt&corpuscollusion.com 2011-08-23
Kazuya Ogata info&sepv.jp
Lorenz Leutgeb lorenz.leutgeb&radicle.xyz 2025-08-15
Marc Krochmal marc&apple.com
Mark Wood mark.d.wood&kodak.com
Matej Sekoranja matej.sekoranja&cosylab.com 2012-03-23
Math Game House Software mathgamehouse&mac.com
Matt Daue Rapta, Inc mdaue&rapta.ai 2022-09-22
Matthew Owings matt&qwizdom.com 2015-09-21
Michael Boyle michaelboyle&smarttech.com
Michael J Primeaux michael.primeaux&renkara.com
Michael Marks marks_michael&emc.com
Michael Stapelberg michael+iana&stapelberg.ch 2015-01-07
Michael Thomason mthomason&gmail.com
Miele & Cie. KG nils.langhammer&miele.de 2018-04-20
Niall Hogg niall.hogg&interamics.com 2011-10-25
Nick Barendt nbarendt&vxitech.com
Dr. Nils Langhammer Miele & Cie. KG nils.langhammer&miele.de 2018-04-20
Ole-Morten Duesund ole-morten.duesund&bbvisuals.no
Orion Reblitz-Richardson orionr&rakket.com
Paul Dietrich registrar&impinj.com
Phil Willoughby phil.willoughby&strawberrycat.com
Qwady Solutions LLC jdmay&qwady.com 2026-07-23
Qwizdom, Inc. matt&qwizdom.com 2015-09-21
Radicle team&radicle.xyz 2025-08-15
Railduino volker&railduino.de 2018-01-08
Rapta, Inc admin&rapta.ai 2022-09-22
Raymarine UK Limited Geoff.Beer&raymarine.com 2012-05-24
RealNetworks macplayer&real.com
RecoLive Sàrl recoinfo&recolive.com 2012-09-07
RGB Spectrum shershey&rgb.com 2011-10-10
Rich Kilmer rich&infoether.com
Roambotics, Inc. iana&roambotics.com 2013-10-18
Rob Newberry rnewberry&apple.com
Ruben Beltran del Rio Freshout ben&freshout.us 2014-04-14
Schindler Aufzuege ag arno.odermatt&schindler.com 2018-12-19
SCOOP@F Project houda.labiod&telecom-paristech.fr 2016-02-04
Scott Menor Roambotics, Inc. scott&roambotics.com 2013-10-18
SecuGen Corporation connect&secugen.com 2026-09-04
Serge DE LUCA sdeluca&lacie.com
Simon Haertel simonhaertel&web.de
Stefan Pantke sales&turingart.com
Steve Hershey RGB Spectrum shershey&rgb.com 2011-10-10
Stuart Cheshire cheshire&apple.com 2022-07-11
Tatsuhiko Sakai Canon Inc. sakai.tatsuhiko&canon.co.jp 2011-10-03
TheCodingMonkeys monkeys&codingmonkeys.de
TNO info&tno.nl 2026-03-27
Volker Wiegand volker&railduino.de 2018-01-08
Volodymyr Pavliuk gwotan&gmail.com 2024-02-19
Wason Technology, LLC wason&wasontech.com 2014-01-27
Wilco Wijbrandi wilco.wijbrandi&tno.nl 2026-03-27
Yazsoft info&yazsoft.com