Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ticonnectmgr TI Connect Manager Discovery Service Stephen Reid Stephen Reid Defined TXT keys: None
tic-tac-toe tcp Tic Tac Toe game Stuart Cheshire Stuart Cheshire 2019-05-31 Defined TXT keys: None
timezone tcp Time Zone Data Distribution Service - non-TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).
timezones tcp Time Zone Data Distribution Service - over TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).
tinavigator TI Navigator Hub 1.0 Discovery Service Stephen Reid Stephen Reid Defined TXT keys: None
tivo-device tcp TiVo Device Protocol TiVo Inc. Developer Support 2011-10-18 Defined TXT keys: None
tivo-hme TiVo Home Media Engine Protocol Developer Support Developer Support Defined TXT keys: None
tivo-mindrpc tcp TiVo RPC Protocol TiVo Inc. Developer Support 2011-10-18 Defined TXT keys: None
tivo-music TiVo Music Protocol Developer Support Developer Support Defined TXT keys: None
tivo-photos TiVo Photos Protocol Developer Support Developer Support Defined TXT keys: None
tivo-remote TiVo Remote Protocol Developer Support Developer Support Defined TXT keys: protocol, path, swversion, platform, TSN
tivo-videos TiVo Videos Protocol Developer Support Developer Support Defined TXT keys: protocol, path, swversion, platform, TSN
tmsensor tcp Teledyne Marine Sensor Teledyne Marine Anders Brandt 2023-10-03 Defined TXT keys: None
tmsensor udp Teledyne Marine Sensor Teledyne Marine Anders Brandt 2023-10-03 Defined TXT keys: None
todogwa 2Do Sync Helper Tool for Mac OS X and PCs Fahad Gilani Fahad Gilani Defined TXT keys: None
tokenlens tcp AI token usage and billing metering KuoChun Fang KuoChun Fang 2026-07-19 Defined TXT keys: None
tokenlens udp AI token usage and billing metering KuoChun Fang KuoChun Fang 2026-07-19 Defined TXT keys: None
tomboy Tomboy Alex Graveley Alex Graveley Defined TXT keys: None
toothpicserver ToothPics Dental Office Support Server Milton Pulis Milton Pulis Defined TXT keys: None
touch-able iPhone and iPod touch Remote Controllable Amandeep Jawa Amandeep Jawa Defined TXT keys: txtvers, CtlN, DbId, Ver, DvTy, OSsi, DvSv
touch-remote iPhone and iPod touch Remote Pairing Amandeep Jawa Amandeep Jawa Defined TXT keys: txtvers, DvNm, Pair, RemV, RemN, DvTy
tptx-console tcp Coordination service for client users of the TotalPraisTrax iPad application Randy Davenport Chris Watson 2014-03-04 Defined TXT keys: None
transmitr tcp Service discovery and media transfer for peer to peer mobile media transfer app Windward Code LLC Alex Belliotti 2013-11-27 Defined TXT keys: None
trel udp Thread Radio Encapsulation Link Thread Group, Inc. Tom Sciorilli 2021-12-10 2022-05-20 Defined TXT keys: xa, xp
tri-vis-client triCerat Simplify Visibility Client Christopher Karper Christopher Karper Defined TXT keys: None
tri-vis-server triCerat Simplify Visibility Server Christopher Karper Christopher Karper Defined TXT keys: None
tryst Tryst Francisco Ryan Tolmasky Francisco Ryan Tolmasky Defined TXT keys: None
tsbiis tcp The Social Broadband Interference Information Sharing Sérgio Luís Dias Lima Gramacho Sérgio Luís Dias Lima Gramacho 2012-02-27 Defined TXT keys: there is no TXT keys defined for this protocol
tt4inarow Trivial Technology's 4 in a Row Nicolas Payette Nicolas Payette Defined TXT keys: None
ttcheckers Trivial Technology's Checkers Nicolas Payette Nicolas Payette Defined TXT keys: None
ttp4daemon TechTool Pro 4 Anti-Piracy Service Micromat Micromat Defined TXT keys: None
tunage Tunage Media Control Service Matt Patenaude Matt Patenaude Defined TXT keys: None
tuneranger TuneRanger Acertant Technologies, Inc. Acertant Technologies, Inc. Defined TXT keys: None
tvm tcp Vogel's TV mount control Vogel's Products Remco Poelstra 2022-03-29 Defined TXT keys: txtvers, model
twiline-disc tcp Discovery for Twiline systems W. Wahli AG Michael Voser 2023-12-04 Defined TXT keys: txtvers, protovers, caddr, xbusid
twinlevel tcp detect sanitary product Oblamatik AG Simon Ensslen 2012-09-05 Defined TXT keys: None
twosnakes tcp Service to enable multiplayer game called two snakes. Narendra Kumar Reddy Thummaluru Narendra Kumar Reddy Thummaluru 2016-06-01 Defined TXT keys: None
twosnakes sctp Service to enable multiplayer game called two snakes. Narendra Kumar Reddy Thummaluru Narendra Kumar Reddy Thummaluru 2016-06-01 Defined TXT keys: None
tyba tcp Tyba control Tyba Design Limited Oz Andrews 2018-08-24 Defined TXT keys: PRID, HWSN, VERS
tzrpc tcp TZ-Software remote procedure call based synchronization protocol Thomas Zwick Thomas Zwick 2011-10-12 Defined TXT keys: Proprietary
ubertragen Ubertragen Widgetschmie.de Widgetschmie.de Defined TXT keys: None
ucdynamics-tuc udp Tactical Unified Communicator UC Dynamics, LLC Shaun Botha 2018-01-31 Defined TXT keys: None
uddi Universal Description, Discovery and Integration Paul Denning Paul Denning Defined TXT keys: TBD
uddi-inq Universal Description, Discovery and Integration Inquiry Paul Denning Paul Denning Defined TXT keys: TBD
uddi-pub Universal Description, Discovery and Integration Publishing Paul Denning Paul Denning Defined TXT keys: TBD
uddi-sub Universal Description, Discovery and Integration Subscription Paul Denning Paul Denning Defined TXT keys: TBD
uddi-sec Universal Description, Discovery and Integration Security Paul Denning Paul Denning Defined TXT keys: TBD
upnp Universal Plug and Play Andrew Donoho Andrew Donoho Defined TXT keys: None
urlbookmark URL Advertising Sven-S. Porst Sven-S. Porst Defined TXT keys: URL=<URL that is advertised>, name=<Name of the bookmark>
usp-agt-coap udp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-http tcp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-mqtt tcp USP discovery Broadband Forum Broadband Forum 2020-03-17 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-stomp tcp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-agt-ws tcp USP discovery Broadband Forum Broadband Forum 2017-09-28 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-coap udp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-http tcp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-mqtt tcp USP discovery Broadband Forum Broadband Forum 2020-03-17 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-stomp tcp USP discovery Broadband Forum Broadband Forum 2017-01-12 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
usp-ctr-ws tcp USP discovery Broadband Forum Broadband Forum 2017-09-28 http://www.broadband-forum.org/assignments Defined TXT keys: see www.broadband-forum.org/assignments
uswi Universal Switching Corporation products Roger Lemberg Roger Lemberg Defined TXT keys: None
utest uTest Gregory Power Gregory Power Defined TXT keys: None
uwsgi Unbit Web Server Gateway Interface Roberto De Ioris Roberto De Ioris Defined TXT keys: None
vapix-http tcp Indicator for VAPIX support over HTTP Axis Communications Christian Storm 2023-04-18 Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation
vapix-https tcp Indicator for VAPIX support over HTTPS Axis Communications Christian Storm 2023-04-18 Defined TXT keys: https://help.axis.com/en-us/axis-os#axis-bonjour-implementation
ve-decoder American Dynamics VideoEdge Decoder Control Service Gary Sands Gary Sands Defined TXT keys: txtvers, macaddress, protovers, model, serial, path, idp
ve-encoder American Dynamics VideoEdge Encoder Control Service Gary Sands Gary Sands Defined TXT keys: txtvers, macaddress, protovers, model, serial, path, idp
ve-recorder American Dynamics VideoEdge Recorder Control Service Gary Sands Gary Sands Defined TXT keys: txtvers, macaddress, protovers, model, serial, path, idp
vedabase tcp Application specific synchronization protocol Peter Kollath Peter Kollath 2014-05-27 Defined TXT keys: txtvers=1
vhusb tcp USB over IP Sharing System VirtualHere Pty. Ltd. Michael Broadfoot 2015-04-02 Defined TXT keys: <serial number of server>
virtualdj VirtualDJ Remote Control protocol Atomix Productions Stephane Clavel 2011-10-12 Defined TXT keys: None
visel visel Q-System services Lehpaner Sasa Lehpaner Sasa Defined TXT keys: Version=<service version> Type=<service type> Name=<service Name> Zone=<service zone> ID=<serviceID> SString=<serviceString> SString1=<serviceString>
voalte2 tcp Server location via DNS-SD Voalte, Inc. John Simpson 2019-01-22 Defined TXT keys: txtvers, name, (others not publicly documented)
voalte3 tcp Server location via DNS-SD Voalte, Inc. John Simpson 2019-01-22 Defined TXT keys: txtvers, name, (others not publicly documented)
volterio tcp Internal Communication Service Volterio Johannes Ofner 2021-07-23 Defined TXT keys: None
vos Virtual Object System (using VOP/TCP) Reed Hedges; Peter Amstutz Reed Hedges; Peter Amstutz Defined TXT keys: url=<Object URL with full path> type=<Comma-seperated list of object types> title=<Short title of service> descr=<Short description of service>
voxidahmp tcp RTP Mixer/Summation Resource Accurate Always Inc. Yousef Shemisa 2018-12-03 Defined TXT keys: None
vrmg-p2p tcp Verimag mobile class protocol over P2P Verimag, OOO Denis Ionov 2018-07-20 Defined TXT keys: d=<discovery key>, t=<mobile class ID>
vue4rendercow VueProRenderCow Defined TXT keys: None
vxi-11 VXI-11 TCP/IP Instrument Protocol Nick Barendt Nick Barendt Defined TXT keys: None
wakeywakey tcp Proprietary gerry Brown associates Gerry Brown 2012-11-29 Defined TXT keys: None
walkietalkie Walkie Talkie Johan Kool Johan Kool Defined TXT keys: None
wchr udp Powered wheelchair command protocol Tolt Technologies LLC Jay Beavers 2026-02-25 Defined TXT keys: model (device model identifier), sn (device serial number), app (firmware version), boot (bootloader version and signing status), githash (firmware build commit), crash (crash info present flag)
wd-2go tcp NAS Service Protocol Western Digital Inc. Rajesh Batra 2012-07-11 Defined TXT keys: None
wdp tcp Windows Device Portal Microsoft Corporation Hirsch Singhal 2016-03-03 Defined TXT keys: D (device type), S (https port), A (architecture), T (tags)
web-xi tcp HTTP-based protocol for DAQ devices Spectris plc Carsten Hansen 2019-02-13 Defined TXT keys: name, version
webex tcp Cisco WebEx serials products will release Bonjour based service Mobile Team Aulion Huang 2018-02-09 Defined TXT keys: None
webex udp Cisco WebEx serials products will release Bonjour based service Mobile Team Aulion Huang 2018-02-09 Defined TXT keys: None
we-jell Proprietary collaborative messaging protocol Vaughn Amann Vaughn Amann Defined TXT keys: user=<user name> stat=<OK, DND, AWY, FWD:uname> agent=<agent type>
webdav World Wide Web Distributed Authoring and Versioning (WebDAV) Y. Y. Goland Y. Y. Goland Defined TXT keys: u=<username> p=<password> path=<path>
webdavs WebDAV over SSL/TLS Y. Y. Goland Y. Y. Goland Defined TXT keys: u=<username> p=<password> path=<path>
webissync WebIS Sync Protocol Alex Kac Alex Kac Defined TXT keys: None
wedraw weDraw document sharing protocol Oleksandr Zakharchuk Oleksandr Zakharchuk Defined TXT keys: None
whamb Whamb Whamb Whamb Defined TXT keys: None
whistler Honeywell Video Systems Shankar Prasad Shankar Prasad Defined TXT keys: None
wico tcp Session-based protocol for embedded unit WISI Group Patrik Lantto 2026-08-11 Defined TXT keys: None
wicop udp WiFi Control Platform Santorini, LLC Cameron Colpitts 2011-10-25 Defined TXT keys: state=<state> loc=<location>
wifile tcp System for transferring files between mobile device and computer in a local network Artyom Nikolaev Artyom Nikolaev 2016-12-23 Defined TXT keys: None
witap WiTap Sample Game Protocol Rory McGuire Rory McGuire Defined TXT keys: None
witapvoice witapvoice Roberto Garcia Roberto Garcia Defined TXT keys: None
wkgrpsvr Workgroup Server Discovery Forest Hill Forest Hill Defined TXT keys: None
workstation Workgroup Manager Kevin Arnold Kevin Arnold Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Accurate Always Inc. legal&accuratealways.com 2018-11-03
Acertant Technologies, Inc.
Alex Belliotti Windward Code LLC alex&windwardcode.com 2013-11-27
Alex Graveley alex&beatniksoftware.com
Alex Kac webis_sync_protocol&webis.net
Amandeep Jawa daap&apple.com
Anders Brandt Teledyne Marine Anders.Brandt&Teledyne.com 2023-10-03
Andrew Donoho awd&us.ibm.com
Artyom Nikolaev support&wifile.info 2016-12-23
Atomix Productions corporate&atomixproductions.com 2011-10-12
Aulion Huang aulionh&cisco.com 2018-02-09
Axis Communications christnn&axis.com 2023-04-18
Broadband Forum help&broadband-forum.org 2020-03-17
Cameron Colpitts Santorini, LLC cameron&santorinillc.com 2011-10-25
Carsten Hansen Spectris plc Carsten.Hansen&bksv.com 2019-02-13
Chris Watson chrisf16&mac.com 2014-03-04
Christian Storm Axis Communications christnn&axis.com 2023-04-18
Christopher Karper ckarper&dev.tricerat.com
Denis Ionov Verimag, OOO iddi&verimag.ru 2018-07-20
Developer Support devsupport&tivo.com
Developer Support TiVo Inc. devsupport&tivo.com 2011-10-18
Fahad Gilani fahad&guidedways.com
Forest Hill forest&apple.com
Francisco Ryan Tolmasky ftolmasky&adelphia.net
Gary Sands gsands&tycoint.com
Gerry Brown gerry Brown associates gerry&gbrown.com 2012-11-29
gerry Brown associates gerry&gbrown.com 2012-11-29
Gregory Power gpower&apple.com
Hirsch Singhal Microsoft Corporation hirsin&microsoft.com 2016-03-03
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jay Beavers Tolt Technologies LLC jay&tolttechnologies.com 2026-02-25
Johan Kool johan&koolistov.net
Johannes Ofner Volterio johannes.ofner&volterio.com 2021-07-23
John Simpson Voalte, Inc. jms1&voalte.com 2019-01-22
Kevin Arnold imlucid&apple.com
KuoChun Fang RoyFang53&gmail.com 2026-07-19
Lehpaner Sasa lsasa&visel.it
Matt Patenaude MattPat&mattpat.net
Michael Broadfoot VirtualHere Pty. Ltd. mail&virtualhere.com 2015-04-02
Michael Voser support&twiline.com 2023-12-04
Micromat support&micromat.com
Microsoft Corporation hirsin&microsoft.com 2016-03-03
Milton Pulis toothpic&fastq.com
Mobile Team group.felix&cisco.com 2018-02-09
Narendra Kumar Reddy Thummaluru narendrakumar.narribits&gmail.com 2016-06-01
Nick Barendt nbarendt&vxitech.com
Nicolas Payette payetten&trivialtechnology.com
Oblamatik AG info&oblamatik.ch 2012-09-05
Oleksandr Zakharchuk zakharchuk&dialogtech.com
Oz Andrews Tyba Design Limited oz&tyba.co.uk 2018-08-24
Patrik Lantto WISI Group patrik.lantto&wisi.se 2026-08-11
Paul Denning pauld&mitre.org
Peter Amstutz tetron&interreality.org
Peter Kollath root&gopal.home.sk 2014-05-27
Rajesh Batra Western Digital Inc. rajesh.batra&wdc.com 2012-07-11
Randy Davenport rdaven69&gmail.com 2014-03-04
Reed Hedges reed&interreality.org
Remco Poelstra Vogel's Products r.poelstra&vogels.com 2022-03-29
Roberto De Ioris info&unbit.it
Roberto Garcia garcia&apple.com
Roger Lemberg rlemberg&uswi.com
Rory McGuire rlpm&apple.com
Santorini, LLC cameron&santorinillc.com 2011-10-25
Sérgio Luís Dias Lima Gramacho slgramacho&gmail.com 2012-02-27
Shankar Prasad shankar.prasad&honeywell.com
Shaun Botha UC Dynamics, LLC shaun.botha&ucdynamics.com 2018-01-31
Simon Ensslen Oblamatik AG s.ensslen&oblamatik.ch 2012-09-05
Spectris plc Carsten.Hansen&bksv.com 2019-02-13
Stephane Clavel Atomix Productions stephane.clavel&atomixproductions.com 2011-10-12
Stephen Reid sreid&ti.com
Stuart Cheshire cheshire&apple.com 2022-07-11
Sven-S. Porst ssp-web&earthlingsoft.net
Teledyne Marine info&teledynemarine.com 2023-10-03
Thomas Zwick thomas.zwick&tz-software.de 2011-10-12
Thread Group, Inc. help&threadgroup.org 2024-01-22
TiVo Inc. devsupport&tivo.com 2011-10-18
Tolt Technologies LLC jay&tolttechnologies.com 2026-02-25
Tom Sciorilli Thread Group, Inc. tom&threadgroup.org 2021-12-10
Tyba Design Limited info&tyba.co.ik 2018-08-24
UC Dynamics, LLC shaun.botha&ucdynamics.com 2018-01-31
Vaughn Amann vamann&aol.com
Verimag, OOO support&verimag.ru 2018-07-20
VirtualHere Pty. Ltd. mail&virtualhere.com 2015-04-02
Voalte, Inc. engops&voalte.com 2019-01-22
Vogel's Products r.poelstra&vogels.com 2022-03-29
Volterio office&volterio.com 2021-07-23
W. Wahli AG support&twiline.com 2023-12-04
Western Digital Inc. rajesh.batra&wdc.com 2012-07-11
Whamb support&whamb.com
Widgetschmie.de
Windward Code LLC alex&windwardcode.com 2013-11-27
WISI Group patrik.lantto&wisi.se 2026-08-11
Y. Y. Goland yarong&microsoft.com
Yousef Shemisa Accurate Always Inc. yshemisa&accuratealways.com 2018-12-03