Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| workstation | Workgroup Manager | Kevin Arnold | Kevin Arnold | Defined TXT keys: None | |||||||
| wormhole | Roku Cascade Wormhole Protocol | Don Woodward | Don Woodward | Defined TXT keys: txtvers=1 | |||||||
| workgroup | Novell collaboration workgroup | Brady Anderson | Brady Anderson | Defined TXT keys: version=? description=? | |||||||
| wot | tcp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http. |
||||
| wot | udp | W3C WoT Thing Description or Directory | W3C Web of Things Working Group | Kazuyuki Ashimura | 2022-11-22 | 2022-12-15 | Defined TXT keys: td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory. type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing. scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap. |
||||
| wpl-ers-http | tcp | World Programming repository server | World Programming Limited | Thomas Quarendon | 2017-03-17 | Defined TXT keys: None | |||||
| wpl-ers-zmq | tcp | World Programming repository server | World Programming Limited | Thomas Quarendon | 2017-03-17 | Defined TXT keys: None | |||||
| writietalkie | Writie Talkie Data Sharing | Yin Ki Lau | Yin Ki Lau | Defined TXT keys: None | |||||||
| ws | Web Services | Andrew Donoho | Andrew Donoho | Defined TXT keys: None | |||||||
| wtc-heleos | Wyatt Technology Corporation HELEOS | Brent Fulgham | Brent Fulgham | Defined TXT keys: None | |||||||
| wtc-qels | Wyatt Technology Corporation QELS | Brent Fulgham | Brent Fulgham | Defined TXT keys: None | |||||||
| wtc-rex | Wyatt Technology Corporation Optilab rEX | Roy Reapor | Roy Reapor | Defined TXT keys: None | |||||||
| wtc-viscostar | Wyatt Technology Corporation ViscoStar | Roy Reapor | Roy Reapor | Defined TXT keys: None | |||||||
| wtc-wpr | Wyatt Technology Corporation DynaPro Plate Reader | Brent Fulgham | Brent Fulgham | Defined TXT keys: None | |||||||
| wwdcpic | PictureSharing sample code | Marc Krochmal | Marc Krochmal | Defined TXT keys: None | |||||||
| x510 | tcp | Security service to protocols | ITU-T Study Group 17 | Erik Andersen | 2019-08-13 | Defined TXT keys: None | |||||
| x-on | x-on services synchronisation protocol | Matthias Burghardt | Matthias Burghardt | Defined TXT keys: Proprietary | |||||||
| x-plane9 | udp | x-plane9 | Austin Meyer | Austin Meyer | Defined TXT keys: None | ||||||
| xcodedistcc | Xcode Distributed Compiler | Scott Tooker | Scott Tooker | Defined TXT keys: None | |||||||
| xential | tcp | xential document creation services | Xential | Michiel Terpstra | 2013-11-13 | Defined TXT keys: None | |||||
| xgate-rmi | xGate Remote Management Interface | Tim Jobling | Tim Jobling | Defined TXT keys: tech=value (string) model=value (string) version=value (string) | |||||||
| xmiserver | tcp | XMI Systems home terminal local connection | XMI Systems SA | CLAUDE MALLY | 2013-01-18 | Defined TXT keys: coucou | |||||
| xmp | Xperientia Mobile Protocol | Henric Bergh | Henric Bergh | 2007-01 | Defined TXT keys: txtvers, user, system, nodeid, desc | ||||||
| xsanclient | Xsan Client | Jeff Albouze | Jeff Albouze | Defined TXT keys: None | |||||||
| xsanserver | Xsan Server | Jeff Albouze | Jeff Albouze | Defined TXT keys: None | |||||||
| xsansystem | Xsan System | Jeff Albouze | Jeff Albouze | Defined TXT keys: None | |||||||
| xtimelicence | xTime License | AppMac Software | AppMac Software | Defined TXT keys: None | |||||||
| xtshapro | xTime Project | AppMac Software | AppMac Software | Defined TXT keys: None | |||||||
| xul-http | XUL (XML User Interface Language) transported over HTTP | Eran Gampel | Eran Gampel | Defined TXT keys: u=<username> p=<password> path=<path to document> (Same as for _http._tcp) | |||||||
| yakumo | udp | Yakumo iPhone OS Device Control Protocol | Daniel Heffernan | Daniel Heffernan | Defined TXT keys: None | ||||||
| z-wave | tcp | Z-Wave Service Discovery | Sigma Designs, Inc. | Anders Brandt | 2011-10-03 | Defined TXT keys: NIF, EP, LM | |||||
| z-wave | udp | Z-Wave Service Discovery | Sigma Designs, Inc. | Anders Brandt | 2011-10-03 | Defined TXT keys: NIF, EP, LM | |||||
| zeromq | tcp | High performance brokerless messaging | Daniel Holth | Daniel Holth | 2012-04-24 | Defined TXT keys: type, app, label, note | |||||
| zeromq | udp | High performance brokerless messaging | Daniel Holth | Daniel Holth | 2012-04-24 | Defined TXT keys: type, app, label, note | |||||
| zigbee-bridge | tcp | ZigBee Bridge device | ZigBee Alliance's Network Device working group | Leslie Mulder | 2013-05-28 | Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices | |||||
| zigbee-bridge | udp | ZigBee Bridge device | ZigBee Alliance's Network Device working group | Leslie Mulder | 2013-05-28 | Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices | |||||
| zigbee-gateway | tcp | ZigBee IP Gateway | ZigBee Alliance's Network Device working group | Leslie Mulder | 2013-05-28 | Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices | |||||
| zigbee-gateway | udp | ZigBee IP Gateway | ZigBee Alliance's Network Device working group | Leslie Mulder | 2013-05-28 | Defined TXT keys: see: http://www.zigbee.org/Standards/ZigBeeNetworkDevices |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anders Brandt | Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 |
| Andrew Donoho | awd&us.ibm.com | ||
| AppMac Software | appmac&appmac.com | ||
| Austin Meyer | austin&x-plane.com | ||
| Brady Anderson | banderso&novell.com | ||
| Brent Fulgham | bfulgham&wyatt.com | ||
| CLAUDE MALLY | XMI Systems SA | cma&xmisystems.com | 2013-01-18 |
| Daniel Heffernan | me&daniel.ie | ||
| Daniel Holth | dholth&fastmail.fm | 2012-04-24 | |
| Don Woodward | dwoodward&rokulabs.com | ||
| Eran Gampel | eran&aoe6.net | ||
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Henric Bergh | henric&bergh.nu | 2007-01 | |
| ITU-T Study Group 17 | era&x500.eu | 2019-08-13 | |
| Jeff Albouze | foup&apple.com | ||
| Kazuyuki Ashimura | ashimura&w3.org | 2022-11-22 | |
| Kevin Arnold | imlucid&apple.com | ||
| Leslie Mulder | ZigBee Alliance's Network Device working group | ljm&exegin.com | 2013-05-28 |
| Marc Krochmal | marc&apple.com | ||
| Matthias Burghardt | m.burghardt&x-on.de | ||
| Michiel Terpstra | terpstra.m&interactionnext.nl | 2013-11-13 | |
| Roy Reapor | rreapor&wyatt.com | ||
| Scott Tooker | tooker&apple.com | ||
| Sigma Designs, Inc. | anders_brandt&sigmadesigns.com | 2011-10-03 | |
| Thomas Quarendon | World Programming Limited | tom.quarendon&worldprogramming.com | 2017-04-04 |
| Tim Jobling | tim&cambridgeimaging.co.uk | ||
| W3C Web of Things Working Group | team-wot&w3.org | 2022-11-22 | |
| World Programming Limited | support&worldprogramming.com | 2017-04-04 | |
| Xential | info&xential.nl | 2013-11-13 | |
| XMI Systems SA | cma&xmisystems.com | 2013-01-18 | |
| Yin Ki Lau | xdt_software&oodot.com | ||
| ZigBee Alliance's Network Device working group | ljm&exegin.com | 2013-05-28 |