Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rtip 771 udp
cycleserv2 772 tcp
cycleserv2 772 udp
submit 773 tcp
notify 773 udp
rpasswd 774 tcp
acmaint-dbd 774 udp IANA assigned this well-formed service name as a replacement for "acmaint_dbd".
acmaint_dbd 774 udp This entry is an alias to "acmaint-dbd". This entry is now historic, not usable for use with many common service discovery mechanisms.
entomb 775 tcp
acmaint-transd 775 udp IANA assigned this well-formed service name as a replacement for "acmaint_transd".
acmaint_transd 775 udp This entry is an alias to "acmaint-transd". This entry is now historic, not usable for use with many common service discovery mechanisms.
wpages 776 tcp Josyula R. Rao Josyula R. Rao
wpages 776 udp Josyula R. Rao Josyula R. Rao
multiling-http 777 tcp Multiling HTTP Alejandro Bonet Alejandro Bonet
multiling-http 777 udp Multiling HTTP Alejandro Bonet Alejandro Bonet
778-779 Unassigned
wpgs 780 tcp Josyula R. Rao Josyula R. Rao
wpgs 780 udp Josyula R. Rao Josyula R. Rao
781-785 Unassigned
786 Unassigned 2002-05-08
787 Unassigned 2002-10-08
788-799 Unassigned Unauthorized Use Known on port 796
mdbs-daemon 800 tcp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 tcp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
mdbs-daemon 800 udp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 udp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
device 801 tcp
device 801 udp
mbap-s 802 tcp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
mbap-s 802 udp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
803-809 Unassigned
fcp-udp 810 tcp FCP Paul Whittemore Paul Whittemore
fcp-udp 810 udp FCP Datagram Paul Whittemore Paul Whittemore
811-827 Unassigned
itm-mcell-s 828 tcp itm-mcell-s Portnoy Boxman Portnoy Boxman
itm-mcell-s 828 udp itm-mcell-s Portnoy Boxman Portnoy Boxman
pkix-3-ca-ra 829 tcp PKIX-3 CA/RA Carlisle Adams Carlisle Adams
pkix-3-ca-ra 829 udp PKIX-3 CA/RA Carlisle Adams Carlisle Adams
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
831 tcp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
831 udp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
832 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
832 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
834-846 Unassigned
dhcp-failover2 847 tcp dhcp-failover 2 Bernard Volz Bernard Volz
dhcp-failover2 847 udp dhcp-failover 2 Bernard Volz Bernard Volz
gdoi 848 tcp GDOI RFC 3547
gdoi 848 udp GDOI RFC 3547
849-852 Unassigned
domain-s 853 tcp DNS query-response protocol run over TLS IESG IETF Chair 2015-10-08 2022-04-11 RFC 7858
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
dlep 854 tcp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
dlep 854 udp Dynamic Link Exchange Protocol (DLEP) IESG IETF Chair 2017-04-03 RFC 8175
855-859 Unassigned
iscsi 860 tcp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
iscsi 860 udp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
owamp-control 861 tcp OWAMP-Control IESG IETF Chair RFC 4656
owamp-test 861 udp OWAMP-Test IESG IETF Chair 2018-12-21 RFC 8545
twamp-control 862 tcp TWAMP-Control IESG IETF Chair RFC 5357
twamp-test 862 udp TWAMP-Test Receiver Port IESG IETF Chair 2018-12-21 RFC 8545
863-872 Unassigned
rsync 873 tcp rsync Andrew Tridgell Andrew Tridgell
rsync 873 udp rsync Andrew Tridgell Andrew Tridgell
874-885 Unassigned
iclcnet-locate 886 tcp ICL coNETion locate server Bob Lyon Bob Lyon
iclcnet-locate 886 udp ICL coNETion locate server Bob Lyon Bob Lyon
iclcnet-svinfo 887 tcp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
Bob Lyon Bob Lyon
iclcnet_svinfo 887 tcp ICL coNETion server info Bob Lyon Bob Lyon This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
iclcnet-svinfo 887 udp ICL coNETion server info

IANA assigned this well-formed service name as a replacement for "iclcnet_svinfo".
Bob Lyon Bob Lyon
iclcnet_svinfo 887 udp ICL coNETion server info Bob Lyon Bob Lyon This entry is an alias to "iclcnet-svinfo". This entry is now historic, not usable for use with many common service discovery mechanisms.
accessbuilder 888 tcp AccessBuilder Steve Sweeney Steve Sweeney
accessbuilder 888 udp AccessBuilder Steve Sweeney Steve Sweeney
cddbp 888 tcp CD Database Protocol Steve Scherf Steve Scherf This entry records an unassigned but widespread use
889-899 Unassigned
omginitialrefs 900 tcp OMG Initial Refs Christian Callsen Christian Callsen
omginitialrefs 900 udp OMG Initial Refs Christian Callsen Christian Callsen
smpnameres 901 tcp SMPNAMERES Leif Ekblad Leif Ekblad
smpnameres 901 udp SMPNAMERES Leif Ekblad Leif Ekblad
ideafarm-door 902 tcp self documenting Telnet Door
ideafarm-door 902 udp self documenting Door: send 0x00 for info
ideafarm-panic 903 tcp self documenting Telnet Panic Door Wo'o Ideafarm Wo'o Ideafarm
ideafarm-panic 903 udp self documenting Panic Door: send 0x00 for info Wo'o Ideafarm Wo'o Ideafarm
904-909 Unassigned
kink 910 tcp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
kink 910 udp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
xact-backup 911 tcp xact-backup Bill Carroll Bill Carroll
xact-backup 911 udp xact-backup Bill Carroll Bill Carroll
apex-mesh 912 tcp APEX relay-relay service
apex-mesh 912 udp APEX relay-relay service
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
914 tcp Reserved
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
915 tcp Reserved
rift-ties 915 udp Routing in Fat Trees Topology Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
916-952 Unassigned
rndc 953 tcp BIND9 remote name daemon controller Internet Systems Consortium, Inc. Ray Bellis 2017-06-08
953 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Alejandro Bonet babel&ctv.es
Andrew Tridgell tridge&samba.anu.edu.au
Bernard Volz bevolz&gmail.com 2022-08-03
Bill Carroll billc&xactlabs.com
Bob Lyon bl&oasis.icl.co.uk
Carlisle Adams Cadams&entrust.com
Christian Callsen Christian.Callsen&eng.sun.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Internet Systems Consortium, Inc. info&isc.org 2017-06-08
Josyula R. Rao jrrao&watson.ibm.com
Leif Ekblad leif&rdos.net
modbus.org rbelliardi&modbus.org 2014-06-10
Paul Whittemore paul&softarc.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Ray Bellis ray&isc.org 2017-06-08
Steve Scherf steve&moonsoft.com
Steve Sweeney Steven_Sweeney&3mail.3com.com
Wo'o Ideafarm b85f3c23.9ad6f42c&ideafarm.com