Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 953 | udp | Reserved | |||||||||
| 954-988 | Unassigned | ||||||||||
| ftps-data | 989 | tcp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps-data | 989 | udp | ftp protocol, data, over TLS/SSL | ||||||||
| ftps | 990 | tcp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| ftps | 990 | udp | ftp protocol, control, over TLS/SSL | Christopher Allen | Christopher Allen | ||||||
| nas | 991 | tcp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| nas | 991 | udp | Netnews Administration System | Vera Heinau; Heiko Schlichting | Vera Heinau; Heiko Schlichting | 2017-02-10 | RFC 4707 | ||||
| telnets | 992 | tcp | telnet protocol over TLS/SSL | ||||||||
| telnets | 992 | udp | telnet protocol over TLS/SSL | ||||||||
| imaps | 993 | tcp | IMAP over TLS protocol | IESG | IETF Chair | 2021-02-22 | RFC 3501; RFC 8314; RFC 9051 | ||||
| 993 | udp | Reserved | 2021-02-22 | RFC 9051 | |||||||
| 994 | tcp | Reserved | 2011-08-31 | (previous contact was Christopher Allen) | |||||||
| 994 | udp | Reserved | |||||||||
| pop3s | 995 | tcp | POP3 over TLS protocol | IESG | IETF Chair | 2017-12-12 | RFC 8314 | ||||
| pop3s | 995 | udp | pop3 protocol over TLS/SSL (was spop3) | Gordon Mangione | Gordon Mangione | ||||||
| vsinet | 996 | tcp | vsinet | Rob Juergens | Rob Juergens | ||||||
| vsinet | 996 | udp | vsinet | Rob Juergens | Rob Juergens | ||||||
| maitrd | 997 | tcp | |||||||||
| maitrd | 997 | udp | |||||||||
| busboy | 998 | tcp | |||||||||
| puparp | 998 | udp | |||||||||
| garcon | 999 | tcp | |||||||||
| applix | 999 | udp | Applix ac | ||||||||
| puprouter | 999 | tcp | |||||||||
| puprouter | 999 | udp | |||||||||
| cadlock2 | 1000 | tcp | |||||||||
| cadlock2 | 1000 | udp | |||||||||
| webpush | 1001 | tcp | HTTP Web Push | IESG | IETF Chair | 2016-11-01 | RFC 8030 | ||||
| 1001 | udp | Reserved | |||||||||
| 1002-1007 | Unassigned | ||||||||||
| 1008 | udp | Possibly used by Sun Solaris???? | |||||||||
| 1009 | Unassigned | ||||||||||
| surf | 1010 | tcp | surf | Joseph Geer | Joseph Geer | ||||||
| surf | 1010 | udp | surf | Joseph Geer | Joseph Geer | ||||||
| 1011-1020 | Reserved | ||||||||||
| exp1 | 1021 | tcp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | udp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | sctp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp1 | 1021 | dccp | RFC3692-style Experiment 1 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | tcp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | udp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | sctp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| exp2 | 1022 | dccp | RFC3692-style Experiment 2 | IESG | IETF Chair | [1]RFC 4727; RFC 6335 | |||||
| 1023 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1023 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1024 | tcp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| 1024 | udp | Reserved | 2024-12-20 | RFC 6335 | |||||||
| blackjack | 1025 | tcp | network blackjack | ||||||||
| blackjack | 1025 | udp | network blackjack | ||||||||
| cap | 1026 | tcp | Calendar Access Protocol | Doug Royer | Doug Royer | 2010-12-09 | |||||
| cap | 1026 | udp | Calendar Access Protocol | Doug Royer | Doug Royer | 2010-12-09 | |||||
| 6a44 | 1027 | udp | IPv6 Behind NAT44 CPEs | IESG | IETF Chair | 2012-08-02 | RFC 6751 | ||||
| 1027 | tcp | Reserved | |||||||||
| 1028 | Deprecated | 2004-02 | |||||||||
| solid-mux | 1029 | tcp | Solid Mux Server | Anders Borg | Anders Borg | 2004-11 | |||||
| solid-mux | 1029 | udp | Solid Mux Server | Anders Borg | Anders Borg | 2004-11 | |||||
| 1030 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1031 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1032 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| netinfo-local | 1033 | tcp | local netinfo port | Marc Majka | Marc Majka | 2002-08 | |||||
| netinfo-local | 1033 | udp | local netinfo port | Marc Majka | Marc Majka | 2002-08 | |||||
| activesync | 1034 | tcp | ActiveSync Notifications | Sandra Vargas | Sandra Vargas | 2003-03 | |||||
| activesync | 1034 | udp | ActiveSync Notifications | Sandra Vargas | Sandra Vargas | 2003-03 | |||||
| mxxrlogin | 1035 | tcp | MX-XR RPC | Valassis | John Eckert | 2003-04 | 2015-05-05 | ||||
| mxxrlogin | 1035 | udp | MX-XR RPC | Valassis | John Eckert | 2003-04 | 2015-05-05 | ||||
| nsstp | 1036 | tcp | Nebula Secure Segment Transfer Protocol | Steve Ravida | Steve Ravida | ||||||
| nsstp | 1036 | udp | Nebula Secure Segment Transfer Protocol | Steve Ravida | Steve Ravida | ||||||
| ams | 1037 | tcp | AMS | Ronald R. Ohmer | Ronald R. Ohmer | 2004-02 | |||||
| ams | 1037 | udp | AMS | Ronald R. Ohmer | Ronald R. Ohmer | 2004-02 | |||||
| mtqp | 1038 | tcp | Message Tracking Query Protocol | RFC 3887 | |||||||
| mtqp | 1038 | udp | Message Tracking Query Protocol | RFC 3887 | |||||||
| sbl | 1039 | tcp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| sbl | 1039 | udp | Streamlined Blackhole | Jonathan A. Zdziaraski | Jonathan A. Zdziaraski | 2004-11 | |||||
| netarx | 1040 | tcp | Netarx Netcare | Sandy Kronenberg | Sandy Kronenberg | 2008-04-03 | |||||
| netarx | 1040 | udp | Netarx Netcare | Sandy Kronenberg | Sandy Kronenberg | 2008-04-03 | |||||
| danf-ak2 | 1041 | tcp | AK2 Product | Karl Palsson | Karl Palsson | 2004-11 | |||||
| danf-ak2 | 1041 | udp | AK2 Product | Karl Palsson | Karl Palsson | 2004-11 | |||||
| afrog | 1042 | tcp | Subnet Roaming | Michael Chapman | Michael Chapman | 2004-11 | |||||
| afrog | 1042 | udp | Subnet Roaming | Michael Chapman | Michael Chapman | 2004-11 | |||||
| boinc-client | 1043 | tcp | BOINC Client Control | David Anderson | David Anderson | 2004-11 | |||||
| boinc-client | 1043 | udp | BOINC Client Control | David Anderson | David Anderson | 2004-11 | |||||
| dcutility | 1044 | tcp | Dev Consortium Utility | Chris Ryland | Chris Ryland | 2004-11 | |||||
| dcutility | 1044 | udp | Dev Consortium Utility | Chris Ryland | Chris Ryland | 2004-11 | |||||
| fpitp | 1045 | tcp | Fingerprint Image Transfer Protocol | Steven Fields | Steven Fields | 2002-02 | |||||
| fpitp | 1045 | udp | Fingerprint Image Transfer Protocol | Steven Fields | Steven Fields | 2002-02 | |||||
| wfremotertm | 1046 | tcp | WebFilter Remote Monitor | Tim Morgan | Tim Morgan | 2004-11 | |||||
| wfremotertm | 1046 | udp | WebFilter Remote Monitor | Tim Morgan | Tim Morgan | 2004-11 | |||||
| neod1 | 1047 | tcp | Sun's NEO Object Request Broker | ||||||||
| neod1 | 1047 | udp | Sun's NEO Object Request Broker | ||||||||
| neod2 | 1048 | tcp | Sun's NEO Object Request Broker | Rohit Garg | Rohit Garg | ||||||
| neod2 | 1048 | udp | Sun's NEO Object Request Broker | Rohit Garg | Rohit Garg | ||||||
| td-postman | 1049 | tcp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-postman | 1049 | udp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| cma | 1050 | tcp | CORBA Management Agent | Ramy Zaarour | Ramy Zaarour | ||||||
| cma | 1050 | udp | CORBA Management Agent | Ramy Zaarour | Ramy Zaarour | ||||||
| optima-vnet | 1051 | tcp | Optima VNET | Ralf Doewich | Ralf Doewich | ||||||
| optima-vnet | 1051 | udp | Optima VNET | Ralf Doewich | Ralf Doewich | ||||||
| ddt | 1052 | tcp | Dynamic DNS Tools | Remi Lefebvre | Remi Lefebvre | ||||||
| ddt | 1052 | udp | Dynamic DNS Tools | Remi Lefebvre | Remi Lefebvre | ||||||
| remote-as | 1053 | tcp | Remote Assistant (RA) | Roman Kriis | Roman Kriis | Unauthorized Use Known on port 1053 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anders Borg | anders.borg&solid.se | 2004-11 | |
| Chris Ryland | cpr&emsoftware.com | 2004-11 | |
| Christopher Allen | ChristopherA&consensus.com | ||
| David Anderson | davea&ssl.berkeley.edu | 2004-11 | |
| Doug Royer | DouglasRoyer&gmail.com | 2010-12-09 | |
| Franz-Josef Leuders | development&tobit.com | ||
| Gordon Mangione | gordmµsoft.com | ||
| Heiko Schlichting | heiko.schlichting&fu-berlin.de | 2022-06-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| John Eckert | Valassis | eckertj&valassis.com | 2015-05-05 |
| Jonathan A. Zdziaraski | jonathan&nuclearelephant.com | 2004-11 | |
| Joseph Geer | jgeer&peapod.com | ||
| Karl Palsson | karl_p&danfoss.com | 2004-11 | |
| Marc Majka | majka&apple.com | 2002-08 | |
| Michael Chapman | mchapman&fortresstech.com | 2004-11 | |
| Ralf Doewich | ralf.doewich&optimatele.com | ||
| Ramy Zaarour | ramy&lumos.com | ||
| Remi Lefebvre | remi&debian.org | ||
| Rob Juergens | robj&vsi.com | ||
| Rohit Garg | rohit.garg&eng.sun.com | ||
| Roman Kriis | roman&previo.ee | ||
| Ronald R. Ohmer | rohmer&aisconsulting.net | 2004-02 | |
| Sandra Vargas | Sandramaµsoft.com | 2003-03 | |
| Sandy Kronenberg | sandy&netarx.com | 2008-04-03 | |
| Steve Ravida | steve.ravida&nebulaholdings.com | ||
| Steven Fields | sfields&identix.com | 2002-02 | |
| Tim Morgan | timm&surfcontrol.com | 2004-11 | |
| Valassis | eckertj&valassis.com | 2015-05-05 | |
| Vera Heinau | vera.heinau&fu-berlin.de | 2022-06-07 |