Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mpm-snd 46 tcp MPM [default send] Jon Postel Jon Postel
mpm-snd 46 udp MPM [default send] Jon Postel Jon Postel
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
auditd 48 tcp Digital Audit Daemon Larry Scott Larry Scott
auditd 48 udp Digital Audit Daemon Larry Scott Larry Scott
tacacs 49 tcp Login Host Protocol (TACACS) Pieter Ditmars Pieter Ditmars
tacacs 49 udp Login Host Protocol (TACACS) Pieter Ditmars Pieter Ditmars
re-mail-ck 50 tcp Remote Mail Checking Protocol Steve Dorner Steve Dorner
re-mail-ck 50 udp Remote Mail Checking Protocol Steve Dorner Steve Dorner
51 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
xns-time 52 tcp XNS Time Protocol Susie Armstrong Susie Armstrong
xns-time 52 udp XNS Time Protocol Susie Armstrong Susie Armstrong
domain 53 tcp Domain Name Server Paul Mockapetris Paul Mockapetris
domain 53 udp Domain Name Server Paul Mockapetris Paul Mockapetris
xns-ch 54 tcp XNS Clearinghouse Susie Armstrong Susie Armstrong
xns-ch 54 udp XNS Clearinghouse Susie Armstrong Susie Armstrong
isi-gl 55 tcp ISI Graphics Language
isi-gl 55 udp ISI Graphics Language
xns-auth 56 tcp XNS Authentication Susie Armstrong Susie Armstrong
xns-auth 56 udp XNS Authentication Susie Armstrong Susie Armstrong
57 tcp any private terminal access Jon Postel Jon Postel
57 udp any private terminal access Jon Postel Jon Postel
xns-mail 58 tcp XNS Mail Susie Armstrong Susie Armstrong
xns-mail 58 udp XNS Mail Susie Armstrong Susie Armstrong
59 tcp any private file service Jon Postel Jon Postel
59 udp any private file service Jon Postel Jon Postel
60 tcp Unassigned
60 udp Unassigned
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
acas 62 tcp ACA Services E. Wald E. Wald
acas 62 udp ACA Services E. Wald E. Wald
whoispp 63 tcp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 tcp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
whoispp 63 udp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 udp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
covia 64 tcp Communications Integrator (CI) Dan Smith Dan Smith
covia 64 udp Communications Integrator (CI) Dan Smith Dan Smith
tacacs-ds 65 tcp TACACS-Database Service Kathy Huber Kathy Huber
tacacs-ds 65 udp TACACS-Database Service Kathy Huber Kathy Huber
sql-net 66 tcp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 tcp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
sql-net 66 udp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 udp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
bootps 67 udp Bootstrap Protocol Server
bootpc 68 tcp Bootstrap Protocol Client Bill Croft Bill Croft
bootpc 68 udp Bootstrap Protocol Client Bill Croft Bill Croft
tftp 69 tcp Trivial File Transfer David Clark David Clark
tftp 69 udp Trivial File Transfer David Clark David Clark
gopher 70 tcp Gopher Mark McCahill Mark McCahill
gopher 70 udp Gopher Mark McCahill Mark McCahill
netrjs-1 71 tcp Remote Job Service
netrjs-1 71 udp Remote Job Service
netrjs-2 72 tcp Remote Job Service
netrjs-2 72 udp Remote Job Service
netrjs-3 73 tcp Remote Job Service
netrjs-3 73 udp Remote Job Service
netrjs-4 74 tcp Remote Job Service Bob Braden Bob Braden
netrjs-4 74 udp Remote Job Service Bob Braden Bob Braden
75 tcp any private dial out service Jon Postel Jon Postel
75 udp any private dial out service Jon Postel Jon Postel
deos 76 tcp Distributed External Object Store Robert Ullmann Robert Ullmann
deos 76 udp Distributed External Object Store Robert Ullmann Robert Ullmann
77 tcp any private RJE service Jon Postel Jon Postel
77 udp any private RJE service Jon Postel Jon Postel
vettcp 78 tcp vettcp Christopher Leong Christopher Leong
vettcp 78 udp vettcp Christopher Leong Christopher Leong
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www-http 80 tcp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
www-http 80 udp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
81 Unassigned 2007-09-06
xfer 82 tcp XFER Utility Thomas M. Smith Thomas M. Smith
xfer 82 udp XFER Utility Thomas M. Smith Thomas M. Smith
mit-ml-dev 83 tcp MIT ML Device David Reed David Reed
mit-ml-dev 83 udp MIT ML Device David Reed David Reed
ctf 84 tcp Common Trace Facility Hugh Thomas Hugh Thomas
ctf 84 udp Common Trace Facility Hugh Thomas Hugh Thomas
mit-ml-dev 85 tcp MIT ML Device David Reed David Reed
mit-ml-dev 85 udp MIT ML Device David Reed David Reed
mfcobol 86 tcp Micro Focus Cobol Simon Edwards Simon Edwards
mfcobol 86 udp Micro Focus Cobol Simon Edwards Simon Edwards
87 tcp any private terminal link Jon Postel Jon Postel
87 udp any private terminal link Jon Postel Jon Postel
kerberos 88 tcp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
kerberos 88 udp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
su-mit-tg 89 tcp SU/MIT Telnet Gateway Mark Crispin Mark Crispin
su-mit-tg 89 udp SU/MIT Telnet Gateway Mark Crispin Mark Crispin
dnsix 90 tcp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
dnsix 90 udp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
mit-dov 91 tcp MIT Dover Spooler Eliot Moss Eliot Moss
mit-dov 91 udp MIT Dover Spooler Eliot Moss Eliot Moss
npp 92 tcp Network Printing Protocol Louis Mamakos Louis Mamakos
npp 92 udp Network Printing Protocol Louis Mamakos Louis Mamakos

Contact Information

Name Organization Contact URI Last Updated
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Croft Croft&sumex-aim.stanford.edu
Bob Braden Braden&isi.edu
Charles Watt watt&sware.com
Christopher Leong leong&kolmod.mlo.dec.com
Dan Smith dan.smith&den.galileo.com
David Clark ddc&lcs.mit.edu
David Reed
David Zimmerman dpz&rutgers.edu
E. Wald ewald&via.enet.dec.com
Eliot Moss EBM&xx.lcs.mit.edu
Hugh Thomas thomas&oils.enet.dec.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jack Haverty jhaverty&oracle.com
Jon Postel postel&isi.edu
Kathy Huber khuber&bbn.com
Larry Scott scott&zk3.dec.com
Louis Mamakos louie&sayshell.umd.edu
Mark Crispin MRC&panda.com
Mark McCahill mpm&boombox.micro.umn.edu
Paul Mockapetris PVM&isi.edu
Pieter Ditmars pditmars&bbn.com
Randall Stewart IETF TSVWG rrs&lakerest.net
Rickard Schoultz schoultz&sunet.se
Robert Ullmann ariel&world.std.com
Simon Edwards sedwards&rocketsoftware.com 2024-10-11
Steve Dorner s-dorner&uiuc.edu
Susie Armstrong Armstrong.wbst128@xerox
Thomas M. Smith Thomas.M.Smith&lmco.com
Tim Berners-Lee timbl&w3.org