Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| npp | 92 | udp | Network Printing Protocol | Louis Mamakos | Louis Mamakos | ||||||
| dcp | 93 | tcp | Device Control Protocol | Daniel Tappan | Daniel Tappan | ||||||
| dcp | 93 | udp | Device Control Protocol | Daniel Tappan | Daniel Tappan | ||||||
| objcall | 94 | tcp | Tivoli Object Dispatcher | Tom Bereiter | Tom Bereiter | ||||||
| objcall | 94 | udp | Tivoli Object Dispatcher | Tom Bereiter | Tom Bereiter | ||||||
| supdup | 95 | tcp | SUPDUP | Mark Crispin | Mark Crispin | ||||||
| supdup | 95 | udp | SUPDUP | Mark Crispin | Mark Crispin | ||||||
| dixie | 96 | tcp | DIXIE Protocol Specification | Tim Howes | Tim Howes | ||||||
| dixie | 96 | udp | DIXIE Protocol Specification | Tim Howes | Tim Howes | ||||||
| swift-rvf | 97 | tcp | Swift Remote Virtural File Protocol | Maurice R. Turcotte | Maurice R. Turcotte | ||||||
| swift-rvf | 97 | udp | Swift Remote Virtural File Protocol | Maurice R. Turcotte | Maurice R. Turcotte | ||||||
| tacnews | 98 | tcp | TAC News | Jon Postel | Jon Postel | ||||||
| tacnews | 98 | udp | TAC News | Jon Postel | Jon Postel | ||||||
| metagram | 99 | tcp | Metagram Relay | Geoff Goodfellow | Geoff Goodfellow | ||||||
| metagram | 99 | udp | Metagram Relay | Geoff Goodfellow | Geoff Goodfellow | ||||||
| 100 | Unassigned | 2012-03-21 | Known Unauthorized Use on 100 | ||||||||
| hostname | 101 | tcp | NIC Host Name Server | Jon Postel | Jon Postel | ||||||
| hostname | 101 | udp | NIC Host Name Server | Jon Postel | Jon Postel | ||||||
| iso-tsap | 102 | tcp | ISO-TSAP Class 0 | Marshall Rose | Marshall Rose | ||||||
| iso-tsap | 102 | udp | ISO-TSAP Class 0 | Marshall Rose | Marshall Rose | ||||||
| gppitnp | 103 | tcp | Genesis Point-to-Point Trans Net | ||||||||
| gppitnp | 103 | udp | Genesis Point-to-Point Trans Net | ||||||||
| acr-nema | 104 | tcp | ACR-NEMA Digital Imag. & Comm. 300 | Patrick McNamee | Patrick McNamee | ||||||
| acr-nema | 104 | udp | ACR-NEMA Digital Imag. & Comm. 300 | Patrick McNamee | Patrick McNamee | ||||||
| cso | 105 | tcp | CCSO name server protocol | Martin Hamilton | Martin Hamilton | ||||||
| cso | 105 | udp | CCSO name server protocol | Martin Hamilton | Martin Hamilton | ||||||
| csnet-ns | 105 | tcp | Mailbox Name Nameserver | Marvin Solomon | Marvin Solomon | ||||||
| csnet-ns | 105 | udp | Mailbox Name Nameserver | Marvin Solomon | Marvin Solomon | ||||||
| 3com-tsmux | 106 | tcp | 3COM-TSMUX | Jeremy Siegel | Jeremy Siegel | Known Unauthorized Use on 106 | |||||
| 3com-tsmux | 106 | udp | 3COM-TSMUX | Jeremy Siegel | Jeremy Siegel | Known Unauthorized Use on 106 | |||||
| rtelnet | 107 | tcp | Remote Telnet Service | Jon Postel | Jon Postel | ||||||
| rtelnet | 107 | udp | Remote Telnet Service | Jon Postel | Jon Postel | ||||||
| snagas | 108 | tcp | SNA Gateway Access Server | Kevin Murphy | Kevin Murphy | ||||||
| snagas | 108 | udp | SNA Gateway Access Server | Kevin Murphy | Kevin Murphy | ||||||
| pop2 | 109 | tcp | Post Office Protocol - Version 2 | Joyce K. Reynolds | Joyce K. Reynolds | ||||||
| pop2 | 109 | udp | Post Office Protocol - Version 2 | Joyce K. Reynolds | Joyce K. Reynolds | ||||||
| pop3 | 110 | tcp | Post Office Protocol - Version 3 | Marshall Rose | Marshall Rose | ||||||
| pop3 | 110 | udp | Post Office Protocol - Version 3 | Marshall Rose | Marshall Rose | ||||||
| sunrpc | 111 | tcp | SUN Remote Procedure Call | Chuck McManis | Chuck McManis | ||||||
| sunrpc | 111 | udp | SUN Remote Procedure Call | Chuck McManis | Chuck McManis | ||||||
| mcidas | 112 | tcp | McIDAS Data Transmission Protocol | Glenn Davis | Glenn Davis | ||||||
| mcidas | 112 | udp | McIDAS Data Transmission Protocol | Glenn Davis | Glenn Davis | ||||||
| ident | 113 | tcp | |||||||||
| auth | 113 | tcp | Authentication Service | Mike St. Johns | Mike St. Johns | ||||||
| auth | 113 | udp | Authentication Service | Mike St. Johns | Mike St. Johns | ||||||
| 114 | unassigned | Deprecated June 2004 | |||||||||
| sftp | 115 | tcp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| sftp | 115 | udp | Simple File Transfer Protocol | Mark Lottor | Mark Lottor | ||||||
| ansanotify | 116 | tcp | ANSA REX Notify | Nicola J. Howarth | Nicola J. Howarth | ||||||
| ansanotify | 116 | udp | ANSA REX Notify | Nicola J. Howarth | Nicola J. Howarth | ||||||
| uucp-path | 117 | tcp | UUCP Path Service | ||||||||
| uucp-path | 117 | udp | UUCP Path Service | ||||||||
| sqlserv | 118 | tcp | SQL Services | Larry Barnes | Larry Barnes | ||||||
| sqlserv | 118 | udp | SQL Services | Larry Barnes | Larry Barnes | ||||||
| nntp | 119 | tcp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| nntp | 119 | udp | Network News Transfer Protocol | IESG | IETF Chair | 2018-07-06 | RFC 3977 | ||||
| cfdptkt | 120 | tcp | CFDPTKT | John Ioannidis | John Ioannidis | ||||||
| cfdptkt | 120 | udp | CFDPTKT | John Ioannidis | John Ioannidis | ||||||
| erpc | 121 | tcp | Encore Expedited Remote Pro.Call | Jack O'Neil | Jack O'Neil | ||||||
| erpc | 121 | udp | Encore Expedited Remote Pro.Call | Jack O'Neil | Jack O'Neil | ||||||
| smakynet | 122 | tcp | SMAKYNET | Pierre Arnaud | Pierre Arnaud | ||||||
| smakynet | 122 | udp | SMAKYNET | Pierre Arnaud | Pierre Arnaud | ||||||
| ntp | 123 | tcp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| ntp | 123 | udp | Network Time Protocol | Dave Mills | Dave Mills | RFC 5905 | |||||
| ansatrader | 124 | tcp | ANSA REX Trader | Nicola J. Howarth | Nicola J. Howarth | ||||||
| ansatrader | 124 | udp | ANSA REX Trader | Nicola J. Howarth | Nicola J. Howarth | ||||||
| locus-map | 125 | tcp | Locus PC-Interface Net Map Ser | Eric Peterson | Eric Peterson | ||||||
| locus-map | 125 | udp | Locus PC-Interface Net Map Ser | Eric Peterson | Eric Peterson | ||||||
| nxedit | 126 | tcp | NXEdit | Don Payette | Don Payette | Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above | |||||
| nxedit | 126 | udp | NXEdit | Don Payette | Don Payette | Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above | |||||
| locus-con | 127 | tcp | Locus PC-Interface Conn Server | Eric Peterson | Eric Peterson | ||||||
| locus-con | 127 | udp | Locus PC-Interface Conn Server | Eric Peterson | Eric Peterson | ||||||
| gss-xlicen | 128 | tcp | GSS X License Verification | John Light | John Light | ||||||
| gss-xlicen | 128 | udp | GSS X License Verification | John Light | John Light | ||||||
| pwdgen | 129 | tcp | Password Generator Protocol | Frank J. Wacho | Frank J. Wacho | ||||||
| pwdgen | 129 | udp | Password Generator Protocol | Frank J. Wacho | Frank J. Wacho | ||||||
| cisco-fna | 130 | tcp | cisco FNATIVE | ||||||||
| cisco-fna | 130 | udp | cisco FNATIVE | ||||||||
| cisco-tna | 131 | tcp | cisco TNATIVE | ||||||||
| cisco-tna | 131 | udp | cisco TNATIVE | ||||||||
| cisco-sys | 132 | tcp | cisco SYSMAINT | ||||||||
| cisco-sys | 132 | udp | cisco SYSMAINT | ||||||||
| statsrv | 133 | tcp | Statistics Service | Dave Mills | Dave Mills | ||||||
| statsrv | 133 | udp | Statistics Service | Dave Mills | Dave Mills | ||||||
| ingres-net | 134 | tcp | INGRES-NET Service | Mike Berrow | Mike Berrow | ||||||
| ingres-net | 134 | udp | INGRES-NET Service | Mike Berrow | Mike Berrow | ||||||
| epmap | 135 | tcp | DCE endpoint resolution | Joe Pato | Joe Pato | ||||||
| epmap | 135 | udp | DCE endpoint resolution | Joe Pato | Joe Pato | ||||||
| profile | 136 | tcp | PROFILE Naming System | Larry Peterson | Larry Peterson | ||||||
| profile | 136 | udp | PROFILE Naming System | Larry Peterson | Larry Peterson | ||||||
| netbios-ns | 137 | tcp | NETBIOS Name Service | ||||||||
| netbios-ns | 137 | udp | NETBIOS Name Service | ||||||||
| netbios-dgm | 138 | tcp | NETBIOS Datagram Service | ||||||||
| netbios-dgm | 138 | udp | NETBIOS Datagram Service | ||||||||
| netbios-ssn | 139 | tcp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| netbios-ssn | 139 | udp | NETBIOS Session Service | Jon Postel | Jon Postel | ||||||
| emfis-data | 140 | tcp | EMFIS Data Service | ||||||||
| emfis-data | 140 | udp | EMFIS Data Service | ||||||||
| emfis-cntl | 141 | tcp | EMFIS Control Service | Gerd Beling | Gerd Beling | ||||||
| emfis-cntl | 141 | udp | EMFIS Control Service | Gerd Beling | Gerd Beling | ||||||
| bl-idm | 142 | tcp | Britton-Lee IDM | Susie Snitzer | Susie Snitzer |