Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ardusmul 1835 udp ARDUS Multicast Toshikatsu Ito Toshikatsu Ito
ste-smsc 1836 tcp ste-smsc Tom Snauwaert Tom Snauwaert
ste-smsc 1836 udp ste-smsc Tom Snauwaert Tom Snauwaert
csoft1 1837 tcp csoft1 John Coll John Coll
csoft1 1837 udp csoft1 John Coll John Coll
talnet 1838 tcp TALNET Aaron Lav Aaron Lav
talnet 1838 udp TALNET Aaron Lav Aaron Lav
netopia-vo1 1839 tcp netopia-vo1
netopia-vo1 1839 udp netopia-vo1
netopia-vo2 1840 tcp netopia-vo2
netopia-vo2 1840 udp netopia-vo2
netopia-vo3 1841 tcp netopia-vo3
netopia-vo3 1841 udp netopia-vo3
netopia-vo4 1842 tcp netopia-vo4
netopia-vo4 1842 udp netopia-vo4
netopia-vo5 1843 tcp netopia-vo5 Marc Epard Marc Epard
netopia-vo5 1843 udp netopia-vo5 Marc Epard Marc Epard
direcpc-dll 1844 tcp DirecPC-DLL Chris Kerrigan Chris Kerrigan
direcpc-dll 1844 udp DirecPC-DLL Chris Kerrigan Chris Kerrigan
altalink 1845 tcp altalink Alberto Raydan Alberto Raydan
altalink 1845 udp altalink Alberto Raydan Alberto Raydan
tunstall-pnc 1846 tcp Tunstall PNC Robert M. Moore Robert M. Moore
tunstall-pnc 1846 udp Tunstall PNC Robert M. Moore Robert M. Moore
slp-notify 1847 tcp SLP Notification RFC 3082
slp-notify 1847 udp SLP Notification RFC 3082
fjdocdist 1848 tcp fjdocdist Yuichi Ohiwa Yuichi Ohiwa
fjdocdist 1848 udp fjdocdist Yuichi Ohiwa Yuichi Ohiwa
alpha-sms 1849 tcp ALPHA-SMS Benjamin Grimm Benjamin Grimm
alpha-sms 1849 udp ALPHA-SMS Benjamin Grimm Benjamin Grimm
gsi 1850 tcp GSI William Mullaney William Mullaney
gsi 1850 udp GSI William Mullaney William Mullaney
ctcd 1851 tcp ctcd John Ryan John Ryan
ctcd 1851 udp ctcd John Ryan John Ryan
virtual-time 1852 tcp Virtual Time Angie S. Morner Angie S. Morner
virtual-time 1852 udp Virtual Time Angie S. Morner Angie S. Morner
vids-avtp 1853 tcp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
vids-avtp 1853 udp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
buddy-draw 1854 tcp Buddy Draw Marvin Shin Marvin Shin
buddy-draw 1854 udp Buddy Draw Marvin Shin Marvin Shin
fiorano-rtrsvc 1855 tcp Fiorano RtrSvc
fiorano-rtrsvc 1855 udp Fiorano RtrSvc
fiorano-msgsvc 1856 tcp Fiorano MsgSvc Albert Holt Albert Holt
fiorano-msgsvc 1856 udp Fiorano MsgSvc Albert Holt Albert Holt
datacaptor 1857 tcp DataCaptor Steven M. Forrester Steven M. Forrester
datacaptor 1857 udp DataCaptor Steven M. Forrester Steven M. Forrester
privateark 1858 tcp PrivateArk Ronen Zoran Ronen Zoran
privateark 1858 udp PrivateArk Ronen Zoran Ronen Zoran
gammafetchsvr 1859 tcp Gamma Fetcher Server Cnaan Aviv Cnaan Aviv
gammafetchsvr 1859 udp Gamma Fetcher Server Cnaan Aviv Cnaan Aviv
sunscalar-svc 1860 tcp SunSCALAR Services Sanjay Radia Sanjay Radia
sunscalar-svc 1860 udp SunSCALAR Services Sanjay Radia Sanjay Radia
lecroy-vicp 1861 tcp LeCroy VICP Anthony Cake Anthony Cake
lecroy-vicp 1861 udp LeCroy VICP Anthony Cake Anthony Cake
mysql-cm-agent 1862 tcp MySQL Cluster Manager Agent Andrew Morgan Andrew Morgan 2009-12-08
mysql-cm-agent 1862 udp MySQL Cluster Manager Agent Andrew Morgan Andrew Morgan 2009-12-08
msnp 1863 tcp MSNP William Lai William Lai
msnp 1863 udp MSNP William Lai William Lai
paradym-31port 1864 tcp Paradym 31 Port David Wooden David Wooden
paradym-31port 1864 udp Paradym 31 Port David Wooden David Wooden
entp 1865 tcp ENTP Seiko Epson Seiko Epson
entp 1865 udp ENTP Seiko Epson Seiko Epson
swrmi 1866 tcp swrmi Jun Yoshii Jun Yoshii
swrmi 1866 udp swrmi Jun Yoshii Jun Yoshii
udrive 1867 tcp UDRIVE Robby Walker Robby Walker
udrive 1867 udp UDRIVE Robby Walker Robby Walker
viziblebrowser 1868 tcp VizibleBrowser Jimmy Talbot Jimmy Talbot
viziblebrowser 1868 udp VizibleBrowser Jimmy Talbot Jimmy Talbot
transact 1869 tcp TransAct TransAct Futures Development Team TransAct Futures Development Team
transact 1869 udp TransAct TransAct Futures Development Team TransAct Futures Development Team
sunscalar-dns 1870 tcp SunSCALAR DNS Service Sanjay Radia Sanjay Radia
sunscalar-dns 1870 udp SunSCALAR DNS Service Sanjay Radia Sanjay Radia
canocentral0 1871 tcp Cano Central 0
canocentral0 1871 udp Cano Central 0
canocentral1 1872 tcp Cano Central 1 Mark McNamara Mark McNamara
canocentral1 1872 udp Cano Central 1 Mark McNamara Mark McNamara
fjmpjps 1873 tcp Fjmpjps
fjmpjps 1873 udp Fjmpjps
fjswapsnp 1874 tcp Fjswapsnp Y. Ohiwa Y. Ohiwa
fjswapsnp 1874 udp Fjswapsnp Y. Ohiwa Y. Ohiwa
westell-stats 1875 tcp westell stats Thomas McCabe Thomas McCabe
westell-stats 1875 udp westell stats Thomas McCabe Thomas McCabe
ewcappsrv 1876 tcp ewcappsrv Howard Yin Howard Yin
ewcappsrv 1876 udp ewcappsrv Howard Yin Howard Yin
hp-webqosdb 1877 tcp hp-webqosdb Kim Scott Kim Scott
hp-webqosdb 1877 udp hp-webqosdb Kim Scott Kim Scott
drmsmc 1878 tcp drmsmc Katsuhiko Abe Katsuhiko Abe
drmsmc 1878 udp drmsmc Katsuhiko Abe Katsuhiko Abe
nettgain-nms 1879 tcp NettGain NMS Dr. Yair Shapira Dr. Yair Shapira
nettgain-nms 1879 udp NettGain NMS Dr. Yair Shapira Dr. Yair Shapira
vsat-control 1880 tcp Gilat VSAT Control Yariv Kaplan Yariv Kaplan
vsat-control 1880 udp Gilat VSAT Control Yariv Kaplan Yariv Kaplan
ibm-mqseries2 1881 tcp IBM WebSphere MQ Everyplace Jane Porter Jane Porter
ibm-mqseries2 1881 udp IBM WebSphere MQ Everyplace Jane Porter Jane Porter
ecsqdmn 1882 tcp CA eTrust Common Services Paul Wissmiller Paul Wissmiller
ecsqdmn 1882 udp CA eTrust Common Services Paul Wissmiller Paul Wissmiller
mqtt 1883 tcp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
mqtt 1883 udp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
idmaps 1884 tcp Internet Distance Map Svc Sugih Jamim Sugih Jamim
idmaps 1884 udp Internet Distance Map Svc Sugih Jamim Sugih Jamim
vrtstrapserver 1885 tcp Veritas Trap Server Russell Thrasher Russell Thrasher
vrtstrapserver 1885 udp Veritas Trap Server Russell Thrasher Russell Thrasher

Contact Information

Name Organization Contact URI Last Updated
Aaron Lav aaron&taltrade.com
Albert Holt alberth&fiorano.com
Alberto Raydan alberto&altasol.com
Andrew Morgan andrew.morgan&sun.com 2009-12-08
Angie S. Morner webmaster&dsbcpas.com
Anthony Cake anthonyrc&lecroy.com
Benjamin Grimm bg&webnetix.de
Chris Kerrigan ckerrigan&hns.com
Cnaan Aviv cnaan&gammasite.com
David Wooden dwooden&wizdom.com
Dr. Yair Shapira yair&flashnetworks.com
Howard Yin howard.yin&ericsson.com
Jane Porter janeporter&uk.ibm.com
Jimmy Talbot jtalbot&vizible.com
John Coll john&csoft.co.uk
John Ryan john&cybertrace.com
Jun Yoshii yoshii&ael.fujitsu.co.jp
Katsuhiko Abe kabe&hst.fujitsu.co.jp
Kim Scott kims&cup.hp.com
Marc Epard marc&netopia.com
Mark McNamara markm&research.canon.com.au
Marvin Shin president&medialingo.com
OASIS robin&oasis-open.org 2015-02-10
Paul Wissmiller Paul.Wissmiller&ca.com
Robby Walker webmaster&cd-lab.com
Robert M. Moore robert.moore&tunstall.co.uk
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Ronen Zoran ronenz&cyber-ark.com
Russell Thrasher rthrashe&veritas.com
Sanjay Radia srradia&kasumbi.eng.sun.com
Sascha Kuemmel kuemmel&vidsoft.de
Seiko Epson Ishida.Hitoshi&exc.epson.co.jp
Steven M. Forrester StevenF&capsuletech.com
Sugih Jamim jamin&eecs.umich.edu
Thomas McCabe tmcca&westell.com
Tom Snauwaert tom.snauwaert&st-electronics.be
Toshikatsu Ito ito-t&pfu.co.jp
TransAct Futures Development Team 1869info&transactfutures.com
William Lai wlai&microsoft.com
William Mullaney mullanwi&usa.net
Y. Ohiwa y-ohiwa&ael.fujitsu.co.jp
Yariv Kaplan yarivk&gilat.com
Yuichi Ohiwa y-ohiwa&ael.fujitsu.co.jp