Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| macromedia-fcs | 1935 | udp | Macromedia Flash Communications server MX | Pritham Shetty | Pritham Shetty | ||||||
| jetcmeserver | 1936 | tcp | JetCmeServer Server Port | ||||||||
| jetcmeserver | 1936 | udp | JetCmeServer Server Port | ||||||||
| jwserver | 1937 | tcp | JetVWay Server Port | ||||||||
| jwserver | 1937 | udp | JetVWay Server Port | ||||||||
| jwclient | 1938 | tcp | JetVWay Client Port | ||||||||
| jwclient | 1938 | udp | JetVWay Client Port | ||||||||
| jvserver | 1939 | tcp | JetVision Server Port | ||||||||
| jvserver | 1939 | udp | JetVision Server Port | ||||||||
| jvclient | 1940 | tcp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| jvclient | 1940 | udp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| dic-aida | 1941 | tcp | DIC-Aida | Frans S.C. Witte | Frans S.C. Witte | ||||||
| dic-aida | 1941 | udp | DIC-Aida | Frans S.C. Witte | Frans S.C. Witte | ||||||
| res | 1942 | tcp | Real Enterprise Service | Bob Janssen | Bob Janssen | ||||||
| res | 1942 | udp | Real Enterprise Service | Bob Janssen | Bob Janssen | ||||||
| beeyond-media | 1943 | tcp | Beeyond Media | Bob Deblier | Bob Deblier | ||||||
| beeyond-media | 1943 | udp | Beeyond Media | Bob Deblier | Bob Deblier | ||||||
| close-combat | 1944 | tcp | close-combat | David Hua | David Hua | ||||||
| close-combat | 1944 | udp | close-combat | David Hua | David Hua | ||||||
| dialogic-elmd | 1945 | tcp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| dialogic-elmd | 1945 | udp | dialogic-elmd | Roger Kay | Roger Kay | ||||||
| tekpls | 1946 | tcp | tekpls | Brian Abramson | Brian Abramson | ||||||
| tekpls | 1946 | udp | tekpls | Brian Abramson | Brian Abramson | ||||||
| sentinelsrm | 1947 | tcp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| sentinelsrm | 1947 | udp | SentinelSRM | Michael Zunke | Michael Zunke | 2010-07-23 | Unauthorized Use Known on port 1947 | ||||
| eye2eye | 1948 | tcp | eye2eye | Trevor Bell | Trevor Bell | ||||||
| eye2eye | 1948 | udp | eye2eye | Trevor Bell | Trevor Bell | ||||||
| ismaeasdaqlive | 1949 | tcp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqlive | 1949 | udp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqtest | 1950 | tcp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqtest | 1950 | udp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| bcs-lmserver | 1951 | tcp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| bcs-lmserver | 1951 | udp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| mpnjsc | 1952 | tcp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| mpnjsc | 1952 | udp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| rapidbase | 1953 | tcp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| rapidbase | 1953 | udp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| abr-api | 1954 | tcp | ABR-API (diskbridge) | ||||||||
| abr-api | 1954 | udp | ABR-API (diskbridge) | ||||||||
| abr-secure | 1955 | tcp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| abr-secure | 1955 | udp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| vrtl-vmf-ds | 1956 | tcp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| vrtl-vmf-ds | 1956 | udp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| unix-status | 1957 | tcp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| unix-status | 1957 | udp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| dxadmind | 1958 | tcp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| dxadmind | 1958 | udp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| simp-all | 1959 | tcp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| simp-all | 1959 | udp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| nasmanager | 1960 | tcp | Merit DAC NASmanager | Richard S. Conto | Richard S. Conto | ||||||
| nasmanager | 1960 | udp | Merit DAC NASmanager | Richard S. Conto | Richard S. Conto | ||||||
| bts-appserver | 1961 | tcp | BTS APPSERVER | Carl Obsorn | Carl Obsorn | ||||||
| bts-appserver | 1961 | udp | BTS APPSERVER | Carl Obsorn | Carl Obsorn | ||||||
| biap-mp | 1962 | tcp | BIAP-MP | Louis Slothouber | Louis Slothouber | ||||||
| biap-mp | 1962 | udp | BIAP-MP | Louis Slothouber | Louis Slothouber | ||||||
| webmachine | 1963 | tcp | WebMachine | Tim Jowers | Tim Jowers | ||||||
| webmachine | 1963 | udp | WebMachine | Tim Jowers | Tim Jowers | ||||||
| solid-e-engine | 1964 | tcp | SOLID E ENGINE | Ari Valtanen | Ari Valtanen | ||||||
| solid-e-engine | 1964 | udp | SOLID E ENGINE | Ari Valtanen | Ari Valtanen | ||||||
| tivoli-npm | 1965 | tcp | Tivoli NPM | Ivana Cuozzo | Ivana Cuozzo | ||||||
| tivoli-npm | 1965 | udp | Tivoli NPM | Ivana Cuozzo | Ivana Cuozzo | ||||||
| slush | 1966 | tcp | Slush | Damien Miller | Damien Miller | ||||||
| slush | 1966 | udp | Slush | Damien Miller | Damien Miller | ||||||
| sns-quote | 1967 | tcp | SNS Quote | Robert Ellman | Robert Ellman | ||||||
| sns-quote | 1967 | udp | SNS Quote | Robert Ellman | Robert Ellman | ||||||
| lipsinc | 1968 | tcp | LIPSinc | ||||||||
| lipsinc | 1968 | udp | LIPSinc | ||||||||
| lipsinc1 | 1969 | tcp | LIPSinc 1 | Robert Armington | Robert Armington | ||||||
| lipsinc1 | 1969 | udp | LIPSinc 1 | Robert Armington | Robert Armington | ||||||
| netop-rc | 1970 | tcp | NetOp Remote Control | ||||||||
| netop-rc | 1970 | udp | NetOp Remote Control | ||||||||
| netop-school | 1971 | tcp | NetOp School | NetOp Technical Support | NetOp Technical Support | ||||||
| netop-school | 1971 | udp | NetOp School | NetOp Technical Support | NetOp Technical Support | ||||||
| intersys-cache | 1972 | tcp | Cache | Mark Hanson | Mark Hanson | ||||||
| intersys-cache | 1972 | udp | Cache | Mark Hanson | Mark Hanson | ||||||
| dlsrap | 1973 | tcp | Data Link Switching Remote Access Protocol | Steve T. Chiang | Steve T. Chiang | ||||||
| dlsrap | 1973 | udp | Data Link Switching Remote Access Protocol | Steve T. Chiang | Steve T. Chiang | ||||||
| drp | 1974 | tcp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| drp | 1974 | udp | DRP | Richard Alan Johnson | Richard Alan Johnson | ||||||
| tcoflashagent | 1975 | tcp | TCO Flash Agent | ||||||||
| tcoflashagent | 1975 | udp | TCO Flash Agent | ||||||||
| tcoregagent | 1976 | tcp | TCO Reg Agent | ||||||||
| tcoregagent | 1976 | udp | TCO Reg Agent | ||||||||
| tcoaddressbook | 1977 | tcp | TCO Address Book | Allan Panitch | Allan Panitch | ||||||
| tcoaddressbook | 1977 | udp | TCO Address Book | Allan Panitch | Allan Panitch | ||||||
| unisql | 1978 | tcp | UniSQL | ||||||||
| unisql | 1978 | udp | UniSQL | ||||||||
| unisql-java | 1979 | tcp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| unisql-java | 1979 | udp | UniSQL Java | Keith Yarbrough | Keith Yarbrough | ||||||
| panquest-xact | 1980 | tcp | PanQuest XACT | Chris Vertonghen | Chris Vertonghen | 2025-11-20 | |||||
| panquest-xact | 1980 | udp | PanQuest XACT | Chris Vertonghen | Chris Vertonghen | 2025-11-20 | |||||
| p2pq | 1981 | tcp | p2pQ | Warren Alexander | Warren Alexander | ||||||
| p2pq | 1981 | udp | p2pQ | Warren Alexander | Warren Alexander | ||||||
| estamp | 1982 | tcp | Evidentiary Timestamp | Todd Glassey | Todd Glassey | ||||||
| estamp | 1982 | udp | Evidentiary Timestamp | Todd Glassey | Todd Glassey | ||||||
| lhtp | 1983 | tcp | Loophole Test Protocol | Kade Hansson | Kade Hansson | ||||||
| lhtp | 1983 | udp | Loophole Test Protocol | Kade Hansson | Kade Hansson | ||||||
| bb | 1984 | tcp | BB | Sean MacGuire | Sean MacGuire | ||||||
| bb | 1984 | udp | BB | Sean MacGuire | Sean MacGuire | ||||||
| hsrp | 1985 | tcp | Hot Standby Router Protocol | RFC 2281 | |||||||
| hsrp | 1985 | udp | Hot Standby Router Protocol | RFC 2281 |