Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| hsrp | 1985 | udp | Hot Standby Router Protocol | RFC 2281 | |||||||
| licensedaemon | 1986 | tcp | cisco license management | ||||||||
| licensedaemon | 1986 | udp | cisco license management | ||||||||
| tr-rsrb-p1 | 1987 | tcp | cisco RSRB Priority 1 port | ||||||||
| tr-rsrb-p1 | 1987 | udp | cisco RSRB Priority 1 port | ||||||||
| tr-rsrb-p2 | 1988 | tcp | cisco RSRB Priority 2 port | ||||||||
| tr-rsrb-p2 | 1988 | udp | cisco RSRB Priority 2 port | ||||||||
| tr-rsrb-p3 | 1989 | tcp | cisco RSRB Priority 3 port | ||||||||
| tr-rsrb-p3 | 1989 | udp | cisco RSRB Priority 3 port | ||||||||
| mshnet | 1989 | tcp | MHSnet system | Bob Kummerfeld | Bob Kummerfeld | This entry records an unassigned but widespread use | |||||
| mshnet | 1989 | udp | MHSnet system | Bob Kummerfeld | Bob Kummerfeld | This entry records an unassigned but widespread use | |||||
| stun-p1 | 1990 | tcp | cisco STUN Priority 1 port | ||||||||
| stun-p1 | 1990 | udp | cisco STUN Priority 1 port | ||||||||
| stun-p2 | 1991 | tcp | cisco STUN Priority 2 port | ||||||||
| stun-p2 | 1991 | udp | cisco STUN Priority 2 port | ||||||||
| stun-p3 | 1992 | tcp | cisco STUN Priority 3 port | ||||||||
| stun-p3 | 1992 | udp | cisco STUN Priority 3 port | ||||||||
| ipsendmsg | 1992 | tcp | IPsendmsg | Bob Kummerfeld | Bob Kummerfeld | This entry records an unassigned but widespread use | |||||
| ipsendmsg | 1992 | udp | IPsendmsg | Bob Kummerfeld | Bob Kummerfeld | This entry records an unassigned but widespread use | |||||
| snmp-tcp-port | 1993 | tcp | cisco SNMP TCP port | ||||||||
| snmp-tcp-port | 1993 | udp | cisco SNMP TCP port | ||||||||
| stun-port | 1994 | tcp | cisco serial tunnel port | ||||||||
| stun-port | 1994 | udp | cisco serial tunnel port | ||||||||
| perf-port | 1995 | tcp | cisco perf port | ||||||||
| perf-port | 1995 | udp | cisco perf port | ||||||||
| tr-rsrb-port | 1996 | tcp | cisco Remote SRB port | ||||||||
| tr-rsrb-port | 1996 | udp | cisco Remote SRB port | ||||||||
| gdp-port | 1997 | tcp | cisco Gateway Discovery Protocol | ||||||||
| gdp-port | 1997 | udp | cisco Gateway Discovery Protocol | ||||||||
| x25-svc-port | 1998 | tcp | cisco X.25 service (XOT) | ||||||||
| x25-svc-port | 1998 | udp | cisco X.25 service (XOT) | ||||||||
| tcp-id-port | 1999 | tcp | cisco identification port | ||||||||
| tcp-id-port | 1999 | udp | cisco identification port | ||||||||
| cisco-sccp | 2000 | tcp | Cisco SCCP | Dan Wing | Dan Wing | 2003-11 | |||||
| cisco-sccp | 2000 | udp | Cisco SCCp | Dan Wing | Dan Wing | 2003-11 | |||||
| dc | 2001 | tcp | |||||||||
| wizard | 2001 | udp | curry | ||||||||
| globe | 2002 | tcp | |||||||||
| globe | 2002 | udp | |||||||||
| brutus | 2003 | tcp | Brutus Server | Johannes Skov Frandsen | Johannes Skov Frandsen | 2008-02-28 | |||||
| brutus | 2003 | udp | Brutus Server | Johannes Skov Frandsen | Johannes Skov Frandsen | 2008-02-28 | |||||
| mailbox | 2004 | tcp | |||||||||
| emce | 2004 | udp | CCWS mm conf | ||||||||
| berknet | 2005 | tcp | |||||||||
| oracle | 2005 | udp | |||||||||
| invokator | 2006 | tcp | |||||||||
| raid-cd | 2006 | udp | raid | ||||||||
| dectalk | 2007 | tcp | |||||||||
| raid-am | 2007 | udp | |||||||||
| conf | 2008 | tcp | |||||||||
| terminaldb | 2008 | udp | |||||||||
| news | 2009 | tcp | |||||||||
| whosockami | 2009 | udp | |||||||||
| search | 2010 | tcp | |||||||||
| pipe-server | 2010 | udp | IANA assigned this well-formed service name as a replacement for "pipe_server". | ||||||||
| pipe_server | 2010 | udp | This entry is an alias to "pipe-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| raid-cc | 2011 | tcp | raid | ||||||||
| servserv | 2011 | udp | |||||||||
| ttyinfo | 2012 | tcp | |||||||||
| raid-ac | 2012 | udp | |||||||||
| raid-am | 2013 | tcp | |||||||||
| raid-cd | 2013 | udp | |||||||||
| troff | 2014 | tcp | |||||||||
| raid-sf | 2014 | udp | |||||||||
| cypress | 2015 | tcp | |||||||||
| raid-cs | 2015 | udp | |||||||||
| bootserver | 2016 | tcp | |||||||||
| bootserver | 2016 | udp | |||||||||
| cypress-stat | 2017 | tcp | |||||||||
| bootclient | 2017 | udp | |||||||||
| terminaldb | 2018 | tcp | |||||||||
| rellpack | 2018 | udp | |||||||||
| whosockami | 2019 | tcp | |||||||||
| about | 2019 | udp | |||||||||
| xinupageserver | 2020 | tcp | |||||||||
| xinupageserver | 2020 | udp | |||||||||
| servexec | 2021 | tcp | |||||||||
| xinuexpansion1 | 2021 | udp | |||||||||
| down | 2022 | tcp | |||||||||
| xinuexpansion2 | 2022 | udp | |||||||||
| xinuexpansion3 | 2023 | tcp | |||||||||
| xinuexpansion3 | 2023 | udp | |||||||||
| xinuexpansion4 | 2024 | tcp | |||||||||
| xinuexpansion4 | 2024 | udp | |||||||||
| ellpack | 2025 | tcp | |||||||||
| xribs | 2025 | udp | |||||||||
| scrabble | 2026 | tcp | |||||||||
| scrabble | 2026 | udp | |||||||||
| shadowserver | 2027 | tcp | |||||||||
| shadowserver | 2027 | udp | |||||||||
| submitserver | 2028 | tcp | |||||||||
| submitserver | 2028 | udp | |||||||||
| hsrpv6 | 2029 | tcp | Hot Standby Router Protocol IPv6 | Ian Wilson | Ian Wilson | 2004-11 | |||||
| hsrpv6 | 2029 | udp | Hot Standby Router Protocol IPv6 | Ian Wilson | Ian Wilson | 2004-11 | |||||
| device2 | 2030 | tcp | |||||||||
| device2 | 2030 | udp | |||||||||
| mobrien-chat | 2031 | tcp | mobrien-chat | Mike O'Brien | Mike O'Brien | 2004-11 | |||||
| mobrien-chat | 2031 | udp | mobrien-chat | Mike O'Brien | Mike O'Brien | 2004-11 | |||||
| blackboard | 2032 | tcp | |||||||||
| blackboard | 2032 | udp | |||||||||
| glogger | 2033 | tcp |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Bob Kummerfeld | bob&sarad.cs.su.oz.au | |
| Dan Wing | danwing&gmail.com | 2022-11-07 |
| Ian Wilson | hsrp-info&cisco.com | 2004-11 |
| Johannes Skov Frandsen | joe&42tools.com | 2008-02-28 |
| Mike O'Brien | mike&mobrien.com | 2004-11 |