Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bl-idm 142 tcp Britton-Lee IDM Susie Snitzer Susie Snitzer
bl-idm 142 udp Britton-Lee IDM Susie Snitzer Susie Snitzer
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
uma 144 tcp Universal Management Architecture Jay Whitney Jay Whitney
uma 144 udp Universal Management Architecture Jay Whitney Jay Whitney
uaac 145 tcp UAAC Protocol David A. Gomberg David A. Gomberg
uaac 145 udp UAAC Protocol David A. Gomberg David A. Gomberg
iso-tp0 146 tcp ISO-IP0
iso-tp0 146 udp ISO-IP0
iso-ip 147 tcp ISO-IP Marshall Rose Marshall Rose
iso-ip 147 udp ISO-IP Marshall Rose Marshall Rose
jargon 148 tcp Jargon Bill Weinman Bill Weinman
jargon 148 udp Jargon Bill Weinman Bill Weinman
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
sql-net 150 tcp SQL-NET Martin Picard Martin Picard
sql-net 150 udp SQL-NET Martin Picard Martin Picard
hems 151 tcp HEMS
hems 151 udp HEMS
bftp 152 tcp Background File Transfer Program Annette DeSchon Annette DeSchon
bftp 152 udp Background File Transfer Program Annette DeSchon Annette DeSchon
sgmp 153 tcp SGMP Marty Schoffstahl Marty Schoffstahl
sgmp 153 udp SGMP Marty Schoffstahl Marty Schoffstahl
netsc-prod 154 tcp NETSC
netsc-prod 154 udp NETSC
netsc-dev 155 tcp NETSC Sergio Heker Sergio Heker
netsc-dev 155 udp NETSC Sergio Heker Sergio Heker
sqlsrv 156 tcp SQL Service Craig Rogers Craig Rogers
sqlsrv 156 udp SQL Service Craig Rogers Craig Rogers
knet-cmp 157 tcp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
knet-cmp 157 udp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
pcmail-srv 158 tcp PCMail Server Mark L. Lambert Mark L. Lambert
pcmail-srv 158 udp PCMail Server Mark L. Lambert Mark L. Lambert
nss-routing 159 tcp NSS-Routing Yakov Rekhter Yakov Rekhter
nss-routing 159 udp NSS-Routing Yakov Rekhter Yakov Rekhter
sgmp-traps 160 tcp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
sgmp-traps 160 udp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
snmp 161 tcp SNMP
snmp 161 udp SNMP
snmptrap 162 tcp SNMPTRAP Marshall Rose Marshall Rose
snmptrap 162 udp SNMPTRAP Marshall Rose Marshall Rose
cmip-man 163 tcp CMIP/TCP Manager
cmip-man 163 udp CMIP/TCP Manager
cmip-agent 164 tcp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
cmip-agent 164 udp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
s-net 166 tcp Sirius Systems Brian Lloyd Brian Lloyd
s-net 166 udp Sirius Systems Brian Lloyd Brian Lloyd
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
rsvd 168 tcp RSVD Alan Sandell Alan Sandell 2008-05-01
rsvd 168 udp RSVD Alan Sandell Alan Sandell 2008-05-01
send 169 tcp SEND William Oldwin William Oldwin 2019-04-22
send 169 udp SEND William Oldwin William Oldwin 2019-04-22
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid
multiplex 171 tcp Network Innovations Multiplex
multiplex 171 udp Network Innovations Multiplex
cl-1 172 tcp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 tcp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
cl-1 172 udp Network Innovations CL/1

IANA assigned this well-formed service name as a replacement for "cl/1".
Kevin DeVault Kevin DeVault
cl/1 172 udp Network Innovations CL/1 Kevin DeVault Kevin DeVault This entry is an alias to "cl-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
xyplex-mux 173 tcp Xyplex Bob Stewart Bob Stewart
xyplex-mux 173 udp Xyplex Bob Stewart Bob Stewart
mailq 174 tcp MAILQ Rayan Zachariassen Rayan Zachariassen
mailq 174 udp MAILQ Rayan Zachariassen Rayan Zachariassen
vmnet 175 tcp VMNET Christopher Tengi Christopher Tengi
vmnet 175 udp VMNET Christopher Tengi Christopher Tengi
genrad-mux 176 tcp GENRAD-MUX Ron Thornton Ron Thornton
genrad-mux 176 udp GENRAD-MUX Ron Thornton Ron Thornton
xdmcp 177 tcp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
xdmcp 177 udp X Display Manager Control Protocol Robert W. Scheifler Robert W. Scheifler
nextstep 178 tcp NextStep Window Server Leo Hourvitz Leo Hourvitz
nextstep 178 udp NextStep Window Server Leo Hourvitz Leo Hourvitz
bgp 179 tcp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 udp Border Gateway Protocol Kirk Lougheed Kirk Lougheed
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ris 180 tcp Intergraph Dave Buehmann Dave Buehmann
ris 180 udp Intergraph Dave Buehmann Dave Buehmann
unify 181 tcp Unify Daegis, Inc. Chris Anderson 2012-07-31
unify 181 udp Unify Daegis, Inc. Chris Anderson 2012-07-31
audit 182 tcp Unisys Audit SITP Gil Greenbaum Gil Greenbaum
audit 182 udp Unisys Audit SITP Gil Greenbaum Gil Greenbaum
ocbinder 183 tcp OCBinder
ocbinder 183 udp OCBinder
ocserver 184 tcp OCServer Jerrilynn Okamura Jerrilynn Okamura
ocserver 184 udp OCServer Jerrilynn Okamura Jerrilynn Okamura
remote-kis 185 tcp Remote-KIS
remote-kis 185 udp Remote-KIS
kis 186 tcp KIS Protocol Ralph Droms Ralph Droms
kis 186 udp KIS Protocol Ralph Droms Ralph Droms
aci 187 tcp Application Communication Interface Rick Carlos Rick Carlos
aci 187 udp Application Communication Interface Rick Carlos Rick Carlos
mumps 188 tcp Plus Five's MUMPS Hokey Stenn Hokey Stenn
mumps 188 udp Plus Five's MUMPS Hokey Stenn Hokey Stenn
qft 189 tcp Queued File Transport Wayne Schroeder Wayne Schroeder
qft 189 udp Queued File Transport Wayne Schroeder Wayne Schroeder
gacp 190 tcp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
gacp 190 udp Gateway Access Control Protocol C. Philip Wood C. Philip Wood

Contact Information

Name Organization Contact URI Last Updated
Alan Sandell alan.sandell&ist.co.uk 2008-05-01
Albert G. Broscius broscius&dsl.cis.upenn.edu
Amatzia Ben-Artzi
Annette DeSchon DESCHON&isi.edu
Bill Weinman wew&bearnet.com
Bob Stewart STEWART&xyplex.com
Brian Lloyd brian&lloyd.com
Brian Reid reid&decwrl.dec.com
C. Philip Wood cpw&lanl.gov
Chris Anderson Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Christopher Tengi tengi&princeton.edu
Craig Rogers Rogers&isi.edu
Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Dave Buehmann ingr!daveb&uunet.uu.net
David A. Gomberg gomberg&gateway.mitre.org
Gary S. Malkin GMALKIN&xylogics.com
Gil Greenbaum gcole&nisd.cam.unisys.com
Hokey Stenn hokey&plus5.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jay Whitney jw&powercenter.com
Jerrilynn Okamura
Kevin DeVault
Kirk Lougheed LOUGHEED&mathom.cisco.com
Leo Hourvitz leo&next.com
Mark L. Lambert markl&ptt.lcs.mit.edu
Marshall Rose mrose17&gmail.com 2024-07-29
Martin Picard
Marty Schoffstahl schoff&nisc.nyser.net
Ralph Droms rdroms&nri.reston.va.us
Randall Stewart IETF TSVWG rrs&lakerest.net
Rayan Zachariassen rayan&ai.toronto.edu
Rick Carlos rick&ticipa.csc.ti.com
Robert W. Scheifler RWS&xx.lcs.mit.edu
Ron Thornton thornton&aerostation.org 2020-09-01
Sergio Heker heker&jvncc.csc.org
Susie Armstrong Armstrong.wbst128&xerox.com
Susie Snitzer
Wayne Schroeder schroeder&sds.sdsc.edu
William Oldwin william&bitsome.ie 2022-01-28
Yakov Rekhter Yakov&ibm.com