Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ivs-video 2232 udp IVS Video default Thierry Turletti Thierry Turletti
infocrypt 2233 tcp INFOCRYPT Erica Liu Erica Liu
infocrypt 2233 udp INFOCRYPT Erica Liu Erica Liu
directplay 2234 tcp DirectPlay Ajay Jindal Ajay Jindal
directplay 2234 udp DirectPlay Ajay Jindal Ajay Jindal
sercomm-wlink 2235 tcp Sercomm-WLink Melinda Tsao Melinda Tsao
sercomm-wlink 2235 udp Sercomm-WLink Melinda Tsao Melinda Tsao
nani 2236 tcp Nani Steve Benoit Steve Benoit
nani 2236 udp Nani Steve Benoit Steve Benoit
optech-port1-lm 2237 tcp Optech Port1 License Manager Gerard Cannie Gerard Cannie
optech-port1-lm 2237 udp Optech Port1 License Manager Gerard Cannie Gerard Cannie
aviva-sna 2238 tcp AVIVA SNA SERVER Vick Keshishian Vick Keshishian
aviva-sna 2238 udp AVIVA SNA SERVER Vick Keshishian Vick Keshishian
imagequery 2239 tcp Image Query Charles Jacobs Charles Jacobs
imagequery 2239 udp Image Query Charles Jacobs Charles Jacobs
recipe 2240 tcp RECIPe Charlie Limoges Charlie Limoges 1997-12-16
recipe 2240 udp RECIPe Charlie Limoges Charlie Limoges 1997-12-16
ivsd 2241 tcp IVS Daemon Thierry Turletti Thierry Turletti
ivsd 2241 udp IVS Daemon Thierry Turletti Thierry Turletti
foliocorp 2242 tcp Folio Remote Server Pat Mcgowan Pat Mcgowan
foliocorp 2242 udp Folio Remote Server Pat Mcgowan Pat Mcgowan
magicom 2243 tcp Magicom Protocol Yossi Appleboum Yossi Appleboum
magicom 2243 udp Magicom Protocol Yossi Appleboum Yossi Appleboum
nmsserver 2244 tcp NMS Server Dmitry Krasnonosenkikh Dmitry Krasnonosenkikh
nmsserver 2244 udp NMS Server Dmitry Krasnonosenkikh Dmitry Krasnonosenkikh
hao 2245 tcp HaO Panic Ride Panic Ride
hao 2245 udp HaO Panic Ride Panic Ride
pc-mta-addrmap 2246 tcp PacketCable MTA Addr Map Dave Maxwell Dave Maxwell
pc-mta-addrmap 2246 udp PacketCable MTA Addr Map Dave Maxwell Dave Maxwell
antidotemgrsvr 2247 tcp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
antidotemgrsvr 2247 udp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
ums 2248 tcp User Management Service Andrew Crockford Andrew Crockford
ums 2248 udp User Management Service Andrew Crockford Andrew Crockford
rfmp 2249 tcp RISO File Manager Protocol Shinji Yamanaka Shinji Yamanaka
rfmp 2249 udp RISO File Manager Protocol Shinji Yamanaka Shinji Yamanaka
remote-collab 2250 tcp remote-collab Richard Walters Richard Walters
remote-collab 2250 udp remote-collab Richard Walters Richard Walters
dif-port 2251 tcp Distributed Framework Port Sebastien Lambla Sebastien Lambla
dif-port 2251 udp Distributed Framework Port Sebastien Lambla Sebastien Lambla
njenet-ssl 2252 tcp NJENET using SSL Hans U Schmidt Hans U Schmidt
njenet-ssl 2252 udp NJENET using SSL Hans U Schmidt Hans U Schmidt
dtv-chan-req 2253 tcp DTV Channel Request Richard Hodges Richard Hodges
dtv-chan-req 2253 udp DTV Channel Request Richard Hodges Richard Hodges
seispoc 2254 tcp Seismic P.O.C. Port Robert Reimiller Robert Reimiller
seispoc 2254 udp Seismic P.O.C. Port Robert Reimiller Robert Reimiller
vrtp 2255 tcp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
vrtp 2255 udp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
pcc-mfp 2256 tcp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
pcc-mfp 2256 udp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
simple-tx-rx 2257 tcp simple text/file transfer Daniel Kilsdonk Daniel Kilsdonk 2006-08
simple-tx-rx 2257 udp simple text/file transfer Daniel Kilsdonk Daniel Kilsdonk 2006-08
rcts 2258 tcp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
rcts 2258 udp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
bid-serv 2259 tcp BIF identifiers resolution service Li Zhiping Zhang Bo 2023-03-06
bid-serv 2259 udp BIF identifiers resolution service Li Zhiping Zhang Bo 2023-03-06
apc-2260 2260 tcp APC 2260 American Power Conversion American Power Conversion 2002-02
apc-2260 2260 udp APC 2260 American Power Conversion American Power Conversion 2002-02
comotionmaster 2261 tcp CoMotion Master Server
comotionmaster 2261 udp CoMotion Master Server
comotionback 2262 tcp CoMotion Backup Server Friedman Wagner-Dobler Friedman Wagner-Dobler 2005-09
comotionback 2262 udp CoMotion Backup Server Friedman Wagner-Dobler Friedman Wagner-Dobler 2005-09
ecwcfg 2263 tcp ECweb Configuration Service Anders Hjelm Anders Hjelm 2006-03
ecwcfg 2263 udp ECweb Configuration Service Anders Hjelm Anders Hjelm 2006-03
apx500api-1 2264 tcp Audio Precision Apx500 API Port 1
apx500api-1 2264 udp Audio Precision Apx500 API Port 1
apx500api-2 2265 tcp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
apx500api-2 2265 udp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
mfserver 2266 tcp M-Files Server Samppa Lahtinen Samppa Lahtinen 2004-06
mfserver 2266 udp M-files Server Samppa Lahtinen Samppa Lahtinen 2004-06
ontobroker 2267 tcp OntoBroker Dr. Michael Erdmann Dr. Michael Erdmann 2004-12
ontobroker 2267 udp OntoBroker Dr. Michael Erdmann Dr. Michael Erdmann 2004-12
amt 2268 tcp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
amt 2268 udp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
mikey 2269 tcp MIKEY Karl Norrman Karl Norrman 2004-12
mikey 2269 udp MIKEY Karl Norrman Karl Norrman 2004-12
starschool 2270 tcp starSchool Adam Ernst Adam Ernst 2004-12
starschool 2270 udp starSchool Adam Ernst Adam Ernst 2004-12
mmcals 2271 tcp Secure Meeting Maker Scheduling
mmcals 2271 udp Secure Meeting Maker Scheduling
mmcal 2272 tcp Meeting Maker Scheduling Andrew H Derbyshire Andrew H Derbyshire 2004-12
mmcal 2272 udp Meeting Maker Scheduling Andrew H Derbyshire Andrew H Derbyshire 2004-12
mysql-im 2273 tcp MySQL Instance Manager Petr Chardin Petr Chardin 2004-12
mysql-im 2273 udp MySQL Instance Manager Petr Chardin Petr Chardin 2004-12
pcttunnell 2274 tcp PCTTunneller ProControl Technology AB ProControl Technology AB 2004-12
pcttunnell 2274 udp PCTTunneller ProControl Technology AB ProControl Technology AB 2004-12
ibridge-data 2275 tcp iBridge Conferencing
ibridge-data 2275 udp iBridge Conferencing
ibridge-mgmt 2276 tcp iBridge Management Patrick Fisher Patrick Fisher 2004-12
ibridge-mgmt 2276 udp iBridge Management Patrick Fisher Patrick Fisher 2004-12
bluectrlproxy 2277 tcp Bt device control proxy Mark de Rooi Mark de Rooi 2004-12
bluectrlproxy 2277 udp Bt device control proxy Mark de Rooi Mark de Rooi 2004-12
s3db 2278 tcp Simple Stacked Sequences Database David Brandon David Brandon 2006-08
s3db 2278 udp Simple Stacked Sequences Database David Brandon David Brandon 2006-08
xmquery 2279 tcp xmquery Niels Christiansen Niels Christiansen
xmquery 2279 udp xmquery Niels Christiansen Niels Christiansen
lnvpoller 2280 tcp LNVPOLLER
lnvpoller 2280 udp LNVPOLLER
lnvconsole 2281 tcp LNVCONSOLE
lnvconsole 2281 udp LNVCONSOLE
lnvalarm 2282 tcp LNVALARM
lnvalarm 2282 udp LNVALARM

Contact Information

Name Organization Contact URI Last Updated
Adam Ernst cosmicsoft&cosmicsoft.net 2004-12
Ajay Jindal ajayj&microsoft.com
American Power Conversion ports&apcc.com 2002-02
Anders Hjelm anders.hjelm&ec.se 2006-03
Andrew Crockford andrew.crockford&modus-interactive.co.uk
Andrew H Derbyshire ahd&meetingmaker.plus.kew.com 2004-12
Charles Jacobs cjacobs&numinous.com
Charlie Limoges Charlie.Limoges&gdc4s.com
Daniel Kilsdonk dan&prospeed.net 2006-08
Dave Maxwell d.maxwell&cablelabs.com
David Brandon dade&smoolabs.net 2006-08
Dmitry Krasnonosenkikh Dmitry_Krasnonosenkih&nmss.com
Dr. Michael Erdmann erdmann&ontoprise.de 2004-12
Erica Liu liue&isolation.com
Friedman Wagner-Dobler Friedman.Wagner-Dobler&gdc4s.com 2005-09
Gerard Cannie jcannie&opticaltech.com
Hans U Schmidt schmidth&de.ibm.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Karl Norrman karl.norrman&ericsson.com 2004-12
Kunihiko Morota morota.kunihiko&jp.panasonic.com 2005-08
Li Zhiping CAICT lizhiping&caict.ac.cn 2023-06-29
Mark de Rooi derooi&xs4all.nl 2004-12
Max Fudim fudim&virtue3d.com
Melinda Tsao melinda&tpe1.sercomm.com.tw
Niels Christiansen nchris&austin.ibm.com
Panic Ride panicride&hao.org
Pat Mcgowan pmcgowan&folio.com
Patrick Fisher pfisher&hns.com 2004-12
Petr Chardin petr&mysql.com 2004-12
ProControl Technology AB info&pctworld.com 2004-12
Richard Hodges rh&matriplex.com
Richard Walters walters&cs.ucdavis.edu
Robert Reimiller bob&certsoft.com
Robert Wright, Founder and Principal Engineer Audio Precision Inc. ianaports&ap.com 2006-05
Rod Waltermann walterma&us.lenovo.com 2006-02
Samppa Lahtinen samppa.lahtinen&motivesys.com 2004-06
Sebastien Lambla lambla&bouygtel.com
Shinji Yamanaka syamanaka&jci.co.jp
Steve Benoit benoit&math.colostate.edu 2015-09-07
Terry Eldridge Terry.Eldridge&6pointn.com 2006-08
Thierry Turletti Thierry.Turletti&sophia.inria.fr
Vick Keshishian vickenK&192.219.82.71
Yossi Appleboum yossia&magicom.co.il
Zhang Bo CAICT zhangbo3&caict.ac.cn 2023-06-29