Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| gacp | 190 | udp | Gateway Access Control Protocol | C. Philip Wood | C. Philip Wood | ||||||
| prospero | 191 | tcp | Prospero Directory Service | B. Clifford Neuman | B. Clifford Neuman | ||||||
| prospero | 191 | udp | Prospero Directory Service | B. Clifford Neuman | B. Clifford Neuman | ||||||
| osu-nms | 192 | tcp | OSU Network Monitoring System | Doug Karl | Doug Karl | ||||||
| osu-nms | 192 | udp | OSU Network Monitoring System | Doug Karl | Doug Karl | ||||||
| srmp | 193 | tcp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| srmp | 193 | udp | Spider Remote Monitoring Protocol | Ted J. Socolofsky | Ted J. Socolofsky | ||||||
| irc | 194 | tcp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| irc | 194 | udp | Internet Relay Chat Protocol | Jarkko Oikarinen | Jarkko Oikarinen | ||||||
| dn6-nlm-aud | 195 | tcp | DNSIX Network Level Module Audit | ||||||||
| dn6-nlm-aud | 195 | udp | DNSIX Network Level Module Audit | ||||||||
| dn6-smm-red | 196 | tcp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| dn6-smm-red | 196 | udp | DNSIX Session Mgt Module Audit Redir | Lawrence Lebahn | Lawrence Lebahn | ||||||
| dls | 197 | tcp | Directory Location Service | ||||||||
| dls | 197 | udp | Directory Location Service | ||||||||
| dls-mon | 198 | tcp | Directory Location Service Monitor | Scott Bellew | Scott Bellew | ||||||
| dls-mon | 198 | udp | Directory Location Service Monitor | Scott Bellew | Scott Bellew | ||||||
| smux | 199 | tcp | SMUX | Marshall Rose | Marshall Rose | ||||||
| smux | 199 | udp | SMUX | Marshall Rose | Marshall Rose | ||||||
| src | 200 | tcp | IBM System Resource Controller | Gerald McBrearty | Gerald McBrearty | ||||||
| src | 200 | udp | IBM System Resource Controller | Gerald McBrearty | Gerald McBrearty | ||||||
| at-rtmp | 201 | tcp | AppleTalk Routing Maintenance | ||||||||
| at-rtmp | 201 | udp | AppleTalk Routing Maintenance | ||||||||
| at-nbp | 202 | tcp | AppleTalk Name Binding | ||||||||
| at-nbp | 202 | udp | AppleTalk Name Binding | ||||||||
| at-3 | 203 | tcp | AppleTalk Unused | ||||||||
| at-3 | 203 | udp | AppleTalk Unused | ||||||||
| at-echo | 204 | tcp | AppleTalk Echo | ||||||||
| at-echo | 204 | udp | AppleTalk Echo | ||||||||
| at-5 | 205 | tcp | AppleTalk Unused | ||||||||
| at-5 | 205 | udp | AppleTalk Unused | ||||||||
| at-zis | 206 | tcp | AppleTalk Zone Information | ||||||||
| at-zis | 206 | udp | AppleTalk Zone Information | ||||||||
| at-7 | 207 | tcp | AppleTalk Unused | ||||||||
| at-7 | 207 | udp | AppleTalk Unused | ||||||||
| at-8 | 208 | tcp | AppleTalk Unused | Rob Chandhok | Rob Chandhok | ||||||
| at-8 | 208 | udp | AppleTalk Unused | Rob Chandhok | Rob Chandhok | ||||||
| qmtp | 209 | tcp | The Quick Mail Transfer Protocol | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| qmtp | 209 | udp | The Quick Mail Transfer Protocol | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| z39-50 | 210 | tcp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | tcp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| z39-50 | 210 | udp | ANSI Z39.50 IANA assigned this well-formed service name as a replacement for "z39.50". |
Mark H. Needleman | Mark H. Needleman | ||||||
| z39.50 | 210 | udp | ANSI Z39.50 | Mark H. Needleman | Mark H. Needleman | This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | tcp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
Bill Harrell | Bill Harrell | ||||||
| 914c/g | 211 | tcp | Texas Instruments 914C/G Terminal | Bill Harrell | Bill Harrell | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 914c-g | 211 | udp | Texas Instruments 914C/G Terminal IANA assigned this well-formed service name as a replacement for "914c/g". |
Bill Harrell | Bill Harrell | ||||||
| 914c/g | 211 | udp | Texas Instruments 914C/G Terminal | Bill Harrell | Bill Harrell | This entry is an alias to "914c-g". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| anet | 212 | tcp | ATEXSSTR | Jim Taylor | Jim Taylor | ||||||
| anet | 212 | udp | ATEXSSTR | Jim Taylor | Jim Taylor | ||||||
| ipx | 213 | tcp | IPX | Don Provan | Don Provan | ||||||
| ipx | 213 | udp | IPX | Don Provan | Don Provan | ||||||
| vmpwscs | 214 | tcp | VM PWSCS | Dan Shia | Dan Shia | ||||||
| vmpwscs | 214 | udp | VM PWSCS | Dan Shia | Dan Shia | ||||||
| softpc | 215 | tcp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| softpc | 215 | udp | Insignia Solutions | Martyn Thomas | Martyn Thomas | ||||||
| CAIlic | 216 | tcp | Computer Associates Int'l License Server | Chuck Spitz | Chuck Spitz | ||||||
| CAIlic | 216 | udp | Computer Associates Int'l License Server | Chuck Spitz | Chuck Spitz | ||||||
| dbase | 217 | tcp | dBASE Unix | Don Gibson | Don Gibson | ||||||
| dbase | 217 | udp | dBASE Unix | Don Gibson | Don Gibson | ||||||
| mpp | 218 | tcp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| mpp | 218 | udp | Netix Message Posting Protocol | Shannon Yeh | Shannon Yeh | ||||||
| uarps | 219 | tcp | Unisys ARPs | Ashok Marwaha | Ashok Marwaha | ||||||
| uarps | 219 | udp | Unisys ARPs | Ashok Marwaha | Ashok Marwaha | ||||||
| imap3 | 220 | tcp | Interactive Mail Access Protocol v3 | James Rice | James Rice | ||||||
| imap3 | 220 | udp | Interactive Mail Access Protocol v3 | James Rice | James Rice | ||||||
| fln-spx | 221 | tcp | Berkeley rlogind with SPX auth | ||||||||
| fln-spx | 221 | udp | Berkeley rlogind with SPX auth | ||||||||
| rsh-spx | 222 | tcp | Berkeley rshd with SPX auth | ||||||||
| rsh-spx | 222 | udp | Berkeley rshd with SPX auth | ||||||||
| cdc | 223 | tcp | Certificate Distribution Center | Kannan Alagappan | Kannan Alagappan | ||||||
| cdc | 223 | udp | Certificate Distribution Center | Kannan Alagappan | Kannan Alagappan | ||||||
| masqdialer | 224 | tcp | masqdialer | Charles Wright | Charles Wright | Possible Conflict of Port 222 with "Masqdialer" | |||||
| masqdialer | 224 | udp | masqdialer | Charles Wright | Charles Wright | Possible Conflict of Port 222 with "Masqdialer" | |||||
| 225-241 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| direct | 242 | tcp | Direct | Herb Sutter | Paul Horton | ||||||
| direct | 242 | udp | Direct | Herb Sutter | Paul Horton | ||||||
| sur-meas | 243 | tcp | Survey Measurement | Dave Clark | Dave Clark | ||||||
| sur-meas | 243 | udp | Survey Measurement | Dave Clark | Dave Clark | ||||||
| inbusiness | 244 | tcp | inbusiness | Derrick Hisatake | Derrick Hisatake | ||||||
| inbusiness | 244 | udp | inbusiness | Derrick Hisatake | Derrick Hisatake | ||||||
| link | 245 | tcp | LINK | ||||||||
| link | 245 | udp | LINK | ||||||||
| dsp3270 | 246 | tcp | Display Systems Protocol | Weldon J. Showalter | Weldon J. Showalter | ||||||
| dsp3270 | 246 | udp | Display Systems Protocol | Weldon J. Showalter | Weldon J. Showalter | ||||||
| subntbcst-tftp | 247 | tcp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | tcp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| subntbcst-tftp | 247 | udp | SUBNTBCST_TFTP IANA assigned this well-formed service name as a replacement for "subntbcst_tftp". |
John Fake | John Fake | ||||||
| subntbcst_tftp | 247 | udp | SUBNTBCST_TFTP | John Fake | John Fake | This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bhfhs | 248 | tcp | bhfhs | John Kelly | John Kelly | ||||||
| bhfhs | 248 | udp | bhfhs | John Kelly | John Kelly | ||||||
| 249-255 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| rap | 256 | tcp | RAP | J. S. Greenfield | J. S. Greenfield | ||||||
| rap | 256 | udp | RAP | J. S. Greenfield | J. S. Greenfield | ||||||
| set | 257 | tcp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| set | 257 | udp | Secure Electronic Transaction | Donald Eastlake | Donald Eastlake | ||||||
| 258 | Unassigned | 2006-09-13 | |||||||||
| esro-gen | 259 | tcp | Efficient Short Remote Operations | Mohsen Banan | Mohsen Banan | ||||||
| esro-gen | 259 | udp | Efficient Short Remote Operations | Mohsen Banan | Mohsen Banan | ||||||
| openport | 260 | tcp | Openport | John Marland | John Marland | ||||||
| openport | 260 | udp | Openport | John Marland | John Marland | ||||||
| nsiiops | 261 | tcp | IIOP Name Service over TLS/SSL | Jeff Stewart | Jeff Stewart |