Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dxmessagebase2 | 2875 | tcp | DX Message Base Transport Protocol | G.E. Ozz Nixon Jr. | G.E. Ozz Nixon Jr. | 2009-01-13 | |||||
| dxmessagebase2 | 2875 | udp | DX Message Base Transport Protocol | G.E. Ozz Nixon Jr. | G.E. Ozz Nixon Jr. | 2009-01-13 | |||||
| sps-tunnel | 2876 | tcp | SPS Tunnel | Bill McIntosh | Bill McIntosh | ||||||
| sps-tunnel | 2876 | udp | SPS Tunnel | Bill McIntosh | Bill McIntosh | ||||||
| bluelance | 2877 | tcp | BLUELANCE | Michael Padrezas | Michael Padrezas | ||||||
| bluelance | 2877 | udp | BLUELANCE | Michael Padrezas | Michael Padrezas | ||||||
| aap | 2878 | tcp | AAP | Stephen Hanna | Stephen Hanna | ||||||
| aap | 2878 | udp | AAP | Stephen Hanna | Stephen Hanna | ||||||
| ucentric-ds | 2879 | tcp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| ucentric-ds | 2879 | udp | ucentric-ds | Alex Vasilevsky | Alex Vasilevsky | ||||||
| synapse | 2880 | tcp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| synapse | 2880 | udp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| ndsp | 2881 | tcp | NDSP | ||||||||
| ndsp | 2881 | udp | NDSP | ||||||||
| ndtp | 2882 | tcp | NDTP | ||||||||
| ndtp | 2882 | udp | NDTP | ||||||||
| ndnp | 2883 | tcp | NDNP | Khelben Blackstaff | Khelben Blackstaff | ||||||
| ndnp | 2883 | udp | NDNP | Khelben Blackstaff | Khelben Blackstaff | ||||||
| flashmsg | 2884 | tcp | Flash Msg | Jeffrey Zinkerman | Jeffrey Zinkerman | ||||||
| flashmsg | 2884 | udp | Flash Msg | Jeffrey Zinkerman | Jeffrey Zinkerman | ||||||
| topflow | 2885 | tcp | TopFlow | Ted Ross | Ted Ross | ||||||
| topflow | 2885 | udp | TopFlow | Ted Ross | Ted Ross | ||||||
| responselogic | 2886 | tcp | RESPONSELOGIC | Bruce Casey | Bruce Casey | ||||||
| responselogic | 2886 | udp | RESPONSELOGIC | Bruce Casey | Bruce Casey | ||||||
| aironetddp | 2887 | tcp | aironet | Victor Griswold | Victor Griswold | ||||||
| aironetddp | 2887 | udp | aironet | Victor Griswold | Victor Griswold | ||||||
| spcsdlobby | 2888 | tcp | SPCSDLOBBY | Matthew Williams | Matthew Williams | ||||||
| spcsdlobby | 2888 | udp | SPCSDLOBBY | Matthew Williams | Matthew Williams | ||||||
| rsom | 2889 | tcp | RSOM | Justine Higgins | Justine Higgins | ||||||
| rsom | 2889 | udp | RSOM | Justine Higgins | Justine Higgins | ||||||
| cspclmulti | 2890 | tcp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| cspclmulti | 2890 | udp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| cinegrfx-elmd | 2891 | tcp | CINEGRFX-ELMD License Manager | Greg Ercolano | Greg Ercolano | ||||||
| cinegrfx-elmd | 2891 | udp | CINEGRFX-ELMD License Manager | Greg Ercolano | Greg Ercolano | ||||||
| snifferdata | 2892 | tcp | SNIFFERDATA | Jeff Mangasarian | Jeff Mangasarian | ||||||
| snifferdata | 2892 | udp | SNIFFERDATA | Jeff Mangasarian | Jeff Mangasarian | ||||||
| vseconnector | 2893 | tcp | VSECONNECTOR | Ingo Franzki | Ingo Franzki | ||||||
| vseconnector | 2893 | udp | VSECONNECTOR | Ingo Franzki | Ingo Franzki | ||||||
| abacus-remote | 2894 | tcp | ABACUS-REMOTE | Mike Bello | Mike Bello | ||||||
| abacus-remote | 2894 | udp | ABACUS-REMOTE | Mike Bello | Mike Bello | ||||||
| natuslink | 2895 | tcp | NATUS LINK | Jonathan Mergy | Jonathan Mergy | ||||||
| natuslink | 2895 | udp | NATUS LINK | Jonathan Mergy | Jonathan Mergy | ||||||
| ecovisiong6-1 | 2896 | tcp | ECOVISIONG6-1 | Henrik Holst | Henrik Holst | ||||||
| ecovisiong6-1 | 2896 | udp | ECOVISIONG6-1 | Henrik Holst | Henrik Holst | ||||||
| citrix-rtmp | 2897 | tcp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| citrix-rtmp | 2897 | udp | Citrix RTMP | Myk Willis | Myk Willis | ||||||
| appliance-cfg | 2898 | tcp | APPLIANCE-CFG | Gary A. James | Gary A. James | ||||||
| appliance-cfg | 2898 | udp | APPLIANCE-CFG | Gary A. James | Gary A. James | ||||||
| powergemplus | 2899 | tcp | POWERGEMPLUS | Koich Nakamura | Koich Nakamura | ||||||
| powergemplus | 2899 | udp | POWERGEMPLUS | Koich Nakamura | Koich Nakamura | ||||||
| quicksuite | 2900 | tcp | QUICKSUITE | William Egge | William Egge | ||||||
| quicksuite | 2900 | udp | QUICKSUITE | William Egge | William Egge | ||||||
| allstorcns | 2901 | tcp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| allstorcns | 2901 | udp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| netaspi | 2902 | tcp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| netaspi | 2902 | udp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| suitcase | 2903 | tcp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| suitcase | 2903 | udp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| m2ua | 2904 | tcp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | udp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | sctp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m3ua | 2905 | tcp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| 2905 | udp | De-registered | 2001-06-07 | ||||||||
| m3ua | 2905 | sctp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| caller9 | 2906 | tcp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| caller9 | 2906 | udp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| webmethods-b2b | 2907 | tcp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| webmethods-b2b | 2907 | udp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| mao | 2908 | tcp | mao | Marc Baudoin | Marc Baudoin | ||||||
| mao | 2908 | udp | mao | Marc Baudoin | Marc Baudoin | ||||||
| funk-dialout | 2909 | tcp | Funk Dialout | Cimarron Boozer | Cimarron Boozer | ||||||
| funk-dialout | 2909 | udp | Funk Dialout | Cimarron Boozer | Cimarron Boozer | ||||||
| tdaccess | 2910 | tcp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| tdaccess | 2910 | udp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| blockade | 2911 | tcp | Blockade | VP - Research & Development | VP - Research & Development | ||||||
| blockade | 2911 | udp | Blockade | VP - Research & Development | VP - Research & Development | ||||||
| epicon | 2912 | tcp | Epicon | Michael Khalandovsky | Michael Khalandovsky | ||||||
| epicon | 2912 | udp | Epicon | Michael Khalandovsky | Michael Khalandovsky | ||||||
| boosterware | 2913 | tcp | Booster Ware | Ido Ben-David | Ido Ben-David | ||||||
| boosterware | 2913 | udp | Booster Ware | Ido Ben-David | Ido Ben-David | ||||||
| gamelobby | 2914 | tcp | Game Lobby | Paul Ford-Hutchinson | Paul Ford-Hutchinson | ||||||
| gamelobby | 2914 | udp | Game Lobby | Paul Ford-Hutchinson | Paul Ford-Hutchinson | ||||||
| tksocket | 2915 | tcp | TK Socket | Dino Ciano | Dino Ciano | 2011-03-02 | |||||
| tksocket | 2915 | udp | TK Socket | Dino Ciano | Dino Ciano | 2011-03-02 | |||||
| elvin-server | 2916 | tcp | Elvin Server IANA assigned this well-formed service name as a replacement for "elvin_server". |
||||||||
| elvin_server | 2916 | tcp | Elvin Server | This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| elvin-server | 2916 | udp | Elvin Server IANA assigned this well-formed service name as a replacement for "elvin_server". |
||||||||
| elvin_server | 2916 | udp | Elvin Server | This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||||
| elvin-client | 2917 | tcp | Elvin Client IANA assigned this well-formed service name as a replacement for "elvin_client". |
David Arnold | David Arnold | ||||||
| elvin_client | 2917 | tcp | Elvin Client | David Arnold | David Arnold | This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| elvin-client | 2917 | udp | Elvin Client IANA assigned this well-formed service name as a replacement for "elvin_client". |
David Arnold | David Arnold | ||||||
| elvin_client | 2917 | udp | Elvin Client | David Arnold | David Arnold | This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| kastenchasepad | 2918 | tcp | Kasten Chase Pad | Marc Gauthier | Marc Gauthier | ||||||
| kastenchasepad | 2918 | udp | Kasten Chase Pad | Marc Gauthier | Marc Gauthier | ||||||
| roboer | 2919 | tcp | roboER | Paul Snook | Paul Snook | ||||||
| roboer | 2919 | udp | roboER | Paul Snook | Paul Snook | ||||||
| roboeda | 2920 | tcp | roboEDA | Paul Snook | Paul Snook | ||||||
| roboeda | 2920 | udp | roboEDA | Paul Snook | Paul Snook | ||||||
| cesdcdman | 2921 | tcp | CESD Contents Delivery Management | Shinya Abe | Shinya Abe | ||||||
| cesdcdman | 2921 | udp | CESD Contents Delivery Management | Shinya Abe | Shinya Abe | ||||||
| cesdcdtrn | 2922 | tcp | CESD Contents Delivery Data Transfer | Shinya Abe | Shinya Abe |