Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| nsiiops | 261 | tcp | IIOP Name Service over TLS/SSL | Jeff Stewart | Jeff Stewart | ||||||
| nsiiops | 261 | udp | IIOP Name Service over TLS/SSL | Jeff Stewart | Jeff Stewart | ||||||
| arcisdms | 262 | tcp | Arcisdms | Russell Crook | Russell Crook | ||||||
| arcisdms | 262 | udp | Arcisdms | Russell Crook | Russell Crook | ||||||
| hdap | 263 | tcp | HDAP | Troy Gau | Troy Gau | ||||||
| hdap | 263 | udp | HDAP | Troy Gau | Troy Gau | ||||||
| bgmp | 264 | tcp | BGMP | Dave Thaler | Dave Thaler | ||||||
| bgmp | 264 | udp | BGMP | Dave Thaler | Dave Thaler | ||||||
| x-bone-ctl | 265 | tcp | X-Bone CTL | Joe Touch | Joe Touch | ||||||
| x-bone-ctl | 265 | udp | X-Bone CTL | Joe Touch | Joe Touch | ||||||
| sst | 266 | tcp | SCSI on ST | Donald D. Woelz | Donald D. Woelz | ||||||
| sst | 266 | udp | SCSI on ST | Donald D. Woelz | Donald D. Woelz | ||||||
| td-service | 267 | tcp | Tobit David Service Layer | ||||||||
| td-service | 267 | udp | Tobit David Service Layer | ||||||||
| td-replica | 268 | tcp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-replica | 268 | udp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| manet | 269 | tcp | MANET Protocols | RFC 5498 | |||||||
| manet | 269 | udp | MANET Protocols | RFC 5498 | |||||||
| 270 | tcp | Reserved | |||||||||
| gist | 270 | udp | Q-mode encapsulation for GIST messages | RFC 5971 | |||||||
| pt-tls | 271 | tcp | IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) | IESG | IETF Chair | 2012-07-31 | RFC 6876 | ||||
| 271 | udp | Reserved | |||||||||
| 272-279 | Unassigned | ||||||||||
| http-mgmt | 280 | tcp | http-mgmt | Adrian Pell | Adrian Pell | ||||||
| http-mgmt | 280 | udp | http-mgmt | Adrian Pell | Adrian Pell | ||||||
| personal-link | 281 | tcp | Personal Link | Dan Cummings | Dan Cummings | ||||||
| personal-link | 281 | udp | Personal Link | Dan Cummings | Dan Cummings | ||||||
| cableport-ax | 282 | tcp | Cable Port A/X | Craig Langfahl | Craig Langfahl | ||||||
| cableport-ax | 282 | udp | Cable Port A/X | Craig Langfahl | Craig Langfahl | ||||||
| rescap | 283 | tcp | rescap | Paul Hoffman | Paul Hoffman | ||||||
| rescap | 283 | udp | rescap | Paul Hoffman | Paul Hoffman | ||||||
| corerjd | 284 | tcp | corerjd | Chris Thornhill | Chris Thornhill | ||||||
| corerjd | 284 | udp | corerjd | Chris Thornhill | Chris Thornhill | ||||||
| 285 | Unassigned | ||||||||||
| fxp | 286 | tcp | FXP Communication | James Darnall | James Darnall | ||||||
| fxp | 286 | udp | FXP Communication | James Darnall | James Darnall | ||||||
| k-block | 287 | tcp | K-BLOCK | Simon P Jackson | Simon P Jackson | ||||||
| k-block | 287 | udp | K-BLOCK | Simon P Jackson | Simon P Jackson | ||||||
| 288-299 | Unassigned | ||||||||||
| tacacss | 300 | tcp | TLS Secure Login Host Protocol (TACACSS) | IESG | IETF Chair | 2025-07-15 | RFC 9887 | ||||
| 300 | udp | Reserved | |||||||||
| 301-307 | Unassigned | ||||||||||
| novastorbakcup | 308 | tcp | Novastor Backup | Brian Dickman | Brian Dickman | ||||||
| novastorbakcup | 308 | udp | Novastor Backup | Brian Dickman | Brian Dickman | ||||||
| entrusttime | 309 | tcp | EntrustTime | Peter Whittaker | Peter Whittaker | ||||||
| entrusttime | 309 | udp | EntrustTime | Peter Whittaker | Peter Whittaker | ||||||
| bhmds | 310 | tcp | bhmds | John Kelly | John Kelly | ||||||
| bhmds | 310 | udp | bhmds | John Kelly | John Kelly | ||||||
| asip-webadmin | 311 | tcp | AppleShare IP WebAdmin | Ann Huang | Ann Huang | ||||||
| asip-webadmin | 311 | udp | AppleShare IP WebAdmin | Ann Huang | Ann Huang | ||||||
| vslmp | 312 | tcp | VSLMP | Gerben Wierda | Gerben Wierda | ||||||
| vslmp | 312 | udp | VSLMP | Gerben Wierda | Gerben Wierda | ||||||
| magenta-logic | 313 | tcp | Magenta Logic | Karl Rousseau | Karl Rousseau | ||||||
| magenta-logic | 313 | udp | Magenta Logic | Karl Rousseau | Karl Rousseau | ||||||
| opalis-robot | 314 | tcp | Opalis Robot | Laurent Domenech | Laurent Domenech | ||||||
| opalis-robot | 314 | udp | Opalis Robot | Laurent Domenech | Laurent Domenech | ||||||
| dpsi | 315 | tcp | DPSI | Tony Scamurra | Tony Scamurra | ||||||
| dpsi | 315 | udp | DPSI | Tony Scamurra | Tony Scamurra | ||||||
| decauth | 316 | tcp | decAuth | Michael Agishtein | Michael Agishtein | ||||||
| decauth | 316 | udp | decAuth | Michael Agishtein | Michael Agishtein | ||||||
| zannet | 317 | tcp | Zannet | Zan Oliphant | Zan Oliphant | ||||||
| zannet | 317 | udp | Zannet | Zan Oliphant | Zan Oliphant | ||||||
| pkix-timestamp | 318 | tcp | PKIX TimeStamp | Robert Zuccherato | Robert Zuccherato | ||||||
| pkix-timestamp | 318 | udp | PKIX TimeStamp | Robert Zuccherato | Robert Zuccherato | ||||||
| ptp-event | 319 | tcp | PTP Event | Kang Lee | Kang Lee | 2010-07-27 | |||||
| ptp-event | 319 | udp | PTP Event | Kang Lee | Kang Lee | 2010-07-27 | |||||
| ptp-general | 320 | tcp | PTP General | Kang Lee | Kang Lee | 2010-07-27 | |||||
| ptp-general | 320 | udp | PTP General | Kang Lee | Kang Lee | 2010-07-27 | |||||
| pip | 321 | tcp | PIP | Gordon Mohr | Gordon Mohr | ||||||
| pip | 321 | udp | PIP | Gordon Mohr | Gordon Mohr | ||||||
| rtsps | 322 | tcp | RTSPS | Anders Klemets | Anders Klemets | ||||||
| rtsps | 322 | udp | RTSPS | Anders Klemets | Anders Klemets | ||||||
| rpki-rtr | 323 | tcp | Resource PKI to Router Protocol | IESG | IETF Chair | RFC 6810 | |||||
| 323 | udp | Reserved | |||||||||
| rpki-rtr-tls | 324 | tcp | Resource PKI to Router Protocol over TLS | IESG | IETF Chair | RFC 6810 | |||||
| 324 | udp | Reserved | |||||||||
| 325-332 | Unassigned | ||||||||||
| texar | 333 | tcp | Texar Security Port | Eugen Bacic | Eugen Bacic | ||||||
| texar | 333 | udp | Texar Security Port | Eugen Bacic | Eugen Bacic | ||||||
| 334-343 | Unassigned | ||||||||||
| pdap | 344 | tcp | Prospero Data Access Protocol | B. Clifford Neuman | B. Clifford Neuman | ||||||
| pdap | 344 | udp | Prospero Data Access Protocol | B. Clifford Neuman | B. Clifford Neuman | ||||||
| pawserv | 345 | tcp | Perf Analysis Workbench | ||||||||
| pawserv | 345 | udp | Perf Analysis Workbench | ||||||||
| zserv | 346 | tcp | Zebra server | ||||||||
| zserv | 346 | udp | Zebra server | ||||||||
| fatserv | 347 | tcp | Fatmen Server | ||||||||
| fatserv | 347 | udp | Fatmen Server | ||||||||
| csi-sgwp | 348 | tcp | Cabletron Management Protocol | ||||||||
| csi-sgwp | 348 | udp | Cabletron Management Protocol | ||||||||
| mftp | 349 | tcp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| mftp | 349 | udp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| matip-type-a | 350 | tcp | MATIP Type A | Alain Robert | Alain Robert | RFC 2351 | |||||
| matip-type-a | 350 | udp | MATIP Type A | Alain Robert | Alain Robert | RFC 2351 | |||||
| matip-type-b | 351 | tcp | MATIP Type B | Alain Robert | Alain Robert | RFC 2351 | |||||
| matip-type-b | 351 | udp | MATIP Type B | Alain Robert | Alain Robert | RFC 2351 | |||||
| bhoetty | 351 | tcp | bhoetty | John Kelly | John Kelly | This entry records an unassigned but widespread use (added 5/21/97) | |||||
| bhoetty | 351 | udp | bhoetty | John Kelly | John Kelly | This entry records an unassigned but widespread use (added 5/21/97) | |||||
| dtag-ste-sb | 352 | tcp | DTAG | Ruediger Wald | Ruediger Wald | (assigned long ago) | |||||
| dtag-ste-sb | 352 | udp | DTAG | Ruediger Wald | Ruediger Wald | (assigned long ago) | |||||
| bhoedap4 | 352 | tcp | bhoedap4 | John Kelly | John Kelly | This entry records an unassigned but widespread use (added 5/21/97) |