Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| netwkpathengine | 3209 | tcp | HP OpenView Network Path Engine Server | Anthony Walker | Anthony Walker | ||||||
| netwkpathengine | 3209 | udp | HP OpenView Network Path Engine Server | Anthony Walker | Anthony Walker | ||||||
| flamenco-proxy | 3210 | tcp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| flamenco-proxy | 3210 | udp | Flamenco Networks Proxy | Corey Corrick | Corey Corrick | ||||||
| avsecuremgmt | 3211 | tcp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| avsecuremgmt | 3211 | udp | Avocent Secure Management | Brian S. Stewart | Brian S. Stewart | ||||||
| surveyinst | 3212 | tcp | Survey Instrument | Al Amet | Al Amet | ||||||
| surveyinst | 3212 | udp | Survey Instrument | Al Amet | Al Amet | ||||||
| neon24x7 | 3213 | tcp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| neon24x7 | 3213 | udp | NEON 24X7 Mission Control | Tony Lubrano | Tony Lubrano | ||||||
| jmq-daemon-1 | 3214 | tcp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-1 | 3214 | udp | JMQ Daemon Port 1 | ||||||||
| jmq-daemon-2 | 3215 | tcp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| jmq-daemon-2 | 3215 | udp | JMQ Daemon Port 2 | Martin West | Martin West | ||||||
| ferrari-foam | 3216 | tcp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| ferrari-foam | 3216 | udp | Ferrari electronic FOAM | Johann Deutinger | Johann Deutinger | ||||||
| unite | 3217 | tcp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| unite | 3217 | udp | Unified IP & Telecom Environment | Christer Gunnarsson | Christer Gunnarsson | 2009-03-26 | |||||
| smartpackets | 3218 | tcp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| smartpackets | 3218 | udp | EMC SmartPackets | Steve Spataro | Steve Spataro | ||||||
| wms-messenger | 3219 | tcp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| wms-messenger | 3219 | udp | WMS Messenger | WM Software Inc. | WM Software Inc. | 2022-07-18 | |||||
| xnm-ssl | 3220 | tcp | XML NM over SSL | ||||||||
| xnm-ssl | 3220 | udp | XML NM over SSL | ||||||||
| xnm-clear-text | 3221 | tcp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| xnm-clear-text | 3221 | udp | XML NM over TCP | Mark Trostler | Mark Trostler | ||||||
| glbp | 3222 | tcp | Gateway Load Balancing Pr | Douglas McLaggan | Douglas McLaggan | ||||||
| glbp | 3222 | udp | Gateway Load Balancing Pr | Douglas McLaggan | Douglas McLaggan | ||||||
| digivote | 3223 | tcp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| digivote | 3223 | udp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| aes-discovery | 3224 | tcp | AES Discovery Port | Ken Richard | Ken Richard | ||||||
| aes-discovery | 3224 | udp | AES Discovery Port | Ken Richard | Ken Richard | ||||||
| fcip-port | 3225 | tcp | FCIP | RFC 3821 | |||||||
| fcip-port | 3225 | udp | FCIP | RFC 3821 | |||||||
| isi-irp | 3226 | tcp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| isi-irp | 3226 | udp | ISI Industry Software IRP | Peter Sandstrom | Peter Sandstrom | ||||||
| dwnmshttp | 3227 | tcp | DiamondWave NMS Server | ||||||||
| dwnmshttp | 3227 | udp | DiamondWave NMS Server | ||||||||
| dwmsgserver | 3228 | tcp | DiamondWave MSG Server | Varma Bhupatiraju | Varma Bhupatiraju | ||||||
| dwmsgserver | 3228 | udp | DiamondWave MSG Server | Varma Bhupatiraju | Varma Bhupatiraju | ||||||
| global-cd-port | 3229 | tcp | Global CD Port | Vitaly Revsin | Vitaly Revsin | ||||||
| global-cd-port | 3229 | udp | Global CD Port | Vitaly Revsin | Vitaly Revsin | ||||||
| sftdst-port | 3230 | tcp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| sftdst-port | 3230 | udp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| vidigo | 3231 | tcp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| vidigo | 3231 | udp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| whisker | 3233 | tcp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| whisker | 3233 | udp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| alchemy | 3234 | tcp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| alchemy | 3234 | udp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| mdap-port | 3235 | tcp | MDAP port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| mdap-port | 3235 | udp | MDAP Port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| apparenet-ts | 3236 | tcp | appareNet Test Server | ||||||||
| apparenet-ts | 3236 | udp | appareNet Test Server | ||||||||
| apparenet-tps | 3237 | tcp | appareNet Test Packet Sequencer | ||||||||
| apparenet-tps | 3237 | udp | appareNet Test Packet Sequencer | ||||||||
| apparenet-as | 3238 | tcp | appareNet Analysis Server | ||||||||
| apparenet-as | 3238 | udp | appareNet Analysis Server | ||||||||
| apparenet-ui | 3239 | tcp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| apparenet-ui | 3239 | udp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| triomotion | 3240 | tcp | Trio Motion Control Port | Tony Matthews | Tony Matthews | 2002-02 | |||||
| triomotion | 3240 | udp | Trio Motion Control Port | Tony Matthews | Tony Matthews | 2002-02 | |||||
| sysorb | 3241 | tcp | SysOrb Monitoring Server | Jakob Oestergaard | Jakob Oestergaard | 2002-02 | |||||
| sysorb | 3241 | udp | SysOrb Monitoring Server | Jakob Oestergaard | Jakob Oestergaard | 2002-02 | |||||
| sdp-id-port | 3242 | tcp | Session Description ID | Greg Rose | Greg Rose | 2002-02 | |||||
| sdp-id-port | 3242 | udp | Session Description ID | Greg Rose | Greg Rose | 2002-02 | |||||
| timelot | 3243 | tcp | Timelot Port | David Ferguson | David Ferguson | 2002-02 | |||||
| timelot | 3243 | udp | Timelot Port | David Ferguson | David Ferguson | 2002-02 | |||||
| onesaf | 3244 | tcp | OneSAF | Gene McCulley | Gene McCulley | 2002-02 | |||||
| onesaf | 3244 | udp | OneSAF | Gene McCulley | Gene McCulley | 2002-02 | |||||
| vieo-fe | 3245 | tcp | VIEO Fabric Executive | James Cox | James Cox | 2002-02 | |||||
| vieo-fe | 3245 | udp | VIEO Fabric Executive | James Cox | James Cox | 2002-02 | |||||
| dvt-system | 3246 | tcp | DVT SYSTEM PORT | ||||||||
| dvt-system | 3246 | udp | DVT SYSTEM PORT | ||||||||
| dvt-data | 3247 | tcp | DVT DATA LINK | Phillip Heil | Phillip Heil | 2002-02 | |||||
| dvt-data | 3247 | udp | DVT DATA LINK | Phillip Heil | Phillip Heil | 2002-02 | |||||
| procos-lm | 3248 | tcp | PROCOS LM | Torsten Rendelmann | Torsten Rendelmann | ||||||
| procos-lm | 3248 | udp | PROCOS LM | Torsten Rendelmann | Torsten Rendelmann | ||||||
| ssp | 3249 | tcp | State Sync Protocol | Stephane Beaulieu | Stephane Beaulieu | 2002-02 | |||||
| ssp | 3249 | udp | State Sync Protocol | Stephane Beaulieu | Stephane Beaulieu | 2002-02 | |||||
| hicp | 3250 | tcp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| hicp | 3250 | udp | HMS hicp port | Joel Palsson | Joel Palsson | 2002-02 | |||||
| sysscanner | 3251 | tcp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| sysscanner | 3251 | udp | Sys Scanner | Dick Georges | Dick Georges | 2002-02 | |||||
| dhe | 3252 | tcp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| dhe | 3252 | udp | DHE port | Fabrizio Massimo Ferrara | Fabrizio Massimo Ferrara | 2002-02 | |||||
| pda-data | 3253 | tcp | PDA Data | ||||||||
| pda-data | 3253 | udp | PDA Data | ||||||||
| pda-sys | 3254 | tcp | PDA System | Jian Fan | Jian Fan | 2002-02 | |||||
| pda-sys | 3254 | udp | PDA System | Jian Fan | Jian Fan | 2002-02 | |||||
| semaphore | 3255 | tcp | Semaphore Connection Port | Jay Eckles | Jay Eckles | 2002-02 | |||||
| semaphore | 3255 | udp | Semaphore Connection Port | Jay Eckles | Jay Eckles | 2002-02 | |||||
| cpqrpm-agent | 3256 | tcp | Compaq RPM Agent Port | ||||||||
| cpqrpm-agent | 3256 | udp | Compaq RPM Agent Port | ||||||||
| cpqrpm-server | 3257 | tcp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| cpqrpm-server | 3257 | udp | Compaq RPM Server Port | Royal King | Royal King | 2002-02 | |||||
| ivecon-port | 3258 | tcp | Ivecon Server Port | Serguei Tevs | Serguei Tevs | 2002-02 | |||||
| ivecon-port | 3258 | udp | Ivecon Server Port | Serguei Tevs | Serguei Tevs | 2002-02 | |||||
| epncdp2 | 3259 | tcp | Epson Network Common Devi | Oishi Toshiaki | Oishi Toshiaki | 2002-02 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Al Amet | aamet&point-inc.com | ||
| Andrea Lanza | andrea&andrealanza.eu | 2014-02-21 | |
| Anthony Walker | anthony_walker&hp.com | 2002-03 | |
| Brian S. Stewart | Brian.Stewart&avocent.com | ||
| Christer Gunnarsson | christer.gunnarsson&ascom.com | 2020-09-30 | |
| Christian Treczoks | ct&braehler.com | ||
| Corey Corrick | corey.corrick&flamenconetworks.com | ||
| David Ferguson | dferguson&xtralot.com | 2002-02 | |
| Dick Georges | georges&monaco.net | 2002-02 | |
| Douglas McLaggan | glbp-info&cisco.com | ||
| Fabrizio Massimo Ferrara | fmf&gesi.it | 2002-02 | |
| Fred Klassen | fklassen&jaalam.com | 2002-02 | |
| Gene McCulley | mcculley&cuspy.com | 2002-02 | |
| Greg Rose | ggr&qualcomm.com | 2002-02 | |
| Jakob Oestergaard | joe&sysorb.com | 2002-02 | |
| James Cox | jocox&view.com | 2002-02 | |
| Jay Eckles | ecklesweb&yahoo.com | 2002-02 | |
| Jian Fan | fjian&dmfsys.com | 2002-02 | |
| Joel Palsson | HMS Industrial Networks AB | ianacontact&hms.se | 2002-02 |
| Johan Deleu | johan.deleu&alcatel.be | 2002-02 | |
| Johann Deutinger | deutinger&ferrari-electronic.de | ||
| Ken Richard | kenr&aeseducation.com | ||
| Mark Trostler | trostler&juniper.net | ||
| Martin West | Martin.West&spirit-soft.com | ||
| Mikhail Belov | mikhail&imrgold.com | 2002-02 | |
| Oishi Toshiaki | SEIKO EPSON Corporation | Oishi.Toshiaki&exc.epson.co.jp | 2002-02 |
| Peter Ijkhout | peter&deltasolutions.nl | ||
| Peter Sandstrom | peter.sandstrom&tassen.fi | ||
| Phillip Heil | phil.heil&dvtsensors.com | 2002-02 | |
| Royal King | royal.king&compaq.com | 2002-02 | |
| Rudolf Cardinal | rudolf&pobox.com | 2002-02 | |
| Serguei Tevs | STevs&ivecon.com | 2002-02 | |
| Stephane Beaulieu | stephane&cisco.com | 2002-02 | |
| Steve Spataro | spataro_steve&emc.com | ||
| Tony Lubrano | tlubrano&neonsys.com | ||
| Tony Matthews | tmatthews&triomotion.com | 2002-02 | |
| Torsten Rendelmann | torsten.rendelmann&procos.com | ||
| Varma Bhupatiraju | varma&calient.net | ||
| Vitaly Revsin | vitaly&netapp.com | ||
| WM Software Inc. | support&wmsoftware.com | 2022-07-18 |