Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| must-backplane | 3515 | tcp | MUST Backplane | Rick Stefanik | Rick Stefanik | 2002-05 | |||||
| must-backplane | 3515 | udp | MUST Backplane | Rick Stefanik | Rick Stefanik | 2002-05 | |||||
| smartcard-port | 3516 | tcp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| smartcard-port | 3516 | udp | Smartcard Port | Scott Guthery | Scott Guthery | 2002-05 | |||||
| 802-11-iapp | 3517 | tcp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| 802-11-iapp | 3517 | udp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| artifact-msg | 3518 | tcp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| artifact-msg | 3518 | udp | Artifact Message Server | Ron Capwell | Ron Capwell | 2002-06 | |||||
| nvmsgd | 3519 | tcp | Netvion Messenger Port | ||||||||
| galileo | 3519 | udp | Netvion Galileo Port | ||||||||
| galileolog | 3520 | tcp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| galileolog | 3520 | udp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| mc3ss | 3521 | tcp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| mc3ss | 3521 | udp | Telequip Labs MC3SS | Michael Sparks | Michael Sparks | 2002-06 | |||||
| nssocketport | 3522 | tcp | DO over NSSocketPort | Douglas Davidson | Douglas Davidson | 2002-06 | |||||
| nssocketport | 3522 | udp | DO over NSSocketPort | Douglas Davidson | Douglas Davidson | 2002-06 | |||||
| odeumservlink | 3523 | tcp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| odeumservlink | 3523 | udp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| ecmport | 3524 | tcp | ECM Server port | ||||||||
| ecmport | 3524 | udp | ECM Server port | ||||||||
| eisport | 3525 | tcp | EIS Server port | Paul Kraus | Paul Kraus | 2002-06 | |||||
| eisport | 3525 | udp | EIS Server port | Paul Kraus | Paul Kraus | 2002-06 | |||||
| starquiz-port | 3526 | tcp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| starquiz-port | 3526 | udp | starQuiz Port | Adam Ernst | Adam Ernst | 2002-06 | |||||
| beserver-msg-q | 3527 | tcp | VERITAS Backup Exec Server | Katherine Wattwood | Katherine Wattwood | 2002-06 | |||||
| beserver-msg-q | 3527 | udp | VERITAS Backup Exec Server | Katherine Wattwood | Katherine Wattwood | 2002-06 | |||||
| jboss-iiop | 3528 | tcp | JBoss IIOP | ||||||||
| jboss-iiop | 3528 | udp | JBoss IIOP | ||||||||
| jboss-iiop-ssl | 3529 | tcp | JBoss IIOP/SSL | Francisco Reverbel | Francisco Reverbel | 2002-06 | |||||
| jboss-iiop-ssl | 3529 | udp | JBoss IIOP/SSL | Francisco Reverbel | Francisco Reverbel | 2002-06 | |||||
| gf | 3530 | tcp | Grid Friendly | Daivd P. Chassin | Daivd P. Chassin | 2002-06 | |||||
| gf | 3530 | udp | Grid Friendly | Daivd P. Chassin | Daivd P. Chassin | 2002-06 | |||||
| joltid | 3531 | tcp | Joltid | Ahti Heinla | Ahti Heinla | 2002-06 | |||||
| joltid | 3531 | udp | Joltid | Ahti Heinla | Ahti Heinla | 2002-06 | |||||
| raven-rmp | 3532 | tcp | Raven Remote Management Control | ||||||||
| raven-rmp | 3532 | udp | Raven Remote Management Control | ||||||||
| raven-rdp | 3533 | tcp | Raven Remote Management Data | Daniel Sorlov | Daniel Sorlov | 2002-06 | |||||
| raven-rdp | 3533 | udp | Raven Remote Management Data | Daniel Sorlov | Daniel Sorlov | 2002-06 | |||||
| urld-port | 3534 | tcp | URL Daemon Port | Jim Binkley | Jim Binkley | 2002-06 | |||||
| urld-port | 3534 | udp | URL Daemon Port | Jim Binkley | Jim Binkley | 2002-06 | |||||
| ms-la | 3535 | tcp | MS-LA | Eric Ledoux | Eric Ledoux | ||||||
| ms-la | 3535 | udp | MS-LA | Eric Ledoux | Eric Ledoux | ||||||
| snac | 3536 | tcp | SNAC | Tatsuya Igarashi | Tatsuya Igarashi | 2002-07 | |||||
| snac | 3536 | udp | SNAC | Tatsuya Igarashi | Tatsuya Igarashi | 2002-07 | |||||
| ni-visa-remote | 3537 | tcp | Remote NI-VISA port | Sinnadurai Dharshan | Sinnadurai Dharshan | 2002-07 | |||||
| ni-visa-remote | 3537 | udp | Remote NI-VISA port | Sinnadurai Dharshan | Sinnadurai Dharshan | 2002-07 | |||||
| ibm-diradm | 3538 | tcp | IBM Directory Server | ||||||||
| ibm-diradm | 3538 | udp | IBM Directory Server | ||||||||
| ibm-diradm-ssl | 3539 | tcp | IBM Directory Server SSL | Mark Cavage | Mark Cavage | 2002-07 | |||||
| ibm-diradm-ssl | 3539 | udp | IBM Directory Server SSL | Mark Cavage | Mark Cavage | 2002-07 | |||||
| pnrp-port | 3540 | tcp | PNRP User Port | Igor Kostic | Igor Kostic | 2002-07 | |||||
| pnrp-port | 3540 | udp | PNRP User Port | Igor Kostic | Igor Kostic | 2002-07 | |||||
| voispeed-port | 3541 | tcp | VoiSpeed Port | Virgilio Lattanzi | Virgilio Lattanzi | 2002-07 | |||||
| voispeed-port | 3541 | udp | VoiSpeed Port | Virgilio Lattanzi | Virgilio Lattanzi | 2002-07 | |||||
| hacl-monitor | 3542 | tcp | HA cluster monitor | Jason Ko | Jason Ko | 2002-07 | |||||
| hacl-monitor | 3542 | udp | HA cluster monitor | Jason Ko | Jason Ko | 2002-07 | |||||
| qftest-lookup | 3543 | tcp | qftest Lookup Port | Gregor Schmid | Gregor Schmid | 2002-07 | |||||
| qftest-lookup | 3543 | udp | qftest Lookup Port | Gregor Schmid | Gregor Schmid | 2002-07 | |||||
| teredo | 3544 | tcp | Teredo Port | RFC 4380 | |||||||
| teredo | 3544 | udp | Teredo Port | RFC 4380 | |||||||
| camac | 3545 | tcp | CAMAC equipment | Eugene Zhiganov | Eugene Zhiganov | 2002-07 | |||||
| camac | 3545 | udp | CAMAC equipment | Eugene Zhiganov | Eugene Zhiganov | 2002-07 | |||||
| 3546 | Unassigned | 2002-09 | |||||||||
| symantec-sim | 3547 | tcp | Symantec SIM | George Dzieciol | George Dzieciol | 2002-07 | |||||
| symantec-sim | 3547 | udp | Symantec SIM | George Dzieciol | George Dzieciol | 2002-07 | |||||
| interworld | 3548 | tcp | Interworld | John Stephen | John Stephen | 2002-07 | |||||
| interworld | 3548 | udp | Interworld | John Stephen | John Stephen | 2002-07 | |||||
| tellumat-nms | 3549 | tcp | Tellumat MDR NMS | Hennie van der Merwe | Hennie van der Merwe | 2002-07 | |||||
| tellumat-nms | 3549 | udp | Tellumat MDR NMS | Hennie van der Merwe | Hennie van der Merwe | 2002-07 | |||||
| ssmpp | 3550 | tcp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| ssmpp | 3550 | udp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| apcupsd | 3551 | tcp | Apcupsd Information Port | Riccardo Facchetti | Riccardo Facchetti | 2002-07 | |||||
| apcupsd | 3551 | udp | Apcupsd Information Port | Riccardo Facchetti | Riccardo Facchetti | 2002-07 | |||||
| taserver | 3552 | tcp | TeamAgenda Server Port | Dany Ayotte | Dany Ayotte | 2002-07 | |||||
| taserver | 3552 | udp | TeamAgenda Server Port | Dany Ayotte | Dany Ayotte | 2002-07 | |||||
| rbr-discovery | 3553 | tcp | Red Box Recorder ADP | Simon Jolly | Simon Jolly | 2002-07 | |||||
| rbr-discovery | 3553 | udp | Red Box Recorder ADP | Simon Jolly | Simon Jolly | 2002-07 | |||||
| questnotify | 3554 | tcp | Quest Notification Server | Rob Griffin | Rob Griffin | 2002-07 | |||||
| questnotify | 3554 | udp | Quest Notification Server | Rob Griffin | Rob Griffin | 2002-07 | |||||
| razor | 3555 | tcp | Vipul's Razor | Vipul Ved Prakash | Vipul Ved Prakash | 2002-07 | |||||
| razor | 3555 | udp | Vipul's Razor | Vipul Ved Prakash | Vipul Ved Prakash | 2002-07 | |||||
| sky-transport | 3556 | tcp | Sky Transport Protocol | Michael Paddon | Michael Paddon | 2002-07 | |||||
| sky-transport | 3556 | udp | Sky Transport Protocol | Michael Paddon | Michael Paddon | 2002-07 | |||||
| personalos-001 | 3557 | tcp | PersonalOS Comm Port | Shane Roberts | Shane Roberts | 2002-07 | |||||
| personalos-001 | 3557 | udp | PersonalOS Comm Port | Shane Roberts | Shane Roberts | 2002-07 | |||||
| mcp-port | 3558 | tcp | MCP user port | Professor Paul S. Wang | Professor Paul S. Wang | 2002-07 | |||||
| mcp-port | 3558 | udp | MCP user port | Professor Paul S. Wang | Professor Paul S. Wang | 2002-07 | |||||
| cctv-port | 3559 | tcp | CCTV control port | John Skidmore | John Skidmore | 2002-07 | |||||
| cctv-port | 3559 | udp | CCTV control port | John Skidmore | John Skidmore | 2002-07 | |||||
| iniserve-port | 3560 | tcp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| iniserve-port | 3560 | udp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| bmc-onekey | 3561 | tcp | BMC-OneKey | Portnoy Boxman | Portnoy Boxman | 2002-08 | |||||
| bmc-onekey | 3561 | udp | BMC-OneKey | Portnoy Boxman | Portnoy Boxman | 2002-08 | |||||
| sdbproxy | 3562 | tcp | SDBProxy | Eric Grange | Eric Grange | 2002-08 | |||||
| sdbproxy | 3562 | udp | SDBProxy | Eric Grange | Eric Grange | 2002-08 | |||||
| watcomdebug | 3563 | tcp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| watcomdebug | 3563 | udp | Watcom Debug | Dave Neudoerffer | Dave Neudoerffer | ||||||
| esimport | 3564 | tcp | Electromed SIM port | Francois Marchand | Francois Marchand | 2002-08 | |||||
| esimport | 3564 | udp | Electromed SIM port | Francois Marchand | Francois Marchand | 2002-08 | |||||
| m2pa | 3565 | tcp | M2PA | RFC 4165 | |||||||
| 3565 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Ernst | contact&cosmicsoft.net | 2002-06 | |
| Ahti Heinla | ahti&ahti.bluemoon.ee | 2002-06 | |
| Cormac Long | webmaster&smsforum.net | 2002-07 | |
| Daivd P. Chassin | david.chassin&pnl.gov | 2002-06 | |
| Daniel Sorlov | daniel&sorlov.com | 2002-06 | |
| Dany Ayotte | ayotte&teamsoft.com | 2002-07 | |
| Dave Neudoerffer | Dave.Neudoerffer&ianywhere.com | ||
| Douglas Davidson | drd&apple.com | 2002-06 | |
| Eric Grange | egrange&creative-it.net | 2002-08 | |
| Eric Ledoux | ericleµsoft.com | ||
| Eugene Zhiganov | zed&dfe3300.karelia.ru | 2002-07 | |
| Francisco Reverbel | reverbel&ime.usp.br | 2002-06 | |
| Francois Marchand | francois.marchand&electromed.com | 2002-08 | |
| George Dzieciol | gdzieciol&symantec.com | 2002-07 | |
| Gregor Schmid | gregor.schmid&qfs.de | 2024-01-05 | |
| Hennie van der Merwe | hvandermerwe&tellumat.com | 2002-07 | |
| Igor Kostic | igorkoµsoft.com | 2002-08 | |
| Jason Ko | jason_ko&hp.com | 2002-07 | |
| Jim Binkley | jrb&cs.pdx.edu | 2002-06 | |
| John Skidmore | JSkidmore&vicon-cctv.com | 2002-07 | |
| John Stephen | iana&mundocani.com | 2002-07 | |
| Katherine Wattwood | katherine.wattwood&veritas.com | 2002-06 | |
| Mads Peter Back | iana-contact&webhouse.dk | 2002-06 | |
| Mark Cavage | mcavage&us.ibm.com | 2002-07 | |
| Michael Paddon | michael.paddon&activesky.com | 2002-07 | |
| Michael Sparks | msparks&telequiplabs.com | 2002-06 | |
| Paul Kraus | paul.kraus&veritas.com | 2002-06 | |
| Peter Moylan | peter&ee.newcastle.edu.au | 2002-08 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Professor Paul S. Wang | pwang&cs.kent.edu | 2002-07 | |
| Ray Caruso | ray.caruso&netvion.com | 2002-06 | |
| Riccardo Facchetti | riccardo&inetcosmos.org | 2002-07 | |
| Rick Stefanik | r.stefanik&gatelinx.com | 2002-05 | |
| Rob Griffin | quest_iana&oz.quest.com | 2002-07 | |
| Ron Capwell | ron&artifactsoftware.com | 2002-06 | |
| Scott Guthery | sguthery&mobile-mind.com | 2002-05 | |
| Shane Roberts | iana&shaneroberts.com | 2014-12-18 | |
| Simon Jolly | simon.jolly&origin-data.co.uk | 2002-07 | |
| Sinnadurai Dharshan | sinnadurai.dharshan&ni.com | 2002-07 | |
| Stuart J. Kerry | Chair IEEE 802.11 WG | stuart&ok-brit.com | 2002-05 |
| Tatsuya Igarashi | Tatsuya.Igarashi&jp.sony.com | 2002-07 | |
| Vipul Ved Prakash | mail&vipul.net | 2002-07 | |
| Virgilio Lattanzi | virgilio&harpax.com | 2002-07 |