Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
start-network 3615 tcp Start Messaging Network Peter Rocca Peter Rocca 2002-10
start-network 3615 udp Start Messaging Network Peter Rocca Peter Rocca 2002-10
cd3o-protocol 3616 tcp cd3o Control Protocol Chris Wilcox Chris Wilcox 2002-10
cd3o-protocol 3616 udp cd3o Control Protocol Chris Wilcox Chris Wilcox 2002-10
sharp-server 3617 tcp ATI SHARP Logic Engine Bill Reveile Bill Reveile
sharp-server 3617 udp ATI SHARP Logic Engine Bill Reveile Bill Reveile
aairnet-1 3618 tcp AAIR-Network 1
aairnet-1 3618 udp AAIR-Network 1
aairnet-2 3619 tcp AAIR-Network 2 James Mealey James Mealey 2002-10
aairnet-2 3619 udp AAIR-Network 2 James Mealey James Mealey 2002-10
ep-pcp 3620 tcp EPSON Projector Control Port
ep-pcp 3620 udp EPSON Projector Control Port
ep-nsp 3621 tcp EPSON Network Screen Port SEIKO EPSON SEIKO EPSON 2002-10
ep-nsp 3621 udp EPSON Network Screen Port SEIKO EPSON SEIKO EPSON 2002-10
ff-lr-port 3622 tcp FF LAN Redundancy Port Fieldbus Foundation Fieldbus Foundation 2002-10
ff-lr-port 3622 udp FF LAN Redundancy Port Fieldbus Foundation Fieldbus Foundation 2002-10
haipe-discover 3623 tcp HAIPIS Dynamic Discovery Mike Irani Mike Irani 2002-10
haipe-discover 3623 udp HAIPIS Dynamic Discovery Mike Irani Mike Irani 2002-10
dist-upgrade 3624 tcp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
dist-upgrade 3624 udp Distributed Upgrade Port Jason Schoon Jason Schoon 2002-10
volley 3625 tcp Volley David Catmull David Catmull 2002-10
volley 3625 udp Volley David Catmull David Catmull 2002-10
bvcdaemon-port 3626 tcp bvControl Daemon Ravi Gokhale Ravi Gokhale 2002-10
bvcdaemon-port 3626 udp bvControl Daemon Ravi Gokhale Ravi Gokhale 2002-10
jamserverport 3627 tcp Jam Server Port Art Pope Art Pope 2002-10
jamserverport 3627 udp Jam Server Port Art Pope Art Pope 2002-10
ept-machine 3628 tcp EPT Machine Interface Victor H. Farrace Victor H. Farrace 2002-10
ept-machine 3628 udp EPT Machine Interface Victor H. Farrace Victor H. Farrace 2002-10
escvpnet 3629 tcp ESC/VP.net Hiroyuki Hashimoto Hiroyuki Hashimoto 2002-10
escvpnet 3629 udp ESC/VP.net Hiroyuki Hashimoto Hiroyuki Hashimoto 2002-10
cs-remote-db 3630 tcp C&S Remote Database Port
cs-remote-db 3630 udp C&S Remote Database Port
cs-services 3631 tcp C&S Web Services Port Computer Software GmbH Computer Software GmbH 2002-10
cs-services 3631 udp C&S Web Services Port Computer Software GmbH Computer Software GmbH 2002-10
distcc 3632 tcp distributed compiler Martin Pool Martin Pool 2002-11 Defined TXT keys: None
distcc 3632 udp distributed compiler Martin Pool Martin Pool 2002-11 Defined TXT keys: None
wacp 3633 tcp Wyrnix AIS port Harry T. Vennik Harry T. Vennik 2002-11
wacp 3633 udp Wyrnix AIS port Harry T. Vennik Harry T. Vennik 2002-11
hlibmgr 3634 tcp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
hlibmgr 3634 udp hNTSP Library Manager Kenji Tetsuyama Kenji Tetsuyama 2002-11
sdo 3635 tcp Simple Distributed Objects Alexander Philippou Alexander Philippou 2002-11
sdo 3635 udp Simple Distributed Objects Alexander Philippou Alexander Philippou 2002-11
servistaitsm 3636 tcp SerVistaITSM Ralph Campbell Ralph Campbell 2002-11
servistaitsm 3636 udp SerVistaITSM Ralph Campbell Ralph Campbell 2002-11
scservp 3637 tcp Customer Service Port Jonathan A. Zdziarski Jonathan A. Zdziarski 2002-11
scservp 3637 udp Customer Service Port Jonathan A. Zdziarski Jonathan A. Zdziarski 2002-11
ehp-backup 3638 tcp EHP Backup Protocol Ed Fair Ed Fair 2002-11
ehp-backup 3638 udp EHP Backup Protocol Ed Fair Ed Fair 2002-11
xap-ha 3639 tcp Extensible Automation Mark Harrison Mark Harrison 2002-11
xap-ha 3639 udp Extensible Automation Mark Harrison Mark Harrison 2002-11
netplay-port1 3640 tcp Netplay Port 1
netplay-port1 3640 udp Netplay Port 1
netplay-port2 3641 tcp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
netplay-port2 3641 udp Netplay Port 2 Predrag Filipovic Predrag Filipovic 2002-11
juxml-port 3642 tcp Juxml Replication port Colin Reid Colin Reid 2002-11
juxml-port 3642 udp Juxml Replication port Colin Reid Colin Reid 2002-11
audiojuggler 3643 tcp AudioJuggler Morten Mertner Morten Mertner 2002-11
audiojuggler 3643 udp AudioJuggler Morten Mertner Morten Mertner 2002-11
ssowatch 3644 tcp ssowatch Marie-France Dubreuil Marie-France Dubreuil 2002-11
ssowatch 3644 udp ssowatch Marie-France Dubreuil Marie-France Dubreuil 2002-11
cyc 3645 tcp Cyc Stephen Reed Stephen Reed 2003-01
cyc 3645 udp Cyc Stephen Reed Stephen Reed 2003-01
xss-srv-port 3646 tcp XSS Server Port Joe Purcell Joe Purcell 2003-01
xss-srv-port 3646 udp XSS Server Port Joe Purcell Joe Purcell 2003-01
splitlock-gw 3647 tcp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
splitlock-gw 3647 udp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
fjcp 3648 tcp Fujitsu Cooperation Port Kouji Sugisawa Kouji Sugisawa 2003-01
fjcp 3648 udp Fujitsu Cooperation Port Kouji Sugisawa Kouji Sugisawa 2003-01
nmmp 3649 tcp Nishioka Miyuki Msg Protocol TAKEDA Hiroyuki TAKEDA Hiroyuki 2003-01
nmmp 3649 udp Nishioka Miyuki Msg Protocol TAKEDA Hiroyuki TAKEDA Hiroyuki 2003-01
prismiq-plugin 3650 tcp PRISMIQ VOD plug-in Richard Hodges Richard Hodges 2003-01
prismiq-plugin 3650 udp PRISMIQ VOD plug-in Richard Hodges Richard Hodges 2003-01
xrpc-registry 3651 tcp XRPC Registry Slava Monich Slava Monich 2003-01
xrpc-registry 3651 udp XRPC Registry Slava Monich Slava Monich 2003-01
vxcrnbuport 3652 tcp VxCR NBU Default Port Boris Star Boris Star 2003-01
vxcrnbuport 3652 udp VxCR NBU Default Port Boris Star Boris Star 2003-01
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
vaprtm 3654 tcp VAP RealTime Messenger Boris Polevoy Boris Polevoy 2003-01
vaprtm 3654 udp VAP RealTime Messenger Boris Polevoy Boris Polevoy 2003-01
abatemgr 3655 tcp ActiveBatch Exec Agent
abatemgr 3655 udp ActiveBatch Exec Agent
abatjss 3656 tcp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
abatjss 3656 udp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
immedianet-bcn 3657 tcp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
immedianet-bcn 3657 udp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
ps-ams 3658 tcp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
ps-ams 3658 udp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
apple-sasl 3659 tcp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
apple-sasl 3659 udp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
can-nds-ssl 3660 tcp IBM Tivoli Directory Service using SSL
can-nds-ssl 3660 udp IBM Tivoli Directory Service using SSL
can-ferret-ssl 3661 tcp IBM Tivoli Directory Service using SSL Nic Catrambone Nic Catrambone 2003-01
can-ferret-ssl 3661 udp IBM Tivoli Directory Service using SSL Nic Catrambone Nic Catrambone 2003-01
pserver 3662 tcp pserver Patrick Furlong Patrick Furlong 2003-01
pserver 3662 udp pserver Patrick Furlong Patrick Furlong 2003-01
dtp 3663 tcp DIRECWAY Tunnel Protocol John Border John Border 2003-01
dtp 3663 udp DIRECWAY Tunnel Protocol John Border John Border 2003-01
ups-engine 3664 tcp UPS Engine Port
ups-engine 3664 udp UPS Engine Port
ent-engine 3665 tcp Enterprise Engine Port Mike Delgrosso Mike Delgrosso 2003-01

Contact Information

Name Organization Contact URI Last Updated
Alexander Philippou alex&noemax.com 2003-10
Andrew Tune Andrew.Tune&splitlock.com 2003-01
Art Pope apope&sarnoff.com 2002-10
Ben Rosenberg brosenberg&advsyscon.com 2003-01
Bill Homan bhoman&spanworks.com 2003-01
Bill Reveile breveile&allentek.com
Boris Polevoy vapcom&mail.ru 2003-01
Boris Star boris.star&veritas.com 2003-01
Chris Wilcox cwilcox&cd3o.com 2002-10
Colin Reid creid&projux.com 2002-11
Computer Software GmbH BrunoRistok&cs-ag.de 2002-10
David Catmull uncommon&uncommonplace.com 2006-01
David M. O'Rourke daveo&apple.com 2003-01
Ed Fair ed_fair&yahoo.com 2002-11
Edgar Alan Tu Edgar_Tu&playstation.sony.com 2003-01
Fieldbus Foundation dave.glanzer&fieldbus.org 2002-10
Harry T. Vennik htvennik&zonnet.nl 2002-11
Hiroyuki Hashimoto easymp&exc.epson.co.jp 2002-10
James Mealey jymealey&yahoo.com 2002-10
Jason Schoon jason.schoon&intermec.com 2002-10
Joe Purcell jpurcell&ensuretech.com 2003-01
John Border border&hns.com 2003-01
Jonathan A. Zdziarski johathan&networkdweebs.com 2002-11
Kenji Tetsuyama kenji&onkyo.co.jp 2002-11
Kouji Sugisawa sugisawa.kouji&soft.fujitsu.com 2003-01
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
Marie-France Dubreuil Marie-France.Dubreuil&evidian.com 2002-11
Mark Harrison Mark&xapautomation.org 2002-11
Martin Pool mbp&samba.org 2002-11
Mike Delgrosso mdelgros&tripplite.com 2003-01
Mike Irani irani_mike&bah.com 2002-10
Morten Mertner mm&audiojuggler.com 2002-11
Nic Catrambone ncatramb&us.ibm.com 2003-01
Patrick Furlong pfurlong&darkknight.ca 2003-01
Peter Rocca rocca&multiboard.com 2002-10
Predrag Filipovic pfilipovic&digital5.com 2002-11
Ralph Campbell ralph.campbell&xasystems.com 2002-11
Ravi Gokhale rgokhale&bindview.com 2002-10
Richard Hodges rhodges&prismiq.com 2003-01
SEIKO EPSON Sato.Minoru3&exc.epson.co.jp 2002-10
Slava Monich Slava.Monich&nokia.com 2003-01
Stephen Reed reed&cyc.com 2003-01
TAKEDA Hiroyuki takeda&atashi.net 2003-01
Victor H. Farrace vfarrace&eaglept.com 2002-10