Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| lansurveyorxml | 3815 | udp | LANsurveyor XML | Michael Swan | Michael Swan | 2004-04 | |||||
| sunlps-http | 3816 | tcp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| sunlps-http | 3816 | udp | Sun Local Patch Server | Barry Greenberg | Barry Greenberg | 2004-04 | |||||
| tapeware | 3817 | tcp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| tapeware | 3817 | udp | Yosemite Tech Tapeware | Luke Dion | Luke Dion | 2004-04 | |||||
| crinis-hb | 3818 | tcp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| crinis-hb | 3818 | udp | Crinis Heartbeat | Eric McMurry | Eric McMurry | 2004-04 | |||||
| epl-slp | 3819 | tcp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| epl-slp | 3819 | udp | EPL Sequ Layer Protocol | Hans Weibel | Hans Weibel | 2004-10 | |||||
| scp | 3820 | tcp | Siemens AuD SCP | Johann Arnold | Johann Arnold | 2004-10 | |||||
| scp | 3820 | udp | Siemens AuD SCP | Johann Arnold | Johann Arnold | 2004-10 | |||||
| pmcp | 3821 | tcp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| pmcp | 3821 | udp | ATSC PMCP Standard | Graham Jones | Graham Jones | 2004-11 | |||||
| acp-discovery | 3822 | tcp | Compute Pool Discovery | ||||||||
| acp-discovery | 3822 | udp | Compute Pool Discovery | ||||||||
| acp-conduit | 3823 | tcp | Compute Pool Conduit | ||||||||
| acp-conduit | 3823 | udp | Compute Pool Conduit | ||||||||
| acp-policy | 3824 | tcp | Compute Pool Policy | Andy Belk | Andy Belk | 2005-02 | |||||
| acp-policy | 3824 | udp | Compute Pool Policy | Andy Belk | Andy Belk | 2005-02 | |||||
| ffserver | 3825 | tcp | Antera FlowFusion Process Simulation | Armin Liebchen | Armin Liebchen | 2007-06 | |||||
| ffserver | 3825 | udp | Antera FlowFusion Process Simulation | Armin Liebchen | Armin Liebchen | 2007-06 | |||||
| warmux | 3826 | tcp | WarMUX game server | Christophe Gisquet | Christophe Gisquet | 2011-05-26 | |||||
| warmux | 3826 | udp | WarMUX game server | Christophe Gisquet | Christophe Gisquet | 2011-05-26 | |||||
| netmpi | 3827 | tcp | Netadmin Systems MPI service | Göran Runfeldt | Göran Runfeldt | 2007-07-10 | |||||
| netmpi | 3827 | udp | Netadmin Systems MPI service | Göran Runfeldt | Göran Runfeldt | 2007-07-10 | |||||
| neteh | 3828 | tcp | Netadmin Systems Event Handler | ||||||||
| neteh | 3828 | udp | Netadmin Systems Event Handler | ||||||||
| neteh-ext | 3829 | tcp | Netadmin Systems Event Handler External | Jonas Krogell | Jonas Krogell | 2007-07-10 | |||||
| neteh-ext | 3829 | udp | Netadmin Systems Event Handler External | Jonas Krogell | Jonas Krogell | 2007-07-10 | |||||
| cernsysmgmtagt | 3830 | tcp | Cerner System Management Agent | Mike Craft | Mike Craft | 2008-01-29 | |||||
| cernsysmgmtagt | 3830 | udp | Cerner System Management Agent | Mike Craft | Mike Craft | 2008-01-29 | |||||
| dvapps | 3831 | tcp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| dvapps | 3831 | udp | Docsvault Application Service | Ketul Patel | Ketul Patel | 2006-10 | |||||
| xxnetserver | 3832 | tcp | xxNETserver | XXT LLC | Matt Ferrari | 2006-10 | 2012-07-12 | ||||
| xxnetserver | 3832 | udp | xxNETserver | XXT LLC | Matt Ferrari | 2006-10 | 2012-07-12 | ||||
| aipn-auth | 3833 | tcp | AIPN LS Authentication | Qiang Zhang | Qiang Zhang | 2006-10 | |||||
| aipn-auth | 3833 | udp | AIPN LS Authentication | Qiang Zhang | Qiang Zhang | 2006-10 | |||||
| spectardata | 3834 | tcp | Spectar Data Stream Service | ||||||||
| spectardata | 3834 | udp | Spectar Data Stream Service | ||||||||
| spectardb | 3835 | tcp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| spectardb | 3835 | udp | Spectar Database Rights Service | Jan Rutger Voorhorst | Jan Rutger Voorhorst | 2006-10 | |||||
| markem-dcp | 3836 | tcp | MARKEM NEXTGEN DCP | ||||||||
| markem-dcp | 3836 | udp | MARKEM NEXTGEN DCP | ||||||||
| mkm-discovery | 3837 | tcp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| mkm-discovery | 3837 | udp | MARKEM Auto-Discovery | Vadym Kargin | Vadym Kargin | 2005-08 | |||||
| sos | 3838 | tcp | Scito Object Server | Arno Klaassen | Arno Klaassen | 2003-11 | |||||
| sos | 3838 | udp | Scito Object Server | Arno Klaassen | Arno Klaassen | 2003-11 | |||||
| amx-rms | 3839 | tcp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| amx-rms | 3839 | udp | AMX Resource Management Suite | Ron Barber | Ron Barber | 2003-11 | |||||
| flirtmitmir | 3840 | tcp | www.FlirtMitMir.de | Carsten Falticska | Carsten Falticska | 2003-11 | |||||
| flirtmitmir | 3840 | udp | www.FlirtMitMir.de | Carsten Falticska | Carsten Falticska | 2003-11 | |||||
| shiprush-db-svr | 3841 | tcp | ShipRush Database Server | Z-Firm LLC | Rafael Zimberoff | 2003-11 | 2014-08-22 | ||||
| 3841 | udp | Reserved | 2003-11 | 2014-08-22 | |||||||
| nhci | 3842 | tcp | NHCI status port | Eric Welch | Eric Welch | 2003-11 | |||||
| nhci | 3842 | udp | NHCI status port | Eric Welch | Eric Welch | 2003-11 | |||||
| quest-agent | 3843 | tcp | Quest Common Agent | Peter Maher | Peter Maher | 2003-11 | |||||
| quest-agent | 3843 | udp | Quest Common Agent | Peter Maher | Peter Maher | 2003-11 | |||||
| rnm | 3844 | tcp | RNM | sn0w of renegade labs | sn0w of renegade labs | 2003-11 | |||||
| rnm | 3844 | udp | RNM | sn0w of renegade labs | sn0w of renegade labs | 2003-11 | |||||
| v-one-spp | 3845 | tcp | V-ONE Single Port Proxy | Daniel Becker | Daniel Becker | ||||||
| v-one-spp | 3845 | udp | V-ONE Single Port Proxy | Daniel Becker | Daniel Becker | ||||||
| an-pcp | 3846 | tcp | Astare Network PCP | Tony Gulino | Tony Gulino | 2003-08 | |||||
| an-pcp | 3846 | udp | Astare Network PCP | Tony Gulino | Tony Gulino | 2003-08 | |||||
| msfw-control | 3847 | tcp | MS Firewall Control | Oren Trutner | Oren Trutner | 2003-08 | |||||
| msfw-control | 3847 | udp | MS Firewall Control | Oren Trutner | Oren Trutner | 2003-08 | |||||
| item | 3848 | tcp | IT Environmental Monitor | Keith Wright | Keith Wright | 2003-08 | |||||
| item | 3848 | udp | IT Environmental Monitor | Keith Wright | Keith Wright | 2003-08 | |||||
| spw-dnspreload | 3849 | tcp | SPACEWAY DNS Preload | Daniel Friedman | Daniel Friedman | 2003-08 | |||||
| spw-dnspreload | 3849 | udp | SPACEWAY DNS Preload | Daniel Friedman | Daniel Friedman | 2003-08 | |||||
| qtms-bootstrap | 3850 | tcp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| qtms-bootstrap | 3850 | udp | QTMS Bootstrap Protocol | Phil Willis | Phil Willis | 2003-08 | |||||
| spectraport | 3851 | tcp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| spectraport | 3851 | udp | SpectraTalk Port | Madhav Karhade | Madhav Karhade | 2003-08 | |||||
| sse-app-config | 3852 | tcp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| sse-app-config | 3852 | udp | SSE App Configuration | Tim Wilson | Tim Wilson | 2003-08 | |||||
| sscan | 3853 | tcp | SONY scanning protocol | Takashi Aihara | Takashi Aihara | 2003-08 | |||||
| sscan | 3853 | udp | SONY scanning protocol | Takashi Aihara | Takashi Aihara | 2003-08 | |||||
| stryker-com | 3854 | tcp | Stryker Comm Port | Andrew Schultz | Andrew Schultz | 2003-08 | |||||
| stryker-com | 3854 | udp | Stryker Comm Port | Andrew Schultz | Andrew Schultz | 2003-08 | |||||
| opentrac | 3855 | tcp | OpenTRAC | Scott Miller | Scott Miller | 2003-08 | |||||
| opentrac | 3855 | udp | OpenTRAC | Scott Miller | Scott Miller | 2003-08 | |||||
| informer | 3856 | tcp | INFORMER | Filippo Fadda | Filippo Fadda | 2003-08 | |||||
| informer | 3856 | udp | INFORMER | Filippo Fadda | Filippo Fadda | 2003-08 | |||||
| trap-port | 3857 | tcp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port | 3857 | udp | Trap Port | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port-mom | 3858 | tcp | Trap Port MOM | Norm Freedman | Norm Freedman | 2003-08 | |||||
| trap-port-mom | 3858 | udp | Trap Port MOM | Norm Freedman | Norm Freedman | 2003-08 | |||||
| nav-port | 3859 | tcp | Navini Port | Chris Sanders | Chris Sanders | 2003-08 | |||||
| nav-port | 3859 | udp | Navini Port | Chris Sanders | Chris Sanders | 2003-08 | |||||
| sasp | 3860 | tcp | Server/Application State Protocol (SASP) | Alan Bivens | Alan Bivens | 2003-08 | |||||
| sasp | 3860 | udp | Server/Application State Protocol (SASP) | Alan Bivens | Alan Bivens | 2003-08 | |||||
| winshadow-hd | 3861 | tcp | winShadow Host Discovery | Shu-Wei Tan | Shu-Wei Tan | 2003-03 | |||||
| winshadow-hd | 3861 | udp | winShadow Host Discovery | Shu-Wei Tan | Shu-Wei Tan | 2003-03 | |||||
| giga-pocket | 3862 | tcp | GIGA-POCKET | Yoshikazu Watanabe | Yoshikazu Watanabe | ||||||
| giga-pocket | 3862 | udp | GIGA-POCKET | Yoshikazu Watanabe | Yoshikazu Watanabe | ||||||
| asap-tcp | 3863 | tcp | asap tcp port | ||||||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | RFC 5352 | |||||||
| 3864 | udp | Reserved | This entry has been removed on 2006-06-23. | ||||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | RFC 5352 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Bivens | jbivens&us.ibm.com | 2003-08 | |
| Andrew Schultz | aschultz&strykercom.com | 2003-08 | |
| Andy Belk | register1&azulsystems.com | 2005-02 | |
| Armin Liebchen | armin&anteradesign.com | 2007-06 | |
| Arno Klaassen | arno&ccr.jussieu.fr | 2003-11 | |
| Barry Greenberg | barry.greenberg&sun.com | 2004-04 | |
| Carsten Falticska | falticska&freenet.de | 2003-11 | |
| Chris Sanders | csanders&navini.com | 2003-08 | |
| Christophe Gisquet | christophe.gisquet&gmail.com | 2011-05-26 | |
| Daniel Becker | dbecker&v-one.com | ||
| Daniel Friedman | dfriedman&hns.com | 2003-08 | |
| Eric McMurry | emcmurry&crinisnetworks.com | 2004-04 | |
| Eric Welch | eric&innosys.com | 2003-11 | |
| Filippo Fadda | fadda&osway.com | 2003-08 | |
| Göran Runfeldt | goran&netadmin.se | 2007-07-10 | |
| Graham Jones | gjones&nab.org | 2004-11 | |
| Hans Weibel | hans.weibel&zhwin.ch | 2004-10 | |
| Jan Rutger Voorhorst | janrutger&roadware.nl | 2006-10 | |
| Johann Arnold | johann.arnold&siemens.com | 2004-10 | |
| Jonas Krogell | jonas.krogell&netadmin.se | 2007-07-10 | |
| Keith Wright | kwright&sensatronics.com | 2003-08 | |
| Ketul Patel | ketulp76&yahoo.com | 2006-10 | |
| Luke Dion | ldion&tapeware.com | 2004-04 | |
| Madhav Karhade | madhav.karhade&wibhu.com | 2003-08 | |
| Matt Ferrari | XXT LLC | xxt.matt&sbcglobal.net | 2012-07-12 |
| Michael Swan | swan&neon.com | 2004-04 | |
| Mike Craft | mcraft&cerner.com | 2008-01-29 | |
| Norm Freedman | normfree&san.rr.com | 2003-08 | |
| Oren Trutner | orentrutµsoft.com | 2003-08 | |
| Peter Maher | quest_iana&oz.quest.com | 2003-11 | |
| Phil Willis | phil.willis&prism-uk.com | 2003-08 | |
| Qiang Zhang | qzhang&iwncomm.com | 2006-10 | |
| Rafael Zimberoff | rafael&zfirmllc.com | 2003-11 | |
| Ron Barber | ron.barber&amx.com | 2003-11 | |
| Scott Miller | scott&opentrac.org | 2003-08 | |
| Shu-Wei Tan | stan&omnicomtech.com | 2003-03 | |
| Takashi Aihara | aiharat&sm.sony.co.jp | 2003-08 | |
| Tim Wilson | tim.wilson&motorola.com | 2003-08 | |
| Tony Gulino | astaregod&hotmail.com | 2003-08 | |
| Vadym Kargin | vkargin&markem.com | 2005-08 | |
| XXT LLC | xxt.matt&sbcglobal.net | 2012-07-12 | |
| Yoshikazu Watanabe | nabe&sm.sony.co.jp | ||
| Z-Firm LLC | rafael&zfirmllc.com | 2014-08-22 | |
| sn0w of renegade labs | sn0w&devious.tsongkie.com | 2003-11 |