Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
asap-sctp-tls 3864 sctp asap-sctp/tls RFC 5352
xpl 3865 tcp xpl automation protocol Ian Lowe Ian Lowe 2003-08
xpl 3865 udp xpl automation protocol Ian Lowe Ian Lowe 2003-08
dzdaemon 3866 tcp Sun SDViz DZDAEMON Port Kevin Rushforth Kevin Rushforth 2003-08
dzdaemon 3866 udp Sun SDViz DZDAEMON Port Kevin Rushforth Kevin Rushforth 2003-08
dzoglserver 3867 tcp Sun SDViz DZOGLSERVER Port Kevin Rushforth Kevin Rushforth 2003-08
dzoglserver 3867 udp Sun SDViz DZOGLSERVER Port Kevin Rushforth Kevin Rushforth 2003-08
diameter 3868 tcp DIAMETER
3868 udp Reserved
diameter 3868 sctp DIAMETER RFC 3588
ovsam-mgmt 3869 tcp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-mgmt 3869 udp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-d-agent 3870 tcp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-d-agent 3870 udp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
avocent-adsap 3871 tcp Avocent DS Authorization Eduardo Fernandez Eduardo Fernandez 2003-08
avocent-adsap 3871 udp Avocent DS Authorization Eduardo Fernandez Eduardo Fernandez 2003-08
oem-agent 3872 tcp OEM Agent Narain Jagathesan Narain Jagathesan 2003-11
oem-agent 3872 udp OEM Agent Narain Jagathesan Narain Jagathesan 2003-11
fagordnc 3873 tcp fagordnc Luis Zugasti Luis Zugasti 2003-11
fagordnc 3873 udp fagordnc Luis Zugasti Luis Zugasti 2003-11
sixxsconfig 3874 tcp SixXS Configuration Jeroen Massar Jeroen Massar 2003-11
sixxsconfig 3874 udp SixXS Configuration Jeroen Massar Jeroen Massar 2003-11
pnbscada 3875 tcp PNBSCADA Philip N. Bergstresser Philip N. Bergstresser
pnbscada 3875 udp PNBSCADA Philip N. Bergstresser Philip N. Bergstresser
dl-agent 3876 tcp DirectoryLockdown Agent

IANA assigned this well-formed service name as a replacement for "dl_agent".
Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
dl_agent 3876 tcp DirectoryLockdown Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16 This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
dl-agent 3876 udp DirectoryLockdown Agent

IANA assigned this well-formed service name as a replacement for "dl_agent".
Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16
dl_agent 3876 udp DirectoryLockdown Agent Jason Lockett; Melanie Kacerek Jason Lockett; Melanie Kacerek 2008-12-16 This entry is an alias to "dl-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
xmpcr-interface 3877 tcp XMPCR Interface Port Christopher Carlson Christopher Carlson 2003-10
xmpcr-interface 3877 udp XMPCR Interface Port Christopher Carlson Christopher Carlson 2003-10
fotogcad 3878 tcp FotoG CAD interface Jason Szabo Jason Szabo 2003-10
fotogcad 3878 udp FotoG CAD interface Jason Szabo Jason Szabo 2003-10
appss-lm 3879 tcp appss license manager Peter Krueger Peter Krueger 2003-10
appss-lm 3879 udp appss license manager Peter Krueger Peter Krueger 2003-10
igrs 3880 tcp IGRS Huang Jingnan Huang Jingnan 2003-10
igrs 3880 udp IGRS Huang Jingnan Huang Jingnan 2003-10
idac 3881 tcp Data Acquisition and Control Chatziandreoglou Christos Chatziandreoglou Christos 2003-10
idac 3881 udp Data Acquisition and Control Chatziandreoglou Christos Chatziandreoglou Christos 2003-10
msdts1 3882 tcp DTS Service Port Sergei Ivanov Sergei Ivanov 2003-10
msdts1 3882 udp DTS Service Port Sergei Ivanov Sergei Ivanov 2003-10
vrpn 3883 tcp VR Peripheral Network Sensics Yuval Boger 2003-10 2015-05-04
vrpn 3883 udp VR Peripheral Network Sensics Yuval Boger 2003-10 2015-05-04
softrack-meter 3884 tcp SofTrack Metering John T. McCann John T. McCann 2003-10
softrack-meter 3884 udp SofTrack Metering John T. McCann John T. McCann 2003-10
topflow-ssl 3885 tcp TopFlow SSL Ken Nelson Ken Nelson
topflow-ssl 3885 udp TopFlow SSL Ken Nelson Ken Nelson
nei-management 3886 tcp NEI management port Kevin Murphy Kevin Murphy 2003-10
nei-management 3886 udp NEI management port Kevin Murphy Kevin Murphy 2003-10
ciphire-data 3887 tcp Ciphire Data Transport Lars Eilebrecht Lars Eilebrecht 2003-10
ciphire-data 3887 udp Ciphire Data Transport Lars Eilebrecht Lars Eilebrecht 2003-10
ciphire-serv 3888 tcp Ciphire Services Lars Eilebrecht Lars Eilebrecht 2003-10
ciphire-serv 3888 udp Ciphire Services Lars Eilebrecht Lars Eilebrecht 2003-10
dandv-tester 3889 tcp D and V Tester Control Port Voiko Loukanov Voiko Loukanov 2003-10
dandv-tester 3889 udp D and V Tester Control Port Voiko Loukanov Voiko Loukanov 2003-10
ndsconnect 3890 tcp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
ndsconnect 3890 udp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
rtc-pm-port 3891 tcp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
rtc-pm-port 3891 udp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
pcc-image-port 3892 tcp PCC-image-port Shiro Tamoto Shiro Tamoto 2003-10
pcc-image-port 3892 udp PCC-image-port Shiro Tamoto Shiro Tamoto 2003-10
cgi-starapi 3893 tcp CGI StarAPI Server Garry Moore Garry Moore 2003-10
cgi-starapi 3893 udp CGI StarAPI Server Garry Moore Garry Moore 2003-10
syam-agent 3894 tcp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
syam-agent 3894 udp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
syam-smc 3895 tcp SyAm SMC Service Port Michael Daniele Michael Daniele 2003-10
syam-smc 3895 udp SyAm SMC Service Port Michael Daniele Michael Daniele 2003-10
sdo-tls 3896 tcp Simple Distributed Objects over TLS Alexander Philippou Alexander Philippou 2003-10
sdo-tls 3896 udp Simple Distributed Objects over TLS Alexander Philippou Alexander Philippou 2003-10
sdo-ssh 3897 tcp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
sdo-ssh 3897 udp Simple Distributed Objects over SSH Alexander Philippou Alexander Philippou 2003-10
senip 3898 tcp IAS, Inc. SmartEye NET Internet Protocol Matt Nowicki Matt Nowicki 2003-10
senip 3898 udp IAS, Inc. SmartEye NET Internet Protocol Matt Nowicki Matt Nowicki 2003-10
itv-control 3899 tcp ITV Port Alex Nicu Alex Nicu 2003-10
itv-control 3899 udp ITV Port Alex Nicu Alex Nicu 2003-10
udt-os 3900 tcp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 tcp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 3900 udp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 udp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
omnilink-port 3904 tcp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
omnilink-port 3904 udp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
topovista-data 3906 tcp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
topovista-data 3906 udp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
imoguia-port 3907 tcp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
imoguia-port 3907 udp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
hppronetman 3908 tcp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
hppronetman 3908 udp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
surfcontrolcpa 3909 tcp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
surfcontrolcpa 3909 udp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
prnrequest 3910 tcp Printer Request Port Brett Green Brett Green 2003-11
prnrequest 3910 udp Printer Request Port Brett Green Brett Green 2003-11
prnstatus 3911 tcp Printer Status Port Brett Green Brett Green 2003-11
prnstatus 3911 udp Printer Status Port Brett Green Brett Green 2003-11
gbmt-stars 3912 tcp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2003-11

Contact Information

Name Organization Contact URI Last Updated
Alex Nicu alex.nicu&philips.com 2003-10
Alexander Philippou alex&noemax.com 2003-10
Brett Green brett_green&hp.com 2003-11
Chatziandreoglou Christos chatzi&xan.forthnet.gr 2003-10
Christopher Carlson cjc&dobbz.com 2003-10
Devon Dawson devon.dawson&hp.com 2003-11
Eduardo Fernandez eduardo.fernandez&avocent.com 2003-08
Emidio Cunha emidio&janeladigital.com 2003-11
Garry Moore garry.moore&cgi.com 2003-10
Gregg Townsend gmt&cs.arizona.edu 2003-11
Harry Goldschmitt hgoldschmitt&hgac.com 2003-11
Huang Jingnan huangjnb&lenovo.com 2003-10
Hywel Morgan hywelm&surfcontrol.com 2003-11
Ian Lowe ian&xplproject.org.uk 2003-08
James Powell james&mailhost.unidata.com
Jason Lockett Jay.Lockett&quest.com 2008-12-16
Jason Szabo jason.szabo&vexcel.com 2003-10
Jeroen Massar jeroen&unfix.org 2005-08
John T. McCann jmccann&softwaremetering.com 2003-10
Ken Nelson nelson&toplayer.com
Kevin Murphy kevin.murphy&networkengines.com 2003-10
Kevin Rushforth kevin.rushforth&sun.com 2003-08
Lars Eilebrecht le+iana&leogic.com 2003-10
Luis Zugasti lzugasti&fagorautomation.es 2003-11
Matt Nowicki nowickim&iasdirect.com 2003-10
Melanie Kacerek melanie.kacerek&quest.com 2008-12-16
Michael Daniele michael.daniele&syamsoftware.com 2003-11
Mike Pontillo pontillo&hp.com 2003-08
Narain Jagathesan narain.jagathesan&oracle.com 2003-11
Paul B. Finley pfinley&us.ibm.com 2003-10
Peter Krueger krueger&appss.de 2003-10
Philip N. Bergstresser phil&bergstresser.org
PV Shivkumar p.shivkumar&oracle.com 2003-10
Roland Schneider rsch&nicherms.com 2003-10
Ronen Shaul ronen&arnetsystems.com 2003-10
Sensics vrpn&sensics.com 2015-05-04
Sergei Ivanov sergei&microsoft.com 2003-10
Shiro Tamoto tamoto.shiro&jp.panasonic.com 2003-10
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Voiko Loukanov v.loukanov&dvelectronics.com 2003-10
Yuval Boger Sensics vrpn&sensics.com 2015-05-04