Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ups 401 tcp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
ups 401 udp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
genie 402 tcp Genie Protocol Mark Hankin Mark Hankin
genie 402 udp Genie Protocol Mark Hankin Mark Hankin
decap 403 tcp decap
decap 403 udp decap
nced 404 tcp nced
nced 404 udp nced
ncld 405 tcp ncld Richard Jones Richard Jones
ncld 405 udp ncld Richard Jones Richard Jones
imsp 406 tcp Interactive Mail Support Protocol John Myers John Myers
imsp 406 udp Interactive Mail Support Protocol John Myers John Myers
timbuktu 407 tcp Timbuktu Marc Epard Marc Epard
timbuktu 407 udp Timbuktu Marc Epard Marc Epard
prm-sm 408 tcp Prospero Resource Manager Sys. Man.
prm-sm 408 udp Prospero Resource Manager Sys. Man.
prm-nm 409 tcp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
prm-nm 409 udp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
decladebug 410 tcp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
decladebug 410 udp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
rmt 411 tcp Remote MT Protocol Peter Eriksson Peter Eriksson
rmt 411 udp Remote MT Protocol Peter Eriksson Peter Eriksson
synoptics-trap 412 tcp Trap Convention Port Illan Raab Illan Raab
synoptics-trap 412 udp Trap Convention Port Illan Raab Illan Raab
smsp 413 tcp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
smsp 413 udp Storage Management Services Protocol Murthy Srinivas Murthy Srinivas
infoseek 414 tcp InfoSeek Steve Kirsch Steve Kirsch
infoseek 414 udp InfoSeek Steve Kirsch Steve Kirsch
bnet 415 tcp BNet Jim Mertz Jim Mertz
bnet 415 udp BNet Jim Mertz Jim Mertz
silverplatter 416 tcp Silverplatter Peter Ciuffetti Peter Ciuffetti
silverplatter 416 udp Silverplatter Peter Ciuffetti Peter Ciuffetti
onmux 417 tcp Onmux Stephen Hanna Stephen Hanna
onmux 417 udp Onmux Stephen Hanna Stephen Hanna
hyper-g 418 tcp Hyper-G Frank Kappe Frank Kappe
hyper-g 418 udp Hyper-G Frank Kappe Frank Kappe
ariel1 419 tcp Ariel 1 Joel Karafin Joel Karafin
ariel1 419 udp Ariel 1 Joel Karafin Joel Karafin
smpte 420 tcp SMPTE Si Becker Si Becker
smpte 420 udp SMPTE Si Becker Si Becker
ariel2 421 tcp Ariel 2
ariel2 421 udp Ariel 2
ariel3 422 tcp Ariel 3 Joel Karafin Joel Karafin
ariel3 422 udp Ariel 3 Joel Karafin Joel Karafin
opc-job-start 423 tcp IBM Operations Planning and Control Start
opc-job-start 423 udp IBM Operations Planning and Control Start
opc-job-track 424 tcp IBM Operations Planning and Control Track Conny Larsson Conny Larsson
opc-job-track 424 udp IBM Operations Planning and Control Track Conny Larsson Conny Larsson
icad-el 425 tcp ICAD Larry Stone Larry Stone
icad-el 425 udp ICAD Larry Stone Larry Stone
smartsdp 426 tcp smartsdp Marie-Pierre Belanger Marie-Pierre Belanger
smartsdp 426 udp smartsdp Marie-Pierre Belanger Marie-Pierre Belanger
svrloc 427 tcp Server Location Veizades Veizades
svrloc 427 udp Server Location Veizades Veizades
ocs-cmu 428 tcp OCS_CMU

IANA assigned this well-formed service name as a replacement for "ocs_cmu".
ocs_cmu 428 tcp OCS_CMU This entry is an alias to "ocs-cmu". This entry is now historic, not usable for use with many common service discovery mechanisms.
ocs-cmu 428 udp OCS_CMU

IANA assigned this well-formed service name as a replacement for "ocs_cmu".
ocs_cmu 428 udp OCS_CMU This entry is an alias to "ocs-cmu". This entry is now historic, not usable for use with many common service discovery mechanisms.
ocs-amu 429 tcp OCS_AMU

IANA assigned this well-formed service name as a replacement for "ocs_amu".
Florence Wyman Florence Wyman
ocs_amu 429 tcp OCS_AMU Florence Wyman Florence Wyman This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms.
ocs-amu 429 udp OCS_AMU

IANA assigned this well-formed service name as a replacement for "ocs_amu".
Florence Wyman Florence Wyman
ocs_amu 429 udp OCS_AMU Florence Wyman Florence Wyman This entry is an alias to "ocs-amu". This entry is now historic, not usable for use with many common service discovery mechanisms.
utmpsd 430 tcp UTMPSD
utmpsd 430 udp UTMPSD
utmpcd 431 tcp UTMPCD
utmpcd 431 udp UTMPCD
iasd 432 tcp IASD Nir Baroz Nir Baroz
iasd 432 udp IASD Nir Baroz Nir Baroz
nnsp 433 tcp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
nnsp 433 udp NNTP for transit servers (NNSP) IESG IETF Chair 2018-07-06 RFC 3977
mobileip-agent 434 tcp MobileIP-Agent
mobileip-agent 434 udp MobileIP-Agent
mobilip-mn 435 tcp MobilIP-MN Kannan Alagappan Kannan Alagappan
mobilip-mn 435 udp MobilIP-MN Kannan Alagappan Kannan Alagappan
dna-cml 436 tcp DNA-CML Dan Flowers Dan Flowers
dna-cml 436 udp DNA-CML Dan Flowers Dan Flowers
comscm 437 tcp comscm Jim Teague Jim Teague
comscm 437 udp comscm Jim Teague Jim Teague
dsfgw 438 tcp dsfgw Andy McKeen Andy McKeen
dsfgw 438 udp dsfgw Andy McKeen Andy McKeen
dasp 439 tcp dasp Thomas Obermair Thomas Obermair
dasp 439 udp dasp Thomas Obermair Thomas Obermair
sgcp 440 tcp sgcp Marshall Rose Marshall Rose
sgcp 440 udp sgcp Marshall Rose Marshall Rose
decvms-sysmgt 441 tcp decvms-sysmgt Lee Barton Lee Barton
decvms-sysmgt 441 udp decvms-sysmgt Lee Barton Lee Barton
cvc-hostd 442 tcp cvc_hostd

IANA assigned this well-formed service name as a replacement for "cvc_hostd".
Bill Davidson Bill Davidson
cvc_hostd 442 tcp cvc_hostd Bill Davidson Bill Davidson This entry is an alias to "cvc-hostd". This entry is now historic, not usable for use with many common service discovery mechanisms.
cvc-hostd 442 udp cvc_hostd

IANA assigned this well-formed service name as a replacement for "cvc_hostd".
Bill Davidson Bill Davidson
cvc_hostd 442 udp cvc_hostd Bill Davidson Bill Davidson This entry is an alias to "cvc-hostd". This entry is now historic, not usable for use with many common service discovery mechanisms.
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
snpp 444 tcp Simple Network Paging Protocol RFC 1568
snpp 444 udp Simple Network Paging Protocol RFC 1568
microsoft-ds 445 tcp Microsoft-DS Pradeep Bahl Pradeep Bahl
microsoft-ds 445 udp Microsoft-DS Pradeep Bahl Pradeep Bahl
ddm-rdb 446 tcp DDM-Remote Relational Database Access
ddm-rdb 446 udp DDM-Remote Relational Database Access
ddm-dfm 447 tcp DDM-Distributed File Management Steven Ritland Steven Ritland
ddm-dfm 447 udp DDM-Distributed File Management Steven Ritland Steven Ritland

Contact Information

Name Organization Contact URI Last Updated
Andy McKeen mckeen&osf.org
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bill Davidson billd&equalizer.cray.com
Charles Bennett bennettc&ohio.edu 2008-08-29
Conny Larsson cocke&vnet.ibm.com
Dan Flowers flowers&smaug.lkg.dec.com
Florence Wyman wyman&peabody.plk.af.mil
Frank Kappe fkappe&iicm.tu-graz.ac.at
Hewlett Packard
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
Jim Mertz JMertz+RV09&rvdc.unisys.com
Jim Teague teague&zso.dec.com
Joel Karafin jkarafin&infotrieve.com
John Myers jgm+&cmu.edu
Kannan Alagappan kannan&sejour.lkg.dec.com
Larry Stone lcs&icad.com
Lee Barton barton&star.enet.dec.com
Marc Epard marc&netopia.com
Marie-Pierre Belanger belanger_marie&emc.com
Mark Hankin
Marshall Rose mrose17&gmail.com 2024-07-29
Murthy Srinivas murthy&novell.com
Nir Baroz nbaroz&encore.com
Peter Ciuffetti petec&silverplatter.com
Peter Eriksson pen&lysator.liu.se
Pradeep Bahl pradeepb&microsoft.com
Randall Stewart IETF TSVWG rrs&lakerest.net
Richard Jones
Si Becker 71362.22&compuserve.com
Stephen Hanna hanna&world.std.com
Steve Kirsch stk&infoseek.com
Steven Ritland srr&us.ibm.com
Thomas Obermair tommy&inlab.m.eunet.de
veizades&ftp.com