Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| d-data-control | 4302 | udp | Diagnostic Data Control | Jon March | Jon March | 2006-09 | |||||
| srcp | 4303 | tcp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| srcp | 4303 | udp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| owserver | 4304 | tcp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| owserver | 4304 | udp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| batman | 4305 | tcp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| batman | 4305 | udp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| pinghgl | 4306 | tcp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| pinghgl | 4306 | udp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| trueconf | 4307 | tcp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| trueconf | 4307 | udp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| compx-lockview | 4308 | tcp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| compx-lockview | 4308 | udp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| dserver | 4309 | tcp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| dserver | 4309 | udp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| mirrtex | 4310 | tcp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| mirrtex | 4310 | udp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| p6ssmc | 4311 | tcp | P6R Secure Server Management Console | Jim Susoy | Jim Susoy | 2010-01-21 | |||||
| 4311 | udp | Reserved | |||||||||
| pscl-mgt | 4312 | tcp | Parascale Membership Manager | John Muth | John Muth | 2010-01-21 | |||||
| 4312 | udp | Reserved | |||||||||
| perrla | 4313 | tcp | PERRLA User Services | Cliff Batson | Cliff Batson | 2010-01-21 | |||||
| 4313 | udp | Reserved | |||||||||
| choiceview-agt | 4314 | tcp | ChoiceView Agent | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4314 | udp | Reserved | |||||||||
| 4315 | Unassigned | Unauthorized Use Known on port 4315 | |||||||||
| choiceview-clt | 4316 | tcp | ChoiceView Client | Radish Systems | Richard A. Davis | 2013-03-28 | |||||
| 4316 | udp | Reserved | |||||||||
| opentelemetry | 4317 | tcp | OpenTelemetry Protocol | OpenTelemetry | Morgan McLean | 2020-12-09 | |||||
| 4317 | udp | Reserved | |||||||||
| 4318 | Unassigned | ||||||||||
| skytale | 4319 | tcp | Sentyron SkyTale encrypted communication | Sentyron B.V. | Mark Revier | 2022-01-20 | 2025-10-30 | ||||
| skytale | 4319 | udp | Sentyron SkyTale encrypted communication | Sentyron B.V. | Mark Revier | 2022-01-20 | 2025-10-30 | ||||
| fdt-rcatp | 4320 | tcp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| fdt-rcatp | 4320 | udp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| rwhois | 4321 | tcp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| rwhois | 4321 | udp | Remote Who Is | Mark Kosters | Mark Kosters | RFC 2167 | |||||
| trim-event | 4322 | tcp | TRIM Event Service | ||||||||
| trim-event | 4322 | udp | TRIM Event Service | ||||||||
| trim-ice | 4323 | tcp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| trim-ice | 4323 | udp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| geognosisadmin | 4325 | tcp | Cadcorp GeognoSIS Administrator | Computer Aided Development Corporation Ltd (Cadcorp) | Martin Daly | 2022-08-12 | |||||
| geognosisman | 4325 | udp | Cadcorp GeognoSIS Administrator | Computer Aided Development Corporation Ltd (Cadcorp) | Martin Daly | 2022-08-12 | |||||
| geognosis | 4326 | tcp | Cadcorp GeognoSIS | Martin Daly | Martin Daly | 2006-11 | 2022-08-12 | ||||
| geognosis | 4326 | udp | Cadcorp GeognoSIS | Martin Daly | Martin Daly | 2006-11 | 2022-08-12 | ||||
| jaxer-web | 4327 | tcp | Jaxer Web Protocol | Uri Sarid | Uri Sarid | 2008-01-07 | |||||
| jaxer-web | 4327 | udp | Jaxer Web Protocol | Uri Sarid | Uri Sarid | 2008-01-07 | |||||
| jaxer-manager | 4328 | tcp | Jaxer Manager Command Protocol | Uri Sarid | Uri Sarid | 2008-01-22 | |||||
| jaxer-manager | 4328 | udp | Jaxer Manager Command Protocol | Uri Sarid | Uri Sarid | 2008-01-22 | |||||
| publiqare-sync | 4329 | tcp | PubliQare Distributed Environment Synchronisation Engine | Tom Maaswinkel | Tom Maaswinkel | 2011-02-07 | |||||
| 4329 | udp | Reserved | |||||||||
| dey-sapi | 4330 | tcp | DEY Storage Administration REST API | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 4330 | udp | Reserved | |||||||||
| ktickets-rest | 4331 | tcp | ktickets REST API for event management and ticketing systems (embedded POS devices) | KeyTicket Solutions | MANG Ioan-Alexandru | 2014-04-04 | |||||
| 4331 | udp | Reserved | |||||||||
| getty-focus | 4332 | tcp | Getty Images FOCUS service | Matthew Margolis | Bryan Ramirez | 2019-04-18 | |||||
| 4332 | udp | Reserved | |||||||||
| ahsp | 4333 | tcp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| ahsp | 4333 | udp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| ahsp | 4333 | sctp | ArrowHead Service Protocol (AHSP) | QuantuMatriX Technologies | Matthew Schultz | 2014-04-10 | |||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4334 | udp | Reserved | |||||||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4335 | udp | Reserved | |||||||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| 4336 | udp | Reserved | |||||||||
| 4337-4339 | Unassigned | ||||||||||
| gaia | 4340 | tcp | Gaia Connector Protocol | Philippe Detournay | Philippe Detournay | 2007-11-12 | |||||
| gaia | 4340 | udp | Gaia Connector Protocol | Philippe Detournay | Philippe Detournay | 2007-11-12 | |||||
| 4341 | tcp | Reserved | 2007-11-12 | 2018-11-30 | |||||||
| lisp-data | 4341 | udp | LISP Data Packets | IESG | IETF Chair | 2007-11-12 | 2021-02-17 | RFC 9300 | |||
| 4342 | tcp | Reserved | 2018-11-30 | ||||||||
| lisp-control | 4342 | udp | LISP Control Packets | IETF | IESG | 2007-05 | 2021-02-25 | RFC 9301 | |||
| unicall | 4343 | tcp | UNICALL | James Powell | James Powell | ||||||
| unicall | 4343 | udp | UNICALL | James Powell | James Powell | ||||||
| vinainstall | 4344 | tcp | VinaInstall | Jay Slupesky | Jay Slupesky | ||||||
| vinainstall | 4344 | udp | VinaInstall | Jay Slupesky | Jay Slupesky | ||||||
| m4-network-as | 4345 | tcp | Macro 4 Network AS | Paul Wren | Paul Wren | ||||||
| m4-network-as | 4345 | udp | Macro 4 Network AS | Paul Wren | Paul Wren | ||||||
| elanlm | 4346 | tcp | ELAN LM | Paul Ballew | Paul Ballew | ||||||
| elanlm | 4346 | udp | ELAN LM | Paul Ballew | Paul Ballew | ||||||
| lansurveyor | 4347 | tcp | LAN Surveyor | Michael Swan | Michael Swan | ||||||
| lansurveyor | 4347 | udp | LAN Surveyor | Michael Swan | Michael Swan | ||||||
| itose | 4348 | tcp | ITOSE | Michael Haeuptle | Michael Haeuptle | ||||||
| itose | 4348 | udp | ITOSE | Michael Haeuptle | Michael Haeuptle | ||||||
| fsportmap | 4349 | tcp | File System Port Map | Ron Minnich | Ron Minnich | ||||||
| fsportmap | 4349 | udp | File System Port Map | Ron Minnich | Ron Minnich | ||||||
| net-device | 4350 | tcp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| net-device | 4350 | udp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| plcy-net-svcs | 4351 | tcp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| plcy-net-svcs | 4351 | udp | PLCY Net Services | J.J. Ekstrom | J.J. Ekstrom | ||||||
| pjlink | 4352 | tcp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| pjlink | 4352 | udp | Projector Link | Mitsuo Kodama | Mitsuo Kodama | 2005-06 | |||||
| f5-iquery | 4353 | tcp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| f5-iquery | 4353 | udp | F5 iQuery | Tom Kee | Tom Kee | ||||||
| qsnet-trans | 4354 | tcp | QSNet Transmitter | ||||||||
| qsnet-trans | 4354 | udp | QSNet Transmitter | ||||||||
| qsnet-workst | 4355 | tcp | QSNet Workstation | ||||||||
| qsnet-workst | 4355 | udp | QSNet Workstation | ||||||||
| qsnet-assist | 4356 | tcp | QSNet Assistant |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Angelo Masci | angelomasci&yahoo.co.uk | 2007-01 | |
| Bryan Ramirez | bryan.ramirez&gettyimages.com | 2019-04-18 | |
| Cliff Batson | cliff&perrla.com | 2010-01-21 | |
| Computer Aided Development Corporation Ltd (Cadcorp) | martin.daly&cadcorp.com | 2022-08-12 | |
| David Berk | dberk&ping-0.com | 2007-08-30 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Dmitry Odintsov | dimodin&trueconf.com | 2017-05-12 | |
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| Glenn Peterson | glennpµsoft.com | ||
| IESG | iesg&ietf.org | ||
| IETF | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| J.J. Ekstrom | |||
| James Powell | james&enghp.unidata.comp | ||
| Jay Slupesky | js&vina-tech.com | ||
| Jim Susoy | jim.susoy&p6r.com | 2010-01-21 | |
| John Muth | muth¶scale.com | 2010-01-21 | |
| John Payson | john&circad.com | 2007-10-22 | |
| Jon March | jon.march&paget-analyst-services.co.uk | 2006-09 | |
| KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 | |
| Lev Yakupov | lyakupov&trueconf.com | 2017-05-12 | |
| MANG Ioan-Alexandru | KeyTicket Solutions | amang&keyticket.eu | 2014-04-04 |
| Mark Kosters | markk&internic.net | ||
| Mark Revier | Sentyron B.V. | iana&sentyron.com | 2025-10-30 |
| Martin Daly | martin.daly&cadcorp.com | 2022-08-12 | |
| Matthew Margolis | matthew.margolis&gettyimages.com | 2019-04-18 | |
| Matthew Schultz | QuantuMatriX Technologies | matt&qmxtech.com | 2014-04-10 |
| Matthias Trute | mtrute&web.de | 2007-01 | |
| Michael Haeuptle | Michael_Haeuptle&hp.com | ||
| Michael Swan | swan&neon.com | 2004-04 | |
| Mitsuo Kodama | kodama&jbmia.or.jp | 2005-06 | |
| Morgan McLean | OpenTelemetry | morgan_mclean&hotmail.com | 2020-12-09 |
| OpenTelemetry | cncf-opentelemetry-governance&lists.cncf.io | 2020-12-09 | |
| Paul Alfille | paul.alfille&gmail.com | 2007-01 | |
| Paul Ballew | ballew&projtech.com | ||
| Paul Wren | Paul.Wren¯o4.com | ||
| Philippe Detournay | philippe.detournay&acrosoft.be | 2007-11-12 | |
| QuantuMatriX Technologies | admin&qmxtech.com | 2014-04-10 | |
| Radish Systems | rad&radishsystems.com | 2013-03-28 | |
| Richard A. Davis | Radish Systems | rad&radishsystems.com | 2013-03-28 |
| Ron Minnich | rminnich&sarnoff.com | ||
| Russell P. Holsclaw | Fast Data Technology Inc. | rholsclaw&fastdatatech.com | 2006-03 |
| Sentyron B.V. | iana&sentyron.com | 2025-10-30 | |
| Simon Wunderlich | siwu&hrz.tu-chemnitz.de | 2007-08-30 | |
| Siva Poobalasingam | Siva.Poobalasingam&towersoft.com.au | 2007-02 | |
| Sylvain Robert | sylvain.robert&datadis.com | 2008-02-14 | |
| Tom Kee | t.kee&f5.com | ||
| Tom Maaswinkel | tom.maaswinkel&publiqare.nl | 2011-02-07 | |
| Uri Sarid | uri&aptana.com | 2008-01-22 |