Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| axysbridge | 4418 | udp | AXYS communication protocol | Duran Audio B.V. | Gerald van Beuningen | 2016-03-14 | |||||
| cbp | 4419 | tcp | Colnod Binary Protocol | Colsys s.r.o. | Jiri Merth | 2016-03-23 | |||||
| 4419 | udp | Reserved | |||||||||
| nvme | 4420 | tcp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| nvme | 4420 | udp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| scaleft | 4421 | tcp | Multi-Platform Remote Management for Cloud Infrastructure | ScaleFT, Inc | Paul Querna | 2016-04-07 | |||||
| 4421 | udp | Reserved | |||||||||
| tsepisp | 4422 | tcp | TSEP Installation Service Protocol | Technical Software Engineering Plazotta | Peter Plazotta | 2016-06-22 | |||||
| 4422 | udp | Reserved | |||||||||
| thingkit | 4423 | tcp | thingkit secure mesh | thingkit, inc. | Chris Bell | 2016-06-27 | |||||
| 4423 | udp | Reserved | |||||||||
| 4424 | Unassigned | ||||||||||
| netrockey6 | 4425 | tcp | NetROCKEY6 SMART Plus Service | Feitian Technologies | Feitian Technologies | 2010-09-15 | |||||
| netrockey6 | 4425 | udp | NetROCKEY6 SMART Plus Service | Feitian Technologies | Feitian Technologies | 2010-09-15 | |||||
| beacon-port-2 | 4426 | tcp | SMARTS Beacon Port | Eyal Yardeni | Eyal Yardeni | 2003-11 | |||||
| beacon-port-2 | 4426 | udp | SMARTS Beacon Port | Eyal Yardeni | Eyal Yardeni | 2003-11 | |||||
| drizzle | 4427 | tcp | Drizzle database server | Elliot Murphy | Elliot Murphy | 2008-07-09 | |||||
| 4427 | udp | Reserved | |||||||||
| omviserver | 4428 | tcp | OMV-Investigation Server-Client | Serge Vacquier | Serge Vacquier | 2009-05-20 | |||||
| 4428 | udp | Reserved | |||||||||
| omviagent | 4429 | tcp | OMV Investigation Agent-Server | Serge Vacquier | Serge Vacquier | 2009-05-20 | |||||
| 4429 | udp | Reserved | |||||||||
| rsqlserver | 4430 | tcp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| rsqlserver | 4430 | udp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| wspipe | 4431 | tcp | adWISE Pipe | Heikki Ellilä | Heikki Ellilä | 2009-06-18 | |||||
| 4431 | udp | Reserved | |||||||||
| l-acoustics | 4432 | tcp | L-ACOUSTICS management | L-ACOUSTICS | Christophe Pignon | 2012-08-13 | |||||
| l-acoustics | 4432 | udp | L-ACOUSTICS management | L-ACOUSTICS | Christophe Pignon | 2012-08-13 | |||||
| vop | 4433 | tcp | Versile Object Protocol | Versile AS | Tore Skaug | 2012-02-01 | |||||
| 4433 | udp | Reserved | |||||||||
| 4434-4440 | Unassigned | ||||||||||
| 4441 | tcp | Reserved | |||||||||
| netblox | 4441 | udp | Netblox Protocol | Brian S. Locke | Brian S. Locke | 2008-07-10 | |||||
| saris | 4442 | tcp | Saris | ||||||||
| saris | 4442 | udp | Saris | ||||||||
| pharos | 4443 | tcp | Pharos | TeleConsult GmbH, 76275 Ettlingen, Germany | TeleConsult GmbH, 76275 Ettlingen, Germany | Known Unauthorized Use on port 4443 | |||||
| pharos | 4443 | udp | Pharos | TeleConsult GmbH, 76275 Ettlingen, Germany | TeleConsult GmbH, 76275 Ettlingen, Germany | Known Unauthorized Use on port 4443 | |||||
| krb524 | 4444 | tcp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| krb524 | 4444 | udp | KRB524 | B. Clifford Neuman | B. Clifford Neuman | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | tcp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| nv-video | 4444 | udp | NV Video default | Ron Frederick | Ron Frederick | krb524 assigned the port, nv used it without an assignment | |||||
| upnotifyp | 4445 | tcp | UPNOTIFYP | Mark Fox | Mark Fox | ||||||
| upnotifyp | 4445 | udp | UPNOTIFYP | Mark Fox | Mark Fox | ||||||
| n1-fwp | 4446 | tcp | N1-FWP | ||||||||
| n1-fwp | 4446 | udp | N1-FWP | ||||||||
| n1-rmgmt | 4447 | tcp | N1-RMGMT | Lori Tassin | Lori Tassin | ||||||
| n1-rmgmt | 4447 | udp | N1-RMGMT | Lori Tassin | Lori Tassin | ||||||
| asc-slmd | 4448 | tcp | ASC Licence Manager | Casper Stoel | Casper Stoel | ||||||
| asc-slmd | 4448 | udp | ASC Licence Manager | Casper Stoel | Casper Stoel | ||||||
| privatewire | 4449 | tcp | PrivateWire | Uri Resnitzky | Uri Resnitzky | ||||||
| privatewire | 4449 | udp | PrivateWire | Uri Resnitzky | Uri Resnitzky | ||||||
| camp | 4450 | tcp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| camp | 4450 | udp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctisystemmsg | 4451 | tcp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctisystemmsg | 4451 | udp | CTI System Msg | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctiprogramload | 4452 | tcp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ctiprogramload | 4452 | udp | CTI Program Load | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| nssalertmgr | 4453 | tcp | NSS Alert Manager | ||||||||
| nssalertmgr | 4453 | udp | NSS Alert Manager | ||||||||
| nssagentmgr | 4454 | tcp | NSS Agent Manager | Jim Hill | Jim Hill | ||||||
| nssagentmgr | 4454 | udp | NSS Agent Manager | Jim Hill | Jim Hill | ||||||
| prchat-user | 4455 | tcp | PR Chat User | ||||||||
| prchat-user | 4455 | udp | PR Chat User | ||||||||
| prchat-server | 4456 | tcp | PR Chat Server | ||||||||
| prchat-server | 4456 | udp | PR Chat Server | ||||||||
| prRegister | 4457 | tcp | PR Register | Donny Gilor | Donny Gilor | ||||||
| prRegister | 4457 | udp | PR Register | Donny Gilor | Donny Gilor | ||||||
| mcp | 4458 | tcp | Matrix Configuration Protocol | Tim DeBaillie | Tim DeBaillie | 2006-12 | |||||
| mcp | 4458 | udp | Matrix Configuration Protocol | Tim DeBaillie | Tim DeBaillie | 2006-12 | |||||
| 4459 | Unassigned | ||||||||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| 4460 | udp | Reserved | |||||||||
| 4461-4479 | Unassigned | ||||||||||
| agtp | 4480 | tcp | Agent Transfer Protocol | Chris Hood | Chris Hood | 2026-04-30 | |||||
| agtp-quic | 4480 | udp | Agent Transfer Protocol over QUIC | Chris Hood | Chris Hood | 2026-04-30 | |||||
| 4481-4483 | Unassigned | ||||||||||
| hpssmgmt | 4484 | tcp | hpssmgmt service | David Straw | David Straw | 2005-11 | |||||
| hpssmgmt | 4484 | udp | hpssmgmt service | David Straw | David Straw | 2005-11 | |||||
| assyst-dr | 4485 | tcp | Assyst Data Repository Service | Albert Cester | Albert Cester | 2008-08-26 | |||||
| 4485 | udp | Reserved | |||||||||
| icms | 4486 | tcp | Integrated Client Message Service | Resource Allocation Team | Resource Allocation Team | 2010-09-27 | |||||
| icms | 4486 | udp | Integrated Client Message Service | Resource Allocation Team | Resource Allocation Team | 2010-09-27 | |||||
| prex-tcp | 4487 | tcp | Protocol for Remote Execution over TCP | Daniel Ruppert | Daniel Ruppert | 2010-09-16 | |||||
| 4487 | udp | Reserved | |||||||||
| awacs-ice | 4488 | tcp | Apple Wide Area Connectivity Service ICE Bootstrap | Rory McGuire | Rory McGuire | 2010-09-24 | |||||
| awacs-ice | 4488 | udp | Apple Wide Area Connectivity Service ICE Bootstrap | Rory McGuire | Rory McGuire | 2010-09-24 | |||||
| 4489-4499 | Unassigned | Known UNAUTHORIZED USE: Ports 4490 and 4491 | |||||||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| a25-fap-fgw | 4502 | sctp | A25 (FAP-FGW) | 3GPP2 | Zhiming Li | 2012-01-11 | |||||
| 4503 | tcp | Reserved | |||||||||
| m-bus-oms | 4503 | udp | M-Bus-OMS over UDP | OMS-Group e. V. (Open Metering System Group) | Ahmed Kasttet | 2025-05-19 | |||||
| 4504-4533 | Unassigned | ||||||||||
| 4534 | tcp | Reserved | |||||||||
| armagetronad | 4534 | udp | Armagetron Advanced Game Server | Manuel Moos | Yann Kaiser | 2012-11-02 | |||||
| ehs | 4535 | tcp | Event Heap Server | ||||||||
| ehs | 4535 | udp | Event Heap Server | ||||||||
| ehs-ssl | 4536 | tcp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| ehs-ssl | 4536 | udp | Event Heap Server SSL | Brad Johanson | Brad Johanson | 2005-08 | |||||
| wssauthsvc | 4537 | tcp | WSS Security Service | Mark Tirschwell | Mark Tirschwell | 2006-01 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Ahmed Kasttet | OMS-Group e. V. (Open Metering System Group) | ahmed.kasttet&oms-group.org | 2025-05-19 |
| Albert Cester | albert.cester&assyst-intl.com | 2008-08-26 | |
| Amber Huffman | amber.huffman&intel.com | 2018-03-27 | |
| B. Clifford Neuman | bcn&isi.edu | 2022-02-18 | |
| Brad Johanson | bradj&tidebreak.com | 2005-08 | |
| Brian S. Locke | blocke&zortlabs.com | 2008-07-10 | |
| Casper Stoel | cbs&ascinc.com | ||
| Chris Bell | cb&thingkit.co | 2016-06-27 | |
| Chris Hood | chris&nomotic.ai | 2026-04-30 | |
| Christophe Pignon | L-ACOUSTICS | christophe.pignon&l-acoustics.com | 2012-08-13 |
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Colsys s.r.o. | jiri.merth&colsys.cz | 2016-03-23 | |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| Daniel Ruppert | daniel&kaffi.lu | 2010-09-16 | |
| David Straw | david.straw&hp.com | 2005-11 | |
| Donny Gilor | dgilor&pop01.ny.us.ibm.net | ||
| Duran Audio B.V. | info&duran-audio.com | 2016-03-14 | |
| Elliot Murphy | elliot.murphy&gmail.com | 2008-07-09 | |
| Eyal Yardeni | eyal.yardeni&smarts.com | 2003-11 | |
| Feitian Technologies | product&ftsafe.com | 2010-09-15 | |
| Gerald van Beuningen | gerald.van.beuningen&duran-audio.com | 2016-03-14 | |
| Heikki Ellilä | heikki.ellila&western.fi | 2009-06-18 | |
| IANA | iana&iana.org | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jim Hill | jhill&symantec.com | ||
| Jiri Merth | jiri.merth&colsys.cz | 2016-03-23 | |
| L-ACOUSTICS | christophe.pignon&l-acoustics.com | 2012-08-13 | |
| Lori Tassin | Ramsey&network-1.com | ||
| Manuel Moos | z-man&users.sf.net | 2012-11-02 | |
| Marco Bambini | marco&realsoftware.com | 2008-08-28 | |
| Mark Fox | markf&uplanet.com | ||
| Mark Tirschwell | mark.tirschwell&wallstreetsystems.com | 2006-01 | |
| NVM Express, Inc. | admin&nvmexpress.org | 2018-03-27 | |
| OMS-Group e. V. (Open Metering System Group) | office&oms-group.org | 2025-05-19 | |
| Paul Querna | paul.querna&scaleft.com | 2016-04-07 | |
| Peter Plazotta | peter.plazotta&tsep.de | 2016-06-22 | |
| Resource Allocation Team | resources&littlehall.com | 2010-09-27 | |
| Ron Frederick | frederick&parc.xerox.com | ||
| Rory McGuire | rlpm&apple.com | 2010-09-24 | |
| ScaleFT, Inc | notices&scaleft.com | 2016-04-07 | |
| Serge Vacquier | svacquier&axway.com | 2019-03-29 | |
| Technical Software Engineering Plazotta | peter.plazotta&tsep.de | 2016-06-22 | |
| TeleConsult GmbH, 76275 Ettlingen, Germany | teleconsult&t-online.de | ||
| thingkit, inc. | cb&thingkit.co | 2016-06-27 | |
| Tim DeBaillie | debaillie&ciholas.com | 2006-12 | |
| Tore Skaug | Versile AS | tore.skaug&versile.com | 2012-02-01 |
| Uri Resnitzky | info&arx.com | ||
| Versile AS | contact&versile.com | 2012-02-01 | |
| Yann Kaiser | kaiser.yann&gmail.com | 2012-11-02 | |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |