Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| burp | 4971 | tcp | BackUp and Restore Program | Marat Khalili | Marat Khalili | 2017-08-23 | |||||
| 4971 | udp | Reserved | |||||||||
| 4972-4979 | Unassigned | ||||||||||
| ctxs-vpp | 4980 | udp | Citrix Virtual Path | Citrix Systems | Rohith Ramkumar | 2015-04-17 | |||||
| 4980 | tcp | Reserved | |||||||||
| 4981-4982 | Unassigned | ||||||||||
| 4983 | Unassigned | 2005-12-22 | |||||||||
| webyast | 4984 | tcp | WebYast | Federico Lucifredi | Federico Lucifredi | 2009-09-25 | |||||
| 4984 | udp | Reserved | |||||||||
| gerhcs | 4985 | tcp | GER HC Standard | Roger Ward | Roger Ward | 2009-09-25 | |||||
| 4985 | udp | Reserved | |||||||||
| mrip | 4986 | tcp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| mrip | 4986 | udp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| smar-se-port1 | 4987 | tcp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port1 | 4987 | udp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port2 | 4988 | tcp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| smar-se-port2 | 4988 | udp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| parallel | 4989 | tcp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| parallel | 4989 | udp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| busycal | 4990 | tcp | BusySync Calendar Synch. Protocol | David Riggle | David Riggle | 2008-01-07 | Defined TXT keys: Proprietary | ||||
| busycal | 4990 | udp | BusySync Calendar Synch. Protocol | David Riggle | David Riggle | 2008-01-07 | Defined TXT keys: Proprietary | ||||
| vrt | 4991 | tcp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| vrt | 4991 | udp | VITA Radio Transport | Sam Bretheim | Sam Bretheim | 2009-01-08 | |||||
| 4992-4998 | Unassigned | ||||||||||
| hfcs-manager | 4999 | tcp | HFSQL Client/Server Database Engine Manager | PC SOFT | Jerome AERTS | 2006-03-02 | 2014-02-02 | ||||
| hfcs-manager | 4999 | udp | HFSQL Client/Server Database Engine Manager | PC SOFT | Jerome AERTS | 2006-03-02 | 2014-02-02 | ||||
| commplex-main | 5000 | tcp | |||||||||
| commplex-main | 5000 | udp | |||||||||
| commplex-link | 5001 | tcp | |||||||||
| commplex-link | 5001 | udp | |||||||||
| rfe | 5002 | tcp | radio free ethernet | ||||||||
| rfe | 5002 | udp | radio free ethernet | ||||||||
| fmpro-internal | 5003 | tcp | FileMaker, Inc. - Proprietary transport | Clay Maeckel | Clay Maeckel | ||||||
| fmpro-internal | 5003 | udp | FileMaker, Inc. - Proprietary name binding | Clay Maeckel | Clay Maeckel | ||||||
| avt-profile-1 | 5004 | tcp | RTP media data | RFC 3551; RFC 4571 | |||||||
| avt-profile-1 | 5004 | udp | RTP media data | RFC 3551 | |||||||
| avt-profile-1 | 5004 | dccp | RTP media data | RFC 3551; RFC 5762 | |||||||
| avt-profile-2 | 5005 | tcp | RTP control protocol | RFC 3551; RFC 4571 | |||||||
| avt-profile-2 | 5005 | udp | RTP control protocol | RFC 3551 | |||||||
| avt-profile-2 | 5005 | dccp | RTP control protocol | RFC 3551; RFC 5762 | |||||||
| wsm-server | 5006 | tcp | wsm server | Adam Berk | Adam Berk | ||||||
| wsm-server | 5006 | udp | wsm server | Adam Berk | Adam Berk | ||||||
| wsm-server-ssl | 5007 | tcp | wsm server ssl | Adam Berk | Adam Berk | ||||||
| wsm-server-ssl | 5007 | udp | wsm server ssl | Adam Berk | Adam Berk | ||||||
| synapsis-edge | 5008 | tcp | Synapsis EDGE | Paul Schilling | Paul Schilling | ||||||
| synapsis-edge | 5008 | udp | Synapsis EDGE | Paul Schilling | Paul Schilling | ||||||
| winfs | 5009 | tcp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| winfs | 5009 | udp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| telelpathstart | 5010 | tcp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathstart | 5010 | udp | TelepathStart | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathattack | 5011 | tcp | TelepathAttack | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| telelpathattack | 5011 | udp | TelepathAttack | Helmuth Breitenfellner | Helmuth Breitenfellner | ||||||
| nsp | 5012 | tcp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| nsp | 5012 | udp | NetOnTap Service | Kim Hancock | Kim Hancock | 2007-10-24 | |||||
| fmpro-v6 | 5013 | tcp | FileMaker, Inc. - Proprietary transport | Alex Chen | Alex Chen | 2007-08-01 | |||||
| fmpro-v6 | 5013 | udp | FileMaker, Inc. - Proprietary transport | Alex Chen | Alex Chen | 2007-08-01 | |||||
| 5014 | tcp | Reserved | |||||||||
| onpsocket | 5014 | udp | Overlay Network Protocol | Roger Matthias | Roger Matthias | 2009-08-24 | |||||
| fmwp | 5015 | tcp | FileMaker, Inc. - Web publishing | Alex Chen | Alex Chen | 2009-11-25 | |||||
| 5015 | udp | Reserved | |||||||||
| 5016-5019 | Unassigned | ||||||||||
| zenginkyo-1 | 5020 | tcp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-1 | 5020 | udp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-2 | 5021 | tcp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-2 | 5021 | udp | zenginkyo-2 | Masashi Suzaki | Masashi Suzaki | ||||||
| mice | 5022 | tcp | mice server | Alan Clifford | Alan Clifford | ||||||
| mice | 5022 | udp | mice server | Alan Clifford | Alan Clifford | ||||||
| htuilsrv | 5023 | tcp | Htuil Server for PLD2 | Dennis Reinhardt | Dennis Reinhardt | ||||||
| htuilsrv | 5023 | udp | Htuil Server for PLD2 | Dennis Reinhardt | Dennis Reinhardt | ||||||
| scpi-telnet | 5024 | tcp | SCPI-TELNET | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| scpi-telnet | 5024 | udp | SCPI-TELNET | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| scpi-raw | 5025 | tcp | SCPI-RAW | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| scpi-raw | 5025 | udp | SCPI-RAW | Interchangeable Virtual Instruments Foundation, Inc. | Larry Ostheimer | 2021-05-06 | |||||
| strexec-d | 5026 | tcp | Storix I/O daemon (data) | Storix Inc. | David Huffman | 2005-08 | |||||
| strexec-d | 5026 | udp | Storix I/O daemon (data) | Storix Inc. | David Huffman | 2005-08 | |||||
| strexec-s | 5027 | tcp | Storix I/O daemon (stat) | Storix Inc. | David Huffman | 2005-08 | |||||
| strexec-s | 5027 | udp | Storix I/O daemon (stat) | Storix Inc. | David Huffman | 2005-08 | |||||
| qvr | 5028 | tcp | Quiqum Virtual Relais | Philipp Marcel Albrecht | Philipp Marcel Albrecht | 2009-07-06 | |||||
| 5028 | udp | Reserved | |||||||||
| infobright | 5029 | tcp | Infobright Database Server | Mark Windrim | Mark Windrim | 2009-07-23 | |||||
| infobright | 5029 | udp | Infobright Database Server | Mark Windrim | Mark Windrim | 2009-07-23 | |||||
| 5030 | tcp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5030 | udp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5031 | tcp | Reserved | |||||||||
| dmp | 5031 | udp | Direct Message Protocol | Gjermund Wallenius | Gjermund Wallenius | 2009-09-30 | |||||
| signacert-agent | 5032 | tcp | SignaCert Enterprise Trust Server Agent | Harris, Corporation | Daniel R Somerfield | 2011-08-05 | |||||
| 5032 | udp | Reserved | |||||||||
| jtnetd-server | 5033 | tcp | Janstor Secure Data | Janstor Technology | Anthony Johnson | 2015-06-08 | |||||
| 5033 | udp | Reserved | |||||||||
| jtnetd-status | 5034 | tcp | Janstor Status | Janstor Technology | Anthony Johnson | 2015-06-08 | |||||
| 5034 | udp | Reserved | |||||||||
| 5035-5041 | Unassigned | ||||||||||
| asnaacceler8db | 5042 | tcp | asnaacceler8db | Walter Goodwin | Walter Goodwin | ||||||
| asnaacceler8db | 5042 | udp | asnaacceler8db | Walter Goodwin | Walter Goodwin | ||||||
| swxadmin | 5043 | tcp | ShopWorX Administration | Don W. Fitzpatrick | Don W. Fitzpatrick | 2005-08 | |||||
| swxadmin | 5043 | udp | ShopWorX Administration | Don W. Fitzpatrick | Don W. Fitzpatrick | 2005-08 | |||||
| lxi-evntsvc | 5044 | tcp | LXI Event Service | Nick Barendt | Nick Barendt | 2005-08 | |||||
| lxi-evntsvc | 5044 | udp | LXI Event Service | Nick Barendt | Nick Barendt | 2005-08 | |||||
| osp | 5045 | tcp | Open Settlement Protocol | Dmitry Isakbayev | Dmitry Isakbayev | 2010-03-05 | |||||
| 5045 | udp | Reserved | |||||||||
| 5046 | tcp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Berk | aberk&empirix.com | ||
| Alan Clifford | alan&clifford.ac | ||
| Alex Chen | alex_chen&filemaker.com | 2009-11-25 | |
| Anthony Johnson | Janstor Technology | jtadmin&janstor.com | 2015-06-08 |
| Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 | |
| Clay Maeckel | clay&claris.com | 2023-09-12 | |
| Daniel R Somerfield | dsomerfi&harris.com | 2011-08-05 | |
| David Huffman | sba&storix.com | 2016-03-22 | |
| David Riggle | dave&busymac.com | 2008-01-07 | |
| Delcio Prizon | dprizon&smar.com.br | ||
| Dennis Reinhardt | DennisR&dair.com | ||
| Dmitry Isakbayev | dmitry&transnexus.com | 2010-03-05 | |
| Don W. Fitzpatrick | dwf&internetworxsystems.com | 2005-08 | |
| Federico Lucifredi | flucifredi&novell.com | 2009-09-25 | |
| Gjermund Wallenius | gwallenius&ndlocis.mil.no | 2009-09-30 | |
| Harris, Corporation | dsomerfi&harris.com | 2011-08-05 | |
| Helmuth Breitenfellner | hbreitenf&vnet.imb.com | ||
| Howard Amos | amos&ccww.co.uk | 2006-04 | |
| Interchangeable Virtual Instruments Foundation, Inc. | ivi.contact&ivifoundation.org | 2021-05-06 | |
| Janstor Technology | jtadmin&janstor.com | 2015-06-08 | |
| Jerome AERTS | PC SOFT | jae&pcsoft.fr | 2014-02-02 |
| Kim Hancock | registry&dragondex.com | 2007-10-24 | |
| Larry Ostheimer | larry_ostheimer&keysight.com | 2021-05-06 | |
| Marat Khalili | qm2k&yandex.ru | 2017-08-23 | |
| Mark Windrim | mark.windrim&infobright.com | 2009-07-23 | |
| Masashi Suzaki | susakim&noa.nttdata.jp | ||
| Matthew Ford | Matthew.Ford&forward.com.au | 2003-03 | |
| Nick Barendt | nbarendt&vxitech.com | 2005-08 | |
| Paul Schilling | PaulS&synapsis.com | ||
| PC SOFT | jae&pcsoft.fr | 2014-02-02 | |
| Philipp Marcel Albrecht | info&uisa.ch | 2023-10-23 | |
| Roger Matthias | rogermatthias&yahoo.co.uk | 2009-08-24 | |
| Roger Ward | roger.ward&ger911.com | 2009-09-25 | |
| Rohith Ramkumar | Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 |
| Sam Bretheim | info&opensigint.org | 2009-01-08 | |
| Simon Skaria | simonskµsoft.com | 2006-01 | |
| Storix Inc. | sba&storix.com | 2016-03-22 | |
| Walter Goodwin | wpgoodwin&asna.com |