Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ampl-tableproxy | 5196 | tcp | The protocol is used by two programs that exchange "table" data used in the AMPL modeling language | AMPL Optimization, Inc. | David M. Gay | 2012-05-25 | |||||
| 5196 | udp | Reserved | |||||||||
| tunstall-lwp | 5197 | tcp | Tunstall Lone worker device interface | Tunstall Healthcare (UK) Ltd. | Robert Moore | 2014-12-10 | |||||
| 5197 | udp | Reserved | |||||||||
| 5198-5199 | Unassigned | ||||||||||
| targus-getdata | 5200 | tcp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata | 5200 | udp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | tcp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | udp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata2 | 5202 | tcp | TARGUS GetData 2 | John Keaveney | John Keaveney | ||||||
| targus-getdata2 | 5202 | udp | TARGUS GetData 2 | John Keaveney | John Keaveney | ||||||
| targus-getdata3 | 5203 | tcp | TARGUS GetData 3 | John Keaveney | John Keaveney | ||||||
| targus-getdata3 | 5203 | udp | TARGUS GetData 3 | John Keaveney | John Keaveney | ||||||
| 5204-5208 | Unassigned | ||||||||||
| nomad | 5209 | tcp | Nomad Device Video Transfer | Morega Systems Inc. | Ashraf Tahir | 2012-08-20 | |||||
| 5209 | udp | Reserved | |||||||||
| 5210-5214 | Unassigned | ||||||||||
| noteza | 5215 | tcp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| 5215 | udp | Reserved | |||||||||
| noteza | 5215 | sctp | NOTEZA Data Safety Service | CNS a.s. (IT company registered in Czech republic) | Pavel Mendl | 2014-06-12 | |||||
| 5216-5220 | Unassigned | ||||||||||
| 3exmp | 5221 | tcp | 3eTI Extensible Management Protocol for OAMP | Bill Rettig | Bill Rettig | 2010-05-19 | |||||
| 5221 | udp | Reserved | |||||||||
| xmpp-client | 5222 | tcp | XMPP Client Connection | RFC 6120 | |||||||
| 5222 | udp | Reserved | |||||||||
| hpvirtgrp | 5223 | tcp | HP Virtual Machine Group Management | John Williams | John Williams | 2007-06 | |||||
| hpvirtgrp | 5223 | udp | HP Virtual Machine Group Management | John Williams | John Williams | 2007-06 | |||||
| hpvirtctrl | 5224 | tcp | HP Virtual Machine Console Operations | John Williams | John Williams | 2007-06 | |||||
| hpvirtctrl | 5224 | udp | HP Virtual Machine Console Operations | John Williams | John Williams | 2007-06 | |||||
| hp-server | 5225 | tcp | HP Server | Brett Green | Brett Green | ||||||
| hp-server | 5225 | udp | HP Server | Brett Green | Brett Green | ||||||
| hp-status | 5226 | tcp | HP Status | Brett Green | Brett Green | ||||||
| hp-status | 5226 | udp | HP Status | Brett Green | Brett Green | ||||||
| perfd | 5227 | tcp | HP System Performance Metric Service | Chris Bertin | Chris Bertin | 2009-05-19 | |||||
| perfd | 5227 | udp | HP System Performance Metric Service | Chris Bertin | Chris Bertin | 2009-05-19 | |||||
| hpvroom | 5228 | tcp | HP Virtual Room Service | Scott Levin | Scott Levin | 2009-03-19 | |||||
| 5228 | udp | Reserved | |||||||||
| jaxflow | 5229 | tcp | Netflow/IPFIX/sFlow Collector and Forwarder Management | JaxMP | Stephen Hull | 2014-08-15 | |||||
| 5229 | udp | Reserved | |||||||||
| jaxflow-data | 5230 | tcp | JaxMP RealFlow application and protocol data | JaxMP | Stephen Hull | 2014-08-15 | |||||
| 5230 | udp | Reserved | |||||||||
| crusecontrol | 5231 | tcp | Remote Control of Scan Software for Cruse Scanners | Cruse Spezialmaschinen GmbH | Christof J. Reetz | 2014-08-15 | |||||
| 5231 | udp | Reserved | |||||||||
| csedaemon | 5232 | tcp | Cruse Scanning System Service | Christof J. Reetz | Christof J. Reetz | 2011-03-09 | |||||
| 5232 | udp | Reserved | |||||||||
| enfs | 5233 | tcp | Etinnae Network File Service | Chris Peel | Chris Peel | 2011-03-09 | |||||
| 5233 | udp | Reserved | |||||||||
| eenet | 5234 | tcp | EEnet communications | Helmut Giritzer | Helmut Giritzer | 2005-11 | |||||
| eenet | 5234 | udp | EEnet communications | Helmut Giritzer | Helmut Giritzer | 2005-11 | |||||
| galaxy-network | 5235 | tcp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| galaxy-network | 5235 | udp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| padl2sim | 5236 | tcp | |||||||||
| padl2sim | 5236 | udp | |||||||||
| mnet-discovery | 5237 | tcp | m-net discovery | Andy Crick | Andy Crick | 2007-11-13 | |||||
| mnet-discovery | 5237 | udp | m-net discovery | Andy Crick | Andy Crick | 2007-11-13 | |||||
| 5238-5241 | Unassigned | ||||||||||
| attune | 5242 | tcp | ATTUne API | Bellvedi Ltd. | Sean D. Sollé | 2022-06-01 | |||||
| 5242 | udp | Reserved | |||||||||
| xycstatus | 5243 | tcp | xyClient Status API and rendevous point | Xycare Ltd | Luke Bailey | 2022-06-06 | |||||
| 5243 | udp | Reserved | |||||||||
| 5244 | Unassigned | ||||||||||
| downtools | 5245 | tcp | DownTools Control Protocol | Jarrod Sayers | Jarrod Sayers | 2009-04-07 | |||||
| downtools-disc | 5245 | udp | DownTools Discovery Protocol | Jarrod Sayers | Jarrod Sayers | 2009-04-07 | |||||
| 5246 | tcp | Reserved | |||||||||
| capwap-control | 5246 | udp | CAPWAP Control Protocol | RFC 5415 | |||||||
| 5247 | tcp | Reserved | |||||||||
| capwap-data | 5247 | udp | CAPWAP Data Protocol | RFC 5415 | |||||||
| caacws | 5248 | tcp | CA Access Control Web Service | Gabriel Kalmar | Gabriel Kalmar | 2008-03-06 | |||||
| caacws | 5248 | udp | CA Access Control Web Service | Gabriel Kalmar | Gabriel Kalmar | 2008-03-06 | |||||
| caaclang2 | 5249 | tcp | CA AC Lang Service | Gabriel Kalmar | Gabriel Kalmar | 2008-02-19 | |||||
| caaclang2 | 5249 | udp | CA AC Lang Service | Gabriel Kalmar | Gabriel Kalmar | 2008-02-19 | |||||
| soagateway | 5250 | tcp | soaGateway | Greg Bodine | Greg Bodine | 2002-02 | |||||
| soagateway | 5250 | udp | soaGateway | Greg Bodine | Greg Bodine | 2002-02 | |||||
| caevms | 5251 | tcp | CA eTrust VM Service | Kevin Bond | Kevin Bond | 2004-11 | |||||
| caevms | 5251 | udp | CA eTrust VM Service | Kevin Bond | Kevin Bond | 2004-11 | |||||
| movaz-ssc | 5252 | tcp | Movaz SSC | Lou Berger | Lou Berger | 2004-11 | |||||
| movaz-ssc | 5252 | udp | Movaz SSC | Lou Berger | Lou Berger | 2004-11 | |||||
| kpdp | 5253 | tcp | Kohler Power Device Protocol | Bill Gross | Bill Gross | 2010-11-01 | |||||
| 5253 | udp | Reserved | |||||||||
| logcabin | 5254 | tcp | LogCabin storage service | Diego Ongaro | Diego Ongaro | 2015-04-14 | |||||
| 5254 | udp | Reserved | |||||||||
| 5255-5263 | Unassigned | ||||||||||
| 3com-njack-1 | 5264 | tcp | 3Com Network Jack Port 1 | Abhay Rajaram | Abhay Rajaram | 2003-03 | |||||
| 3com-njack-1 | 5264 | udp | 3Com Network Jack Port 1 | Abhay Rajaram | Abhay Rajaram | 2003-03 | |||||
| 3com-njack-2 | 5265 | tcp | 3Com Network Jack Port 2 | Abhay Rajaram | Abhay Rajaram | 2003-03 | |||||
| 3com-njack-2 | 5265 | udp | 3Com Network Jack Port 2 | Abhay Rajaram | Abhay Rajaram | 2003-03 | |||||
| 5266-5268 | Unassigned | ||||||||||
| xmpp-server | 5269 | tcp | XMPP Server Connection | RFC 6120 | |||||||
| 5269 | udp | Reserved | |||||||||
| cartographerxmp | 5270 | tcp | Cartographer XMP | Bobby Krupczak | Bobby Krupczak | 2008-04-03 | 2011-08-31 | ||||
| cartographerxmp | 5270 | udp | Cartographer XMP | Bobby Krupczak | Bobby Krupczak | 2008-04-03 | 2011-08-31 | ||||
| cuelink | 5271 | tcp | StageSoft CueLink messaging | Todd Pichler | Todd Pichler | 2010-03-26 | |||||
| cuelink-disc | 5271 | udp | StageSoft CueLink discovery | Todd Pichler | Todd Pichler | 2010-03-26 | |||||
| pk | 5272 | tcp | PK | Patrick Kara | Patrick Kara | ||||||
| pk | 5272 | udp | PK | Patrick Kara | Patrick Kara | ||||||
| 5273-5279 | Unassigned | ||||||||||
| xmpp-bosh | 5280 | tcp | Bidirectional-streams Over Synchronous HTTP (BOSH) | Peter Saint-Andre | Peter Saint-Andre | 2009-11-25 | |||||
| 5280 | udp | Reserved | |||||||||
| undo-lm | 5281 | tcp | Undo License Manager | Undo Ltd | Edward Moffett | 2010-04-19 | 2019-01-25 | ||||
| 5281 | udp | Reserved | |||||||||
| transmit-port | 5282 | tcp | Marimba Transmitter Port | Johan Eriksson | Johan Eriksson | 2002-04 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhay Rajaram | Abhay_Rajaram&3com.com | 2003-03 | |
| AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 | |
| Andy Crick | acrick&haascnc.com | 2007-11-13 | |
| Ashraf Tahir | Morega Systems Inc. | atahir&morega.com | 2012-08-20 |
| Bellvedi Ltd. | iana&bellvedi.com | 2022-06-01 | |
| Bill Gross | william.gross&kohler.com | 2010-11-01 | |
| Bill Rettig | WRettig&efji.com | 2010-05-19 | |
| Bobby Krupczak | rdk&krupczak.org | 2008-04-03 | |
| Brett Green | Brett_Green&hp.com | ||
| Chris Bertin | chris.bertin&hp.com | 2009-05-19 | |
| Chris Peel | chrispeel.gsi&googlemail.com | 2011-03-09 | |
| Christof J. Reetz | cjr&netplan.de | 2011-03-09 | |
| Christof J. Reetz | Cruse Spezialmaschinen GmbH | cjr&crusescanner.com | 2014-08-15 |
| CNS a.s. (IT company registered in Czech republic) | HAJN.L&cns.cz | 2014-06-12 | |
| Cruse Spezialmaschinen GmbH | cjr&crusescanner.com | 2014-08-15 | |
| David M. Gay | AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 |
| Diego Ongaro | ongaro&cs.stanford.edu | 2015-04-14 | |
| Edward Moffett | Undo Ltd | office.manager&undo.io | 2019-01-25 |
| Gabriel Kalmar | kalga01&ca.com | 2008-03-06 | |
| Greg Bodine | gregory.bodine&ca.com | 2002-02 | |
| Helmut Giritzer | helmut.giritzer&epluse.at | 2005-11 | |
| Jarrod Sayers | jarrod&downtools.com.au | 2009-04-07 | |
| JaxMP | shull&jaxmp.com | 2014-08-15 | |
| Johan Eriksson | johan&marimba.com | 2002-04 | |
| John Keaveney | johnkeaveney&targusinfo.com | ||
| John Williams | John.H.Williams&hp.com | 2007-06 | |
| Kevin Bond | kevin.bond&ca.com | 2004-11 | |
| Lou Berger | lberger&movaz.com | 2004-11 | |
| Luke Bailey | Xycare Ltd | luke.bailey&xycare.co.uk | 2022-06-06 |
| Michael Andre | mandre&gatewayticketing.com | 2007-10-04 | |
| Morega Systems Inc. | atahir&morega.com | 2012-08-20 | |
| Patrick Kara | Patrick&eba.net | ||
| Pavel Mendl | CNS a.s. (IT company registered in Czech republic) | Pavel.MENDL&cns.cz | 2014-06-12 |
| Peter Saint-Andre | stpeter&stpeter.im | 2009-11-25 | |
| Robert Moore | Tunstall Healthcare (UK) Ltd. | robert.moore&tunstall.com | 2014-12-10 |
| Scott Levin | scott.levin&hp.com | 2009-03-19 | |
| Sean D. Sollé | Bellvedi Ltd. | iana&bellvedi.com | 2022-06-01 |
| Stephen Hull | JaxMP | shull&jaxmp.com | 2014-08-15 |
| Todd Pichler | todd.pichler&stagesoft.com | 2010-03-26 | |
| Tunstall Healthcare (UK) Ltd. | robert.moore&tunstall.com | 2014-12-10 | |
| Undo Ltd | office.manager&undo.io | 2019-01-25 | |
| Xycare Ltd | luke.bailey&xycare.co.uk | 2022-06-06 |