Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| transmit-port | 5282 | tcp | Marimba Transmitter Port | Johan Eriksson | Johan Eriksson | 2002-04 | |||||
| transmit-port | 5282 | udp | Marimba Transmitter Port | Johan Eriksson | Johan Eriksson | 2002-04 | |||||
| 5283-5297 | Unassigned | ||||||||||
| presence | 5298 | tcp | XMPP Link-Local Messaging | Eric St. Onge | Eric St. Onge | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| presence | 5298 | udp | XMPP Link-Local Messaging | Eric St. Onge | Eric St. Onge | 2008-01-14 | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html | ||||
| nlg-data | 5299 | tcp | NLG Data Service | Andy Shellam | Andy Shellam | 2008-02-19 | |||||
| nlg-data | 5299 | udp | NLG Data Service | Andy Shellam | Andy Shellam | 2008-02-19 | |||||
| hacl-hb | 5300 | tcp | HA cluster heartbeat | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-hb | 5300 | udp | HA cluster heartbeat | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-gs | 5301 | tcp | HA cluster general services | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-gs | 5301 | udp | HA cluster general services | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-cfg | 5302 | tcp | HA cluster configuration | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-cfg | 5302 | udp | HA cluster configuration | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-probe | 5303 | tcp | HA cluster probing | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-probe | 5303 | udp | HA cluster probing | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-local | 5304 | tcp | HA Cluster Commands | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-local | 5304 | udp | HA Cluster Commands | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-test | 5305 | tcp | HA Cluster Test | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| hacl-test | 5305 | udp | HA Cluster Test | Eric Soderberg; Edward Yim | Eric Soderberg; Edward Yim | ||||||
| sun-mc-grp | 5306 | tcp | Sun MC Group | Michael DeMoney | Michael DeMoney | ||||||
| sun-mc-grp | 5306 | udp | Sun MC Group | Michael DeMoney | Michael DeMoney | ||||||
| sco-aip | 5307 | tcp | SCO AIP | Barrie Cooper | Barrie Cooper | ||||||
| sco-aip | 5307 | udp | SCO AIP | Barrie Cooper | Barrie Cooper | ||||||
| cfengine | 5308 | tcp | CFengine | Mark Burgess | Mark Burgess | ||||||
| cfengine | 5308 | udp | CFengine | Mark Burgess | Mark Burgess | ||||||
| jprinter | 5309 | tcp | J Printer | Ken Blackwell | Ken Blackwell | ||||||
| jprinter | 5309 | udp | J Printer | Ken Blackwell | Ken Blackwell | ||||||
| outlaws | 5310 | tcp | Outlaws | Richard Fife | Richard Fife | ||||||
| outlaws | 5310 | udp | Outlaws | Richard Fife | Richard Fife | ||||||
| 5311 | Unassigned | 2004-05-07 | |||||||||
| permabit-cs | 5312 | tcp | Permabit Client-Server | Jered Floyd | Jered Floyd | 2004-06 | |||||
| permabit-cs | 5312 | udp | Permabit Client-Server | Jered Floyd | Jered Floyd | 2004-06 | |||||
| rrdp | 5313 | tcp | Real-time & Reliable Data | Ted Hoshi | Ted Hoshi | 2004-06 | |||||
| rrdp | 5313 | udp | Real-time & Reliable Data | Ted Hoshi | Ted Hoshi | 2004-06 | |||||
| opalis-rbt-ipc | 5314 | tcp | opalis-rbt-ipc | Laurent Domenech | Laurent Domenech | ||||||
| opalis-rbt-ipc | 5314 | udp | opalis-rbt-ipc | Laurent Domenech | Laurent Domenech | ||||||
| hacl-poll | 5315 | tcp | HA Cluster UDP Polling | Hoa Nguyen | Hoa Nguyen | ||||||
| hacl-poll | 5315 | udp | HA Cluster UDP Polling | Hoa Nguyen | Hoa Nguyen | ||||||
| hpbladems | 5316 | tcp | HPBladeSystem Monitor Service | Alan Minchew | Alan Minchew | 2011-05-23 | 2011-05-16 | ||||
| 5316 | udp | Unassigned | 2011-05-16 | ||||||||
| hpdevms | 5317 | tcp | HP Device Monitor Service | Alan Minchew | Alan Minchew | 2011-05-16 | |||||
| 5317 | udp | Reserved | |||||||||
| pkix-cmc | 5318 | tcp | PKIX Certificate Management using CMS (CMC) | IESG | IETF Chair | 2026-02-13 | RFC 10003 | ||||
| 5318 | udp | Reserved | |||||||||
| roughtime | 5319 | tcp | Roughtime time synchronization | IESG | IETF Chair | 2026-03-27 | RFC 10049 | ||||
| roughtime | 5319 | udp | Roughtime time synchronization | IESG | IETF Chair | 2026-03-27 | RFC 10049 | ||||
| bsfserver-zn | 5320 | tcp | Webservices-based Zn interface of BSF | Bert Paul | Bert Paul | 2008-05-01 | |||||
| 5320 | udp | Reserved | |||||||||
| bsfsvr-zn-ssl | 5321 | tcp | Webservices-based Zn interface of BSF over SSL | Bert Paul | Bert Paul | 2008-07-03 | |||||
| 5321 | udp | Reserved | |||||||||
| 5322-5342 | Unassigned | ||||||||||
| kfserver | 5343 | tcp | Sculptor Database Server | Keith Ashman | Keith Ashman | 2005-12 | |||||
| kfserver | 5343 | udp | Sculptor Database Server | Keith Ashman | Keith Ashman | 2005-12 | |||||
| xkotodrcp | 5344 | tcp | xkoto DRCP | Jeff Heisz | Jeff Heisz | 2006-02 | |||||
| xkotodrcp | 5344 | udp | xkoto DRCP | Jeff Heisz | Jeff Heisz | 2006-02 | |||||
| 5345-5348 | Unassigned | ||||||||||
| stuns | 5349 | tcp | Session Traversal Utilities for NAT (STUN) port | IESG | IETF Chair | 2019-03-28 | RFC 8489 | ||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | tcp | TURN over TLS | 2019-08-02 | RFC 8656 | ||||||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| stun-behaviors | 5349 | tcp | STUN Behavior Discovery over TLS | RFC 5780 | |||||||
| stun-behaviors | 5349 | udp | Reserved for a future enhancement of STUN-BEHAVIOR | RFC 5780 | |||||||
| 5350 | tcp | Reserved | |||||||||
| pcp-multicast | 5350 | udp | Port Control Protocol Multicast | IESG | IETF Chair | RFC 6887 | |||||
| 5351 | tcp | Reserved | |||||||||
| pcp | 5351 | udp | Port Control Protocol | IESG | IETF Chair | RFC 6887 | |||||
| dns-llq | 5352 | tcp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| dns-llq | 5352 | udp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| mdns | 5353 | tcp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdns | 5353 | udp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdnsresponder | 5354 | tcp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| mdnsresponder | 5354 | udp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| llmnr | 5355 | tcp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| llmnr | 5355 | udp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| ms-smlbiz | 5356 | tcp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| ms-smlbiz | 5356 | udp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| wsdapi | 5357 | tcp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi | 5357 | udp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | tcp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | udp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| ms-alerter | 5359 | tcp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| ms-alerter | 5359 | udp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| ms-sideshow | 5360 | tcp | Protocol for Windows SideShow | Dan Polivy | Dan Polivy | 2008-03-12 | |||||
| ms-sideshow | 5360 | udp | Protocol for Windows SideShow | Dan Polivy | Dan Polivy | 2008-03-12 | |||||
| ms-s-sideshow | 5361 | tcp | Secure Protocol for Windows SideShow | Dan Polivy | Dan Polivy | 2008-03-12 | |||||
| ms-s-sideshow | 5361 | udp | Secure Protocol for Windows SideShow | Dan Polivy | Dan Polivy | 2008-03-12 | |||||
| serverwsd2 | 5362 | tcp | Microsoft Windows Server WSD2 Service | Erhan Soyer-Osman | Erhan Soyer-Osman | 2008-03-26 | |||||
| serverwsd2 | 5362 | udp | Microsoft Windows Server WSD2 Service | Erhan Soyer-Osman | Erhan Soyer-Osman | 2008-03-26 | |||||
| net-projection | 5363 | tcp | Windows Network Projection | Rob Williams | Rob Williams | 2009-02-17 | |||||
| net-projection | 5363 | udp | Windows Network Projection | Rob Williams | Rob Williams | 2009-02-17 | |||||
| kdnet | 5364 | udp | Microsoft Kernel Debugger | Microsoft Corporation | Joe Ballantyne | 2013-06-16 | |||||
| 5364 | tcp | Reserved | |||||||||
| 5365-5396 | Unassigned | ||||||||||
| stresstester | 5397 | tcp | StressTester(tm) Injector | Graham Parsons | Graham Parsons | 2005-08 | |||||
| stresstester | 5397 | udp | StressTester(tm) Injector | Graham Parsons | Graham Parsons | 2005-08 | |||||
| elektron-admin | 5398 | tcp | Elektron Administration | Chris Hawk | Chris Hawk | 2005-08 | |||||
| elektron-admin | 5398 | udp | Elektron Administration | Chris Hawk | Chris Hawk | 2005-08 | |||||
| securitychase | 5399 | tcp | SecurityChase | Daisuke Shinomiya | Daisuke Shinomiya | 2005-08 | |||||
| securitychase | 5399 | udp | SecurityChase | Daisuke Shinomiya | Daisuke Shinomiya | 2005-08 | |||||
| excerpt | 5400 | tcp | Excerpt Search | John Hinsdale | John Hinsdale | ||||||
| excerpt | 5400 | udp | Excerpt Search | John Hinsdale | John Hinsdale |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Minchew | alan.minchew&hp.com | 2011-05-23 | |
| Andy Shellam | andy&networkmail.eu | 2008-02-19 | |
| Barrie Cooper | barrie&sco.com | ||
| Bernard Aboba | bernardaµsoft.com | 2004-06 | |
| Bert Paul | bert.paul&apertio.com | 2008-07-03 | |
| Chris Hawk | chris&corriente.net | 2005-08 | |
| Daisuke Shinomiya | shinomiya.daisu&jp.fujitsu.com | 2005-08 | |
| Dan Polivy | dpolivyµsoft.com | 2008-03-12 | |
| Edward Yim | eyim&hpmfas4.cup.hp.com | ||
| Erhan Soyer-Osman | erhansoµsoft.com | 2008-03-26 | |
| Eric Soderberg | seric&hposl102.cup.hp | ||
| Eric St. Onge | stonge&apple.com | 2008-01-14 | |
| Gopikrishna Sandra | v-gosandµsoft.com | 2005-02 | |
| Graham Parsons | graham.parsons&reflective.com | 2005-08 | |
| Henry Rawas | henryrµsoft.com | 2005-08 | |
| Hoa Nguyen | hoan&cup.hp.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeff Heisz | jeff.heisz&xkoto.com | 2006-02 | |
| Jered Floyd | jered&permabit.com | 2004-06 | |
| Joe Ballantyne | Microsoft Corporation | joeballµsoft.com | 2013-06-16 |
| Johan Eriksson | johan&marimba.com | 2002-04 | |
| John Hinsdale | hin&alma.com | ||
| Keith Ashman | sciana&sculptor.co.uk | 2005-12 | |
| Ken Blackwell | kenb&bristol.com | ||
| Laurent Domenech | Opalis | ldomenech&opalis.com | |
| Marc McClure | marcmccµsoft.com | 2007-08-07 | |
| Mark Burgess | mark.burgess&iu.hioslo.no | ||
| Michael DeMoney | demoney&eng.sun.com | ||
| Microsoft Corporation | joeballµsoft.com | 2013-06-16 | |
| Richard Fife | richardf&lucasarts.com | ||
| Rob Williams | rob.williamsµsoft.com | 2009-02-17 | |
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Stuart Cheshire | mdnsresponder-ipc&multicastdns.org | 2004-06 | |
| Ted Hoshi | tetsuo.hoshi&jp.yokogawa.com | 2004-06 |