Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
excerpt 5400 udp Excerpt Search John Hinsdale John Hinsdale
excerpts 5401 tcp Excerpt Search Secure John Hinsdale John Hinsdale
excerpts 5401 udp Excerpt Search Secure John Hinsdale John Hinsdale
mftp 5402 tcp OmniCast MFTP Steve Bannister Steve Bannister
mftp 5402 udp OmniCast MFTP Steve Bannister Steve Bannister
hpoms-ci-lstn 5403 tcp HPOMS-CI-LSTN Harold Froehling Harold Froehling
hpoms-ci-lstn 5403 udp HPOMS-CI-LSTN Harold Froehling Harold Froehling
hpoms-dps-lstn 5404 tcp HPOMS-DPS-LSTN Harold Froehling Harold Froehling
hpoms-dps-lstn 5404 udp HPOMS-DPS-LSTN Harold Froehling Harold Froehling
netsupport 5405 tcp NetSupport Paul Sanders Paul Sanders
netsupport 5405 udp NetSupport Paul Sanders Paul Sanders
systemics-sox 5406 tcp Systemics Sox Gary Howland Gary Howland
systemics-sox 5406 udp Systemics Sox Gary Howland Gary Howland
foresyte-clear 5407 tcp Foresyte-Clear Jorge Aldana Jorge Aldana
foresyte-clear 5407 udp Foresyte-Clear Jorge Aldana Jorge Aldana
foresyte-sec 5408 tcp Foresyte-Sec Jorge Aldana Jorge Aldana
foresyte-sec 5408 udp Foresyte-Sec Jorge Aldana Jorge Aldana
salient-dtasrv 5409 tcp Salient Data Server Richard Farnham Richard Farnham
salient-dtasrv 5409 udp Salient Data Server Richard Farnham Richard Farnham
salient-usrmgr 5410 tcp Salient User Manager Richard Farnham Richard Farnham
salient-usrmgr 5410 udp Salient User Manager Richard Farnham Richard Farnham
actnet 5411 tcp ActNet Simon Robillard Simon Robillard
actnet 5411 udp ActNet Simon Robillard Simon Robillard
continuus 5412 tcp Continuus Steven Holtsberg Steven Holtsberg
continuus 5412 udp Continuus Steven Holtsberg Steven Holtsberg
wwiotalk 5413 tcp WWIOTALK Roger Knobbe Roger Knobbe
wwiotalk 5413 udp WWIOTALK Roger Knobbe Roger Knobbe
statusd 5414 tcp StatusD Stephen Misel Stephen Misel
statusd 5414 udp StatusD Stephen Misel Stephen Misel
ns-server 5415 tcp NS Server Jeffrey Chiao Jeffrey Chiao
ns-server 5415 udp NS Server Jeffrey Chiao Jeffrey Chiao
sns-gateway 5416 tcp SNS Gateway Mary Holstage Mary Holstage
sns-gateway 5416 udp SNS Gateway Mary Holstage Mary Holstage
sns-agent 5417 tcp SNS Agent Mary Holstage Mary Holstage
sns-agent 5417 udp SNS Agent Mary Holstage Mary Holstage
mcntp 5418 tcp MCNTP Heiko Rupp Heiko Rupp
mcntp 5418 udp MCNTP Heiko Rupp Heiko Rupp
dj-ice 5419 tcp DJ-ICE Don Tyson Don Tyson
dj-ice 5419 udp DJ-ICE Don Tyson Don Tyson
cylink-c 5420 tcp Cylink-C John Jobe John Jobe
cylink-c 5420 udp Cylink-C John Jobe John Jobe
netsupport2 5421 tcp Net Support 2 Paul Sanders Paul Sanders
netsupport2 5421 udp Net Support 2 Paul Sanders Paul Sanders
salient-mux 5422 tcp Salient MUX Richard Farnham Richard Farnham
salient-mux 5422 udp Salient MUX Richard Farnham Richard Farnham
virtualuser 5423 tcp VIRTUALUSER Chad Williams Chad Williams
virtualuser 5423 udp VIRTUALUSER Chad Williams Chad Williams
beyond-remote 5424 tcp Beyond Remote Michael Berg Michael Berg 2004-11
beyond-remote 5424 udp Beyond Remote Michael Berg Michael Berg 2004-11
br-channel 5425 tcp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
br-channel 5425 udp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
devbasic 5426 tcp DEVBASIC Curtis Smith Curtis Smith
devbasic 5426 udp DEVBASIC Curtis Smith Curtis Smith
sco-peer-tta 5427 tcp SCO-PEER-TTA Andrew Shire Andrew Shire
sco-peer-tta 5427 udp SCO-PEER-TTA Andrew Shire Andrew Shire
telaconsole 5428 tcp TELACONSOLE Joseph M. Newcomer Joseph M. Newcomer
telaconsole 5428 udp TELACONSOLE Joseph M. Newcomer Joseph M. Newcomer
base 5429 tcp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
base 5429 udp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
radec-corp 5430 tcp RADEC CORP David Chell David Chell
radec-corp 5430 udp RADEC CORP David Chell David Chell
park-agent 5431 tcp PARK AGENT John Clifford John Clifford
park-agent 5431 udp PARK AGENT John Clifford John Clifford
postgresql 5432 tcp PostgreSQL Database Tom Lane Tom Lane
postgresql 5432 udp PostgreSQL Database Tom Lane Tom Lane
pyrrho 5433 tcp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
pyrrho 5433 udp Pyrrho DBMS Malcolm Crowe Malcolm Crowe 2005-11
sgi-arrayd 5434 tcp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sgi-arrayd 5434 udp SGI Array Services Daemon Karl Feind Karl Feind 2005-10
sceanics 5435 tcp SCEANICS situation and action notification Richard Olsen Richard Olsen
sceanics 5435 udp SCEANICS situation and action notification Richard Olsen Richard Olsen
5436 tcp Reserved
pmip6-cntl 5436 udp pmip6-cntl RFC 5844
5437 tcp Reserved
pmip6-data 5437 udp pmip6-data RFC 5844
5438-5442 Unassigned
spss 5443 tcp Pearson HTTPS Pearson Pearson 2008-01-17
spss 5443 udp Pearson HTTPS Pearson Pearson 2008-01-17
5444 Unassigned Known UNAUTHORIZED USE: Port 5444
smbdirect 5445 tcp Server Message Block over Remote Direct Memory Access Microsoft Corporation Tom Talpey 2012-03-15
5445 udp Reserved
smbdirect 5445 sctp Server Message Block over Remote Direct Memory Access Microsoft Corporation Tom Talpey 2012-03-15
5446-5449 Unassigned
tiepie 5450 tcp TiePie engineering data acquisition TiePie engineering Reinder Feenstra 2016-04-01
tiepie-disc 5450 udp TiePie engineering data acquisition (discovery) TiePie engineering Reinder Feenstra 2016-04-01
5451-5452 Unassigned
surebox 5453 tcp SureBox Emin BORU Emin BORU 2004-11
surebox 5453 udp SureBox Emin BORU Emin BORU 2004-11
apc-5454 5454 tcp APC 5454 American Power Conversion American Power Conversion
apc-5454 5454 udp APC 5454 American Power Conversion American Power Conversion
apc-5455 5455 tcp APC 5455 American Power Conversion American Power Conversion
apc-5455 5455 udp APC 5455 American Power Conversion American Power Conversion
apc-5456 5456 tcp APC 5456 American Power Conversion American Power Conversion
apc-5456 5456 udp APC 5456 American Power Conversion American Power Conversion
5457-5460 Unassigned
silkmeter 5461 tcp SILKMETER Klaus Fellner Klaus Fellner
silkmeter 5461 udp SILKMETER Klaus Fellner Klaus Fellner
ttl-publisher 5462 tcp TTL Publisher Peter Jacobs Peter Jacobs
ttl-publisher 5462 udp TTL Publisher Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 tcp TTL Price Proxy Peter Jacobs Peter Jacobs
ttlpriceproxy 5463 udp TTL Price Proxy Peter Jacobs Peter Jacobs

Contact Information

Name Organization Contact URI Last Updated
American Power Conversion ports&apcc.com 2002-02
Andrew Shire sndrewsh&sco.com
Chad Williams chad&apple.com
Curtis Smith curtis.smith&vsin.com
David Chell david&softlife.co.nz
Don Tyson don.tyson&cor.dowjones.com
Emin BORU emin&danismanlik.net 2004-11
Gary Howland gary&systemics.com
Harold Froehling hrf&cup.hp.com
Heiko Rupp hwr&pilhuhn.de
Jeffrey Chiao chiaoj&netsoft.com
John Clifford John.Clifford&veritas.com
John Hinsdale hin&alma.com
John Jobe jjobe&cylink.com
Jorge Aldana operator&foresyte.com
Joseph M. Newcomer newcomer&flounder.com
Karl Feind kaf&sgi.com 2005-10
Klaus Fellner webmaster&segue.com
kfellner&segue.com
Malcolm Crowe malcolm.crowe&paisley.ac.uk 2005-11
Mary Holstage holstege&firstfloor.com
Michael Berg mike&dataapples.com 2005-08
Microsoft Corporation stdsreq&microsoft.com 2012-03-15
Odo Maletzki Odo.Maletzki&ioag.de
Paul Sanders p.sanders&dial.pipex.com
Paul Sanders pe77&dial.pipex.com
Pearson chad.smith&pearson.com 2008-01-17
Peter Jacobs pjacobs&tullib.com
Reinder Feenstra r.feenstra&tiepie.nl 2016-04-01
Richard Farnham rfarnham&salient.com
Richard Olsen olsen.richard&yahoo.com
Roger Knobbe RogerK&wonderware.com
Simon Robillard RobillardS&actresearch.com
Stephen Misel steve&satelnet.org
Steve Bannister sbannister&stratacache.com
Steven Holtsberg steveh&continuus.com
TiePie engineering tiepie&tiepie.nl 2016-04-01
Tom Lane tgl&sss.pgh.pa.us
Tom Talpey Microsoft Corporation ttalpey&microsoft.com 2012-03-15